Introduction to

Creo Elements/pro 5.0

Volume -1
Contents

1. Introduction to Pro/Engineer Basic Modeling process
   1.1 Pro/Engineer Basic Modeling process

2. Understanding Pro/Engineer Concepts
   2.1 Understanding Solid modeling Concepts
   2.2 Understanding Feature Based Concepts
   2.3 Understanding Parametric Concepts
   2.4 Understanding Associative Concepts
   2.5 Understanding Model – centric Concepts
   2.6 Recognizing File Extensions

3. Using the Pro/Engineer Interface
   3.1 Understanding the Main Interface
   3.2 Understanding the Folder Browser
   3.3 Understanding the Web Browser
   3.4 Understanding the Window Menu
   3.5 Setting the working directory and opening and saving the files
   3.6 Managing files in Pro/Engineer
   3.7 Understanding Basic display options
   3.8 Analyzing basic 3D orientation
   3.9 Understanding the View Manager
   3.10 Creating and Managing View orientation
   3.11 Creating Style states using View Manager
   3.12 Managing and editing appearances
   3.13 Setting up new part models

4. Selecting and editing
   4.1 Understanding Pro/Engineer Basic controls
   4.2 Using drag Handles
   4.3 Using Keyboard Shortcuts
   4.4 Understanding Model tree
4.5 Understanding Model tree filters
4.6 Understanding Basic Model tree columns
4.7 Selecting items using direct selection
4.8 Selecting items using query selection
4.9 Using the search tool
4.10 Using the smart selection filter
4.11 Understanding Selection filters
4.12 Renaming objects
4.13 Utilizing redo and undo operations
4.14 Editing features and regenerating
4.15 Using Dynamic Edit

5. **Creating Sketcher Geometry**
   5.1 Reviewing Sketcher Theory
   5.2 Understanding Sketcher Intent
   5.3 Modifying the Sketcher Display
   5.4 Utilizing the constraints
   5.5 Sketching with on – the fly constraints
   5.6 Sketching lines
   5.7 Sketching centerlines
   5.8 Sketching Rectangles and Parallelograms
   5.9 Sketching Circles
   5.10 Sketching Arcs
   5.11 Sketching Circular Fillets
   5.12 Sketching Chamfers

6. **Using Sketcher tools**
   6.1 Understanding Construction Geometry theory
   6.2 Sketching Points
   6.3 Using Geometry tools within sketcher
   6.4 Manipulating sketches within sketcher
   6.5 Dimensioning entities within Sketcher
   6.6 Modifying Dimensions within Sketcher
6.7 Sketcher Conflicts

7. Creating sketches for features
   7.1 Creating Sketches (Sketch Feature)
   7.2 Specifying the Sketch setup
   7.3 Utilizing the sketch references
   7.4 Using entity from edge within the sketcher
   7.5 Thickening Edges

8. Creating Datum Features: Planes and axes
   8.1 Creating Datum Features Theory
   8.2 Creating Datum Axes
   8.3 Creating Datum Planes

9. Creating Extrude, Revolve and Ribs
   9.1 Creating Solid Features
   9.2 Common Dashboard options: Extrude Depth
   9.3 Common Dashboard options: Feature Direction
   9.4 Common Dashboard options: Thicken Sketch
   9.5 Creating Solid Revolve Features
   9.6 Common Dashboard options: Revolve Angles
   9.7 Creating Profile Rib Features

10. Utilizing internal sketches and embedded Datum
    10.1 Creating Internal Sketches
    10.2 Creating Embedded datum features

11. Creating sweeps and Blends
    11.1 Creating Sweep with Open Trajectories
    11.2 Creating Sweep with closed Trajectories
    11.3 Analyzing sweep feature attributes
    11.4 Creating a parallel blend protrusion or cut
    11.5 Experimenting with parallel blend attributes
    11.6 Analyzing parallel blend section tools

12. Creating Holes, Shell and draft
    12.1 Common Dashboard Options: Hole Depth
12.2 Creating coaxial holes
12.3 Creating linear holes
12.4 Creating radial and diameter holes
12.5 Exploring hole profile options
12.6 Creating shell features
12.7 Creating draft features
12.8 Creating Basic Split drafts
12.9 Analyzing Draft hinges and pull direction

13. Creating rounds and chamfers
13.1 Creating Rounds Theory
13.2 Creating rounds by selecting edges
13.3 Creating a round by selecting a surface and edges
13.4 Creating rounds by selecting two surfaces
13.5 Creating full rounds
13.6 Creating round sets
13.7 Creating chamfer by selecting edges
13.8 Analyzing basic chamfer dimensioning schemes
13.9 Creating Chamfer Sets

14. Group, copy and mirror tools
14.1 Creating Local Groups
14.2 Copying and pasting features
14.3 Moving and rotating copied features
14.4 Mirroring Selected features
14.5 Mirroring all Features
14.6 Creating Mirrored parts

15. Creating Patterns
15.1 Direction patterning in first direction
15.2 Direction patterning in second direction
15.3 Axis patterning in first direction
15.4 Axis Patterning in second direction
15.5 Direction Patterning with multiple direction types
15.6 Creating reference pattern of features
15.7 Creating reference pattern of components
15.8 Deleting patterns or pattern members

16. Measuring and inspecting Models
16.1 Viewing editing model properties
16.2 Investigating model units
16.3 Analyzing mass properties
16.4 Measuring models
16.5 Creating planar part cross sections
16.6 Measuring Global interference

17. Assembling with Constraints
17.1 Understanding assembly theory
17.2 Creating new assembly models
17.3 Understanding constraint theory
17.4 Understanding assembly constraint status
17.5 Assembling components using default constraint
17.6 Analyzing basic component orientation
17.7 Constraining components using insert
17.8 Constraining components using mate coincident
17.9 Constraining components using align coincident
17.10 Constraining components using align and mate offset
17.11 Constraining components using align and mate oriented
17.12 Constraining components using align and mate angle
17.13 Constraining components using the automatic option
17.14 Utilizing the accessory window

18. Assembling with Connections
18.1 Understanding connection theory
18.2 Dragging connected components
18.3 Assembling components using the slider connection
18.4 Assembling components using the pin connection
18.5 Assembling components using the cylinder connection
18.6 Analyzing collision detection settings
19. Exploding Assemblies
   19.1 Creating and Managing Explode States
   19.2 Creating Explode Lines
   19.3 Animating Explode States

20. Drawing Layout and Views
   20.1 Analyzing Drawing Concepts and theory
   20.2 Understanding the drawing ribbon user interface
   20.3 Creating New drawings and applying formats
   20.4 Creating and orienting general views
   20.5 Utilizing the drawing tree
   20.6 Managing the drawing sheets
   20.7 Adding drawing models
   20.8 Creating projection views
   20.9 Creating cross section views
   20.10 Creating detailed views
   20.11 Creating auxiliary views
   20.12 Creating new drawing using drawing templates
   20.13 Modifying Drawing views
   20.14 Creating assembly and exploded views

21. Creating Drawing Annotations
   21.1 Analyzing annotation concepts and theory
   21.2 Inserting a Bill of Materials Table
   21.3 Showing, erasing and deleting annotations
   21.4 Cleaning up dimensions
   21.5 Manipulating dimensions
   21.6 Creating driven dimension
   21.7 Inserting notes
   21.8 Analyzing drawing associativity
   21.9 Publishing drawings

22. Using Layers
   22.1 Understanding Layers
   22.2 Creating and Managing Layers
22.3 Utilizing layers in part models
22.4 Creating Layer states
22.5 Utilizing layers in assembly models

23. Investigating Parent/child relationship
23.1 Understanding Parent/child relationships
23.2 Viewing part Parent/child information
23.3 Viewing model, feature and component information

24. Capturing and Managing Design Intent
24.1 Handling children of deleted and suppressed items
24.2 Reordering features
24.3 Inserting features
24.4 Redefining features and sketches
24.5 Capturing design intent in sketches
24.6 Capturing design intent in features
24.7 Capturing design intent in parts
24.8 Capturing design intent in assemblies

25. Resolving failures and seeking help
25.1 Understanding and identifying failures
25.2 Analyzing geometry failures
25.3 Analyzing open section failures
25.4 Analyzing missing part reference failures
25.5 Analyzing missing component failures
25.6 Analyzing missing component reference failures
25.7 Analyzing invalid assembly constraint failures
25.8 Understanding resolve mode tools
25.9 Recovering models
Course Overview

This course is designed for new users who want to become proficient with Pro/ENGINEER Wildfire 5.0 as quickly as possible. You will focus on learning core-modeling skills in this comprehensive, hands-on course. Topics include understanding the interface and basic Pro/ENGINEER concepts, selecting and editing, sketching and sketcher tools, and basic feature creation.

The course also includes a comprehensive design project that enables you to practice your new skills by creating realistic parts. After completing the course you will be well prepared to work effectively on product design projects using Pro/ENGINEER Wildfire.

Course Objective

- Learning the basic Pro/ENGINEER Design Process
- Understanding Pro/ENGINEER concepts
- Learning how to use the Pro/ENGINEER interface
- Selecting and editing items
- Sketching geometry and using tools
- Creating sketches for features
- Creating datum planes and datum axes
- Creating extrudes, revolves, and ribs
- Utilizing internal sketches and embedded datums
- Creating sweeps and blends
- Creating holes, shells, and drafts
- Creating rounds and chamfers
- Comprehensive Design Project
- Grouping, copying, and mirroring items
- Creating patterns
- Measuring and inspecting models
- Assembling with constraints
- Assembling with connections
- Exploding assemblies
- Laying out drawings and creating views
- Creating drawing annotations
- Using layers
- Investigating parent/child relationships
- Capturing and managing design intent
- Resolving failures and seeking help
- Comprehensive Design Project
How to use this course

The information in this Web based course is organized into modules which are comprised of topics. Each topic is divided into one or more of the following sections:

- **Lecture** - The lecture portion is comprised of the following:
  - Concept - This section contains the initial introduction to the topic and is presented in the form of a slide with audio.
  - Theory - This section provides detailed information introduced in the Concept.
- **Demonstration** - This is a recorded video that demonstrates the procedure lab.
- **Labs** - There are two different types of labs that you will use in this course:
  - Procedure - Procedures provide step-by-step instructions on how to complete the topic within Pro/ENGINEER. Procedures are short, focused, and simple labs that cover specific topics to which they apply. Not every topic has a Procedure as there are knowledge topics that cannot be exercised.
  - Exercise - Exercises are longer than procedures and are typically more involved and use more complicated models. Exercises may be specific to a topic or may cover multiple topics, so not every topic will have an associated exercise. You may also have Challenge exercises and Project exercises, which are more involved and are used to review a broader range of information.

The first module is typically a process module. In the process module, you are introduced to the generic high-level processes used during the course and after the course is completed. This module also typically contains an exercise.

Most courses also have a project module, which encapsulates the knowledge gained in the course. The project will contain one or more exercises that provide the process steps, but remove much of the detail from the procedure, task, and detailed step levels. Thus students are encouraged to remember or reuse the information provided in the course.

Note that not all courses have process or project modules.
Running the Procedures and Exercises

To make the labs as concise as possible, each begins with a header. The header lists the name of the lab and a brief scenario. The header lists the working directory, the file you are to open, and the initial datum display.

An example of a Procedure is shown below, but Exercises follow the same general rules:

**PROCEDURE - Creating Solid Extrude Features**

**Scenario**
Create solid extrude features.

**Task 1:** Create solid extrude features.

1. Start the Extrude Tool from the feature toolbar.
2. Select Sketch 1.
3. Drag the drag handle down below datum plane TOP to a depth of 16.
4. Click Complete Feature from the dashboard.

The following gives a brief description of the items highlighted above:

1. Procedure/Exercise Name - This is the name of the lab.
2. Scenario - This briefly describes what will be done in the lab.
3. Close Windows/Erase Not Displayed - This indicates that you should close any open files and erase them from memory. Click the Close Window icon until the icon is disabled and then click the Erase Not Displayed icon and...
click OK. These icons have been added to the left side of the main toolbar.

4. **Folder Name** - This is the working directory for the lab. Lab files are stored on a module by module basis. Within each module, you will find subdirectories for each lab. In this example, Extrude_Features is the working directory. To set the working directory, select the folder from the browser, right-click and select Set Working Directory.

5. **Model to Open** - This is the file to be opened from the working directory (extrude.prt for example). In the browser, right-click on the file and select Open. The model could be a part, drawing, assembly, etc. Also, if you are expected to create a model, you will see Create New here.

6. **Datum Display Setting** - The initial datum display is shown here. For example, Graphic means that you should display datum planes but not display datum axes, datum points and datum coordinate systems. Before beginning the lab, set the icons in the datum display toolbar to match those shown in the header.

7. **Task Name** - Labs are broken into distinct tasks. There may be one or more tasks within a lab.

8. **Lab Steps** - These are the individual steps required to complete a task.
Module 1

Introduction to the Pro/ENGINEER Wildfire Basic Modeling Process

Module Overview

In this module, you learn about the basic modeling process that is typically used to scope, model, assemble, and document a Pro/ENGINEER solid model. This simplified process is fundamentally used at most companies, although your specific company process may differ. The process is supported throughout the course modules and again followed in a course project.

This module also introduces you to various fundamental Pro/ENGINEER concepts including feature-based modeling and associativity between part models, assemblies, and drawings. You will learn more detail about these and other concepts in subsequent modules.
1.1 Pro/ENGINEER Wildfire Basic Modeling Process

The Basic Modeling Process can be summarized in four high-level steps:

1. Preparing for Part Model Design
2. Creating a New Part Model
3. Creating a New Assembly by Assembling the Part Models
4. Creating a Drawing of the New Part Model

Preparing for Part Model Design

Often, before you create a new part model design, it is necessary to know information about the components that will surround it in an assembly. Consequently, you may want to open and inspect these parts before beginning the new design. At your company, this preparation stage may occur at the same time as the new part model design, or it may not occur at all. Either way, having knowledge of adjoining parts can help in the new part model design.
Creating a New Part Model

A new part model accurately captures a design from a concept through solid feature-based modeling. A part model enables you to graphically view the product before it is manufactured. A part model can be used to:

- Capture mass property information.
- Vary design parameters to determine the best options.
- Graphically visualize what a model will look like before it is manufactured.

Creating a New Assembly by Assembling the Part Models

An assembly is created from one or more parts. The parts are located and assembled with respect to one another just as they are on a real product. An assembly can be used to:

- Check for fit between parts.
- Check for interference between parts.
- Capture bill of material information.
- Calculate the total weight of an assembly.

Creating a Drawing of the Part or Assembly

Once a part or assembly has been modeled, it is usually necessary to document that part or assembly by creating a 2-D drawing of it. The 2-D drawing usually contains views of the part or assembly, dimensions, and a title block. The drawing may also contain notes, tables, and further design information. Not every company requires that a drawing be created of a model.
Module 2

Understanding Pro/ENGINEER Concepts

Module Overview

In this module, you will first learn about basic concepts and benefits of solid modeling using Pro/ENGINEER. You will then learn how complex models can be easily created using a combination of simple features. Parametric capabilities that are native to Pro/ENGINEER enable you to easily add design intent and make design changes. Associativity means that a change made to your solid model design will be automatically propagated to all referenced objects such as drawings, assemblies, and so on. You will also learn how a model-centric modeler enables downstream deliverables to be created with references to and driven by the design model.

Finally, you will learn how to recognize some of the basic file extensions used to identify different types of Pro/ENGINEER objects.
2.1 Understanding Solid Modeling Concepts

Pro/ENGINEER Wildfire enables you to create solid model representations of your part and assembly models.

Solid Models:

- Are realistic visual representation of designs.
- Contain properties such as mass, volume, and center of gravity.
- Can also be used to check for interferences in an assembly.

Pro/ENGINEER enables you to create realistic solid model representations of your part and assembly models. These virtual design models can be used to easily visualize and evaluate your design before costly prototypes are manufactured.

The models contain material properties such as mass, volume, center of gravity, and surface area. As features are added or removed from the model, these properties update. For example, if you add a hole to a model, then the mass of the model decreases.
In addition, solid models enable tolerance analysis and clearance/interference checking when placed into assemblies.

## 2.2 Understanding Feature-Based Concepts

In this example, we have a connecting rod in seven stages of its creation:

- First, an extrusion is created, which forms the overall shape and size of the model.
- An additional extrusion is created at the top of the model.
- A third extrusion is created at the bottom of the model.
- A hole is created at the bottom of the model.
- Another hole is created at the top of the model.
- A round is created on the four inside edges.
- A small radial hole is created at the top of the model.
2.3 Understanding Parametric Concepts

Understanding Parametric Concepts

Pro/ENGINEER models are value driven, using dimensions and parameters to define the size and location of features within the model. If you change the value of a feature dimension, that feature will update according to the change. The change then automatically propagates through to related features in the model, updating the entire part.

![Parametric Feature Relationships](image)

Parent/Child Relationships

Relationships between features in Pro/ENGINEER provide a powerful tool for capturing design intent. During the modeling process, design intent is added as one feature is created with reference to another.

When creating a new feature, any feature referenced during its creation becomes a parent of the new feature. The new feature referencing the parent is referred to as a child of the parent. If the parent feature is updated, any children of the parent update accordingly. These relationships are referred to as parent/child relationships.

This example shows a piston model intersected with a hole feature. In the middle figure, the piston height is modified from 18.5 to 25. Notice that the hole moves upward as the piston height increases. The design intent of the piston is to have the hole located a specified distance from the top of the piston. The hole will maintain that distance no matter how tall the piston becomes. This intent was added by dimensioning the hole to the top surface of the piston.
Alternatively, if the intent of the design is to have the hole located a specified distance from the bottom of the piston, the hole would be dimensioned from the bottom surface of the piston, yielding a different result when the height of the piston is modified.

The right most figure shows modifications made to the location and diameter of the hole.

**Best Practices**

When creating features in your model, try to reference features and geometry that are robust, will likely not be deleted, and provide the desired design intent. While this is not always possible, striving to do so will help you build robust, easy to modify models.

### 2.4 Understanding Associative Concepts

Bi-directional associativity means that all changes made to an object in any mode of Pro/ENGINEER are automatically reflected in every related mode.

For example, a change made in a drawing is reflected in the part being documented in the drawing. That same change is also reflected in every assembly using that part model.

It is important to understand that the associativity between different modes is possible because the part shown in a drawing is not copied into the drawing, but rather associatively linked to the drawing. Likewise, an assembly is not a large file containing copies of every part in the assembly, but rather a file containing associative links to every model used in the assembly.
Best Practices

Because drawing and assembly files have associative links to the models contained in them, these objects cannot be opened without the models they contain being present.

In other words, you cannot send your colleague only a drawing file to open, he or she must have the drawing file along with any model referenced in the drawing. For an assembly, he or she must have the assembly file and all models used in the assembly.

2.5 Understanding Model-Centric Concepts

In a model-centric product development tool, the design model is the common source for all deliverables making use of that design model. This means that all downstream deliverables point directly to a common design model. The model is referenced as components in assemblies, views in a drawing, the cavity of a mold, geometry meshed in a FEM model, and so on.

The benefit of using a model-centric development tool is that a change made to the design model will automatically update all related downstream deliverables.
Model-Centric

- Assemblies reference the models being assembled.
- The drawing references the model being documented.
- The FEM model references the model being meshed.
- The mold tool references the model being molded.

2.6 Recognizing File Extensions

The following are three file extensions used to identify three common Pro/ENGINEER object types: parts, assemblies, and drawings.

- .prt — This extension represents a part object.
- .asm — This extension represents an assembly object. An assembly file contains pointers and instructions that identify and position a collection of parts and subassemblies.
- .drw — This extension represents a 2-D drawing. The drawing file contains pointers, instructions, and detail items for documenting part and assembly models in a drawing.
Check your Knowledge

1. Solid models contain properties such as...
   A - Mass.
   B - Volume.
   C - Center of gravity.
   D - all of the above.

2. True or False? With feature-based modeling, each newly created feature builds upon the previous features and can reference any of them.
   A - True
   B - False

3. True or False? When creating a new feature, any feature referenced during its creation becomes a child of the new feature.
   A - True
   B - False

4. A change made to a part model is also reflected in...
   A - a drawing that uses that part.
   B - an assembly that uses that part.
   C - a second assembly that uses that part.
   D - all of the above.
   E - A and B only.

5. True or False? In Pro/ENGINEER, the drawing is the center of all downstream deliverables.
   A - True
   B - False
Module 3

Using the Pro/ENGINEER Interface

Module Overview

Pro/ENGINEER's user interface is an intuitive, user-friendly experience. The system is designed to make the most of its available space by displaying certain information at the right time, and then using that space to display different information at a different time.

This module introduces you to the main user interface and defines each area and how you will use it. You will gain an understanding of basic skills including file manipulation and management, as well as setting the working directory and saving and opening files. You will learn basic Pro/ENGINEER display options for datum display that will aid you throughout this course. You will also learn about 3-D view orientations and style states, as well as understand how to manage and apply appearances.
3.1 Understanding the Main Interface

Main Interface Theory

There are many different areas of the Pro/ENGINEER user interface that you use when creating models. The areas that display depend upon the function being performed. Areas of the main interface include:

- **Graphics Window** — the working area of Pro/ENGINEER Wildfire in which you create and modify Pro/ENGINEER models such as parts, assemblies, and drawings.

- **Main Menu** — Located at the top of the interface, the main menu contains standard options such as File, Edit, and View.

- **Toolbars** — Toolbars contain icons for commonly used tools and functions.

- **Message Window** — the message window provides you with prompts, feedback, and messages from Pro/ENGINEER Wildfire.

- **Dashboard** — locked at the top of the user interface, the Dashboard appears when you create or edit the definition of a feature. The
Dashboard provides you with controls, inputs, status, and guidance for carrying out a task, such as creating or editing a feature. Changes are immediately visible on the screen. Various dashboard tabs are available with additional feature options. Dashboard icons on the left include feature controls while the Pause, Preview, Create Feature, and Cancel Feature options are on the right.

- **Dialog Boxes** — Are content-sensitive windows that appear, displaying and prompting you for information.
**Menu Manager** — A cascading menu that appears on the far right during the use of certain functions and modes within Pro/ENGINEER Wildfire. You work from top to bottom in this menu; however, clicking “Done” is done from bottom to top. Bold menu options will be automatically selected if the middle mouse button is clicked.

**Drawing Ribbon** — A context-sensitive menu across the top of the interface that appears when working on drawings. The drawing ribbon arranges commands into logical tasks through tabs and groups.

---

### 3.2 Understanding the Folder Browser

The Folder Browser is a pane in the Navigator that enables you to browse the folders on your computer and network.

- **The Folder Browser is divided into:**
  - Common Folders
  - Folder Tree
- **The Folder Browser enables you to:**
  - Browse folders.
  - View In Session objects.
  - View contents of your Desktop, My Documents, and Network Neighborhood.
  - Browse directly to the Working Directory.
  - Resize the width by dragging the sash control.
  - Click the sash expand/collapse buttons to close the Navigator.
Folder Browser Theory

The Navigator is a pane in the Pro/ENGINEER user interface that contains a series of tabs across the top. One of those tabs is the Folder Browser. By default, Pro/ENGINEER launches with the Folder Browser open. The Folder Browser enables you to browse the folders on your computer and network. You can resize the Folder Browser width by dragging the sash control or close the Navigator entirely by clicking the sash expand/collapse buttons.

The Folder Browser is divided into the Common Folders and the Folder Tree.

The Folder Tree

The Folder Tree enables you to browse your computer's folder structure. By default, the Folder Tree is collapsed at the bottom of the Folder Browser window. You can also use the Folder Tree to set a new working directory, add folders to the Common Folders, as well as add, delete, and rename folders on your computer. The contents of a folder selected in the Folder Tree are displayed in the Browser.
The Common Folders

The Common Folders area of the Navigator contains folders that, when selected, direct you to the folder location in the Folder Tree or Browser. To add a folder to this area of the interface, right-click the folder in the Folder Tree or Browser and select Add to common folders. The six standard Common Folders include:

- In Session — Enables you to view all files currently In Session.
- Desktop — Enables you to view the contents of your Desktop.
- My Documents — Enables you to view the contents of your My Documents folder.
- Working Directory — Enables you to view the contents of the current Working Directory.
- Network Neighborhood — Enables you to view the contents of your Network Neighborhood.
- Favorites — Enables you to view the folders or Web sites you have designated as favorites. To access your favorites you could also select the Favorites tab from the top of the Navigator.

3.3 Understanding the Web Browser

The Web Browser is an embedded Pro/ENGINEER window that enables you to perform context-sensitive tasks.

- You can perform the following tasks:
  - Browse the file system.
  - Preview Pro/ENGINEER models.
  - Open Pro/ENGINEER models.
  - Browse and Navigate Web pages.
  - Set the Working Directory.
  - Cut/Copy/Paste/Delete folders and objects.

Understanding the Web Browser Theory

The browser is an integrated content viewer within Pro/ENGINEER Wildfire. It works in conjunction with the Folder Browser so you can find files on your computer as well as browse Web pages. The browser is embedded in the Pro/ENGINEER interface, and slides over the graphics window. The Web browser is divided into four sections: file list, preview window, browser controls, and sash.
- **File List** — Displays the contents of a folder selected in the Folder Browser. You can set either List or Details display, filter the list based on file type, or display instances and/or all versions of a file. Double-click a folder to view its contents or double-click a file to open it in Pro/ENGINEER. Select a file to preview it in the preview window or drag and drop it into the graphics window to open it. You can also cut, copy, paste, and delete folders and objects in the File List.

<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Last modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>appearance.asm</td>
<td>92 KB</td>
<td>13-Feb-09 04:32:45 PM</td>
</tr>
<tr>
<td>bolt_5-10_5.prt</td>
<td>94 KB</td>
<td>13-Feb-09 04:32:50 PM</td>
</tr>
<tr>
<td>chuck_5.prt</td>
<td>315 KB</td>
<td>13-Feb-09 04:32:54 PM</td>
</tr>
<tr>
<td>chuck-collar_5.prt</td>
<td>688 KB</td>
<td>13-Feb-09 04:32:59 PM</td>
</tr>
<tr>
<td>drill_chuck_5.asm</td>
<td>46 KB</td>
<td>13-Feb-09 04:33:04 PM</td>
</tr>
<tr>
<td>final_gear_shpt_5.prt</td>
<td>1 MB</td>
<td>13-Feb-09 04:33:08 PM</td>
</tr>
<tr>
<td>gearbox_front_5.prt</td>
<td>1 MB</td>
<td>13-Feb-09 04:33:13 PM</td>
</tr>
<tr>
<td>gearbox_rear_5.prt</td>
<td>2 MB</td>
<td>13-Feb-09 04:33:18 PM</td>
</tr>
<tr>
<td>primary_gear_shpt_5.prt</td>
<td>396 KB</td>
<td>13-Feb-09 04:33:22 PM</td>
</tr>
<tr>
<td>reduction_gear_shpt_5.prt</td>
<td>2 MB</td>
<td>13-Feb-09 04:33:26 PM</td>
</tr>
<tr>
<td>standard_bil_5.prt</td>
<td>603 KB</td>
<td>13-Feb-09 04:33:34 PM</td>
</tr>
</tbody>
</table>

- **Preview Window** — When a model is selected from the file list, you can dynamically preview it by expanding the preview window. You can Spin, Pan, and Zoom in the preview window to observe model geometry. You can also edit the model display. By default, the preview window is collapsed at the bottom of the browser.

- **Browser Controls** — The Web browser contains standard control buttons Back, Forward, Stop, Refresh, Home, and Print, and supports tabbed browsing. Select a sub-folder to view its contents in the browser, or type a Web address in the Address field. Click the arrow next to a folder in the Address field to view its contents or begin typing the name of the desired file or folder in the Search field to dynamically filter the folder's contents in
the browser. You can switch between tabs by clicking on the desired one, as well as add and close tabs.

- **Sash** — Enables you to open or close the browser, as well as adjust its width. To open or close the browser, click the expand/collapse buttons on the sash. To adjust the width of the browser, drag the window sash.

3.4 Understanding the Window Menu

The Window Menu contains commands for activating, opening, closing, and resizing Pro/ENGINEER windows. You can also switch between open windows.

- A window must be active to use all applicable Pro/ENGINEER features.
- The word Active appears on the title bar of the active window next to the model name.
- The active model has a dot next to its name in the Window menu.

The Importance of the Active Model

Pro/ENGINEER enables you to have multiple windows open at the same time, each containing a different model. This is a common occurrence during the design process. However, at any given moment, all applicable functionality is available only on the active model. Click Window > Activate to activate the model in the window you selected, or click Window > MODEL_NAME to activate a different open window. You can determine which window is active in two different ways:
• The word Active appears on the title bar of the active window next to the model name.
• The active model has a dot next to its name in the Window menu.

Other Window Menu Functions

In addition to activating windows and switching between open windows, the following additional functions are available in the Window menu:

• Create a new window - When a part or assembly is open, click Window > New to create a new window with the current object present in the new window. This new window becomes the active window.
• Close a window - Clicking Window > Close closes the active window. If there was an object in that window, the object remains in memory. If only one window was open, the object is removed from the window and the window remains open.
  o Resize a window - You can resize the Pro/ENGINEER window by clicking Window > Maximize, Window > Default Size, and Window > Restore. You can also click the maximize or minimize buttons in the window’s title bar.

3.5 Setting the Working Directory and Opening and Saving Files

The Working Directory is the location for opening files from and saving new files to.

• Pro/ENGINEER is started in the default working directory.
• Different working directories can be set.
• New working directory locations are not saved upon exiting Pro/ENGINEER.

Working Directory Theory

The working directory is the designated location for opening and saving files. Typically, the default working directory is the directory from which Pro/ENGINEER is started. However, there are three methods to define a new working directory:

• From the Folder Tree or Browser — Right-click the folder that is to be the new working directory and select Set Working Directory.
From the File menu — Click File > Set Working Directory and browse to and select the directory that is to be the new working directory. Click OK.

From the File Open dialog box — Right-click the folder that is to be the new working directory and select Set Working Directory.

You can browse directly to the working directory at any time by selecting the Working Directory common folder from the Navigator.

The new working directory setting is not saved upon exiting Pro/ENGINEER.

Opening Files

You can use any of the following methods to open a file:

- Browse to the desired folder using the Navigator (either with Common Folders or through the Folder Tree) to display its contents in the browser. Then, you can either double-click the file in the file list, or right-click the file in the file list and select Open.

- You can also drag the file from the file list onto the graphics window.

- Click File > Open from the main menu or Open from the main toolbar and the File Open dialog box appears. Browse to the file, select it, and either double-click it or click Open.

The File Open dialog box is the equivalent of the Navigator and Browser combination in the main interface.

Saving Files

You can use any of the following methods to save a file:

- Click File > Save from the main menu
- Click Save from the main toolbar. By default, a file is saved to the current working directory. However, if a file is retrieved from a directory other than the working directory and then saved, the file saves to the directory from which it was retrieved.

Saving a Copy of Files

You can also save a copy of an existing file. Saving a copy enables you to create an exact copy of a file, but with a different name. When saving a copy of an assembly, you must also decide what to do about its dependent components. You can do nothing, or save a copy of them also and either rename them with a suffix or give them all new names.
Procedure: Setting the Working Directory and Opening and Saving Files

Scenario

Set the working directory, and open and save a file.

Task 1. Set the working directory, open a file, and then save it.

1. In the **Folder Browser**, click **Working Directory**.
   - Click **Folder Tree** to expand it.
   - If necessary, expand the Intro_ProE_WF5 folder and click **Module_03** to view its contents in the Browser.
   - Right-click the **Sample_Topic** folder and select **Set Working Directory**.

   For each procedure in this course, the working directory to be set is specified in the header at the top.

2. In the Browser, double-click **Sample_Topic** to view its contents.
   - Select NUT.PRT.
   - Click and drag the Preview window to expand it.
   - In the Preview window, right-click and select **Refit**.
   - Double-click NUT.PRT to open it.
3. Click **Save** from the main toolbar.
   - Click **OK**.

4. Click **Close Window** from the main toolbar.

**Task 2. Set a new working directory, open a new model, and then save it.**

1. In the **Folder Tree**, expand the **Sample_Topic** folder.

2. Right-click **Sample_Subfolder** and select **Set Working Directory**.

3. Double-click **Sample_Subfolder** to view its contents in the Browser.

4. Double-click **SCREW.PRT** to open it.
5. Click the **Folder Browser**.

6. In the **Folder Tree**, right-click the **Sample_Topic** folder and select **Set Working Directory**.

7. Click **Save**.

   o Notice that even though the working directory is set to **Sample_Topic**, the file is saved to **Sample_Subfolder**.
   o Click **OK**.

8. Click **Close Window** from the main toolbar.
9. Close the **Folder Tree** in the **Folder Browser**.

This completes the procedure.

### 3.6 Managing Files in Pro/ENGINEER

Pro/ENGINEER is a memory-based system, meaning that files are stored within RAM while you work on them.

- An object in system memory is In Session.
- Erasing Memory (RAM)
  - Erase Current
  - Erase Not Displayed
- Version Numbers are increased by one each time you save the model.
- Deleting Models
  - Delete All Versions
  - Delete Old Versions
- Renaming Models
  - Rename On Disk and In Session
  - Rename In Session

**Understanding In Session Memory and Erasing Models from It**

Pro/ENGINEER Wildfire is a memory-based system, which means that files you create and edit are stored within system memory (RAM) while you are working on them. It is important to remember that until you save your files, you risk losing them if there is a power outage or system crash. When a model is in system memory, it is referred to as being **In Session**.

Models are stored In Session (in system memory, or RAM) until you either erase them or exit Pro/ENGINEER Wildfire. When you close the window that contains a model, the model is still In Session. This is especially important if you are working on files that have the same name but are in various stages of completion, such as in this course. Both the Folder Browser and File Open dialog boxes have an icon that will cause only models In Session to be displayed.

There are two different methods to erase models from session:

- **Current** — Only the model in the current window is erased from system memory (and the window closed). You can click **File > Erase > Current** from the main menu to erase the current window’s contents from system memory.
• Not Displayed — Only erases from system memory those models that are not found in any Pro/ENGINEER windows. You can click **Erase Not Displayed** from the main toolbar or you can click **File > Erase > Not Displayed** from the main menu.

Erasing models does not delete them from the hard drive or network storage area; it only removes them from that session.

**Understanding Version Numbers**

Every time you save an object, you write it to disk. Rather than overwriting the current file on disk, the system creates a new version of the file on disk and gives it a version number that increments each time the file is saved. This is also known as a *dot number*, and can be seen in the lower-right figure.

**Deleting Models**

Deleting files permanently removes them from the working directory on your hard drive or network storage area. Be careful when deleting files; you cannot undo deleted files.

There are two different methods to delete models:

• **Old Versions** — the system deletes all but the latest version of the given file.
• **All Versions** — the system deletes all versions of the given file.

**Renaming Models**

If you need to edit the name of any model, you can rename it from directly within Pro/ENGINEER.

There are two different methods to rename models:

• **On Disk and In Session** — the system renames the file both in system memory and on the hard drive.
• **In Session** — The system renames the file only in system memory.

Problems can result if you rename a file on disk and then retrieve a model (not already in session) that depends on the previous file name; for example, a part cannot be found for an assembly.
Procedure: Managing Files in Pro/ENGINEER

Scenario
Erase files from memory and rename a part.

Task 1. Open and close files to understand the In Session concept.

1. Click Close Window from the main toolbar.

2. Click Erase Not Displayed from the main toolbar and click OK from the Erase Not Displayed dialog box.

3. Click Working Directory from the Folder Browser to view the working directory contents in the Browser.

4. In the Browser, double-click DRILL_BIT_BLACK.PRT to open it again.

5. Click Folder Browser from the top of the model tree.


7. In the Browser, double-click DRILL_BIT_GRAY.PRT to open it.

8. Click Close Window from the main toolbar to close the window containing DRILL_BIT_GRAY.PRT. This leaves DRILL_BIT_BLACK.PRT still open.
9. Close the Browser window by clicking the sash collapse button.

10. Click **Folder Browser** from the top of the model tree.

11. In the Folder Browser, click **In Session** to view in session contents in the Browser.

   - Right-click **DRILL_BITGRAY.PRT** and select **Open**.

12. Click **Close Window** from the main toolbar.

13. Click **Erase Not Displayed** from the main toolbar.

14. Click **OK** from the Erase Not Displayed dialog box to erase **DRILL_BIT_GRAY.PRT** from system memory.
15. Click **Folder Browser** from the top of the model tree.

16. Click **In Session** from the Folder Browser. Notice that **DRILL_BIT_GRAY.PRT** is no longer in session memory.

17. Close the Browser by clicking the sash collapse button.

**Task 2. Rename DRILL_BIT_BLACK.PRT and erase it from session.**

1. Click **File > Rename** from the main menu.

2. In the Rename dialog box, edit the new name to **DRILL_BIT_NEW**.

3. Verify that the **Rename on disk and in session** option is selected.

4. Click **OK** to complete the rename.

5. Click **OK** from the Rename Success dialog box.
6. Click **Close Window**. 

7. Click **Erase Not Displayed** from the main toolbar.

8. Click **OK** from the Erase Not Displayed dialog box.

This completes the procedure.

### 3.7 Understanding Basic Display Options

You can modify the display of both the model and datum types.

- Display is controlled independently for the following datum options:
  - Datum Planes
There are four different model display options:
- Shaded
- No Hidden
- Hidden Line
- Wireframe

Repaint redraws the screen.

Setting Datum Display

Datum entities are 2-D reference geometry that you use for building feature geometry, orienting models, dimensioning, measuring, and assembling. There are four main datum types:

- Datum Planes
- Datum Axes
- Datum Points
- Coordinate Systems
The display of each of these datum types is controlled independently by using the following icons on the main toolbar:

- **Plane Display** - Enable/Disable datum plane display.
- **Axis Display** - Enable/Disable datum axis display.
- **Point Display** - Enable/Disable datum point display.
- **Csys Display** - Enable/Disable datum coordinate system display.

The initial datum display for a given exercise is included after the specified file to be used for that exercise. For example, `Plane Display Axis Display Point Display Csys Display` means that you should display datum planes only, and that you should not display datum axes, datum points, and datum coordinate systems.

**Setting Model Display**

There are four different 3-D model display options in the graphics window:

![Model Display Options](image-url)
- **Shading** — The model is shaded according to the view orientation. Hidden lines are not visible in shaded view display.
- **No hidden** — Hidden lines in the model are not displayed.
- **Hidden line** — Hidden lines in the model are displayed, by default, in a slightly darker color than visible lines.
- **Wireframe** — Hidden lines are displayed as regular lines. That is, all lines are the same color.

In the lower-right figure, the same model is displayed in four different ways. Clockwise from the top left, the display is Shaded, No Hidden, Wireframe, and Hidden Line.

**Repainting the Screen**

You can repaint a view to remove all temporarily displayed information. Repainting redraws the screen, and is done either by clicking **View > Repaint** from the main menu or **Repaint** from the main toolbar.

**Procedure: Understanding Basic Display Options**

**Scenario**

Edit the datum entity display and model display.

Task 1. **Edit the datum display.**

1. Click **Axis Display**, **Point Display**, and **Csys Display** from the main toolbar to disable their display.
2. Click **Plane Display** from the main toolbar to disable their display.

3. Click **Axis Display** from the main toolbar to enable their display.

4. Click **Axis Display** to disable their display.

5. Click **Point Display** to enable their display.
6. Click **Point Display** to disable their display.

7. Click **Csx Display** to enable their display.

8. Click **Csx Display** to disable their display.
Task 2. Edit the model display.

1. Click No hidden \(\text{No hidden}\) from the main toolbar.

2. Click Hidden line \(\text{Hidden line}\).
3. Click **Wireframe**.

4. Click **Shading**.

This completes the procedure.

### 3.8 Analyzing Basic 3-D Orientation

Manipulate the 3-D orientation of your design models in the Pro/ENGINEER Wildfire graphics window.
Keyboard/Mouse Orientation:
- Spin
- Pan
- Zoom
- Turn
- Wheel Zoom

Additional Orientation Options:
- Previous
- Refit
- Named View List
- Spin Center

3-D Orientations using the Keyboard and Mouse
Orientation using Keyboard and Mouse Combinations

To view a model in a specific orientation, you can spin, pan, and zoom the model using a combination of keyboard and mouse functions. For each orientation, you press and hold a key and click the appropriate mouse button, as shown in the following table.

<table>
<thead>
<tr>
<th>Orientation</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spin</td>
<td><img src="image" alt="Spin Orientation" /></td>
</tr>
<tr>
<td>Pan</td>
<td><img src="image" alt="Pan Orientation" /></td>
</tr>
<tr>
<td>Zoom</td>
<td><img src="image" alt="Zoom Orientation" /></td>
</tr>
</tbody>
</table>
Cursor over the area of interest before zooming in. The zoom function uses the cursor position as its area of focus. You can also zoom by using the scroll wheel. To control the level of zoom, press a designated key while using the scroll wheel, as shown in the following table:

<table>
<thead>
<tr>
<th>Zoom Level</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom</td>
<td><img src="image1.png" alt="Zoom" /></td>
</tr>
<tr>
<td>Fine Zoom</td>
<td><img src="image2.png" alt="Fine Zoom" /></td>
</tr>
</tbody>
</table>

```
In addition to using keyboard and mouse combinations, the following additional model orientation options are available:

- **Previous** - Reverts the model to the previously displayed orientation by clicking **View > Orientation > Previous**.
- **Refit** — Refits the entire model in the graphics window.
- **Named View List** — Displays a list of saved view orientations available for a given model. Select the name of the desired saved view, and the model reorients to the selected view. The default Pro/ENGINEER template comes with the following views:
  - **Standard Orientation** — The initial 3-D orientation which cannot be altered.
  - **Default Orientation** — Similar to the Standard Orientation, but its orientation can be redefined to a different orientation.
  - **BACK, BOTTOM, FRONT, LEFT, RIGHT, and TOP**.
- **Spin Center** — Enables and disables the spin center. When enabled, the model spins about the location of the spin center. When disabled, the model spins about the cursor location. Disabling the spin center can be useful when orienting a long model, like a shaft.

**Procedure: Analyzing Basic 3-D Orientation**

**Scenario**
Practice using saved views, the spin center, and basic keyboard and mouse model orientation.
Task 1. Use saved views.

1. Click **Named View List** from the main toolbar and select TOP.
2. Click **Named View List** and select LEFT.
3. Click **Named View List** and select **Default Orientation**.

Task 2. Use the spin center.

1. Middle-click and drag to spin the assembly.
2. Spin the assembly again in a different direction.
3. Spin the assembly in a third direction.
The assembly is spinning about the spin center.

4. Click **Named View List** and select **Standard Orientation**.

5. Click **Spin Center** from the main toolbar to disable it.

6. Cursor over the lower portion of the assembly, near the CHUCK_2.PRT, and spin the assembly.

7. Click **View > Orientation > Previous** from the main menu.

8. Cursor over the upper portion of the assembly and spin the assembly. Notice that the center of rotation is the cursor location.

9. Click **Spin Center** from the main toolbar to enable it.
Task 3. Pan the assembly.

1. Press and hold SHIFT, then middle-click and drag to pan the assembly.

2. Click Named View List and select Standard Orientation.
Task 4. Turn the assembly.

1. Press and hold CTRL, then middle-click and drag to the left to turn the assembly counter-clockwise.

2. Press and hold CTRL, then middle-click and drag to the right to turn the assembly clockwise.

3. Click Named View List and select Standard Orientation.

Task 5. Zoom in and out of the assembly.

1. Press and hold CTRL, then middle-click and drag upward to zoom out.

2. Press and hold CTRL, then middle-click and drag downward to zoom in.

3. If your mouse is equipped with a wheel:
   
   - Roll the mouse wheel away from you to zoom out.
   - Roll the mouse wheel towards you to zoom in.
4. Click **Named View List** and select **Standard Orientation**.

5. Cursor over the hole next to the teeth. Press and hold CTRL, then middle-click and drag downward to zoom in to the hole.

6. Click **Refit** from the main toolbar to refit the model.

This completes the procedure.

---

### 3.9 Understanding the View Manager

The view manager is a content-sensitive dialog box that enables you to edit how a model displays in the graphics window. The view manager contains numerous tabs that enable you to create and manage the following:

- View orientations
- Style states
- Cross-sections
- Explode states
- Layer states
Some important facts about the view manager include:

- The active item is indicated by a red arrow next to its name. In the figure, the active view orientation is the Front.
- A plus sign after the name of the active item indicates that it has changed. You can either save the modified item to capture what has changed, or double-click it or another item to dismiss the changes. In the figure, view orientation Front has been modified from how it was saved.

### 3.10 Creating and Managing View Orientations

You can create and edit view orientations using the View Manager and Orientation dialog boxes.

- Orientation Dialog Box:
  - Orient by reference.
Two references and two directions required

**Saved View Orientation Theory**

A model displays in a certain view orientation when it is first created and any time it is retrieved. In addition to using mouse and keyboard methods to orient a model, you can create predefined view orientations and save them as part of the model. This enables you to set the model orientation in a repeatable, consistent manner for company standards, drawing creation, and quick navigation. Not only does a saved view capture the model's orientation, it also captures the model's level of zoom in the graphics window.

**Creating a New View Orientation**

You can create a new view orientation using the view manager or the Orientation dialog box. When you create a new view orientation, a default name is created for your view. If desired, you can edit the view name. The new view orientation is automatically created at the current model orientation. You can edit the view orientation by redefining it. The Orientation dialog box enables you to specifically define your model orientation, compared to using keyboard and mouse functions, which are more approximate.

The view orientations that display in the Orient tab of the view manager are the same as those that are displayed in the Named View List and Orientation dialog box.

**Orient by Reference**

One method of changing the model orientation in the Orientation dialog box is to Orient by Reference. The Orient by Reference option enables you to select references by which to orient the model. Two directions and two references are required to orient a model.

You can click Undo from the Orientation dialog box to undo any changes you made. The model returns to its most current view state.

**Creating View Orientations in the Orientation Dialog Box**

You can click Reorient from the main toolbar to open the Orientation dialog box directly. This method will display the saved views directly inside of the dialog box. Therefore, you can Orient by Reference and save a new view orientation directly within the dialog box, which is an alternative to using the view manager.
Procedure: Creating and Managing View Orientations

Scenario
Create and access saved view orientations.

Task 1. Create view orientations with the view manager.

1. Orient the model as shown.

2. Start the View Manager from the main toolbar.
   - Select the Orient tab and click New.
   - Edit the name to 3D-1 and press ENTER.

3. In the view manager, double-click Default Orientation, then double-click 3D-1.

4. Zoom in on the assembly as shown.

5. In the view manager, click New.
   - Edit the Orientation name to Conn_Rod and press ENTER.
   - Click Close.
Task 2. Create view orientations with the Reorient dialog box.

1. Click **Named View List** and select **Default Orientation**.

2. Click **Reorient** from the main toolbar.

3. Select the surface in the upper figure as Reference 1.

4. Select the surface in the lower figure as Reference 2.

5. Edit the Reference 2 direction from Top to **Left**.

6. Spin the assembly as necessary and select the surface in the lower figure again as Reference 2.
7. In the Orientation dialog box, expand the Saved Views area if necessary.

   - In the Name field, type the name of the saved view as CYL_HOLE.
   - Click Save and OK.
Task 3. Redefine view orientations with the view manager.

1. Start the View Manager.
   - Double-click 3D-1.

2. Orient the model as shown.

3. In the view manager, right-click on 3D-1(+) and click **Save**.

4. Click **OK** from the Save Display Elements dialog box.
5. In the view manager, double-click **Cyl_Hole**.
   - Right-click **Cyl_Hole** and select **Redefine**.

6. Orient the assembly as shown

7. Select the surface shown in the upper figure as the new Reference 1.
   - In the graphics window, select the surface shown in the lower figure as the new Reference 2.
   - Click **OK** from the Orientation dialog box.
8. Click **Close** from the view manager.

This completes the procedure.
3.11 Creating Style States using the View Manager

Create a style state in an assembly to capture components in various displays and visibilities.

- Style states are only in assemblies.
- Set individual model display (shaded, transparent, wireframe, hidden line, no hidden).

Style State Example

Style States Theory

A style state is a captured state of component visibility in an assembly. You can vary component visibility independently of other components. For example, you can set one component to be displayed as shaded, set another to be displayed as wireframe, and set still another to be displayed as no hidden. In the figure, the component display of the cylinder head has been edited, while the remainder of the assembly remains shaded.

If you redefine a style state you can also edit its component display to blank, or turn off, the display of any component in the assembly.
Creating a Style State

To create a new style state, click New in the Style tab of the view manager. If desired, edit the default style name and press ENTER. The Edit dialog box opens, enabling you to blank (or, in other words, turn off) components from the graphics window. You can select components either from the graphics window or from the model tree. You can also select the Show tab and then set the method of model display. As you select components, their model display changes to the method currently selected in the Edit dialog box.

As you define component visibilities and displays, the model tree displays which settings have been specified for the components. When you finish creating the style state, the graphics window displays the name of the style state.

You can also create style states by first editing component displays, and then capturing the displays in a style state.

There are two default style states in every assembly: Default Style and Master Style. The Master Style cannot be modified, but the Default Style can be modified.

Procedure: Creating Style States using the View Manager

Scenario
Create style states.

Task 1. Create a style state using the view manager.

1. In the graphics window, select the CYLINDER_4.PRT.
2. In the main menu, click View > Display Style > No Hidden.
3. Start the View Manager from the main toolbar.

4. In the view manager, select the Style tab.
   
   - Right-click Master Style and select Save.

5. In the Save Display Elements dialog box, edit the Style name to Cyl_No_Hidden and click OK.

6. In the view manager, double-click Master Style.
Task 2. Create another style state based on the CYL_NO_HIDDEN style state.

1. In the graphics window, press and hold CTRL and select the ENG_BLOCK_FRONT_4.PRT and ENG_BLOCK_REAR_4.PRT.

2. Click View > Display Style > Transparent from the main menu.

3. In the view manager, right-click Cyl_No_Hidden and select Save.

4. In the Save Display Elements dialog box, edit the Style name to Castings_Transparent and click OK.
5. In the view manager, double-click **Master Style**.

6. Click **Close**.

This completes the procedure.
3.12 Managing and Editing Appearances

You can create and manage appearances and apply them to your models.

- A company-standard appearance file is common.
- Use the Appearances Manager to manage, create, and edit appearances.
- Use the appearance gallery to select and apply appearances.
- Apply appearances to parts, surfaces, or components.
- Clear selected or all appearances.

Managing and Editing Appearances Theory

A new model is assigned a greyish-blue, solid appearance by default. The appearance palette can be used to set a new appearance for an entire model, surface, or component in an assembly. The appearance gallery contains a list of user-defined appearances that a company typically creates and distributes as its standards. Your company-specific appearance gallery is usually loaded automatically when you launch Pro/ENGINEER.

Appearances within Pro/ENGINEER typically revolve around three main tasks:

- Creating and editing appearances.
- Applying and clearing appearances.
- Managing appearances.

All appearance operations are initiated from a single icon in the main toolbar. However, the icon is divided into two parts: the icon itself, and the down arrow next to it. When you see in the content, you should select the down arrow to the right of the icon; when you see in the content, you should select the icon itself.

The Appearance Gallery

You access the appearance gallery by clicking Appearance Gallery from the main toolbar. You must select the arrow portion of this icon to access the appearance gallery. The appearance gallery is divided into three distinct palettes:

- My Appearances — Displays an available list of user-defined appearances.
- Model — Displays the appearances that are applied to a component,
part, or surface display.

- Library — Displays a predefined library of appearances from which to use. These libraries accurately simulate real-world materials including metals and plastics. You can switch the library that is displayed by expanding the drop-down list next to it.

The Appearance Manager

The appearance manager enables you to manage your appearances. You access the appearances manager by clicking Appearance Gallery from the main toolbar and selecting Appearances Manager. The Appearances Manager dialog box contains both the contents of the appearance gallery and the appearance editor.

Creating and Editing Appearances

An appearance consists of both Color and Highlight Color. You can modify the properties of both within the appearance editor to create your desired appearance. You can even apply textures and decals to your appearance.

To edit an appearance within the appearances manager, you must first copy it into the My Appearances palette. You can copy the appearance from the Library palette or Model palette by right-clicking and selecting Copy to My Appearances. You can also select an appearance in the My Appearances palette and click New Appearance, which copies the appearance to a new name.

You can also edit an appearance by right-clicking it in the appearance gallery and selecting Edit. This launches the appearance editor.

💡 Use pre-existing appearances as a starting point to quickly and easily create new appearances.

Applying Appearances

Once an appearance has been created, you can apply it to entire part models, part surfaces, or components in an assembly. You can use the selection filter, if necessary, to filter the item that you wish to apply the appearance. If an appearance is assigned to a part at the assembly level, the appearance is saved in the context of the assembly and does not change the appearance of the part at the part level. You can select the appearance first and then apply it to the reference, or you can select the reference first and then apply the appearance.
To apply an appearance, you can click **Appearance Gallery** from the main toolbar and select the desired appearance. This selected appearance is now the “active” appearance, and is the appearance that is applied to the selected references. You can also search for the appearance using the Search field at the top of the appearance gallery and Appearances Manager. Clicking **Apply Appearance** (the icon itself, not the down arrow portion of the icon) from the main toolbar enables you to apply the last active appearance.

**Model Appearances versus My Appearances**

Appearances that are applied to a component, part, or surface display in the Model palette of the appearance gallery and Appearances Manager. You can modify a Model appearance either within the appearances manager or within the model appearance editor. This enables you to replace, or edit, the Model appearance to dynamically change all applied occurrences without affecting the appearance located in the My Appearances palette. Once you are satisfied with the modified appearance, you can copy it into the My Appearances palette within the appearances manager.

**Clearing Appearances**

To clear appearances applied to a component, part, or surface, you can either click **Clear Appearance** or **Clear All Appearance** from the appearance gallery. When clearing an appearance, you are prompted to select the references from which you want the appearance removed. However, the Model appearance is still retained.

For a part, clearing all appearances removes all Model appearances and reverts the part to its default assigned appearance. For an assembly, clearing all appearances removes all Model appearances and returns the components to the appearances they were assigned at the part level.

**Procedure: Managing and Editing Appearances**

**Scenario**
Create and apply appearances.

**Task 1. Copy a library appearance into the My Appearances palette.**
1. Click **Appearance Gallery** from the main toolbar and select **Appearances Manager**.

2. In the Appearances Manager dialog box, select the drop-down in the Library palette and select **std-metals.dmt**.

3. Select the **ptc-std-aluminum-polished** appearance, right-click, and select **Copy to My Appearances**.

4. Locate and select this new appearance from the My Appearances section.

5. Click **Close**.

**Task 2. Apply an appearance to assembly components.**

1. Press and hold **CTRL** and select GEARBOX_REAR_5.PRT and GEARBOX_FRONT_5.PRT.

2. Click **Apply Appearance** from the main toolbar.
Task 3. Copy and edit an appearance.

1. Click Appearance Gallery and select Appearances Manager.

2. Select the ptc-std-aluminum-polished appearance sphere from the Model section.

3. Right-click and select Copy to My Appearances.

4. In the My Appearances section of the dialog box, select the new <ptc-std-aluminum-polished> appearance and edit the name to aluminum-polished-transparent and press ENTER.

5. Drag the Transparency slider to 70 and click Close.
6. Click Appearance Gallery and select the aluminum-polished-transparent appearance sphere.

7. Press and hold CTRL and select GEARBOX_REAR_5.PRT and GEARBOX_FRONT_5.PRT, and then click OK.

Task 4. Create a new appearance.

1. Click Tools > Appearances Manager.

2. In the My Appearances section of the dialog box, select the upper-left appearance sphere, ref_color1.

   - Click New Appearance to copy the ref_color1 appearance.
   - Edit the new appearance Name to MyColor1 and press ENTER.
3. In the Basic tab, click the Color rectangle to edit the color.
   - Expand the RGB / HSV Slider section.
   - Edit the RGB colors to 127, 137, and 145, and click Close.

4. Click Close from the Appearances Manager.

![Color Editor](image)

**Task 5. Apply an appearance to a part.**

1. In the graphics window, select CHUCK_5.PRT.

2. Right-click and select Open.

3. Click Apply Appearance ●.

4. Select CHUCK_5.PRT from the model tree and click OK.
5. Click **Close Window** to view the new part appearance in the assembly.

**Task 6. Apply an appearance to a group of surfaces.**

1. In the model tree, expand **DRILL_CHUCK_5.ASM** and select **CHUCK_COLLAR_5.PRT**.

2. Right-click and select **Open**.

3. Click **Appearance Gallery** and select the **Black** appearance.

4. Press and hold CTRL, and select the four surfaces shown.

5. Click **OK**.
6. Click Close Window to view the new part surface appearance in the assembly.

This completes the procedure.

### 3.13 Setting Up New Part Models

**Creating New Parts**

Create new part models within Pro/ENGINEER either by using File > New, or clicking New. You type the name of the part and select whether you want to use a default template or not. Unless you select the Empty template, the new part will display in the graphics window with some default datum features.

**Using Templates**

New models should be created using a template. Your company will likely have created customized templates to be used. Using a template to create a new model is beneficial because it means that, regardless of who created it, the
model will contain the same consistent set of information, including:

- **Datums** — Most templates contain a set of default datum planes and default coordinate system, all named appropriately.
- **Layers** — When every model contains the same layers, management of both the layers and items on the layer is easier.
- **Units** — Most companies have a company standard for units in their models. Creating every model with the same set of units ensures that no mistakes are made.
- **Parameters** — Every model can have the same standard metadata information.
- **View Orientations** — Having every model contain the same standard view orientations aids the modeling process.

Creating Parameters

Parameters are metadata information that can be included in a model template or created by a user in his own part or assembly. Parameters are important because they enable you to add additional information into part and assembly models. Parameters have several uses:

- Parameters can drive dimension values through relations, or be driven by relations.
- Parameters can be used as a column in a family table. For example, the parameter Cost might have a different value for each instance.
Parameter values can be reported in drawings, or viewed with data management tools such as Pro/INTRALINK or Windchill solutions.

User parameters can be added at the model level (part, assembly, or component) or to a feature or pattern.

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>DESCRIPTION</td>
<td>String</td>
<td>NEW PART</td>
</tr>
<tr>
<td>MODELED_BY</td>
<td>String</td>
<td></td>
</tr>
<tr>
<td>PURCHASED</td>
<td>Yes/No</td>
<td>NO</td>
</tr>
<tr>
<td>PART_NUMBER</td>
<td>Integer</td>
<td>596289</td>
</tr>
</tbody>
</table>

Examples of Parameters

You can create parameters that accept the following types of values:

- **Real Number** — Any numerical value. For example 25.5, 1.666667, 10.5E3, and Pi.
- **Integer** — Any whole number. For example 1, 5, and 257.
- **String** — Any consecutive sequence of alphanumeric characters (letters or numbers).
- **Yes/No** — Accepts either the YES or NO value.

Procedure: Setting Up New Part Models

Scenario
Create new part models.

Task 1. Create a new part using the default template.

1. Click **New** from the main toolbar.
   - Select **Part** as the Type and **Solid** as the Sub-type.
   - Edit the Name to **new_part**.
   - Notice that the **Use default template** check box is selected.
   - Click **OK**.
2. Explore the default datum features created in the graphics window and model tree.

![Layer Tree]

3. In the model tree, click **Show** and select **Layer Tree**. Notice the default layers.

![Layers]

4. Click **File > Properties** from the main menu to access the Model Properties dialog box.

   - Notice the units that are set.
   - Click **Close**.

![Model Properties]

5. Click **Tools > Parameters** from the main menu.

6. In the Parameters dialog box, click in the **Description** parameter **Value** field.

   - Edit the value to **NEW PART** and press ENTER.
Click **New Parameter** and edit the Name to **PURCHASED**.
- Edit the Type to **Yes No** and notice the default value of **NO**.
- Click **New Parameter** and edit the Name to **PART_NUMBER**.
- Edit the Type to **Integer**.
- Click in the **Value** field and edit the number to **596289**.
- Click **OK**.

7. Click **Named View List**. Notice the default view orientations.

8. Click **Named View List** again to close it.

**Task 2. Create a new part by selecting a different template.**

1. Click **New** from the main toolbar.
   - Edit the Name to **select_template**.
   - Clear the **Use default template** check box.
   - Click **OK**.

2. In the New File Options dialog box, select the **inlbs_part_solid** template.
   - Click **OK**.

3. Again, notice the datum features.
4. Click **File > Properties** from the main menu to access the Model Properties dialog box.

5. Notice the units that are set.

6. Click **Close**.

This completes the procedure.
Check your Knowledge

1. An appearance consists of...
   A - color.
   B - highlight color.
   C - textures.
   D - decals.
   E - all of the above.
   F - A and C only.

2. The Folder Browser is divided into...
   A - In Session.
   B - Common Folders.
   C - a Folder Tree.
   D - all of the above.
   E - B and C only.

3. The window menu enables you to...
   A - activate windows.
   B - open windows.
   C - resize windows.
   D - switch between open windows.
   E - all of the above.

4. The working directory...
   A - is saved upon exiting Pro/ENGINEER.
   B - cannot be changed.
C - is the designated location for opening and saving files.
D - all of the above.
E - A and C only.

5. True or False? You can pan a 3-D model.
   A - True
   B - False
Module 4

Selecting and Editing

Module Overview

Before you can edit design models or create new features on models, you have to be able to select within Pro/ENGINEER Wildfire. Selection enables you to choose features, geometry in a part model, or components in an assembly. Once a selection is made, you can perform a variety of operations including editing. Editing enables you to modify not only dimensions of existing design models or features, but you can also edit shape, size, location, and visibility.

In this module, you learn the different ways to select different items in Pro/ENGINEER as well as understand the feedback the system provides you both before and after item selection.
4.1 Understanding Pro/ENGINEER Basic Controls

Understanding Color-Based Feedback

Pro/ENGINEER provides you with color-based feedback during various operations you are performing on models in the graphics window. The following list explains the system color assignments:

- **Cyan:** Preselection Highlighting — When you cursor over a model or an area of a model, various geometry will outline in the cyan color. This is called Preselection Highlighting, which is an indicator of what would be selected if you were to click that location.
- **Red:** Selected Geometry — Once you cursor over and select geometry, it changes to red.
- **Yellow:** Preview Geometry — New geometry in a model displays in yellow, enabling you to preview the completed model. In an assembly, a new component being assembled displays in light yellow and once it is fully constrained displays in darker yellow. This yellow preview color is very beneficial; it provides you feedback when you create valid geometry during creation.

These same three colors apply for both features created in a part and components in an assembly.

Mouse and Keyboard Controls for Making Selections

Different combinations of keyboard and mouse controls enable you to use different methods to make different selections. The following table displays the keyboard and mouse selections that comprise various selection types:
<table>
<thead>
<tr>
<th>Selection Type</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preselection Highlighting (Cyan color)</td>
<td><img src="image" alt="Mouse Pointer" /> Over Geometry</td>
</tr>
<tr>
<td>Query to Next Item (Feature or Component Beneath)</td>
<td><img src="image" alt="Upright Arrow" /> Until Highlighted</td>
</tr>
<tr>
<td>Select Highlighted Geometry (Red color)</td>
<td><img src="image" alt="Upright Arrow" /></td>
</tr>
<tr>
<td>Add or Remove Items from Selection</td>
<td><img src="image" alt="Ctrl" /></td>
</tr>
<tr>
<td>Select Range of Geometry (Chain / Set Selection)</td>
<td><img src="image" alt="Shift" /></td>
</tr>
<tr>
<td>Clear Selection</td>
<td><img src="image" alt="Upright Arrow" /> On Background</td>
</tr>
</tbody>
</table>
4.2 Using Drag Handles

Drag Handle Theory

Drag handles are small, white squares that display in the graphics window. These graphical objects are used to manipulate geometry during creation or redefinition in real time. Using your mouse, drag the handles to resize, reorient, move feature geometry in a model, or reference geometry. In an assembly, drag the handle to adjust component offset. Your changes display dynamically in the graphics window. Right-click a drag handle to access context-sensitive menu options.

You can use various keyboard and mouse combinations to modify how the drag handle is used. The following table displays dragging options comprised of various keyboard and mouse combinations on a drag handle.

<table>
<thead>
<tr>
<th>Dragging Option</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust Drag Handle — Resize, reorient, move, and reference geometry; adjust component offset.</td>
<td><img src="image" alt="Keyboard and Mouse Selection" /></td>
</tr>
<tr>
<td>Snap Drag Handle — Reference geometry such as a datum plane, edge, point, vertex, or surface.</td>
<td><img src="image" alt="Keyboard and Mouse Selection" /> Shift</td>
</tr>
</tbody>
</table>
4.3 Using Keyboard Shortcuts

Keyboard Shortcuts Theory

You can use various keyboard shortcuts to quickly perform commonly used functions. Keyboard shortcuts facilitate a more efficient experience in the user-interface by eliminating the need to move the mouse to make icon or menu selections.

Except for the Delete operation, all keyboard shortcuts use the CTRL key on your keyboard in conjunction with another letter key. There are keyboard shortcuts for various areas of Pro/ENGINEER usage, including file operations, edit operations, and view operations.

The following table contains keyboard shortcuts for various file operations.

<table>
<thead>
<tr>
<th>Keyboard Shortcut</th>
<th>File Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL + N</td>
<td>New — Create a new object.</td>
</tr>
<tr>
<td>CTRL + O</td>
<td>Open — Open an existing object.</td>
</tr>
<tr>
<td>CTRL + S</td>
<td>Save — Save the active object.</td>
</tr>
</tbody>
</table>

The following table contains keyboard shortcuts for various edit operations.

<table>
<thead>
<tr>
<th>Keyboard Shortcut</th>
<th>Edit Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL + G</td>
<td>Regenerate — Regenerate model.</td>
</tr>
<tr>
<td>CTRL + F</td>
<td>Find, or Search — Search for, filter, and select items in the model by rule.</td>
</tr>
<tr>
<td>DEL</td>
<td>Delete — Delete selected features.</td>
</tr>
<tr>
<td>CTRL + C</td>
<td>Copy — Copy selected features.</td>
</tr>
</tbody>
</table>
The following table contains keyboard shortcuts for various view operations.

<table>
<thead>
<tr>
<th>Keyboard Shortcut</th>
<th>View Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL + R</td>
<td>Repaint — Redraw the current view.</td>
</tr>
<tr>
<td>CTRL + D</td>
<td>Standard Orientation — Display object in standard orientation.</td>
</tr>
</tbody>
</table>

### 4.4 Understanding the Model Tree

#### Model Tree Basics

The model tree is part of the Navigator window and, by default, displays along the left side of the main interface. When you open a part model, assembly, or drawing, the Navigator automatically changes its display to the model tree. The model tree contains a hierarchical list of features or components in the order created as well as the display status (hidden/unhidden, suppressed) of those features and components. The model tree can also be customized to display other information.

The model tree can be used in the following ways:

- Visualize model features/assembly components — The model tree displays all features that comprise a model. For assemblies, the model tree also displays the components that comprise that assembly, as well as the assembly constraints for each assembled component.
- Visualize feature order/component assembly order — A model's features are displayed in the order in which they were created, from top to bottom. Similarly, an assembly's components are displayed in the order in which they were assembled, from top to bottom.
- Selection — Selecting a feature or component in the model tree causes that feature or component to become selected in the graphics window.
• Editing — The model tree can be used to edit features or components, their display, or their name.

Since the model tree is part of the Navigator, it has a sash that can control the width or whether the model tree window is open or closed. The sash control can be seen in the top figure of the slide.

**Model Tree Show Options**

The Show menu is located at the top of the model tree and is accessed by clicking *Show*, as shown in the lower-right figure. The Show menu contains the following options:

- **Layer/Model Tree** — Shown in the lower-left figure on the slide, this option toggles the model tree to the layer tree so that all layers associated with a model, assembly, or drawing are displayed. If the layer tree is displayed and the Show menu is selected, the Layer Tree menu selection is replaced by the Model Tree menu selection.
- **Expand All** — Fully expands every branch within the model tree and mechanism tree.
- **Collapse All** — Fully collapses every branch within the model tree and mechanism tree.
- **Preselection Highlighting** — Toggles on or off preselection highlighting. If on, when you cursor over an item in the model tree it is preselected in the graphics window. By default, this option is turned off.
- **Highlight Geometry** — Toggles on or off Highlight Geometry. If on, when you select an item from the model tree it is also selected (in red) in the graphics window.
4.5 Understanding Model Tree Filters

Model Tree Filters Theory

The model tree contains a hierarchical list of features or components in the order created. You can filter what is displayed in the model tree both in terms of item display and feature types. The filtering of item display and feature types is controlled by the Model Tree Items dialog box, shown in the top-left figure. Open the Model Tree Items dialog box by clicking Settings from the top of the model tree, and then selecting Tree Filters.

![Model Tree Items Dialog Box](image)

The filters applied to the model tree are unique to each window except in the case of assemblies, where applied filters only propagate to sub-assemblies of assemblies.

Controlling Model Tree Item Display

The display of the following specific types of items is controlled on the left side of the Model Tree Items dialog box:

- **Features** — The top-right figure shows the model tree with the display of features turned on and off. Notice that when features are turned off, they are turned off in both the assembly and part levels of the model tree. When features are turned off in the assembly, you can only see the components that are assembled, but nothing more granular.
- **Placement folders** — Toggles the display of component placement constraints within assembly components.
- **Annotations** — Toggles the display of annotations.
- **Suppressed Objects** — Toggles the display of suppressed features and components. Suppressed objects in the model tree are preceded with a black square. In the bottom-left figure, the EDGE_ROUNDS and LUBE_HOLE features are suppressed. If the display of suppressed objects was turned off, these two features would not be visible in the model tree.
- **Incomplete Objects** — Toggles the display of incomplete features.
- Excluded Objects — Toggles the display of excluded components.
- Blanked Objects — Toggles the display of blanked mold/cast components.
- Envelope Components — Toggles the display of envelope components.
- Copied References — Toggles the display of copied references.

**Controlling Model Tree Feature Types Display**

The display of feature types is a more granular method of determining which level of feature display you want. In the Feature Types section of the Model Tree Items dialog box, you can control specifically which features to display or not display in the model tree:

- Datum Planes
- Datum Axes
- Curves
- Datum Points
- Coordinate Systems
- Rounds
- Auto Round Members
- Cosmetics
- Sketches
- Used Sketches — Used sketch features are those sketches that are used in another feature, like an Extrude or Revolve feature. When a sketch is used it is automatically changed to a hidden status, as shown in the lower-right figure.

**Saving Model Tree Display**

The model tree display can be saved to a file and loaded at any time. Click **Settings** from the top of the model tree and select **Save Settings File** to save the current model tree display. The default save location is the working directory, and the default settings file name is tree.cfg. You can configure Pro/ENGINEER to always consider tree.cfg as the default model tree display.

---

**4.6 Understanding Basic Model Tree Columns**

**Basic Model Tree Columns Theory**

You can add informational columns to the model tree, including:
• Feat # — Displays the feature number of each feature in the model tree. The first feature created in a model is feature number one, and each consecutive feature is assigned an ascending integer increment.

• Feat ID — Displays the feature ID of each feature in the model tree. The feature ID is a unique number that is assigned by Pro/ENGINEER to each feature that is created.

The information displayed in these columns can be obtained using other methods, but this particular method ensures that it is always displayed directly with no querying required. You can add other informational columns in addition to Feat # and Feat ID. In addition, you can add other column types of information including model parameters, feature parameters, layer information, and mass property information. You access the Model Tree Columns dialog box by clicking Settings from the top of the model tree and selecting Tree Columns. The order of column display and the width of a displayed column can be changed in the Model Tree Columns dialog box.

Adding Columns to the Model Tree

The columns displayed in the model tree are unique to each window except in the case of assemblies, where displayed model tree columns propagate to sub-assemblies of assemblies.

Saving Model Tree Column Display

The model tree display can be saved to a file and loaded at any time. Once you have added the desired columns to the model tree, click Settings from the top of the model tree and select Save Settings File. The default save location is the working directory, and the default settings file name is tree.cfg. You can
configure Pro/ENGINEER to always consider tree.cfg as the default model tree display.

4.7 Selecting Items using Direct Selection

Selecting Items using Direct Selection

After selecting features, geometry, or components in a model, assembly, or drawing, you are able to make modifications to the selected items. Direct selection is one of the three basic methods of selection.

Direct selection occurs when you place your mouse cursor over a feature or component and click to select it. Some key factors about direct selection include:

- You can perform direct selection on both components in an assembly and features in a model.
- You can perform direct selection in both the graphics window on a model or assembly, and in the model tree. When you initially cursor over a model in the Pro/ENGINEER Wildfire graphics window, the component or feature preselects in the cyan color. When you select the item, it becomes highlighted in red. The selected item is dependent on whether you have a part or assembly open. If you have a part open, a selected feature highlights in a red wireframe. If you have an assembly open, the selected component highlights in a red wireframe.
- You can select multiple items by using the CTRL key.
- You can select a range of items from the model tree using the SHIFT key. If you select an item, press SHIFT and select a second item, the entire range of items in between is also selected.
- You can de-select components or features three different ways:
  - Press CTRL and click the selected item again.
  - Click in the graphics window background.
4.8 Selecting Items using Query Selection

Selecting Items using Query Selection

Query selection is one of the three basic methods of selection. Query selection enables you to select features, geometry, or components that are hidden beneath another feature or model. For example, in the lower figure, you may want to select the piston so you can change the overall height of the part. However, the cylinder part obstructs your attempts to click and select the piston. In this situation, you can easily query and select the piston. There are two methods of query selection:

- Select by querying the model — When you select a model directly in the Pro/ENGINEER Wildfire graphics window, the blue edges designate a preselected item. By right-clicking the preselected model or feature, you can query directly through the initial model or feature to the next model or feature. You can continue to right-click to query the next model or feature. When you have queried to the desired model or feature, you then click to make your selection.
- Select using the Pick From List — The Pick From List is similar to querying the model, except that all of the query possibilities are listed in the dialog box for the cursor location. To activate the Pick From List, you cursor over the location you want to query and right-click and select **Pick From List**. Items highlighted in the Pick From List menu also preselect in the graphics window.

**Remember:**
Cursor over to highlight, right-click to query, and click to select.

4.9 Using the Search Tool

The Search Tool is the third basic method of selection. It includes several options to search models by a variety of criteria including:

- Look For — Specifies the type of items you want to search for. For example, you can search for only datum planes, components, or axes.
• Look By — Specifies the types of items you want to search by. This is a further refinement to the Look for option, and is context-sensitive based on the Look for option specified.

• Look In — Specifies which model or models the search will be conducted against. If an assembly or sub-assembly is specified as the Look in object, you can choose whether sub-models are included. You can set the Look in object either by selecting it from the drop-down list in the Search Tool dialog box, or you can click Select Model and select the model from the graphics window.

• Name — Enables you to refine the search by typing in part or all of the name of what you want to search for. You can also use wildcards, both at the beginning and end of the name search string. In the upper-right figure, wildcards are used to search for all features containing pin in their name.

The items that fulfill the criteria specified display in the Found list on the left side of the Search Tool. If you select items in the Found list they will preselect in the graphics window. You can select multiple items using CTRL or SHIFT, or you can select all items by pressing CTRL + A. Move items to the Selected list on the right to select them in the graphics window and therefore perform operations.

The Search Tool becomes invaluable as the complexity of your model increases.

4.10 Using the Smart Selection Filter

Pro/ENGINEER automatically selects the Smart selection filter, if it is available. When using the Smart selection filter, the selection of features, geometry, or
components is a nested process. This means you can select specific items of interest after the initial selection. There are two levels of selection when using the Smart Filter:

- Feature/Component Level
- Geometry Level

When selecting a part in the graphics window, your initial selection highlights a feature in a red wireframe. The Smart selection filter then automatically narrows the selection scope, enabling you to select specific items on that feature that you wish to either modify or use to create another feature. For example, you can select an edge where you wish to add a chamfer. The three specific items that you may wish to select highlight differently, as shown in the figure. Selected surfaces highlight as red-shaded items; selected edges highlight in bold red; and selected vertices highlight in red. The entire selection process occurs automatically. Selection of surfaces usually occurs easier if you zoom in on that area of the model first.

Assemblies have a similar selection scheme. Components are selected initially, followed by geometry such as surfaces, edges, and vertices.

The Smart selection filter is not available if you disable preselection highlighting.

### 4.11 Understanding Selection Filters

Each filter in the selection filter narrows the item types that you can select; enabling you to easily select the item you are looking for. All filters are context-sensitive, so that only those filters that are valid for the geometrical context are available. For example, the Parts filter would not be available while working in a part; rather it would be available while working in an assembly.

<table>
<thead>
<tr>
<th>Filter</th>
<th>Available Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smart</td>
<td>Parts, Features, Geometry, Datums</td>
</tr>
<tr>
<td>Parts</td>
<td>Features, Geometry, Datums</td>
</tr>
<tr>
<td>Features</td>
<td>Geometry, Datums</td>
</tr>
<tr>
<td>Geometry</td>
<td>Datums</td>
</tr>
<tr>
<td>Datums</td>
<td></td>
</tr>
<tr>
<td>Quilts</td>
<td></td>
</tr>
<tr>
<td>Annotation</td>
<td></td>
</tr>
</tbody>
</table>
assembly. Pro/ENGINEER automatically selects the best filter according to the context. However, you can always change the filter by simply selecting it from the selection filter.

The following filters are available in Part mode and Assembly mode:

- **Parts** — Available in Assembly mode only, enables you to only select components in the assembly.
- **Features** — Enables you to only select features in a part or component in the assembly.
- **Geometry** — Enables you to only select geometry, such as edges, surfaces, and vertices.
- **Datums** — Enables you to only select datum features, including datum planes, datum axes, datum points, and coordinate systems.
- **Quilts** — Enables you to only select surface quilts.
- **Annotation** — Enables you to only select annotation features.

### 4.12 Renaming Objects

#### Renaming Features

When you create a feature in a part model, it is automatically assigned a generic name based on its type. For example, the feature may be called “Sketch 1” or “Extrude 2”, or “Revolve 3”. While these names describe the type of feature, they do not describe what the feature is in the context of the design. Consequently, it can be helpful to rename the feature to something more descriptive. The top-right figure shows the model tree before and after feature renaming has occurred. You can see that the model tree is more intuitive once the features have been renamed to a descriptive name. It is much easier to find a feature that needs to be edited.
You can rename model features by using any of the following methods:

- Select the feature in the model tree or graphics window, then right-click and select **Rename** from either the graphics window or model tree.
- Select the feature to be renamed in the model tree. Once selected, select it again from the model tree.
- Click **File > Rename** from the main menu.

Names can contain up to 31 characters and may not include spaces.

**Renaming Components**

To avoid assembly failures, you must rename components within the context of the assembly instead of using Windows Explorer to rename components on the hard drive.

You can rename components by using either of the following methods:

- **Rename on disk and in session** — The system renames the component both in system memory and on the hard drive.
- **Rename in session** — The system renames the component only in system memory.

Click **File > Rename** from the main menu to rename components. Within the Rename dialog box, shown in the lower-left figure, you can click **Commands And Settings** and then select the component to be renamed from either the model tree or graphics window. You can also rename the assembly in this dialog box. In fact, this is the default item to be renamed when this dialog box appears.

### 4.13 Utilizing Undo and Redo Operations

You can undo and redo most of the operations performed on a model. The operations are sequentially stacked in memory as they are performed. You have access to the undo/redo stack when you click the Undo or Redo icons.

Operations valid for undo or redo include creating, deleting, editing, redefining, suppressing, resuming, patterning, and reordering.

The Undo and Redo operations have the following capabilities:

- **Pop-Up Text** — A preview of the operation that is to be undone or redone.
• Undo List — You can select one or many sequential actions to undo.
• Redo List — You can select one or many sequential actions to redo.

4.14 Editing Features and Regenerating

Editing Features using Edit

Edit is a menu selection available from the model tree, pop-up menu, or the drop-down menu. After choosing Edit, the dimensions of the selected features or components display in the graphics window.

Using Edit, you can quickly change the dimensions of a selected feature using one of the two following methods:

• Edit directly on the model — To edit directly on the model, double-click the dimension. Type the new dimensional value and regenerate the model.
• Edit using the Most Recently Used option — When you edit a model, you can also use the most recently used option. When you double-click a dimension, a drop-down list displays the most recent values of the model, as shown in the middle image. You can select a suitable value and regenerate the model.

The most recently used option only displays recent values from the current session. It does not display values used in a previous Pro/ENGINEER Wildfire session.

Editing Features using Edit Definition

Using Edit Definition, you can significantly change the model by redefining the feature:

• Type — Change a protrusion into a cut, for example.
• Size — Make a feature larger or smaller.
• Shape — Change a round cut into a square cut, for example.
• Location — Move a cut from one reference to a different reference.
• References — Change the location of the feature or change the dimensional references.
• Options — Change the additional details of the feature, such as its depth.

In Edit Definition, you can modify the model by:
1. Editing with the dashboard. This is the graphical area in which you can change a feature’s type, size, shape, and location.
2. Editing with drag handles. You can directly change features on a model by manipulating the drag handle. Your changes display dynamically in the graphics window.
3. Using the various context-sensitive right mouse button options on the dynamic preview or drag handles.

Within the dashboard there is a set of icons along the right side that perform the following operations:

- **Preview Feature** — Previews what the completed feature or component will look like in the graphics window.
- **Pause Feature** — Pauses the current feature’s edit definition operation, enabling you to perform other functions such as inserting datum features.
- **Resume Feature** — Resumes a paused feature’s edit definition operation.

**Regeneration Theory**

The **Regenerate** function recalculates the model geometry, incorporating any changes made since the last time the model was saved or regenerated. It is necessary to regenerate a model after you have edited it. However, if you edit the definition of a feature, the regeneration is done for you.

### 4.15 Using Dynamic Edit

The Dynamic Edit operation enables you to dynamically drag a feature’s dimensions or its section entities. Examples of feature dimensions that can be dynamically dragged include:

- **Depth** — You can drag a feature’s depth, as shown in the upper-right figure.
- **Rounds** — You can drag a round’s radius.
- **Chamfers** — You can drag a chamfer’s angle and D values.
- **Pattern Dimensions** — You can drag dimensions used in a pattern feature.

You can also dynamically edit datum feature dimensions.

The Dynamic Drag operation is not available for features created using the menu manager. It is also not available for sheetmetal features at this time.
Features are regenerated in real time when they are dynamically edited. Additionally, child features also regenerate in real time. Real time regeneration may be slow if dragging a parent feature in a large model.

If you dynamically edit a feature in such a way that it cannot successfully regenerate, a caution icon displays next to your cursor and the geometry displays red, as shown in the lower-right figure. You can simply undo the edit or dynamically edit the feature back to a successful status. Other downstream features that do not successfully regenerate display in blue.

**Dynamic Edit Right-Mouse Button Options**

While using dynamic edit, the following options are available in the right-mouse button menu:

- **Show/Hide All Dims** — Enables you to toggle the display of all dimensions on or off. This option can be used when you are more concerned about a feature's shape than its dimensions.
- **Show/Hide Sketch Dims** — Enables you to toggle the display of a sketch's section dimensions on or off. This option can be used to clean up the display if you are only modifying a feature using drag handles.
Module 5

Creating Sketcher Geometry

Module Overview

Most 3-D geometry created in Pro/ENGINEER begins with a 2-D sketched section. Consequently, sketching is one of the most fundamental, consistently performed operations.

In this module, you review the theory behind sketching and learn what goes into creating a robust, predictable sketch. You also learn the tools available for creating sketch geometry.
5.1 Reviewing Sketcher Theory

In Pro/ENGINEER, you use the 2-D Sketcher mode to capture your engineering idea. You sketch your idea using various types of lines which are then trimmed, constrained, dimensioned, and modified accordingly. An example of a sketch is shown in the upper-right figure.

This 2-D sketch is then placed into a 3-D model, as shown in the lower-right figure. Once the sketch is placed, it can be used to create solid features, as shown in the figures on the left. Notice that the same sketch can be used to create two completely different types of geometry.

5.2 Understanding Design Intent

Understanding Design Intent Theory

When creating models with Pro/ENGINEER Wildfire, it is critical that you capture the design intent of the model. Design intent ensures predictable results when a model is modified. Creating sketch features enables you to capture design intent. Design intent is captured and can be varied in sketches by:

- How it is constrained — Changing how a sketch is constrained affects the predictable behavior of the sketch, thereby varying design intent.
- How it is dimensioned — Changing how a sketch is dimensioned affects the predictable behavior of the sketch, again varying design intent.

Using the Intent Manager to Capture Design Intent

The upper-right figure shows a freehand sketch. No design intent has been applied to it. When you edit the sketch, it is not known how it will behave. The middle-right figure shows the desired sketch to be achieved. The Intent Manager
helps you apply design intent to your sketch so it appears as the middle image, not the top image.

Start by sketching the rough shape of your desired sketch. The Intent Manager will begin to dynamically apply constraints to help you lock in your sketch. For example, if you sketch a line approximately vertical, the Intent Manager will dynamically apply a vertical constraint to that line, helping you lock in design intent. When you stop sketching, a series of gray dimensions appears in addition to your constraints.

- The Intent Manager must maintain a fully defined sketch at all times. The dimensions and constraints maintain the size, shape, and location of all sketched items, which helps you capture design intent. Modify the default dimension scheme if needed by editing or adding dimensions so you properly capture your intended design intent.
- The Intent Manager contains both Weak and Strong items.
  - Weak items are gray, whereas Strong items are light orange.
  - Dimensions and constraints can be Weak or Strong.
  - The system will add or remove Weak items as necessary to maintain the fully constrained sketch.
  - You cannot delete Weak items.
  - Strong items are Weak items that were made strong either directly or by modifying them.

### 5.3 Modifying the Sketcher Display

**Sketcher Display Options**

When you enter Sketcher mode, there are four different Sketcher Display types that can be controlled to aid visualization while completing tasks:
The Sketcher Display for a given exercise is included within the procedure and exercise steps where applicable. When you see the sketcher display icons in exercises, you should set your sketcher display to match. For example, indicates that you should display dimensions, constraints, and section vertices.

**Orienting the Sketch Parallel to the Screen**

If you reorient the sketch while in Sketcher mode for any reason, you can click Sketch Orientation. This causes the sketch to reorient parallel to the screen.

### 5.4 Utilizing Constraints

**Utilizing Constraints Theory**

Constraining the sketch is an important means to capture design intent. As you add constraints, you add logic to your sketches. You also minimize the number of dimensions required to document your design intent. This is why it is important to constrain your sketched entities before dimensioning your sketch.

The following table lists the available constraints, which can be activated from the flyout in the Sketcher toolbar, by selecting multiple entities and right-clicking, or by clicking Sketch > Constrain from the main menu:

<table>
<thead>
<tr>
<th>Constraint</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical</td>
<td>Makes lines vertical or aligns points vertically.</td>
</tr>
<tr>
<td>Horizontal</td>
<td>Makes lines horizontal or aligns points horizontally.</td>
</tr>
<tr>
<td>Perpendicular</td>
<td>Makes lines perpendicular to one another.</td>
</tr>
<tr>
<td>Tangent</td>
<td>Makes lines tangent to arcs and circles.</td>
</tr>
<tr>
<td>Midpoint</td>
<td>Places a point on the middle of a line or arc.</td>
</tr>
</tbody>
</table>
Constraint Description
---
**Coincident** - Aligns two entities or vertices to the same point. Also creates Collinear and Point on Entity constraints.

**Symmetric** - Makes two points or vertices symmetric about a centerline.

**Equal** - Makes lines equal length, gives arcs/circles equal radii, makes dimensions equal, or creates equal curvature.

**Parallel** - Makes lines parallel to one another.

At any time, you can click **Sketch > Constrain > Explain** and select a constraint from the sketch. The message window provides an explanation of the constraint.

### 5.5 Sketching with On-the-Fly Constraints

#### Sketching with On-the-Fly Constraints Theory

As you sketch geometry entities, constraints appear dynamically on-the-fly to quickly capture design intent. The constraints actually cause the geometry to snap as you sketch it, based on the constraint that appears. For example, as you sketch a line close to horizontal, a Horizontal constraint will dynamically display and snap the line horizontal, enabling you to quickly capture your horizontal line design intent. Taking advantage of these constraints ensures that you do not have to manually constrain entities after they are sketched.

When a constraint appears, you should perform the following manipulations to further aid you while sketching:

- **Lock constraint** — Enables you to lock the constraint so the geometry remains snapped. Locked constraints are denoted by circles, as shown in the upper-right figure.
- **Disable constraint** — Enables you to disable the constraint so it does not influence the geometry. Of course, you can always re-enable the disabled constraint. Disabled constraints are denoted by slashes, as shown in the lower-left figure.
- **Disable constraints from appearing on-the-fly** — Enables you to sketch an entity without any on-the-fly constraints appearing.
- **Toggle active constraint** — When a constraint appears on-the-fly while sketching, it displays in red and is considered active. When more than one constraint appears at the same time, only one can be the active constraint. The active constraint has the previously defined manipulations applied to it. The toggle manipulation is only available if more than one on-the-fly constraint appears at the same time. In the lower-right image,
the Equal Length constraint is active in the left image and the Horizontal constraint is active in the right image.

The following table lists the manipulations available and the corresponding mouse and keyboard operation:

<table>
<thead>
<tr>
<th>Constraint Manipulation</th>
<th>Mouse/Keyboard Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lock/Disable/Enable the Constraint</td>
<td>Right-click to toggle between constraint types.</td>
</tr>
<tr>
<td>Disable constraints from appearing on-the-fly</td>
<td>Press and hold SHIFT while sketching the entity.</td>
</tr>
<tr>
<td>Toggle the Active Constraint</td>
<td>Press TAB.</td>
</tr>
</tbody>
</table>

Manipulating the constraints on-the-fly does not cancel the Sketcher entity tool that you are using. For example, if you are sketching a line and manipulate a constraint that dynamically appears, the Line tool remains active.

5.6 Sketching Lines

There are two main types of lines available in Sketcher:

- 2 Point Line — Click **Line** from the Sketcher toolbar or right-click and select **Line** to create a line between two points. Each time you click the mouse you start a line point or endpoint. You can continue clicking the mouse to create lines that are chained together. That is, the endpoint of one line is the starting point of the next line. You can either middle-click or select another function from the Sketcher toolbar to terminate line creation.
- 2 Tangent Line — Click **Line Tangent** from the Sketcher toolbar to create a line that is tangent to two circles, two arcs, or a circle and arc. You can only select arcs or circles when creating a 2 Tangent Line.

**Procedure: Sketching Lines**

**Scenario**

Sketch lines in Sketcher.

**Task 1. Sketch line entities in Sketcher.**
1. In the model tree, right-click LINE and select **Edit Definition**.

2. Sketcher display: [Image]

3. Click **Line** from the Sketcher toolbar.

4. Click the existing line endpoint. Move the cursor down, and click again at the vertical and horizontal reference intersection. Notice the Vertical constraint.

5. Move the cursor to the right, and notice the Horizontal constraint.

6. Continue to move the cursor to the right and you will see the Equal Length constraint.

7. Continue to move the cursor to the right until you see the Vertical Alignment constraint.

8. Click again to complete the horizontal line.
9. Move your cursor up and to the right to create a diagonal line. Continue to move the cursor upward until you see the Parallel constraint.

10. Continue to move the cursor to increase the line length until the Equal Length constraint appears.

11. Press TAB to toggle the active constraint to the Parallel constraint.

12. Press TAB again to toggle the active constraint back to the Equal Length constraint.

13. Right-click two times to disable the Equal Length constraint.
14. Keeping the line parallel, continue to move the cursor to increase the line length.

15. Press TAB to activate the Parallel constraint.

16. Right-click to lock the Parallel constraint.

17. Move the cursor to further extend the line length and click to finish the line creation.


19. Click to finish the vertical line creation.

20. Move the cursor to the left and notice the Horizontal constraint. Drag the line horizontally to the left until the Vertical Alignment constraint appears.

21. Click to finish the horizontal line creation.
22. Move the cursor down and drag the line vertically until it snaps to the arc endpoint. Click to finish the vertical line creation.

23. Middle-click to stop sketching.

24. Click **Done Section** from the Sketcher toolbar.

**Task 2. Sketch tangent lines in Sketcher.**

1. Edit the definition of 2-TANGENT_LINE.

2. Click **Line Tangent** from the flyout in the Sketcher toolbar.

3. Click the bottom of the smaller circle to begin sketching a line.

4. Move the cursor around the circle, and notice that the line stays tangent to the circle.

5. Click the top of the larger circle to complete the line. Notice the Tangent constraints.
6. Click **Select One By One** from the Sketcher toolbar.

7. Select the tangent line and press DELETE.

8. Click **Line Tangent**.

9. Sketch another tangent line.

10. Sketch a third tangent line.

11. Click **Done Section**.

This completes the procedure.

### 5.7 Sketching Centerlines

A centerline is a type of construction geometry that can be used to define a line of symmetry with a sketch. They are also used to control sketch geometry. In the lower-left figure the circle is dimensioned to the vertical and horizontal references. In the lower-right figure the circle is dimensioned radially by using a centerline. Centerlines must be fully constrained by using dimensions or constraints like any other sketched entity. They have infinite length and do not create feature geometry.

There are two types of construction Centerlines:
- Centerline — Click **Centerline** from the Sketcher toolbar or right-click and select **Centerline** to create a Centerline through two points.

- 2 Tangent Centerline — Click **Sketch > Line > Centerline Tangent** from the main menu to create a centerline that is tangent to two circles, two arcs, or a circle and arc. You can only select arcs or circles when creating a 2 Tangent Centerline.

### Procedure: Sketching Centerlines

**Scenario**

Sketch centerlines in Sketcher.

![Centerlines](image.png) sketch_centerlines.prt

**Task 1. Sketch centerlines in Sketcher.**

1. In the model tree, select CENTERLINE, right-click, and select **Edit Definition**.

2. Sketcher display:

3. Notice that the horizontal line is asymmetric about the vertical reference. Notice also the dimensioning scheme for the angled line.

4. Click and drag a window around the two lines.

5. Press DELETE.

6. Click **Centerline** from the Line flyout in the Sketcher toolbar.
7. Click on the intersection of the vertical and horizontal references to start sketching a centerline.

8. Move the cursor upwards and click on the vertical reference to create a vertical centerline on top of the vertical reference.

9. Click on the intersection of the vertical and horizontal references to start sketching a second centerline.

10. Drag the centerline so it measures approximately 70° from vertical, and click to place it.

11. Click Line from the Sketcher toolbar.

12. Click in the top left quadrant of the graphics window to start sketching a line.

13. Move the cursor horizontally to the right side of the vertical centerline until it snaps symmetric about the vertical centerline and click to place it.

14. Middle-click to stop line creation.
15. Click **Select One By One** from the Sketcher toolbar, and click and drag one of the line endpoints to resize it to a length of approximately 13. Notice that the line stays symmetrical about the vertical centerline as it is resized.

16. Click **Line** from the Sketcher toolbar and click the right endpoint of the horizontal line.

17. Move the cursor down to the angled centerline, move the cursor up and down on the centerline until the Perpendicular constraint appears, and click to complete the line.

18. Middle-click to stop line creation.

19. Click **Select One By One** and de-select the line.

20. Click and drag the angled centerline to approximately 60°. Notice that the angled line always stays perpendicular about the angled centerline.

21. Click **Done Section** from the Sketcher toolbar.

This completes the procedure.

### 5.8 Sketching Rectangles and Parallelograms

#### Sketching Rectangles and Parallelograms Theory

To create a rectangle, click the **Rectangle** icon from the Sketcher toolbar or right-click and select **Rectangle**. When you sketch a rectangle, you click to define locations for two opposite corners.
To create a slant rectangle, click the Slant Rectangle icon from the rectangle flyout within the Sketcher toolbar. When you sketch a slant rectangle, you click two locations to define a line that becomes the first side, and then specify a third location to define the width.

To create a parallelogram, click the Parallelogram icon from the rectangle flyout within the Sketcher toolbar. When you sketch a parallelogram, you click two locations to define a line that becomes the first side, and then specify a third location to define the width and side angle.

Keep in mind the following when sketching rectangles and parallelograms:

- The four lines are independent once created.
- You can delete, trim, and align each line individually.
- You can use centerlines to create symmetric rectangles.

**Procedure: Sketching Rectangles and Parallelograms**

**Scenario**
Sketch rectangles in Sketcher.

**Task 1. Create rectangles in Sketcher.**

1. In the model tree, right-click RECTANGLE and select **Edit Definition**.

2. Sketcher display:

3. Select the upper line of the rectangle and press DELETE.
4. Press CTRL and select the three remaining lines.

5. Right-click and select **Delete**.

6. Click **Rectangle** from the Sketcher toolbar.

7. Click in the upper-left quadrant to start the rectangle. Move the cursor to the lower-right quadrant, ensuring that the rectangle is symmetric about the vertical and horizontal centerlines.

8. Click to complete the rectangle.
   - Middle-click to complete sketching and view the constraints.

9. Right-click and select **Rectangle**.
   - Click the midpoint of the right side of the rectangle.

10. Move the cursor to the right until the second rectangle snaps to equal length. Move the cursor down until the second rectangle snaps to the bottom of the first rectangle, and click to complete the rectangle.
Task 2. Sketch a parallelogram and a slanted rectangle.

1. Select Parallelogram from the rectangle flyout in the Sketcher toolbar.

2. Click the upper-right vertex of the second rectangle and then click the upper-right vertex of the first rectangle.

3. Move the cursor up vertically until the height snaps to equal length, then click to complete the parallelogram.

4. Select Slant Rectangle from the rectangle flyout in the Sketcher toolbar.

5. Click the upper-left vertex of the parallelogram to begin sketching a slant rectangle.

6. Move the cursor to the vertical reference and upwards until the line snaps parallel, and then click.

7. Move the cursor up and to the right until it snaps to equal length, then click to complete the slant rectangle.
8. Middle-click to stop sketching.

9. Click Done Section ✔️ from the Sketcher toolbar.

This completes the procedure.

5.9 Sketching Circles

There are four types of circles available in Sketcher:

- Center and Point — Click Center and Point Circle ✌ from the Sketcher toolbar and select the location for the center and a location that determines the diameter. You can also right-click and select Circle.
- Concentric — Click Concentric Circle ⚪ from the Sketcher toolbar to create a circle that is concentric about an existing circle or arc.
- 3 Point — Click 3 Point Circle ⚪ from the Sketcher toolbar and select three locations that the circle must pass through.
- Tangent to 3 Entities — Click 3 Tangent Circle ⚪ from the Sketcher toolbar and select three arcs, circles, or lines that the circle must be tangent to.

Procedure: Sketching Circles

Scenario
Sketch Circles in Sketcher.

Task 1. Sketch circles and concentric circles in Sketcher.

1. In the model tree, right-click CTR-PNT_CONCENTRIC_CIRCLE and select Edit Definition.
2. Sketcher display: [Image]

3. Click **Center and Point Circle** from the Sketcher toolbar.

4. Select the vertical and horizontal reference intersection.

5. Move the cursor out until the circle diameter snaps to equal diameter with the arc. Click to complete the circle.

6. Sketch another circle so it snaps to the arc endpoint.

7. Click **Concentric Circle** from the Sketcher toolbar and select the largest circle.
   - Move the cursor up until the circle diameter snaps to the right arc endpoint.
   - Click to complete the circle.
   - Middle-click to cancel further circle creation.
8. Select the arc and create another concentric circle.

9. Middle-click to cancel further circle creation.

10. Click **Done Section** ✔from the Sketcher toolbar.

**Task 2. Sketch 3 point circles in Sketcher.**

1. Edit the definition of 3-PNT_CIRCLE.

2. Click **3 Point Circle** ꚴfrom the Sketcher toolbar.

3. Select the line endpoint and a rectangle corner.

4. Select the opposite rectangle corner.

5. Click **Done Section** ✔.
Task 3. Sketch a tangent circle in Sketcher.

1. Edit the definition of 3-TANGENT_CIRCLE.
2. Click 3 Tangent Circle from the Sketcher toolbar.
3. Select the upper circle.
4. Select the left arc.
5. Select the right circle.
6. Click Done Section.

This completes the procedure.
5.10 Sketching Arcs

There are five types of arcs available in Sketcher:

- **3-Point** — Click **3-Point / Tangent End Arc** from the Sketcher toolbar and select the locations for the two arc endpoints and the arc diameter. When you select an existing line endpoint, a green "quadrant" symbol appears around that endpoint. Move the cursor through the quadrants perpendicular to the line to create a 3-Point arc. You can also right-click in Sketcher and select **3-Point/Tangent End**.

- **Tangent End** — Click **3-Point / Tangent End Arc** from the Sketcher toolbar, select an existing line endpoint, and move the cursor through the green quadrants parallel to the line to create a Tangent End arc. You can also right-click and select **3-Point/Tangent End**.

- **Concentric** — Click **Concentric Arc** from the Sketcher toolbar to create an arc that is concentric about an existing arc or circle.

- **Center and Endpoints** — Click **Center and Ends Arc** from the Sketcher toolbar to create an arc with center and ends that you select.

- **Tangent to 3 Entities** — Click **3 Tangent Arc** from the Sketcher toolbar and select three arcs, circles, or lines that the arc must be tangent to.

**Procedure: Sketching Arcs**

**Scenario**

Sketch Arcs in Sketcher.

**Task 1. Sketch 3 Point and Tangent End Arcs in Sketcher.**

1. In the model tree, right-click 3-PNT_TANGENT-END_ARC and select **Edit Definition**.

2. Sketcher display:

3. Click **3-Point / Tangent End Arc** from the Sketcher toolbar.

   - Select the upper line endpoint, move the cursor horizontal to the left, and select the vertical and horizontal reference intersection.
   - Move the cursor above the horizontal reference and click to create the arc.

4. Click **Undo**.
5. In the graphics window, right-click and select **3-Point / Tangent End**.

   - Select the upper line endpoint, move the cursor up, and select the vertical and horizontal reference intersection to create the tangent arc.

6. Select the endpoint of the previous arc and create a new tangent arc of equal radius.

7. Select the endpoint of the previous arc and create a new tangent arc.

8. Click **Done Section ✓** from the Sketcher toolbar.
Task 2. Sketch Concentric Arcs in Sketcher.

1. Edit the definition of CONCENTRIC_ARC.

2. Click **Concentric Arc** from the Sketcher toolbar.
   - Select the upper arc and select the horizontal reference to the left of the center.
   - Move the cursor clockwise and select the horizontal reference again to create the arc.
   - Middle-click to stop concentric arc creation.

3. Select the lower arc and select the left arc endpoint.

4. Select the right arc endpoint to create the concentric arc.

5. Middle-click to stop concentric arc creation.

6. Click **Done Section**.
Task 3. Sketch Center and Ends Arcs in Sketcher.

1. Edit the definition of CENTER-ENDS_ARC.

2. Click Display Constraints to disable their display.

3. Click Center and Ends Arc from the Sketcher toolbar flyout.
   - Select the vertical and horizontal reference intersection.
   - Select the left and upper endpoints of the lines to create the arc.

4. Select the vertical and horizontal reference intersection again.

5. Select the right and bottom endpoints of the lines to create the arc.

6. Click Done Section.
Task 4. Sketch 3-Tangent Arcs in Sketcher.

1. Edit the definition of 3-TANGENT_ARC.

2. Click **Display Constraints** to enable their display.

3. Click **3 Tangent Arc** from the Sketcher toolbar flyout.

4. Select the left circle, right circle, and line.

5. Click **Undo**.

6. Click **3 Tangent Arc**.

7. Select the line, left circle, and right circle.

8. Click **Done Section**.
This completes the procedure.

### 5.11 Sketching Circular Fillets

The **Circular Fillet** option creates a rounded intersection between any two non-parallel entities. When you create a Circular Fillet between two lines, the lines are automatically trimmed to the fillet. If you create a Circular Fillet between any other entities, you must delete the remaining segments manually.

- Circular Fillets can be applied to either concave or convex corners. The corners do not have to be at 90°.
- The radius size is based on pick location, as shown in the lower-right figure.

In addition to the icon, you can right-click in Sketcher and select **Fillet**.

---

**Procedure: Sketching Circular Fillets**

**Scenario**

Sketch Circular Fillets in Sketcher.

1. In the model tree, right-click CIRCULAR_FILLET and select **Edit Definition**.
2. Sketcher display:

---

**Task 1. Sketch circular fillets in Sketcher.**

1. In the model tree, right-click CIRCULAR_FILLET and select **Edit Definition**.
2. Sketcher display:
3. Click **Circular Fillet** from the Sketcher toolbar.

4. Select the two points to create the fillet.

5. Select two points to create the next fillet.

6. Select two points to create the next fillet.

7. Select two points to create the next fillet.
8. Click **OK** from the Select dialog box.

9. Click **Display Constraints** from the main toolbar to enable their display.

10. Press **CTRL** and select the four fillets.

11. Right-click and select **Equal**.

12. Click **Done Section**.

This completes the procedure.

### 5.12 Sketching Chamfers

**Sketching Chamfers Theory**

The **Chamfer** option creates a straight line between selected locations on any two non-parallel entities. When you create a chamfer, construction lines are created leading from the chamfer endpoints to the intersection of the original entities.
You click **Chamfer Trim** to create a Chamfer and automatically trim away the original geometry.

Keep in mind the following points when sketching chamfers:

- Chamfers can be applied to either concave or convex corners.
- The corners do not have to be at 90 degrees.
- Entities do not have to intersect.
- The size and angle of the chamfer line is based on pick locations.

**Procedure: Sketching Chamfers**

**Scenario**
Sketch chamfers in Sketcher.

**Task 1. Sketch chamfers.**

1. In the model tree, right-click CHAMFERS and select **Edit Definition**.

2. Sketcher display:

3. Click **Chamfer** from the Sketcher toolbar.

4. Select two points to create the chamfer. The construction lines are automatically created.

5. Select two points to create the next chamfer.
Task 2. Sketch chamfers using the Chamfer Trim option.

1. Click Chamfer Trim from the Sketcher toolbar flyout.

2. Select two points to create the chamfer. The geometry is trimmed away.

3. Select two points to create the next chamfer.

4. Click Done Section.

This completes the procedure.
Check your Knowledge

1. Design intent is captured in a sketch by...

   A - how it is constrained.
   B - how it is dimensioned.
   C - making weak dimensions strong.
   D - all of the above.
   E - A and B only.

2. The four display options available in Sketcher are...

   A - refit, repaint, pan, and spin center.
   B - circles, rectangles, arcs, and centerlines.
   C - layers, sketch orientation, chain, and parametric sketch.
   D - dimensions, constraints, grid, and section vertices.

3. Which constraint would you use to make a circle and arc the same radius?

   A - Tangent
   B - Equal
   C - Parallel
   D - Symmetric
   E - All of the above

4. True or False? Excluding construction geometry, the two types of lines you can create in Sketcher are 2 Point Lines and lines tangent to 2 entities.

   A - True
   B - False

5. Which option is not a type of sketched arc?

   A - 3 Point
   B - Tangent end
   C - Center and endpoints
   D - Center and radius
Module 6

Using Sketcher Tools

Module Overview

Once you sketch geometry, it typically needs to be modified or further manipulated.

In this module, you learn the tools available for modifying and manipulating your sketch, as well as how to handle any conflicts that may arise while sketching.
6.1 Understanding Construction Geometry Theory

Understanding Construction Geometry Theory

Construction entities enable you to create references on the fly. Construction geometry is important because it enables you to easily constrain your sketch. It is signified by a dashed yellow entity within Sketcher.

- Construction geometry can be dimensioned and constrained just like regular, solid geometry.
- Solid sketched geometry will snap to construction geometry which means that construction geometry can be used to control a sketch. In the upper-right figure, the arc centers are snapped to the construction line endpoints. Therefore, changing the construction geometry length or angle dimensions will cause the arcs to move accordingly.
- Construction geometry does not appear in the final Sketch feature. Therefore, it does not add entities to the final sketch.
- Construction geometry can make an otherwise difficult dimensioning scheme easy. In the lower-right figure, one dimension is used to control the entire sketch. All line endpoints are snapped to the construction circle. Without the construction circle, a lot more dimensions and constraints would be required to properly constrain the sketch.
- Construction geometry can simplify sketches. In the lower-left figure, the sketch has been simplified by constraining line vertices that must snap to an imaginary arc to a construction geometry arc.

Creating Construction Geometry

Almost any solid sketched geometry entity can be converted into construction geometry. Create construction geometry by sketching conventional geometry. Next, select the geometry, right-click, and select Construction. You can also click Edit > Toggle Construction from the main menu. To change construction geometry back to solid geometry, select it and either right-click and select Geometry or click Edit > Toggle Construction.
6.2 Sketching Points

Sketcher Points are created by using the **Point** icon from the Sketcher toolbar. Sketcher points do not contribute to the resulting sketch geometry in a feature. This makes them similar to construction geometry.

Sketcher points have the following uses:

- **Dimension to theoretical sharps** — In the upper-right figure, a Sketcher Point has been placed at the theoretical corner sharp. As a result, this theoretical sharp can be used for controlling design intent through a dimension.
- **Dimension slanted on arcs** — In the lower-right figure, a Sketcher Point has been placed on each arc. As such, a slanted dimension can be created to measure the distance between arc tangencies.
- **Provide an anchor or pivot point** — In the lower-left figure, a Sketcher Point has been placed at the intersection of the arc and the vertical and horizontal references. As such, the angular dimension can be modified, and the entire sketch will pivot about the Sketcher Point.

6.3 Using Geometry Tools within Sketcher

**Using Geometry Tools within Sketcher Theory**

You can use various Geometry Tools within Sketcher to modify existing geometry. You can dynamically trim entities, trim entities to other entities, divide entities, and mirror entities. You can undo any operation done using Geometry Tools.

**Using Trim/Delete Segment**

You can dynamically trim the parts of sketched entities you no longer need. When dynamically trimming, any entity that you touch while dragging will be deleted. In the upper-left figure, the extra arcs are deleted.
Using Trim Corner

You can trim or extend sketched entities to other entities in Sketcher. To trim entities, select the entity side you want to keep. In the upper-right figure, the two entities are selected to be trimmed, and the gap between the entities is closed.

Using Divide

You can divide a sketched entity into two or more new entities. The system divides the entity at the point(s) you select. In the lower-left figure, the circle is divided to become two separate arcs.

Some sketched features require portions of a sketch to maintain an equal number of entities.

Using Mirror

You can mirror selected sketched entities about a centerline. Mirrored entity geometry will join with the original entity to become one entity given the following two criteria:

- The entity is normal to the centerline being mirrored about.
- One endpoint lies on the centerline.

In the lower-right figure, the top horizontal line and bottom are both perpendicular to the mirroring centerline and have an endpoint that lies on the centerline. When the geometry is mirrored, the result is one horizontal entity on the top and one arc on the bottom.

You cannot mirror dimensions, text entities, or centerlines.

Procedure: Using Geometry Tools within Sketcher

Scenario

Use the different geometry tools in Sketcher.

Task 1. Dynamically trim sketched entities.

1. In the model tree, right-click DYNAMIC_TRIM and select Edit Definition.

2. Sketcher display:
3. Click Trim/Delete Segment from the Sketcher toolbar, and click and drag to dynamically trim the entities.

4. Zoom in on the upper-right part of the sketch.

5. Dynamically trim the three extra arcs.

6. Perform the same trims to the lower sketch portion.

7. Click Done Section from the Sketcher toolbar.

Task 2. Trim sketched entities to other sketched entities.

1. Edit the definition of TRIM_ENTITIES.

2. Click Display Constraints to enable their display.

3. Click Trim Corner from the Sketcher toolbar, and select the two entities to trim.
4. Click **Undo**.

5. Click **Trim Corner** and select the two entities to trim.

6. Select the two entities to trim.

7. Select the two entities to trim.
8. Select the two entities to trim.

9. Click **Done Section ✓**.

**Task 3. Divide sketched entities.**

1. Edit the definition of **DIVIDE**.

2. Click **Divide** from the Sketcher toolbar, and select the two circle locations to divide.

3. Middle click to stop dividing entities.
4. Select the left half of the divided circle.

5. Click **Divide** and divide the arcs four more times.

6. Click **Done Section**.

**Task 4. Mirror sketched entities.**

1. Edit the definition of MIRROR.

2. Click **Display Dimensions** to enable their display. Notice the top 7.25 dimension.
3. Click and drag a window around all sketched entities.

4. Click **Mirror** from the Sketcher toolbar.

5. Select the vertical centerline.

6. Notice the top 14.50 dimension.

7. Select the upper horizontal line and lower arc.

8. Notice that both are single entities.

9. Click **Done Section**.

   This completes the procedure.
6.4 Manipulating Sketches within Sketcher

Manipulating Sketches within Sketcher

You can cut, copy, and paste sketched entities. To do this, you can use either the context-sensitive right-mouse pop-up menu, icons in the main toolbar, or the Edit menu. You can perform cut, copy, and paste operations from within a sketch or from one sketch to another.

Scaling and Rotating Sketches

You can also scale and rotate selected sketch entities. Scaling and rotating pasted entities are the first available operations when you paste sketched entities into a sketch. You can scale and rotate existing sketch entities by selecting them and clicking Edit > Move & Resize from the main menu, Move & Resize from the Sketcher toolbar, or by right-clicking and selecting Move & Resize.

You can scale and rotate entities either by using the Move & Resize dialog box or you can use the drag handles that appear on the entities.

- Click and drag the Location handle to move the entities about Sketcher. To help properly place the entities, you can right-click and drag to relocate the Location handle.
- Click and drag the Scale handle to dynamically scale the entities or enter a value in the Move & Resize dialog box.
- Click and drag the Rotate handle to dynamically rotate the entities or enter a value in the Move & Resize dialog box.

You can also move the location handle to a specified location in the sketch by activating the Reference collector in the Rotate/Scale section of the Move & Resize dialog box. When you select a reference, the location handle snaps onto the reference.
Translating Sketches

Translating entities is another available operation you can perform on pasted sketches. To translate a sketch you can either click and drag the location handle or type a distance value into the fields in the Move & Resize dialog box. The Translate Reference is the location by which the translation distances are measured. The sketch can be translated parallel and perpendicular to the reference. You can retain the default translate reference or you can specify a different one.

6.5 Dimensioning Entities within Sketcher

Dimensioning Entities within Sketcher Theory

When dimensioning a sketch, it is important to create dimensions that capture your design intent because these dimensions are displayed when you edit the model and when you create drawings of the model.

Dimensions are all created using the Normal Dimension icon. You can also right-click and select Dimension. Select entities to be dimensioned and middle-click to place the dimension. At this point you can either press ENTER to accept the current dimension value, or type a different one and press ENTER. The type of dimension created depends upon what is selected and where the dimension is placed.

The following dimension types can be created:

- **Line length** — Select a line and place the dimension. The line length is dimensioned.
- **Angle** — You can create an angle measurement by selecting two linear references. Where you place the dimension determines how the angle is measured (acute versus obtuse). You can also create an arc angle by
selecting an arc endpoint, the arc center, and the other endpoint, and then placing the dimension.

- **Distance** — Select two entities to measure the distance between and place the dimension. Again, where you place the dimension will determine whether it is vertical, horizontal, or slanted. The Dim Orientation dialog box enables you to determine whether the dimension is to be vertical or horizontal.

- **Radius** — Select an arc or circle once, then place the dimension. You can toggle a radius dimension to a diameter or linear dimension by right-clicking and selecting *Convert to Diameter* and *Convert to Linear*, respectively.

- **Diameter** — Double-click an arc or circle, then place the dimension. You can toggle a diameter dimension to a radius or linear dimension by right-clicking and selecting *Convert to Radius* and *Convert to Linear*, respectively.

- **Revolved Diameter** — Select the entity, a centerline, and the entity again and place the dimension. Alternatively, you can select the centerline, the entity, and the centerline again.

- **Arc length** — You can create an arc length dimension by selecting the arc segment, its two endpoints, and placing the dimension. The arc length measurement displays an arch symbol over the dimension value. You can toggle the arc length measurement to an arc angle dimension and vice-versa by right-clicking and selecting *Convert to Angle* and *Convert to Length*, respectively.

- **Included angle** — Similar to a revolved diameter dimension, you can create an included angle dimension by selecting an angled line, a centerline, and the angled line again before placing the dimension. You can toggle the included angle to an angle dimension and vice-versa by right-clicking and selecting *Convert to Angle* and *Convert to Total included angle*, respectively.

**Weak Dimensions**

Because the Intent Manager must maintain a fully defined sketch at all times, a sketch initially is dimensioned using weak dimensions. As you dimension your sketch (these are strong dimensions) using your desired design intent, the weak dimensions automatically disappear.

---

You can convert weak dimensions to strong dimensions by selecting the weak dimension, right-clicking, and selecting *Strong*. Similar to creating a new dimension, you can either accept the current dimension value being made strong, or type a new one. Editing a weak dimension automatically makes it strong.
6.6 Modifying Dimensions within Sketcher

You can modify dimensions in Sketcher by using any of the following methods:

- Edit the dimension manually by double-clicking it. The geometry placement will update to the new dimension. You can also edit the dimension value when you create it without having to double-click it.
- Click and drag the entity that the dimension is attached to. The dimension value will update automatically.
- Use the Modify Dimensions dialog box. When you select the dimension, it highlights in the graphics window. You can edit values or scroll the wheel next to the dimension you wish to modify. The dimension value will increase or decrease depending on the direction of scrolling.
  - You can adjust the sensitivity to adjust how finely or coarsely dimension wheels scroll.
  - If Regenerate is selected, the sketch geometry will update immediately after a dimension is edited. If the check box is cleared, you can adjust any or all dimensions within the Modify Dimensions dialog box, and the geometry will not update until you click Regenerate Section.
  - If Lock Scale is selected, you can modify one dimension and all other dimension values update automatically to new values at the same ratio.

-locking the scale to edit dimensions is common when creating the first feature of a model.
6.7 Sketcher Conflicts

Sketcher Conflict Causes

The Sketcher Intent Manager strives to maintain a fully constrained sketch automatically. Sketcher Conflicts are caused by an over constrained sketch condition that arises from manually adding too many constraints or too many dimensions.

Resolving Sketcher Conflicts

When a Sketcher Conflict occurs, the Resolve Sketch dialog box appears, as shown in the lower right figure. The Resolve Sketch dialog box displays which constraints and/or dimensions conflict. The graphics window also highlights the conflicting items in red. When a Sketcher Conflict arises, you can resolve it by using either of the following techniques:

- Delete the conflicting constraints or dimensions to revert the sketch back to fully constrained.
- Convert dimensions to Reference dimensions. A Reference dimension is not a driving dimension that constrains a sketch. You cannot modify a Reference dimension, but it does update with geometry changes.
Module 7

Creating Sketches for Features

Module Overview

Up to this point, you have learned how to sketch geometry within the Sketcher environment. In this module, you apply that knowledge to the creation of sketch features. Sketch features typically serve as references to other features and can exist separately as their own feature or as the starting point when you create sketch-based features. You learn how to specify the sketch setup for a sketch feature, utilize sketch references, use entity from edge, and thicken edges.
7.1 Creating Sketches ('Sketch' Feature)

Creating Sketches ('Sketch' Feature) Theory

You can create a sketch feature by starting the Sketch Tool from the feature toolbar. Creating a sketch feature involves the following three steps:

- Specify the sketch setup. Once the sketch setup has been defined, you can always change it to another plane.
- Select additional sketch references that you intend to dimension from or snap to with sketch geometry. For example, in the lower-right figure, some of the existing geometry was specified as sketch references for a new Sketch feature.
- Sketch the geometry.

Sketch Feature Requirements

The following rules apply to sketched sections when creating sketch features:

- A sketched section should not contain any “gaps,” or open ends.
- A sketch cannot contain any overlapping entities.
- An open section sketch is required for creating a rib feature.
- All loops of a multiple loop section must be closed.
- When creating a revolve feature, you must only sketch geometry on one side of the centerline.
7.2 Specifying the Sketch Setup

Specifying the Sketch Setup Theory

When you create a sketch feature, the Sketch Setup is used to tell Pro/ENGINEER which plane the sketch feature will be created on and how it will be oriented:

- **Sketch Plane** — The 2-D sketch exists in this planar reference. The sketching plane can be either a datum plane or a planar surface of an existing solid or surface feature. If you create more than one sketch on the same sketch plane, you can click **Use Previous** in the Sketch dialog box to use the previous sketch feature's sketch setup.
- **Sketch Orientation** — Determines how the sketch will be oriented in the graphics window and model. Sketch orientation consists of two items:
  - **Orientation Reference** — The orientation reference determines the 2-D orientation of the sketch. This reference is also either a datum plane or a planar surface and must be normal to the sketch plane.
  - **Orientation Direction** — Determines the direction that the orientation reference faces. The orientation reference can be assigned to face top, bottom, right, or left. These directions are named to reflect how the reference orients with regard to the Pro/ENGINEER graphics window. Note that datum planes have two sides, brown and gray, and that the brown, or positive side, orients to the selected direction.

When you specify a sketch plane, the default orientation reference and orientation direction are determined based on the model's orientation in the graphics window when you entered the sketch setup.

- Different combinations of selected orientation reference and orientation direction will yield the same sketch orientation in the graphics window. In the lower-left figure, the datum plane RIGHT could be selected as the Orientation Reference to face right to yield the same result. You can also reverse the sketch orientation by clicking **Flip** from the Sketch dialog box. If ever you reorient the model while sketching, you can click **Sketch Orientation** to return the sketch parallel to the screen.

When you start a new sketch feature you are required to specify the sketch setup. However, once you are creating the sketch feature you can always reenter sketch setup by clicking either **Sketch Setup** from the Sketcher toolbar or **Sketch > Sketch Setup** from the main menu.
Within the Properties tab of the Sketch dialog box, you can modify the name of the sketch feature as it appears in the model tree. Also, if you edit the definition of an existing closed sketch, you can select **X-Hatch** from the Properties tab to hatch the inside of the sketch within the graphics window. You can also edit the spacing of the hatch lines. While you cannot modify the angle of the hatch lines, you can modify the angle within the drawing view of a drawing.

### 7.3 Utilizing Sketch References

Utilizing Sketch References

You use sketch references to snap sketch geometry to, which can cut down the number of dimensions required. Sketch references are also used by the system for creating the initial weak dimensions and constraints. Should further dimensions be required, you can dimension to or from sketch references. Sketch references appear as dashed entities in the Sketcher.

When selecting entities from existing features, you create a parent/child relationship between the sketch and the entity you added as a reference. However, if you add a sketch reference and it goes unused, the system automatically removes it as a sketch reference. Conversely, if you dimension to or from an entity the system automatically adds it as a sketch reference.

You can add sketch references either by clicking **References** from the Sketcher toolbar or **Sketch > References** from the main menu. At this point, the References dialog box opens. The References dialog box consists of the following items:

- **Select References** — Select entities in the graphics window. The following types of entities can be selected as sketch references:
  - Existing geometry — Select the edges or surfaces of features that have already been created.
  - Sketches — Select geometry from existing sketches.
  - Datum Features — Select datum planes, datum axes, points, and coordinate systems.
- **Select Xsec References** — Select a surface or datum plane to intersect with the sketching plane.
- **Selection Filters** — Used for selecting items within the Reference list. Choices from the drop-down list include Use Edge/Offset, All Non-Dim. Refs, Chain Refs, and All References.
- **Replace** — Select a reference from the list, click **Replace**, and select a new reference.
- **Delete** — Delete the selected reference from the list.
• Reference Status — Displays the status of the sketch with respect to references. Status options include Unsolved Sketch, Partially Placed, and Fully Placed.
• Solve — You can solve an unsolved or partially placed sketch after changing references.

You can also use sketch references for snapping geometry while sketching.

7.4 Using Entity from Edge within Sketcher

Using Entity from Edge within Sketcher

The Use Edge and Offset Edge options in Sketcher create sketcher geometry by projecting selected geometry edges onto the sketching plane. The two options are the same except the offset edge enables you to specify an offset value to the edges. A positive offset value causes the geometry to become larger, whereas a negative offset value causes the geometry to become smaller. Each entity created has the "~" constraint symbol.

The resulting dimensions are always positive when shown in a drawing.

When using the entity from edge options, you can select edges three different ways:

• Single — Edges are selected one at a time.
• Chain — Create sketched entities from a chain of edges or entities. Select two edges from the same surface or face and select which chain of geometry you wish to be created. The lower-right figure shows one possible chain selection from the selected entities.
• Loop — Create sketched entities from a loop of edges or entities. Select a surface or face and the edges or entities that form the loop are selected. If more than one loop exists, you must select the desired one.

7.5 Thickening Edges

Thickening Edges Theory

The Thicken Edge option in Sketcher creates Sketcher geometry by projecting and then offsetting and thickening selected geometry edges onto the sketching plane. You are prompted for two values, a thickness and a positive or negative offset. Both values create Sketcher dimensions that can be modified. In addition, a reference dimension is automatically created between the selected edge and
the thickened edge. The reference dimension cannot be modified directly, but will update with other changes.

Even if negative offset values are entered, the resulting dimensions are always positive when shown in a drawing.

When thickening edges, you can select edges using three different methods:

- Single — Edges are selected one at a time.
- Chain — Create sketched entities from a chain of edges or entities. Select two edges from the same surface or face and select which chain of geometry you wish to be created. The lower-right figure shows one possible chain selection from the selected entities.
- Loop — Create sketched entities from a loop of edges or entities. Select a surface or face and the edges or entities that form the loop are selected. If more than one loop exists, you must select the appropriate one.

In addition, you can control the end cap type on the thickened edges using the following options:

- Open — No additional geometry is added to thickened edges.
- Flat — Line segments are added to ends of the thickened edges.
- Circular — Arcs are added to ends of the thickened edges.
Check Your Knowledge

1. Which steps are used to create a Sketch Feature?
   - A - Specify the Sketch Setup
   - B - Select additional sketch references if needed
   - C - Sketch the geometry
   - D - All of the above
   - E - A and B only

2. Which of the following is not part of specifying the Sketch Setup?
   - A - Specify the Sketch Plane
   - B - Specify the Sketch Orientation
   - C - Specify additional sketching references
   - D - Specify the Orientation Direction

3. What can you select as a sketch reference?
   - A - Entire features
   - B - Entire parts
   - C - Solid or surface geometry
   - D - Sketches
   - E - Datum features
   - F - All of the above
   - G - A, C, and D only
   - H - C, D, and E only

4. True or False? The Offset Edge option only allows you to offset geometry in the positive direction.
5. How many modifiable dimensions does thickening an edge create?

A - 1  
B - 2  
C - 3  
D - 4
Module 8

Creating Datum Features: Planes and Axes

Module Overview

Datum features are commonly required as references when creating other features. In this module, you learn the theory behind creating datum features, and you create datum axes and datum planes.
8.1 Creating Datum Features Theory

Creating Datum Features Theory

Datum features are commonly required as references when creating other features. Datum features can be used as dimensioning references, feature placement references, and assembly references. The default color of datum features in the graphics window is brown (datum planes are both brown and grey, depending upon which side is currently being viewed). The following four types of datum features can be created:

- Datum Planes
- Datum Axes
- Datum Points
- Datum Coordinate Systems

Examples of each type of datum feature are shown in the figure.

8.2 Creating Datum Axes

Datum Axis Definition

Datum axes are individual features that can be redefined, suppressed, hidden, or deleted. A datum axis is a linear reference that has no mass. It is infinite in length, but its display length can be edited by selecting a reference, specifying a value, or dragging the drag handle.

Datum Axis Uses

A datum axis can be used as construction geometry in a feature. It can also be used as a reference for:

- Other datum features such as datum planes.
• Other features such as a hole location.
• Assembling components.

Datum Axis Types

There are four different types of datum axes that can be created within Pro/ENGINEER:

1. Auto Axis — Belongs to another feature and is created in the following two circumstances:
   o A circle is extruded.
   o A hole is created.
2. Axis Feature — Select most any combination of geometry that defines a line in 3-D space. You can select single or multiple references which are set as a combination of Through, Normal, Tangent, and Center constraint types. The following types of axis features can be created:
   o Through an edge
   o Normal to a plane
   o Through a cylindrical surface
   o Through the intersection of two planes or planar surfaces
   o Through two points or vertices
   o Through the center of an arc
   o Tangent to an edge
   o Through a point or vertex, normal to a plane
   o Through the X, Y, or Z axis of a coordinate system
3. Geometry Point — Created only in Sketcher. When the sketch is completed, the axis appears at the location of the geometry point, normal to the sketch plane. A geometry point can only be used for internal sketches of extrude features.
4. Geometry Centerline — Created only in Sketcher. A geometry centerline is created in the sketching plane, and when the sketch is completed, it displays as a datum axis within the graphics window. A geometry centerline can be used as the axis of revolution for a revolve feature. When a geometry centerline is selected in Sketcher, you can right-click...
and select **Construction** to convert it to a sketch entity. Likewise you can select a centerline and right-click and select **Geometry** to convert the centerline to a geometry centerline.

**Selecting Datum Axes**

You can select datum axes by the following methods:

- Select the axis line.
- Select the axis name tag.
- Select the axis in the model tree.
- Search for the axis by name in the search tool.

**Procedure: Creating Datum Axes**

**Scenario**

Create datum axes on a part model.

**Task 1. Create datum axes on a part model.**

1. Start the **Datum Axis Tool** from the feature toolbar.
2. Select the edge.
3. Click **OK** from the Datum Axis dialog box.
4. De-select the datum axis.
5. Start the **Datum Axis Tool**.
6. Select the surface.
7. Click **OK** and de-select the datum axis.

![Datum Axis Tool](image)

8. Start the **Datum Axis Tool**.

9. Press CTRL and select datum plane FRONT and the surface.

![Datum Plane Selection](image)

10. In the Datum Axis dialog box, select the **Display** tab.
   - Select **Adjust Outline**.
   - Select **Reference** from the drop-down list.
   - Select the same surface again.

11. In the Datum Axis dialog box, select the **Properties** tab.
   - Edit the name to **REF_1**.
   - Click **OK** and de-select the datum axis.
12. Start the **Datum Axis Tool**.

13. Select the surface.

14. Right-click and select **Offset References**.

15. Press CTRL and select the two surfaces.

16. Edit the values to **22** and **3**.

17. Click **OK** from the Datum Axis dialog box.
This completes the procedure.

### 8.3 Creating Datum Planes

#### Datum Plane Definition

Datum planes are individual features that can be redefined, suppressed, hidden, or deleted. A datum plane is a planar reference that has no mass. It is infinite in size, but its display size can be edited to visually fit a part, feature, surface, edge, axis, or radius. You can also drag its drag handle. A datum plane has two sides that display brown and grey, as shown in the lower figure. The front, or brown side, is considered to be positive, while the back, or gray side, is considered to be negative.

#### Datum Plane Uses

The RIGHT, FRONT, and TOP datum planes included in all the default templates are known as the default datum planes. Every feature is directly or indirectly...
created off of these datum planes. A datum plane can be used as construction geometry for a feature. It can also be used as a reference for:

- Other datum features such as datum axes.
- Other features such as sketches on an angle.
- Assembling components.

Datum Plane Types

When creating datum planes, you can select most any combination of geometry that defines a plane in 3-D space. You can select single or multiple references which are set as a combination of the following seven constraint types:

1. Through — Select any of the following:
   - Axis, edge, or curve
   - Point or vertex
   - Plane
   - Cylinder
2. Normal — Select any of the following:
   - Axis
   - Edge
   - Curve
   - Plane
3. Parallel — Select a plane
4. Offset — Select either of the following:
   - Plane
   - Coordinate system
5. Angle — Select a plane
6. Tangent — Select a cylinder
7. Blend Section — Select a blend feature and a section number

Selecting Datum Planes

You can select datum planes by the following methods:

- Select the datum frame.
- Select the datum plane tag.
- Select the datum plane in the model tree.
- Search for the datum plane by name in the search tool.

Procedure: Creating Datum Planes

Scenario
Create datum planes in a part model.
Task 1. Create datum planes in a part model.

1. Start the **Datum Plane Tool** from the feature toolbar.

2. Select the right surface and drag the drag handle to an offset of 12.

3. Click **OK** from the Datum Plane dialog box.

4. With DTM1 still selected, start the **Datum Plane Tool**.

5. Drag the drag handle to an offset of 8.

6. Click **OK** from the Datum Plane dialog box and de-select the datum plane.

7. Start the **Datum Plane Tool**.

8. Select the surface.

9. In the **Placement** tab of the Datum Plane dialog box, select **Through** from the drop-down list.
10. In the datum plane dialog box, select the Display tab.
   - Select Adjust Outline.
   - Edit the drop-down list to Reference.
   - Select the surface again.
   - Edit the drop-down list back to Size.
   - Edit the Width and Height to 14 and 10, respectively.
   - Click OK and de-select the datum plane.

11. Start the Datum Plane Tool.

12. Press CTRL and select the cylinder and edge.
13. In the Datum Plane dialog box, select **Tangent** from the surface reference drop-down list.
   - Click **OK** and de-select the datum plane.

14. Start the **Datum Plane Tool**.

15. Press \Ctrl\ and select datum axis A_2 and datum plane RIGHT.

16. In the Datum Plane dialog box, select **Parallel** from the datum plane reference drop-down list.
   - Click **OK**.

17. With DTM5 still selected, start the **Datum Plane Tool**.

18. Press \Ctrl\ and select datum axis A_2.

19. In the Datum Plane dialog box, select **Normal** from the datum plane reference drop-down list.
   - Click **OK** and de-select the datum plane.

21. Press CTRL and select datum axis A_2 and the surface.

22. Edit the offset value to 10 or -10 to attain the proper direction and click OK.

23. Edit the definition of DTM4.

24. In the Datum Plane dialog box, select the Display tab and click Flip.

   - Click OK.

25. De-select the datum plane.
This completes the procedure.
Check Your Knowledge

1. Which of the following is not a valid offset type when creating a new datum plane?
   A - Normal
   B - Parallel
   C - Along
   D - Through
   E - None of the above

2. Which of the following is not a potential use for datum features?
   A - As a parameter reference
   B - As a dimensioning reference
   C - As a feature placement reference
   D - As an assembly reference

3. Which of the following is a typical use for a datum axis?
   A - As a reference for creating datum planes
   B - As a reference defining the axis of revolution for a revolve feature
   C - As a reference for assembling components
   D - All of the above
   E - A and C only

4. What are typical uses of datum planes?
   A - As a reference for creating other datum planes
   B - As a reference defining the axis of revolution for a revolve feature
   C - As a reference for assembling components
   D - All of the above
   E - A and C only
Module 9

Creating Extrudes, Revolves, and Ribs

Module Overview

Once you have created 2-D sketches, you can use those sketches to create 3-D geometry.

In this module, you use 2-D sketches to create 3-D solid geometry features including extrude, revolve, and profile rib features. You also learn about the common dashboard options associated with these types of sketch-based features.
9.1 Creating Solid Extrude Features

Creating Solid Extrude Features

An extrude feature is based on a two-dimensional sketch. It linearly extrudes a sketch perpendicular to the sketching plane to create or remove material. You can either select the sketch first and then start the Extrude tool, or you can start the Extrude tool and then select the sketch.

In an assembly you cannot create an extrude feature that adds material. You can only remove material.

Procedure: Creating Solid Extrude Features

Scenario
Create solid extrude features.

Task 1. Create solid extrude features.

1. Start the Extrude Tool from the feature toolbar.
2. Select Sketch 1.
3. Drag the drag handle down below datum plane TOP to a depth of 16.
4. Click Complete Feature from the dashboard.

5. Start the Extrude Tool.
6. Select **Sketch 2**.

7. Edit the height to **24**.

8. Click **Complete Feature ✔**.

9. Start the **Extrude Tool 🔄**.

10. Select **Sketch 3**.

11. Click **Remove Material 🗑️ from the dashboard**.

12. Edit the depth to **Through All 🍃**.

13. Click **Complete Feature ✔**.
This completes the procedure.

9.2 Common Dashboard Options: Extrude Depth

Common Dashboard Options: Extrude Depth

When you create an extrude feature from a 2-D sketch, the depth at which the feature extrudes can be set in a variety of ways depending upon the design intent you wish to capture. You can specify the desired depth option using the dashboard or by right-clicking on the drag handle in the graphics window. Extrude depth options include:

- **Blind (Variable)** — This is the default depth option. You can edit this depth value by dragging the drag handle, editing the dimension on the model, or using the dashboard.
- **Symmetric** — The section extrudes equally on both sides of the sketch plane. You can edit the total depth at which the feature extrudes just as
you can with the Blind depth option. Therefore, the Symmetric depth is essentially the same as a Blind Symmetric depth.

- **To Next** — This option causes the extrude to stop at the next surface encountered. A depth dimension is not required, as the next surface controls the extrude depth.
- **Through All** — This option causes the section to extrude through the entire model. A depth dimension is not required, as the model itself controls the extrude depth.
- **Through Until** — This option causes the extrude to stop at the selected surface. A depth dimension is not required, as the selected surface controls the extrude depth. Note that the section must pass through the selected surface.
- **To Selected** — This option causes the extrude to stop at the selected surface. A depth dimension is not required, as the selected surface controls the extrude depth. Unlike the Through Until depth option, the section does not have to pass through the selected surface.
- **Side 1/Side 2** — You can independently control the depth at which the section extrudes on each side of the sketching plane. By default, the section extrudes on Side 1; however, you can cause the section to extrude on Side 2 as well. Any of the above options can be used for either side except for Symmetric.

The To Next and Through All options only consider geometry present at the time (in the feature order) when the extrude is created. Features created after the extrude feature is created do not cause the extrude feature's depth to change.

You can also switch depth options by right-clicking on the drag handle in the graphics window.

---

**Procedure: Common Dashboard Options: Extrude Depth**

**Scenario**
Create extrude features using different depth options.

**Task 1. Create extrude features using different depth options.**

1. Start the Extrude Tool.
2. Select sketch BLIND, and edit the depth to 200.
3. Click Complete Feature.
4. Start the **Extrude Tool**.

5. Select sketch SYMMETRIC.

6. In the dashboard, edit the depth to **Symmetric** and drag the drag handle to **125**.

7. Click **Complete Feature**.

8. Start the **Extrude Tool**.

9. Select sketch TO_NEXT.

10. Edit the depth to **To Next**.

11. Click **Complete Feature**.
The To Next preview displays across the whole model because it must calculate the whole model to determine the "next" surface.

12. Start the Extrude Tool.

13. Select sketch THRU_ALL.

14. Edit the depth to Through All and click Remove Material.

15. Click Complete Feature.

16. Start the Extrude Tool.

17. Select sketch THRU_UNTIL.

18. Edit the depth to Intersect Selected Surface and select the surface.

19. Click Complete Feature.
20. Start the **Extrude Tool**.

21. Select sketch TO_SURFACE.

22. Edit the depth to **To Selected** and select the surface.

23. Click **Complete Feature**.

24. Notice the contour at the extrude end.

25. Click **Plane Display**.

26. Start the **Extrude Tool**.

27. Select sketch TO_PLANE.

28. Edit the depth to **To Selected** and select datum plane DTM1.
29. Click **Complete Feature ✓**.

30. Start the **Extrude Tool ➔**.

31. Select sketch BOTH_SIDES and edit the depth to **220**.

32. Select the **Options** tab and edit the Side 2 depth to **To Next ➕**.

33. Click **Complete Feature ✓**.

This completes the procedure.
9.3 Common Dashboard Options: Feature Direction

Common Dashboard Options: Feature Direction

When you create a feature, such as an extrude feature, there are two yellow arrows that appear in the interface, as shown to the right.

In this case, the arrow on the right displays perpendicular to the section and denotes the depth direction. The arrow on the left displays parallel to the section and denotes the material direction.

Specifying the Depth Direction

The depth direction arrow in the interface shows you which direction the feature will be created with respect to the sketching plane. You can flip the direction of feature creation either by using the dashboard or by clicking the arrow in the interface. In the upper-right figure, the depth direction was flipped.

By default, the feature is created in only one direction. This is known as Side 1. However, you can add the second direction so the feature is created in both directions from the sketch plane. This second side is Side 2. In the lower-left figure, the Side 2 depth direction was added to the feature.

Specifying the Material Direction

The material direction arrow in the interface shows you which side of the sketch material will be removed when creating a cut. This arrow only displays when removing material. Like the depth direction arrow, you can flip the material direction either by using the dashboard or by clicking the arrow in the interface. In the lower-right figure, the material direction for the cut was flipped from the inside to the outside. Consequently, the material that was removed flipped from the inside to the outside.

Procedure: Common Dashboard Options: Feature Direction

Scenario
Modify the depth and material directions for various extrude features.

Task 1. Modify the depth and material directions for various extrude features.
1. Edit the definition of HEX.

2. Click **Change Depth Direction** from the dashboard.
   - Click **Preview Feature** from the dashboard.

3. Orient the model and notice the cut is now on the underside of the model.

4. Click **Resume Feature** from the dashboard.

5. In the dashboard, click **Change Material Direction**.
   - Click **Preview Feature**. The hex feature is now removing material on the outside of the sketch.
The hex feature is still removing material from the model (the base).

6. Click **Resume Feature**.

7. In the dashboard, click **Change Material Direction**.
   - Click **Complete Feature**.

8. Press CTRL+D to orient to the **Standard Orientation**.

9. Edit the definition of OVAL. Notice the depth direction points upward.
10. In the dashboard, select the **Options** tab.

   - Edit the Side 2 depth to **Blind** and edit the value to **28**.
   - Click **Complete Feature**.

11. Orient the model and view the underside of the model.

This completes the procedure.
9.4 Common Dashboard Options: Thicken Sketch

Common Dashboard Options: Thicken Sketch Theory

The Thicken Sketch option is available in many types of features including extrude, revolve, blend, and sweep features. When creating one of these features, you can use the Thicken Sketch option to assign a thickness to the selected section outline.

- You can create features that either add or cut away material.
- You can edit the material thickness, as shown in the lower-right figure.
- You can also change the side of the sketch where the thickness is added, or add thickness to both sides of the sketch by using Change Thickness Side to toggle through the options.
- You can use this option on both open and closed sketches.

For example, you can use the Thicken sketch option to sketch a circle and extrude it into a pipe shape with a specified wall thickness, or you can use it to sketch a rectangle and extrude it into box-shaped tubing, again with a specified wall thickness.

Procedure: Common Dashboard Options: Thicken Sketch

Scenario
Thicken the sketches of various extrude features in a model.

1. Notice the hex cut in the bottom of the model.
2. Orient to the Standard Orientation.
3. Edit the definition of OVAL.

4. In the dashboard, click **Thicken Sketch**.
   - Edit the thickness value to **4**.
   - Click **Change Thickness Side**.
   - Click **Complete Feature**.
5. Edit the definition of OVAL.

6. In the dashboard, edit the depth value to 10.

   - Click **Change Depth Direction**.
   - Click **Remove Material**.
   - Click **Change Thickness Side** to thicken on both sides of the sketch.
7. Click **Complete Feature**.

This completes the procedure.

### 9.5 Creating Solid Revolve Features

A revolve feature is based on a two-dimensional sketch. You can use a revolve feature to revolve a sketch about an axis of revolution (in the sketching plane) to create or remove material. You can either select the sketch first and start the Revolve tool, or you can start the Revolve tool and then select the sketch.

When you select a sketch to be revolved, the feature uses, by default, the first geometry centerline sketched within the section as the axis of revolution, as shown in the left image in the lower-left figure. However, you can also select any other straight curve or edge, datum axis, or coordinate system axis as the axis of revolution. If the sketch you are revolving does not contain a geometry centerline, you will need to select one of these other references as the axis of revolution.
In the right image in the lower-left figure, the axis of revolution has been changed to the REV datum axis. There are two rules for defining the axis of revolution:

1. Geometry must be sketched only on one side of the axis of revolution.
2. The axis of revolution must lie in the sketching plane of the section.

You can revolve either an open or closed sketch. In the figures, a closed sketch is used to create the feature that adds material, while an open section is used to create the cut that removes material.

You can also thicken the sketch used to create a revolve feature.

**Procedure: Creating Solid Revolve Features**

**Scenario**
Create solid revolve features about different axes.

**Task 1. Create solid revolve features using different axes of revolution.**

1. Edit the definition of Sketch 1. Notice the vertical and horizontal centerlines.

2. Select the vertical centerline, right-click, and select Geometry.

3. Click Geometry Centerline from the Sketcher toolbar and sketch a horizontal geometry centerline over the horizontal centerline.

4. Click Done Section ✔.
5. Orient to the **Standard Orientation**.

6. Start the **Revolve Tool** from the feature toolbar.

7. Select **Sketch 1** if necessary.

8. Right-click and select **Axis of revolution Collector**.

9. Select datum axis REV.

10. Click **Complete Feature**.

11. Edit the definition of **Revolve 1**.

12. In the dashboard, select the **Placement** tab and click **Internal CL**.
13. Click **Complete Feature ✓**.

14. Click **Axis Display †** to disable their display.

15. Start the **Revolve Tool ‡** from the feature toolbar.

16. Select **Sketch 2**.

17. Click **Remove Material ‡**.

18. Edit the Revolve angle to **75** and press ENTER.

19. Click **Complete Feature ✓**.

20. Edit the definition of **Revolve 2**.
21. Edit the Revolve angle back to 360 and press ENTER.

22. Click Complete Feature ✓.

This completes the procedure.

9.6 Common Dashboard Options: Revolve Angle

When you create a revolve feature from a 2-D sketch, the depth angle at which the feature revolves can be set in a variety of ways depending upon the design intent you wish to capture. Revolve angle options include:

- Variable (Blind) — This the default revolve angle option. You can edit this revolve angle value by dragging the drag handle, editing the dimension on the model, or using the dashboard. The dashboard also contains four predefined angles, 90°, 180°, 270°, and 360° that you can select.
- Symmetric — The section revolves equally on both sides of the sketch plane. You can edit the total angle at which the feature revolves just as you can with the Variable depth angle option. Therefore, the Symmetric angle is essentially same as the Variable Symmetric depth.
- To Selected — This option causes the revolve to stop at the selected surface or datum plane. A dimension for angle value is not required, as the selected surface controls the revolve angle. The location on where you select the datum plane or surface determines where the revolve stops at in relation to the axis of revolution. In the lower-left figure datum plane DTM2 was selected to the right of the axis of revolution. If datum plane DTM2 was selected to the left of the axis of revolution, the feature would have revolved another 180 degrees before stopping.
Side 1/Side 2 — You can independently control the angle at which the section revolves on each side of the sketching plane. By default, the section revolves on Side 1; however, you can cause the section to revolve on Side 2. Any of the above options can be used for either side except for Symmetric.

You can also switch revolve angle options by right-clicking on the drag handle in the graphics window.

Procedure: Common Dashboard Options: Revolve Angle

Scenario
Use the various revolve angle options for a revolve feature.

Task 1. Use the various revolve angle options for a revolve feature.

1. Start the Revolve Tool.

2. Select the visible sketch and select datum axis REV from the model tree.

3. Edit the revolve angle depth value to 90 and click Change Angle Side.
4. Click **Change Angle Side** again.

5. Edit the depth to **Symmetric**.

6. Edit the depth to **To Selected**.

7. Click **Plane Display** and select datum plane DTM2 to the right of the axis of revolution.

8. In the dashboard, select the **Options** tab.
   - Edit the Side 2 depth to **Variable** and type 90 as the value.
9. In the dashboard, edit the Side 2 depth to **To Selected** and select datum plane DTM2 to the left of the axis of revolution.

10. Click **Complete Feature**.

This completes the procedure.

### 9.7 Creating Profile Rib Features

Ribs are typically used to strengthen parts. A profile rib feature is similar to an extruded protrusion, except that it requires an open section sketch. The rib also conforms to existing planar or cylindrical geometry when it is extruded. After you select an open section sketch and set a thickness, Pro/ENGINEER automatically creates the profile rib feature by merging it with your model. The system can add material above or below the sketch, and the thickness can be applied on either side, or be symmetric about the sketch. The **Profile Rib Tool** enables you to create rib features faster than it would be for you to create and sketch a protrusion.
Procedure: Creating Profile Rib Features

Scenario
Create profile rib features on a part model.

Task 1. Create profile rib features on a part model.

1. Start the Profile Rib Tool from the feature toolbar.
2. Select RIB_SKETCH-1.
3. Drag the width to 75.
4. Click Complete Feature.

Notice the angled rib surface is not planar; it is contoured to match the curved surface the sketch is adjacent to.

5. Start the Profile Rib Tool.
7. Orient to view orientation RIGHT.

8. Drag the width to 25. The rib is centered about the sketch.

9. Click Change Thickness Option. The rib moves to the left of the sketch.

10. Click Change Thickness Option again. The rib moves to the right of the sketch.

11. Click Complete Feature.

12. Reorient the model.
13. Start the **Profile Rib Tool**.

14. Select RIB_SKETCH-3. The rib is above the sketch.

15. Click the yellow arrow in the graphics window. The rib is now on the bottom of the sketch.

16. Click **Complete Feature**.

This completes the procedure.
Check Your Knowledge

1. What is not a characteristic of Extrude features?
   A - Based on a 2-D sketch
   B - Can add or remove material in both parts and assemblies
   C - They are extruded perpendicular to the sketching plane
   D - All of the above
   E - B and C only

2. What is not an Extrude depth option?
   A - Blind
   B - Variable
   C - Symmetric
   D - To Selected
   E - Both A and B
   F - None of the above

3. True or False? When editing the definition of a feature, you can edit both the depth direction and material direction.
   A - True
   B - False

4. Which feature type is the Thicken Sketch option available?
   A - Extrude features
   B - Revolve features
   C - Blend features
   D - Sweep features
   E - All of the above
   F - None of the above
5. What is a characteristic of a Revolve feature?

A - Geometry must be sketched only on one side of the axis of revolution.

B - The axis of revolution does not need to lie in the sketching plane of the sketched section.

C - You can change the axis specified as the axis of revolution.

D - All of the above.

E - A and C only.
Module 10

Utilizing Internal Sketches and Embedded Datums

Module Overview

When creating 3-D geometry features, you can select sketches and datum features to help you create that geometry. However, these items do not already have to exist in the model tree. Rather, they can be created at the time they are needed.

In this module, you learn how to create internal sketches when creating sketch-based features as an additional option to selecting a preexisting sketch. You also learn how to create embedded datum features.
Creating Internal Sketches

Internal Sketches

Prior to the release of Pro/ENGINEER Wildfire, internal sketches were the only sketch type available in Pro/ENGINEER. You are now given the choice of using either internal or external sketches within Pro/ENGINEER.

PTC does not recommend one type of sketch over the other; you should use the type that works best for you. In this topic, we discuss how to use internal sketches and some of the benefits they can provide.

Creating an Internal Sketch

Internal sketches are created during the creation of any sketched feature.

- Start the feature tool for any sketched feature (for example, Extrude Tool).
- Click Define from the Placement tab in the dashboard and create a sketch. You can also right-click and select Define Internal Sketch to enter Sketcher.
- Complete the feature and an internal sketch with the name S2D000# is created and embedded within the feature.

Pros and Cons of Internal Sketches

Internal sketches provide some benefits that external sketches do not.

- Organization — Because internal sketches are embedded in the feature they define, you always know where to find them. External sketches are separate features that can be renamed and reordered like other
features. In a model containing hundreds of features, it can take some time to determine which sketch is used to define which feature. This is not a problem, just something to be aware of when selecting the type of sketch you will use.

- **Reduced Feature Count** — Because internal sketches are not features, they do not add to the total number of features in a model. Creating a separate external sketch for every sketched feature in your model can dramatically increase the number of features in a model. In models containing hundreds or even thousands of features, external sketches can dramatically increase the total feature count in a model. Again, this is something you will want to consider when selecting the type of sketch you will use.

- Unfortunately, you cannot simply make an internal sketch external without saving it out and recreating it.

**Pros and Cons of External Sketches**

External sketches provide some benefits that internal sketches do not.

- You can always redefine an external sketch to internal.
- You can select a different sketch for the same feature. This enables you to quickly pursue multiple design options.
- The same external sketch can be specified for multiple features.
- You can unlink a specified external sketch.
- External sketches result in a higher feature count because there is an additional sketch feature for every sketched feature as displayed in the model tree.

**Procedure: Creating Internal Sketches**

**Scenario**
Work with internal and external sketches to see how they differ.

1. Select external **Sketch 2** and notice it in the model.
2. Expand **Extrude 2**, and notice that external Sketch 2 is used within it.
3. De-select the sketch.
4. Orient to the **Standard Orientation** and observe the 12_POINT sketch.

5. Start the **Extrude Tool**.

6. Select the **Placement** tab in the dashboard.
   - Click **Define** to create the internal sketch.
   - Select the front surface of the model.

7. Click **Sketch** from the Sketch dialog box.
8. Sketcher display: ![Sketcher Display Image]

9. Click **Palette** and place the **Hexagon** shape.

10. Delete the length dimension, and edit the resulting radius dimension to **10**.

11. Click **Done Section**.

12. Orient to the **Standard Orientation**.

13. Click **Remove Material**.

14. Click **To Selected** and query select the surface at the bottom of Extrude 2.

15. Click **Complete Feature**.
16. Expand **Extrude 3** in the model tree, and notice the internal sketch S2D0001.

17. Edit the definition of **Extrude 3**.

18. Select the sketch feature 12_POINT as the new sketch.

19. Click **OK** from the Section Selection dialog box to replace the existing internal sketch.

20. Click **Complete Feature ✓**.

21. Expand **Extrude 3** again in the model tree. Notice that Extrude 3 now uses the sketch feature 12_POINT, and is external.
22. Select sketch 12_POINT and press DELETE. Notice that Extrude 3 will also be deleted, as it uses the 12_POINT sketch. Click Cancel from the Delete dialog box.

23. Edit the definition of Extrude 3.

24. In the dashboard, select the Placement tab and click Unlink.

25. Click OK from the Unlink dialog box to break the association.

26. Click Complete Feature ✓.

27. Select sketch 12_POINT and press DELETE. Click OK to delete the sketch feature.

28. In the model tree, expand Extrude 3 and notice that it again contains an internal sketch.

This completes the procedure.
10.2 Creating Embedded Datum Features

Benefits of Embedded Datum Features

Embedded datum features can be used as sketch planes, orientation planes, dimensioning references, placement references for holes, references for draft features, and so on. Datum features can even be embedded in other datum features.

Suppose you have begun the creation of an extrude feature, and then realize the sketch plane you need has not yet been created. You could cancel out of the Extrude Tool, create the datum plane, then start the Extrude Tool again. A better solution would be to simply create the sketch plane as an embedded datum, while the Extrude Tool is still open.

Another benefit of embedded datum features is that they produce a cleaner, more organized model tree. For example, if the sketch plane of an extrude feature you are creating requires that you create three datum planes and an axis, those four datum features will be embedded within the node of the extrude feature; they will not clutter the model tree as regular features would.

Each embedded datum feature functions as some type of reference to the feature in which it is embedded, otherwise it would not be embedded. This makes it easy to determine what each datum is used for and which feature references it.

The display of embedded datum features is automatically set to hidden after they are created. This helps ensure that the display of your model remains uncluttered.

In the following figure, notice the three different displays of the same model tree. The model on the left was created without using embedded datum features. The figure in the middle was created using embedded datum features and the feature nodes are expanded. The figure on the right displays the same model (as the middle figure) with the feature nodes collapsed.
Creating Embedded Datum Features

Embedded datums are created by starting a datum tool during the creation of another feature. Starting the datum tool will automatically pause the creation of the current feature, enabling you to create the required datum feature.

After you have created the required datum features, you can resume the creation of the feature by clicking Resume Feature in the dashboard.

By then selecting the newly created datum features as sketch planes, orientation, dimensioning, placement, or depth references, they become embedded in the feature.

About Embedded Datum Features

When you delete a feature containing embedded datum features, Pro/ENGINEER gives you the option to keep or also delete the embedded datum features.

Sketch and orientation datum planes can only be embedded in features using internal sketches.

If for some reason the datum features you create are not embedded as expected, you can select them in the model tree and drag them into the feature, after creation. This will embed them and set their display to hidden, just as if they were originally embedded. Datums can be un-embedded in the same way, by dragging them from a feature back to the model tree.

Best Practices

Embedded datum features should be used as the design intent dictates. For example, you cannot reuse an embedded datum feature in a downstream feature. Their use promotes the creation of models that are easier to edit, use and thus easier to share with downstream users.

Procedure: Creating Embedded Datum Features

Scenario
Create an extrude feature using a series of embedded datum features created to define sketch, orientation, and depth references.

Task 1. Create an extrude feature referencing embedded datum features.
1. Start the **Extrude Tool** ☐.

2. Start the **Datum Plane Tool** ☐, select the surface, and drag the Offset to **10**.

3. In the Properties tab, edit the Name to **OFFSET** and click **OK**.

4. With **OFFSET** still selected, start the **Datum Axis Tool** ☐, press **CTRL**, and select the top surface.

5. Edit the name to **PIVOT** and click **OK**.

---

Creating each of these datum features after starting a feature tool defines them as embedded.
6. With PIVOT still selected, start the Datum Plane Tool, press CTRL, and select the top surface.

7. Edit the Rotation to either 25 or -25 to attain the proper direction.

8. Edit the name to ORIENT and click OK.

9. With ORIENT still selected, start the Datum Plane Tool, press CTRL, and select datum axis PIVOT.

10. Edit the ORIENT reference from Offset to Normal.
11. Select the **Display** tab and click **Flip** to orient the yellow arrow as shown.

12. Edit the name to **SKETCH** and click **OK**.

13. In the dashboard, click **Resume Feature**.

14. Right-click and select **Define Internal Sketch**.
   - Select SKETCH as the Sketch Plane.
   - Select Orientation **Top** for datum plane ORIENT.
   - Click **Sketch**.

15. If necessary, select datum plane RIGHT as the vertical reference and click **Close** from the References dialog box.

16. Sketcher display:

17. Click **Center and Point Circle** and sketch the circle.

18. Edit the diameter to **32**.

19. Click **Done Section**.
20. Orient to the 3D orientation.

21. In the dashboard, click Change Depth Direction and edit the depth to To Selected.

22. Click Plane Display and Axis Display to disable their display.

23. Start the Datum Plane Tool, press CTRL, and select the two inner hole surfaces.
   
   o Edit the name to DEPTH, and click OK.

24. Click Resume Feature from the dashboard. Because datum plane DEPTH is still selected, it is automatically selected as the depth reference.
25. Click **Complete Feature ✔**.

26. Edit the definition of **Extrude 4**.

27. Click **Remove Material 🔴** and click **Complete Feature ✔**.


29. Edit **Extrude 4**. Notice that dimensions from the feature and all embedded datums are displayed.

This completes the procedure.
Check Your Knowledge

1. What is a benefit to using Internal Sketches versus External Sketches in features?
   A - There is no dependency between the Internal sketch and the feature.
   B - Organization.
   C - Reduced feature count in the model tree.
   D - All of the above.
   E - B and C only.

2. True or False? You can create an embedded datum feature by dragging it into an existing feature in the model tree.
   A - True
   B - False

3. True or False? An internal sketch is contained in the feature it defines.
   A - True
   B - False

4. What BEST describes the result of creating a sketched-based feature using an external sketch?
   A - The sketch will be linked and will be placed as a sub-node under the extruded feature with a different name in the Model Tree than the original.
   B - The sketch will NOT be linked and will be placed as a sub-node under the extruded feature with a different name in the Model Tree than the original.
   C - The sketch will be linked and will be placed as a sub-node under the extruded feature with the same name in the Model Tree as the original.
   D - The external sketch geometry is copied into the extruded feature with a non-associative link.
5. How do you unlink an external sketch that was used to create a sketched-based feature?

A - By using the Edit References command and selecting the Placement tab in the dashboard.

B - By using the Edit Definition command and selecting the Placement tab in the dashboard.

C - By right clicking on the sketch in the Model Tree and selecting the Unlink option in the pop-up menu.

D - There is no way to break a linked external sketch without deleting the feature and recreating it.
Module 11

Creating Sweeps and Blends

Module Overview

Extruded and revolved features comprise the majority of the features on the models that you create. However, there are occasions when extruded and revolved features cannot easily create the necessary geometry. In these instances, you may need to sketch more advanced geometry features.

In this module, you learn how to create two advanced geometry features: the sweep feature and the blend feature.

11.1 Creating Sweeps with Open Trajectories
Creating Sweeps with Open Trajectories

You create a sweep feature to create a constant cross-section feature that follows a trajectory curve. A sweep can either be created as a protrusion or a cut, and is defined as such when starting the feature. Once defined, you cannot redefine a protrusion to a cut, or a cut to a protrusion. You can also specify the thin option for both the swept protrusion and swept cut. A sweep feature consists of both a trajectory and a section.

Defining the Trajectory

The trajectory is the path that a section sweeps along. The trajectory can be open, meaning that it does not have to create a loop, as shown in the figures. It can have sharp or tangent corners, as can be seen respectively in the upper figures' protrusion and the lower figures' cut. The trajectory can also either be selected or sketched.

- Selected trajectory — A selected trajectory can consist of selected datum curves or edges. Other than selecting a sketched curve, the other allowable datum curve types for a trajectory are Intersection of two surfaces, Use Xsec, Project, Wrap, Offset, and Two projection. When selecting a trajectory, the following selection methods and options are available:
  - One By One — Select individual curves or edges.
  - Tangnt Chain — Select a chain of tangent edges.
  - Curve Chain — Select a chain of curves.
  - Bndry Chain — Select a chain of one-sided edges that belong to the same surface list.
  - Surf Chain — Select a chain of edges that belong to the same surface.
  - Intent Chain — Select an intent chain.
  - Select / Unselect — Select or unselect chain edges.
  - Trim / Extend — Trim or extend chain ends.
- Sketched trajectory — Sketch the trajectory to be swept along. The sketched trajectory is created internal to the sweep feature.

When the trajectory has been defined, you can select the start point for the section. The start point is the location from which the section begins to sweep.

**Defining the Section**

Once the trajectory and start point have been defined, you must sketch the section that will be swept along the trajectory. The sketch plane for the section is perpendicular to the trajectory at the start point. The crosshairs seen in the sketching plane are the intersection of the trajectory and sketch plane.

The sketched section may be either open or closed. The swept protrusion in the upper figures is a closed section, while the swept cut in the lower figures is an open section.

**Causes of a Sweep Failure**

A sweep feature may fail if one of the following three situations occur:

- A trajectory crosses itself.
- You align or dimension a section to fixed entities, but the orientation of the section changes when it is swept along the 3-D trajectory.
- A trajectory arc or spline radius is too small, relative to the section, and the feature intersects itself while traversing around the arc.

**Procedure: Creating Sweeps with Open Trajectories**

**Scenario**
Create open trajectory sweeps with an open and closed sketch.

**Task 1. Create an open trajectory sweep protrusion with a closed sketch.**

1. Click **Insert > Sweep > Protrusion** from the main menu.
2. Click **Select Traj > Curve Chain > Select** from the menu manager.
3. Select one segment of **Sketch 1** from the graphics window and click **Select All > Done** from the menu manager.
4. Sketcher display:

5. Sketch a vertical centerline on the vertical reference and click **Palette**.

6. Select the **Profiles** tab and add the **T-profile** to the sketch.
   - Right-click on the X Location handle and drag it to the midpoint of the top horizontal line.
   - Edit the scale to **0.5** and click **Accept Changes**.

7. Orient to the **Standard Orientation** and notice the trajectory and section.

8. Click **Done Section**.

9. Click **OK** from the Protrusion dialog box.

10. In the model tree, right-click **Sketch 1** and select **Hide**.
Task 2. Create an open trajectory sweep cut with an open sketch.

1. Click Insert > Sweep > Cut from the main menu.

2. Click Sketch Traj from the menu manager and select the top surface of the model, followed by Okay from the menu manager.

3. Click Bottom from the menu manager and select the front "T" surface.

4. Select datum planes OFFSET and RIGHT as references, as well as the top surface and two vertices.
5. Click **Center and Point Circle** and sketch two circles that are tangent to the references.

6. Click **Line** and sketch two vertical lines. The first should start at the top reference and snap tangent to the top circle. The second should start at the bottom reference and snap tangent to the bottom circle.

7. Click **Line Tangent** and create the tangent line.

8. Click **Trim/Delete Segment** and trim the circle entities.
9. Click **Done Section ✓**.

10. Click **Free Ends > Done** from the menu manager.

11. Click **Center and Ends Arc** and sketch an arc with a radius of **0.4**.

12. Orient to the **Standard Orientation** and notice the trajectory and section.

13. Click **Done Section ✓**.

14. Click **Okay** from the menu manager and click **OK** from the Cut dialog box.
This completes the procedure.

11.2 Creating Sweeps with Closed Trajectories

Creating Sweeps with Closed Trajectories

You create a sweep feature when you want to create a constant cross-section feature that follows a trajectory curve. A sweep can either be created as a protrusion or a cut, and is defined as such when starting the feature. Once defined, you cannot redefine a protrusion to a cut, or a cut to a protrusion. You can also specify the thin option for both the swept protrusion and swept cut. A sweep feature consists of both a trajectory and a section.

Defining the Trajectory

The trajectory is the path that a section sweeps along. The trajectory can be closed, meaning that it creates a loop, as shown in the figures. It can have sharp or tangent corners. The trajectory can also either be selected or sketched.
Selected trajectory — A selected trajectory can consist of selected datum curves or edges. Other than selecting a sketched curve, the other datum curve types allowed for a trajectory are Intersection of two surfaces, Use Xsec, Project, Wrap, Offset, and Two projection. When selecting a trajectory, the following selection methods and options are available:
  - One By One — Select individual curves or edges.
  - Tangent Chain — Select a chain of tangent edges.
  - Curve Chain — Select a chain of curves.
  - Boundary Chain — Select a chain of one-sided edges that belong to the same surface list.
  - Surf Chain — Select a chain of edges that belong to the same surface.
  - Intent Chain — Select an intent chain.
  - Select / Unselect — Select or unselect chain edges.
  - Trim / Extend — Trim or extend chain ends.

Sketched trajectory — Sketch the trajectory to be swept along. The sketched trajectory is created internal to the sweep feature.

When the trajectory has been defined, you can select the start point by clicking **Start Point** from the menu manager and selecting the desired location on the trajectory. The start point is the location from which the section begins to sweep.

After the start point has been defined, you must select whether you want to add inner faces. When you add inner faces, the top and bottom faces close the swept solid, as is shown in the lower figures. Note that the sketched section must be open when adding inner faces.

**Defining the Section**

Once the trajectory and start point have been defined, you must sketch the section that will be swept along the trajectory. The sketch plane for the section is perpendicular to the trajectory at the start point. The crosshairs seen in the sketching plane are the intersection of the trajectory and sketch plane.

The sketched section may be either open or closed. The swept protrusion in the upper figures is a closed section, while the lower figures display an open section.

**Causes of a Sweep Failure**

A sweep feature may fail if one of the following three situations occur:

- A trajectory crosses itself.
- You align or dimension a section to fixed entities, but the orientation of the section changes when it is swept along the 3-D trajectory.
- A trajectory arc or spline radius is too small relative to the section, and the feature intersects itself while traversing around the arc.
Procedure: Creating Sweeps with Closed Trajectories

Scenario
Create closed trajectory sweeps with an open and closed sketch.

Task 1. Create a closed trajectory sweep protrusion with a closed sketch and without inner faces.

1. Click Insert > Sweep > Protrusion from the main menu.
2. Click Select Traj > Curve Chain > Select from the menu manager.
3. Select one segment of Sketch 2 in the graphics window and click Select All > Done from the menu manager.
4. Click No Inn Fcs > Done from the menu manager.

5. Sketcher display: Sketch a vertical centerline on the vertical reference and click Palette.
7. Select the Profiles tab and add the T-profile to the sketch.
   - Right-click on the X Location handle and drag it to the midpoint of the top horizontal line.
8. Orient to the **Standard Orientation** and notice the trajectory and section.

9. Click **Done Section**.

10. Click **OK** from the Protrusion dialog box.

**Task 2.** Edit the sweep to create a closed trajectory protrusion with an open sketch and inner faces added.
1. Edit the definition of **Protrusion id 1379**.

2. In the Protrusion dialog box, select **Attributes** and click **Define**.

3. In the menu manager, click **Add Inn Fcs > Done**.

4. Click **Trim/Delete Segment** and trim the right side of the sketch.

5. Orient to the **Standard Orientation** and notice the trajectory and section.

6. Click **Done Section**.

7. Click **OK** from the Protrusion dialog box.

This completes the procedure.
11.3 Analyzing Sweep Feature Attributes

If the trajectory of a sweep feature is open (meaning, the start and end points of the trajectory do not touch) you can edit the attributes of the ends of the sweep feature to one of the following options:

- **Merge Ends** — Merge the ends of the sweep into the adjacent solid. To do this, the sweep ends must be touching the other solid geometry. The merged sweep ends are shown in the lower-right figure.

- **Free Ends** — Do not attach the sweep ends to the adjacent geometry. This is the default option, and is shown in the lower-left figure.

**Procedure: Analyzing Sweep Feature Attributes**

**Scenario**
Edit the ends of a sweep feature from free to merged.

**Task 1. Edit the ends of a sweep feature from free to merged.**

1. Orient to the FRONT view. Notice that there is a gap between the ends of the curved tube and the top and bottom flat surfaces.
2. Edit the definition of Protrusion id 429.

3. In the Protrusion dialog box, select Attributes and click Define.

4. In the menu manager, click Merge Ends > Done.

5. Click OK from the Protrusion dialog box. Notice that the gap between the curved tube and the top and bottom flat surfaces is now gone.

This completes the procedure.

11.4 Creating a Parallel Blend Protrusion or Cut

Creating a Parallel Blend Protrusion or Cut

You create blend features when you need to create models that contain different transitional cross-sections. This means that you can create geometry that starts as a circular cross-section, but as you transition along the length of the feature, the feature changes to a square cross-section. Therefore, blend features
can create cuts and protrusions that use different cross-sectional sketches. Parallel blends consist of sections, direction of feature creation, and depth.

**Defining the 2-D Sections**

To create a parallel blend, there must be at least two sections on the same sketching plane. Each section, like any sketch, is fully constrained and dimensioned. When you are ready to create the second or any subsequent section, you must toggle the section. In doing so, the existing sketches become grayed out and temporarily inactive.

Each section has its own start point. The start points should correspond between sections to avoid a twisting effect in the blend. You can move the start point in a sketch by selecting the desired vertex, right-clicking, and selecting **Start Point**. The upper figure shows all three sections as having a start point at the upper-left.

Each section must contain the same number entities (or vertices) per section. There are two exceptions to this rule. First, the blend can start or end as a single point. Second, a number of blend vertex points can be added, which count as ‘entities’. For example, a blend vertex placed on a triangular section enables the system to blend to a square. The system essentially connects the points of each section to create the blend feature.

**Defining the Direction of Feature Creation**

You must specify the direction in which the blend sections are projected. You can flip the direction of feature creation.

**Defining the Depth of the 2-D Sections**

The first section created in the parallel blend remains on the sketching plane. Each subsequent section is projected normal to the sketching plane at a
specified distance in the direction of feature creation. The following depth options are available:

- **Blind** — Specify a depth value between projected sections.
- **Thru Next** — The section is projected up to the next encountered surface.
- **Thru All** — The section is projected through all surfaces.
- **Thru Until** — The section is projected up to the specified surface.
- **From To** — The section is projected between two selected surfaces.

**Procedure: Creating a Parallel Blend Protrusion or Cut**

**Scenario**
Create a blend protrusion and a blend cut.

**Task 1. Create a 3-section blend protrusion.**

1. Click Insert > Blend > Protrusion from the main menu.
2. In the menu manager, click Done > Straight > Done.
   - Select datum plane FRONT and click Okay > Default.
3. Sketcher display:
4. Click Palette and place the blend_section1.
   - Relocate the Location handle to the center.
   - Edit the scale to 1 and click Accept Changes ✅.
5. Click in the background to clear the selection, then right-click and select **Toggle Section**.

6. Add the **blend_section2** from the Sketcher palette. Relocate the Location handle to the center, edit the scale to 1, and click **Accept Changes ✓**.

7. Click in the background, then right-click and select **Toggle Section**.

8. Add the **blend_section3**. Relocate the Location handle to the center, edit the scale to 1, and click **Accept Changes ✓**.

9. Click **Done Section ✓**.

10. Edit the depth for section 2 to **30** and the depth for section 3 to **20**.
11. Orient to the Standard Orientation and click OK.

Task 2. Create a 3-section blend cut.

1. Click Insert > Blend > Cut from the main menu.

2. In the menu manager, click Done > Straight > Done.
   - Select the front surface and click Okay > Default.
   - Select datum planes TOP and RIGHT as references.

3. Sketcher display:

4. Click No hidden

5. Click Centerline and sketch a vertical and horizontal centerline.

6. Click Rectangle, sketch the first section, and dimension it.
7. Right-click and select **Toggle Section**.

8. Click **Rectangle □**. sketch the second section, and dimension it.

9. Right-click and select **Toggle Section**.

10. Click **Rectangle □**. sketch the third section, and dimension it.

11. Click **Done Section ✔**.

12. Click **Shading ☐**.
13. Click **Okay > Blind > Done** from the menu manager.

14. Edit the depth for section 2 to **20** and the depth for section 3 to **30**.

15. Orient to the **Standard Orientation** and click **OK**.

This completes the procedure.
11.5 Experimenting with Parallel Blend Attributes

When the sections of a parallel blend are projected normal to the sketching plane, you can connect the sections by two methods:

- **Straight** — The blend sections are connected using straight lines, as shown in the left figure. This is the default option.
- **Smooth** — The blend sections are connected using smooth curves, as shown in the right figure.

**Procedure: Experimenting with Parallel Blend Attributes**

**Scenario**
Edit the blend shape of a parallel blend.

**Task 1. Edit the blend shape of a parallel blend.**

1. Edit the definition of **Protrusion id 23**.

2. In the Protrusion dialog box, select **Attributes** and click **Define**.
3. In the menu manager, click **Smooth > Done**.

4. Click **OK** from the Protrusion dialog box.

5. Edit the definition of **Cut id 153**.

6. In the Cut dialog box, select **Attributes** and click **Define**.

7. In the menu manager, click **Smooth > Done**.

8. Click **OK** from the Cut dialog box.
9. Resume feature CUT to view the inside of the model.

This completes the procedure.

11.6 Analyzing Parallel Blend Section Tools

The blend feature includes three different tools that are beneficial when you create blend feature sections:

- **Blend vertex** — Each section of a blend must always contain the same number of entities. For sections that do not have enough geometric entities, you can add blend vertices. Blend vertices allow vertices to converge or diverge. In the lower-left figure, the first blend section has six vertices, while the second blend section has only four vertices. Consequently, two blend vertices have been added to the section with only four vertices.

- **Start point** — As a general rule of thumb, the start points between sections should correspond to the same vertex location. Typically, the start point is created on the first location that is selected when creating a section. For example, if sketching a rectangle, the start point will be placed at the first corner of rectangle creation, although it can be relocated. If the start points do not line up between sections, the resulting blend feature will have a twist in it, as shown in the upper-right figure.
• Blending to a point — A blend can start or end as a single point, as shown in the lower-right figure. This is the one exception where blend sections do not have to contain the same number of entities.

**Procedure: Analyzing Parallel Blend Section Tools**

**Scenario**
Create blends using available section tools.

**Task 1. Create a 3-section blend using a blend vertex and a sketcher point.**

1. Click **Insert > Blend > Protrusion** from the main menu and click **Done > Done** from the menu manager.

2. Select the front surface of the model and click **Okay > Default** from the menu manager.

3. Sketcher display:

4. Click **Use Edge**, select **Loop** from the Type dialog box, select the model, and click **Close**.

5. Select the lower-left vertex, right-click, and select **Start Point**.
6. Right-click and select **Toggle Section**.

7. Click **Centerline** and sketch a vertical centerline.

8. Click **Rectangle** and sketch a rectangle, starting at the upper-left and ending at the lower-right. Dimension it as shown.

9. Select the lower-left vertex, right-click, and select **Start Point**.

10. Select the upper-right vertex and click **Sketch > Feature Tools > Blend Vertex** from the main menu.

11. Select the upper-left vertex and click **Sketch > Feature Tools > Blend Vertex**.
12. Right-click and select **Toggle Section**.

13. Click **Point** and create the point, snapping to the midpoint of the lower horizontal line.

14. Click **Done Section** and click **Blind > Done** from the menu manager.
   
   - Type **150** as the first depth and press ENTER.
   - Type **75** as the second depth and press ENTER.

15. Orient to the **Standard Orientation** and click **OK**.
This completes the procedure.
Check Your Knowledge

1. Which of the following is not a component of a sweep feature?
   A - Start point
   B - Selected/sketched trajectory
   C - Sketched section
   D - Blend vertex

2. True or False? The Add Inn Fcs option is only available for closed sweep trajectories.
   A - True
   B - False

3. Which option is not valid for the ends of an open trajectory sweep, solid feature?
   A - Free ends
   B - Merged ends
   C - Trimmed ends
   D - Capped ends
   E - Both C and D

4. True or False? You can create a parallel blend with a minimum of one section.
   A - True
   B - False

5. True or False? When the sketched sections of a parallel blend are connected, the smooth option blends sections using straight lines.
   A - True
   B - False
Module 12

Creating Holes, Shells, and Draft

Module Overview

In addition to creating features that begin with 2-D sketches and proceeding to solid features, you can also create features that are applied directly to a model.

In this module, you learn how to create various types of holes on a model, how to shell a model, and how to apply basic draft to features.
12.1 **Common Dashboard Options: Hole Depth**

When you create a hole, the depth at which the hole drills into a model can be set in a variety of ways depending upon the design intent you wish to capture. You can specify the desired depth option using the dashboard or by right-clicking on the drag handle in the graphics window. Hole depth options include:

- **Blind (Variable)** — This is the default depth option. You can edit this depth value by dragging the drag handle, editing the dimension on the model, or using the dashboard.

- **Symmetric** — The hole will bore equally on both sides of the placement plane. You can edit the total depth at which the hole bores just as you can with the Blind depth option. The Symmetric depth is actually a Blind Symmetric depth.

- **To Next** — This option causes the hole depth to stop at the next surface encountered. A depth dimension is not required, as the next surface controls the hole depth.

- **Through Until** — This option causes the hole to stop at the selected surface. A depth dimension is not required, as the selected surface controls the hole depth. Note that the hole must pass through the selected surface.

- **To Selected** — This option causes the hole to stop at the selected surface. A depth dimension is not required, as the selected surface controls the hole depth. Unlike the Through Until depth option, the hole does not have to pass through the selected surface.

- **Through All** — This option causes the hole to drill through the entire model. A depth dimension is not required, as the model itself controls the hole depth.
- Side 1/Side 2 — You can independently control the hole depth on each side of the placement plane. By default, the hole drills on Side 1; however, you can cause the hole to also drill on Side 2 as well. Any of the previous hole depth options, except Symmetric, can be used for either side.

The To Next and Through All options only consider geometry present at the time (in the feature order) when the hole is created. Features created after the hole is created do not cause the hole to change its depth.

You can also switch depth options by right-clicking the drag handle in the graphics window.

**Procedure: Common Dashboard Options: Hole Depth**

**Scenario**
Redefine hole features to edit their depths using different options.

**Task 1. Redefine the depth options of the six holes.**

1. Edit the definition of BLIND_1.
2. Edit the depth value to **0.5**.
3. Click **Complete Feature**.
4. Edit the definition of BLIND_2.
5. Edit the depth value to **2.25**.
6. Click **Complete Feature ✓**.

7. Edit the definition of **TO_NEXT**.

8. Edit the depth to **To Next ⬤**.

9. Click **Complete Feature ✓**.

10. Edit the definition of **TO_SELECTED**.

11. Edit the depth to **To Selected ⬤** and select the surface.

12. Click **Complete Feature ✓**.
13. Edit the definition of THRU_ALL.

14. Edit the depth to Through All.

15. Click Complete Feature.

16. Click Plane Display to enable their display.

17. Edit the definition of SYMMETRIC. Notice the hole placement plane is a datum plane in space.

18. Edit the depth to Symmetric.
19. Edit the depth to Through All.

20. In the dashboard, select the Shape tab and edit the Side 2 depth to Through All.

21. Click Complete Feature.

22. Click Plane Display to disable their display.

23. Resume the suppressed feature CUT to view the holes.
This completes the procedure.

12.2 Creating Coaxial Holes

Hole Creation Theory

When creating hole features on a model, you locate holes by selecting placement (primary) and offset (secondary) references. The first piece of geometry selected to place the hole is the placement reference. Next, you either select additional placement references or offset references to further dimensionally constrain the hole feature. The type of geometry selected as the placement reference determines the type of hole being created.

Creating Coaxial Holes

To create a coaxial hole, you only select placement references. An axis is selected as the first placement reference. This axis identifies the location of the hole. A second placement reference, of either a surface or datum plane, is then selected to specify the surface where the hole starts drilling into the model. In the figures on this slide, datum axis A_1 and the front surface are the placement references.
You can also view your selected references in the Placement tab of the dashboard.

Once the hole references are satisfied, the hole preview appears with a default diameter dimension and depth value, which can be modified by using the drag handles or dashboard, or by editing the dimensions on the model.

**Procedure: Creating Coaxial Holes**

**Scenario**
Create two coaxial holes, one through all and the other of blind depth.

**Task 1. Create two coaxial holes in the model, one through all and the other of blind depth.**

1. Start the Hole Tool from the feature toolbar.
2. Press CTRL and select datum axis A_1 and the front surface.
3. Edit the diameter to 1.
4. Edit the depth to Through All.
5. Click Complete Feature.
6. Start the Hole Tool.
7. Press CTRL and select datum axis A_2 and the front surface.
8. In the dashboard, select the Placement tab. Notice that your selected references are added to the collector.

9. Edit the diameter to 1.5.

10. Edit the depth value to 0.25.

11. Click Complete Feature ✓.

This completes the procedure.

### 12.3 Creating Linear Holes

**Hole Creation Theory**

When creating hole features on a model, you locate holes by selecting placement (primary) and offset (secondary) references. The first piece of geometry selected to place the hole is the placement reference. Next, you either select additional placement references or offset references to further
dimensionally constrain the hole feature. The type of geometry selected as the placement reference determines the type of hole being created.

**Creating Linear Holes**

To create a linear hole, a planar surface is selected as the placement reference. This surface identifies where the hole starts ‘drilling’ into the model. Two offset references are then selected to dimensionally constrain the hole feature. In the upper figure on this slide, the front surface of the model is the placement reference. In the lower-right figure, the top surface and datum plane DTM1 are the offset references. You can select offset references directly from the model or you can drag the green reference handles to the desired reference.

You can view your selected references in the reference collectors in the **Placement** tab of the dashboard. Within this tab, you can edit offset reference values as well as modify whether the hole is offset or aligned to an offset reference. In the lower-right figure, the hole is aligned to datum plane DTM1.

**Procedure: Creating Linear Holes**

**Scenario**
Create two different linear holes on a model.

**Task 1. Create two different linear holes on a model.**

1. Start the **Hole Tool** from the feature toolbar.
2. Select the front surface.
3. Right-click and select **Offset References Collector**.
4. Press CTRL and select the top surface and datum plane DTM1.

5. Edit the offset values to **3.5** from the top surface and **3.0** from datum plane DTM1.

6. Edit the hole diameter to **1.50** and the depth value to **2**.

7. Click Complete Feature ✓.
8. Start the **Hole Tool**.

9. Select the front surface.

10. Right-click and select **Offset References Collector**.

11. Press CTRL and select the top surface and datum plane DTM1.
12. In the dashboard, select the Placement tab.
   
   - In the Offset References collector, select **Align** from the DTM1 drop-down list.
   - Edit the offset value to **3.5** from the top surface.

13. Edit the hole diameter to **1.50** and the depth value to **2**.

14. Click **Complete Feature ✔️**.
This completes the procedure.

12.4 Creating Radial and Diameter Holes

Hole Creation Theory

When creating hole features on a model, you locate holes by selecting placement (primary) and offset (secondary) references. The first piece of geometry selected to place the hole is the placement reference. Next, you either select additional placement references or offset references to further dimensionally constrain the hole feature. The type of geometry selected as the placement reference determines the type of hole being created.

Creating Radial Holes on a Cylindrical Placement Surface

You can create a radial hole on a cylindrical surface by selecting the cylindrical surface as the placement reference. Furthermore, if the placement reference is a cylindrical surface, you can only create a radial hole. This cylindrical surface
identifies where the hole starts “drilling” into the model. For a radial hole, the specific location chosen on this surface determines the direction from which the angle is measured. For example, in the middle-right figure, if the surface was chosen below datum TOP, the measured angle would be 45° clockwise from TOP, instead of measuring 315° counter-clockwise. To flip the hole to the same angle on the opposite side of the datum plane you can simply specify a negative value.

Two offset references are then selected from which to dimension the hole. You can select references directly from the model or you can drag the green reference handles to the desired reference. The first offset reference is a planar reference from which to offset the hole, and the second is a planar reference to determine the angle. In the middle-right figure, the offset references are the front surface of the model and datum plane TOP.

Creating Radial or Diameter Holes on a Planar Placement Surface

You can select a planar surface as the placement reference to create both a radial or diameter hole. This placement reference identifies where the hole starts “drilling” into the model. For a radial hole, the specific location chosen on this surface determines the location from which the angle is measured. For example, in the lower-right figure, if the surface was chosen above datum TOP but to the right instead of the left, the measured angle would be 65° counter-clockwise from datum TOP, instead of measuring 115° clockwise. To flip the hole to the same angle on the opposite side of the datum plane you can simply specify a negative value.

Two offset references are then selected from which to dimension the hole. The first offset reference is an axis from which to locate the hole radially, and the second is a planar reference to determine the angle. For the planar placement radial hole in the lower-right figure, the secondary references are datum axis A_2 and datum plane TOP. For the diameter hole in the lower-left figure, the secondary references are datum axis A_2 and datum plane RIGHT.

If a planar surface is selected as the placement reference, you can switch the hole type between Linear, Radial, and Diameter. When you switch the hole type, the offset references will automatically switch between radius, diameter, angle, or offsets.

Procedure: Creating Radial and Diameter Holes

Scenario

Create radial and diameter holes on a model.
Task 1. Create radial and diameter holes on a model.

1. Start the Hole Tool from the feature toolbar.

2. Select the cylindrical surface.

3. Right-click and select Offset References Collector.

4. Press CTRL and select datum plane TOP and the front surface.

5. In the dashboard, select the Placement tab.
   - Edit the offset angle to 45 from datum plane TOP.
   - Edit the offset axial value to 0.40 from the front surface.

6. Edit the diameter to 0.40 and the hole depth to To Next

7. Click Complete Feature ✔.
8. Start the **Hole Tool**.

9. Select the front surface.

10. Right-click and select **Offset References Collector**.

11. Press CTRL and select datum axis A_2 and datum plane TOP.

12. In the dashboard, select the **Placement** tab.
   
   - Edit the hole Type from **Linear** to **Radial**.
   - Edit the radius to **0.5** from datum axis A_2.
   - Edit the angle to either **65** or **-65** to attain the proper direction above datum plane TOP.

13. Edit the diameter to **0.40** and the hole depth to **To Next**.

14. Click **Complete Feature** **✓**.
15. Start the **Hole Tool**.

16. Select the front surface.

17. Right-click and select **Offset References Collector**.

18. Press CTRL and select datum axis A_2 and datum plane RIGHT.

19. In the dashboard, select the **Placement** tab.
   - Edit the hole Type from **Linear** to **Diameter**.
   - Edit the diameter to 1.5 from datum axis A_2.
   - Edit the angle to either 60 or -60 to attain the proper direction from datum plane RIGHT.

20. Edit the hole diameter to **0.50** and the hole depth to **Through All**.
21. Click **Complete Feature** ✔.

This completes the procedure.

### 12.5 Exploring Hole Profile Options

**Exploring Hole Profile Options**

When you create a hole in Pro/ENGINEER, the default profile is a rectangular shape, as shown in the top hole in the upper figure. This is the rectangle hole profile. Other hole profiles and options available include, and are shown in the upper figure, respectively:

- Drill point profile — Adds the drill tip to the hole profile. You can edit the drill tip angle.
- Add counterbore — Creates a counterbore on the hole. You can edit the counterbore diameter and depth.
- Add countersink — Creates a countersink on the hole. You can edit the countersink angle and diameter. You can also create an exit countersink on a Through All hole.
- Lightweight hole display — Creates a hole that displays as a ring on the placement surface. Switching a hole feature to lightweight hole display affects the model's mass properties.

Dimensioning the Hole Depth for the Drill Point Profile

When you select the drill point profile, you can dimension the hole depth using two different methods:

- Shoulder — You are able to specify the depth of the drilled hole to the end of the shoulder. This is shown in the left image of the bottom-right figure.
- Tip — You are able to specify the depth of the drilled hole to the tip of the hole. This is shown in the right image of the bottom-right figure.

The Dashboard Shape Tab

At any time during the hole creation process, you can select the Shape tab in the dashboard to see the hole profile you are creating. This hole profile image updates automatically as you modify hole profile options, enabling you to preview the final result. Within the Shape tab you can perform the following operations:

- Edit hole diameter and depth.
- Edit drill tip angle.
- Edit counterbore diameter and depth.
• Edit countersink diameter and angle.
• Enable an exit countersink on a through all hole.

Procedure: Exploring Hole Profile Options

Scenario
Redefine hole features to modify their profile options.

Task 1. Redefine four holes to modify their profiles.

1. Edit the definition of HOLE_1.
2. In the dashboard, click Drill Hole Profile.
3. Click Complete Feature.
4. Edit the definition of HOLE_2.
5. In the dashboard, click Drill Hole Profile.
   - Select the Shape tab to view the profile.
   - Click Tip Depth.
6. Click **Complete Feature**.

![Image of hole with countersink](image)

7. Edit the definition of HOLE_3.

8. In the dashboard, click **Drill Hole Profile**.
   - Select the **Shape** tab to view the profile.
   - Click **Counterbore**.

9. Click **Complete Feature**.

![Image of countersink](image)

10. Edit the definition of HOLE_4.

11. In the dashboard, click **Drill Hole Profile**.
    - Select the **Shape** tab to view the profile.
    - Click **Countersink**.
    - Edit the hole depth to **Through All**.
    - Select the **Exit Countersink** check box.
12. Click **Complete Feature ✓**.

13. Resume EXTRUDE_CUT to compare holes.

14. Edit the definition of HOLE_2.

15. In the dashboard, click **Rectangle Hole Profile**.

   - Click **Lightweight Hole**.

16. Click **Complete Feature ✓**.

17. De-select the feature.
This completes the procedure.

### 12.6 Creating Shell Features

Shell features remove surfaces to hollow out a design model, leaving walls with specified thickness values. There are two parts to the creation of a basic shell feature:

- **Select Surfaces for Removal** — Select the surface or surfaces you want to remove from the model. You may decide not to remove any surfaces from the shell, which results in the creation of a closed shell, with the whole inside of the part hollowed out and no access to the hollow.
- **Thickness** — Specify the thickness of the model walls that remain.
You create shells in the design process to support your design intent. However, be aware that several features could reference a shell created early in the design process.

Shells can be created using the Lead or Follow workflow. You can use drag handles or the dashboard to modify the thickness of the shell feature. The Flip icon in the dashboard is equivalent to specifying a negative shell value.

**Procedure: Creating Shell Features**

**Scenario**
Create a shell feature in a model.

1. **Task 1. Create a shell feature in a model.**

   1. Start the **Shell Tool** from the feature toolbar.
   2. Click **Complete Feature** to create a hollow shell.
   3. Edit the definition of **Shell 1**.
   4. Select the top surface to remove it.
   5. Edit the thickness to **20**.
   6. Click **Complete Feature**.
7. Edit the definition of **Shell 1**.

8. Press CTRL and select the left and right surfaces to remove them, also.

9. Click **Complete Feature** ✓.

This completes the procedure.

### 12.7 Creating Draft Features

You can use draft features as finishing features in molded and cast parts, or anywhere sloped or angled surfaces need to be created. You can define several types of draft features by selecting different combinations of curves, edges, surfaces, and planes for the draft surfaces, draft hinges, pull direction, and split plane (optional). Drafts can add or remove material from a model.

A basic draft feature consists of the following four items:

- **Draft surfaces** — These are the surfaces that are to be drafted. You can select a single surface, multiple individual surfaces, or loop surfaces as the draft surfaces. In the upper-right figure, the left image has one surface drafted, while the right image has four surfaces drafted.
- **Draft hinge** — Determines the location on the model that remains the same size after the draft is created. The draft surfaces pivot about their
There does not have to be a physical intersection. Rather, the intersection can be extrapolated. You can select a datum plane, solid model surface, curve chain, or surface quilt as the draft hinge. In the lower figure, the same model was drafted at the same angle, but with the specified draft hinge progressively lower in the model, as highlighted.

- **Pull direction** — Direction that is used to measure the draft angle. The pull direction is also called the reference plane. By default, the pull direction is the same as the draft hinge. The direction reference is used to define the draft angle direction, and the draft angle is measured normal to this reference. You can select a datum plane, planar model surface, linear reference such as an edge or two points, or a coordinate system axis. The mold opening, or pull direction, is usually normal to this plane.

- **Draft angle** — Values range from -30 degree to +30 degrees. When you specify the draft angle, you can reverse the direction that material is added or removed by entering a negative value or clicking the Reverse Angle icon in the dashboard, or by right-clicking on the angle drag handle and selecting *Flip Angle*.

You can also switch to the different collectors for draft surfaces, draft hinges, and pull direction by right-clicking in the graphics window.

**Best Practices**

If possible, create draft features as some of the last features of your model.

**Procedure: Creating Draft Features**

**Scenario**
Draft three different features.
**Task 1. Draft three features using three different methods.**

1. Start the Draft Tool from the feature toolbar.

2. Select the cylinder surface to draft.

3. In the dashboard, select the References tab.
   - Click in the Draft hinges collector and select the top cylinder surface.
   - Edit the draft angle to 10.
   - Click Reverse Angle.

4. Click Complete Feature.

5. Start the Draft Tool.

6. Press CTRL and select the four vertical surfaces to draft.

7. In the dashboard, click in the Draft hinges collector and select datum plane DTM2.
   - Edit the draft angle to -10.

8. Click Complete Feature.
9. Start the **Draft Tool**.

10. Press CTRL and select the four vertical surfaces to draft.

11. Right-click and select **Draft Hinges**.

12. Select the top surface of the main protrusion.

13. Edit the draft angle to **-10**.

14. Click **Complete Feature**.
15. Orient to the FRONT view and compare the differences in the results of the rectangular protrusions.

This completes the procedure.

12.8 Creating Basic Split Drafts

Creating Draft Splits Theory

You can create draft features with or without split. Splitting a draft enables you to apply different draft angles to different portions of a surface.

Splitting the Draft

You can split a draft feature in two different ways:

- Split by Split Object — Split the draft using a specified datum plane or surface.
• Split by Draft Hinge — Split the draft using the specified draft hinge.

Side Options

Once you split the draft, there are four different options available to control how the draft is handled on either side of the split:

• Draft sides independently — Enables you to specify two independent draft angles for each side of the drafted surface. If you use this option, the system adds a second draft angle to the dashboard. In the lower-right figure, both sides are drafted independently with different draft angles.
• Draft sides dependently — Enables you to specify a single draft angle, with the second side drafted in the opposite direction at the same draft angle. In the lower-left figure, both sides are drafted dependently.
• Draft first side only — Drafts only the first side of the surface, with the second side remaining in the neutral, undrafted position. In the upper-right figure, only the first side is drafted.
• Draft second side only — Drafts only the second side of the surface, with the first side remaining in the neutral, undrafted position.

Draft Tangent Surfaces

By default, the system automatically drafts any surfaces tangent to those selected for drafting. For example, you can select half of a cylinder, and the system drafts the entire 360 degrees around the cylinder. You can disable this behavior by clearing the Draft tangent surfaces check box in the Options tab of the dashboard.

Procedure: Creating Basic Split Drafts

Scenario
Redefine three draft features and add split to them.

Task 1. Redefine three draft features and add split to them.

1. Edit the definition of Draft 1.
2. In the dashboard, select the Split tab.
   o Edit the Split option to Split by draft hinge.
   o Select Side option Draft first side only.
3. Click **Complete Feature ✔**.

4. Edit the definition of **Draft 2**.

5. In the dashboard, select the **Split** tab.
   - Edit the Split option to **Split by draft hinge**.
   - Select Side option **Draft sides independently**.

6. Edit Angle 2 to **-10**.

7. Click **Complete Feature ✔**.

8. Edit the definition of **Draft 3**.
9. In the dashboard, select the **Split** tab.

   - Edit the Split option to **Split by draft hinge**.
   - Select Side option **Draft sides dependently**.

10. Click **Complete Feature**.

This completes the procedure.

12.9 **Analyzing Draft Hinges and Pull Direction**

By default, the pull direction is the same as the draft hinge. That is, the same reference is used for both the pull direction and the draft hinge, as shown in the upper image of the left figure. However, you can select different references for the draft hinge and pull direction. In the lower image of the left figure, the pull direction has been switched to datum plane TOP. The resulting geometry is therefore different even though the draft hinge is the same.

You can further manipulate the draft hinge and pull direction in either of the following ways:

- You can reverse the angle about the draft hinge to add or remove material.
- You can reverse the pull direction by flipping it 180 degrees. In the lower-right figure, the pull direction has been reversed, as shown by the yellow arrow. Because it is measured normal to the pull direction, the draft angle effectively reverses.
Procedure: Analyzing Draft Hinges and Pull Direction

Scenario
Experiment with draft hinges and pull direction in a part model.

Task 1. Experiment with draft hinges and pull direction in a part model.

1. Start the Draft Tool from the feature toolbar.
2. Select the top surface of the small rectangle.
3. Press SHIFT and select the top edge of the small rectangle.
4. Release SHIFT and notice the loop surfaces selected.
5. Right-click and select Draft Hinges.
6. Select the large, angled surface on which the small rectangle lies.
7. Drag the draft angle inwards to 10.
8. Click **Named View List** and select FRONT.

9. In the dashboard, select the **References** tab.

10. Notice the Draft surface, Draft hinge, and Pull direction. The Draft hinge and Pull direction are the same surface.
11. Click **Plane Display** to enable their display.

12. Right-click and select **Pull Direction**.

13. Select datum plane TOP.

14. Click **Plane Display** to disable their display.

15. Notice the difference in draft.

16. In the dashboard, click **Reverse Pull Direction**.

17. Click **Reverse Pull Direction** again.

18. In the dashboard, click **Reverse Angle**.

19. Click **Reverse Angle** again.
20. Press CTRL + D to orient to the **Standard Orientation**.

21. Click **Complete Feature ✔️**.

This completes the procedure.
Check Your Knowledge

1. True or False? When creating a hole using the Through Until depth option, the hole must pass through the selected surface.
   A - True
   B - False

2. Which two placement (primary) references can be used to create a coaxial hole?
   A - A flat surface and centerline
   B - A curved surface and axis
   C - A curved surface and flat surface
   D - A datum plane and datum axis

3. True or False? A linear hole is created by selecting two placement references and one offset reference.
   A - True
   B - False

4. If the placement (primary) reference for a hole is a cylindrical surface, you can only create which type of hole?
   A - Coaxial hole
   B - Radial hole
   C - Linear hole
   D - Diameter hole
   E - All of the above
5. Which option cannot be added to a simple hole profile?

A - Drill point
B - Counterbore
C - Thread surface
D – Countersink
Module 13

Creating Rounds and Chamfers

Module Overview

Once you have created the bulk of your part model, it can be further refined by adding finishing features such as rounds and chamfers.

In this module, you learn how to create rounds and chamfers.
13.1 Creating Rounds Theory

Rounds add or remove material by creating smooth transitions between existing geometry. In the lower-right figure, one round adds material and the other removes material. When creating round features on a model, Pro/ENGINEER awaits the selection of edges and/or surfaces to be used as references. The round tool adapts according to the references that you select to create the round feature.

After the references are selected, the round preview appears with a default radius dimension, which can be modified by using the radius drag handle, by editing the dimension on the model, or by using the dashboard. In the upper figure, the round preview is displayed.

13.2 Creating Rounds by Selecting Edges

You can create rounds by selecting an edge or a combination of edges. Each edge that you select is rounded. If you select an edge that has adjacent tangent edges, by default the round automatically propagates around those tangent edges. The rounds are constructed tangent to the surfaces adjacent to the selected edges.

In the figures, the edges selected for rounding are highlighted on the left. The resulting rounds are shown on the right. Note that because the bottom figure’s edges are tangent to other edges, the round feature is automatically created on the tangent edges.

Procedure: Creating Rounds by Selecting Edges

Scenario
Create rounds on an L-Block and an Oval block by selecting edges.
Task 1. Create rounds on an L-Block.

1. Start the **Round Tool** from the feature toolbar.
2. Press CTRL and select the two edges.
3. Edit the radius value to **2**.
4. Click **Complete Feature**. 

5. Notice that the left round adds material, while the right round removes material.
Task 2. Create tangent rounds on an oval block.

1. Click **Open**, select ROUND_EDGE_2.PRT, and click **Open**.

2. Start the **Round Tool**.

3. Press CTRL and select the two edges.

4. Edit the radius value to **.25**.

5. Click **Complete Feature**.

6. Notice that the left round adds material, while the right round removes material.

7. Also notice that even though just two edges were selected, all edges tangent to the selected edges were also rounded.

This completes the procedure.
13.3 Creating Rounds by Selecting a Surface and Edge

You can create rounds by selecting a surface first and then an edge. These round features are constructed tangent to the selected surface and pass through the selected edge. If the selected edge has adjacent tangent edges, by default, the round automatically propagates around those tangent edges.

In the figures above, the surfaces and edges selected are highlighted on the left, and the resulting rounds are shown on the right.

Procedure: Creating Rounds by Selecting a Surface and Edge

Scenario
Create rounds on a stepped block and an oval block by selecting a surface and edge.

Task 1. Create rounds on a stepped block.

1. Start the Round Tool from the feature toolbar.
2. Press CTRL and select the surface and edge.
3. Edit the radius value to 2.
4. Click Complete Feature. Notice that the round adds material.
5. Start the Round Tool.
6. Press CTRL and select the surface and edge.

7. Edit the radius value to 2.

8. Click **Complete Feature**. Notice that the round removes material.

---

**Task 2. Create tangent rounds on an oval block.**

1. Click **Open**, select SURF-EDGE_2.PRT, and click **Open**.

2. Start the **Round Tool**.

3. Press CTRL and select the surface and edge.

4. Edit the radius value to 0.60.

5. Click **Complete Feature**.
6. Notice that the round adds material. Also notice that even though just the one edge was selected, the round follows all edges tangent to the selected edge.

This completes the procedure.

13.4 Creating Rounds by Selecting Two Surfaces

You can create rounds by selecting two surfaces. The rounds are constructed tangent to the selected surfaces. If the selected references have adjacent tangent geometry, by default the round automatically propagates around that geometry.

For rounds created by selecting two surfaces, the system creates the round between the selected surfaces, and therefore has the ability to span gaps or engulf existing geometry. In addition, rounds created by selecting two surfaces can also provide more robust round geometry in cases where rounds created by selecting edges may fail or create undesired geometry.
In the figures, the surfaces selected are highlighted on the left, and the resulting rounds are shown on the right.

**Managing Round Pieces**

When a round traverses a gap, as shown in the upper figure, it is comprised of two different pieces. You can manage the round pieces individually in the dashboard by specifying their display.

**Procedure: Creating Rounds by Selecting Two Surfaces**

**Scenario**
Create rounds on two blocks by selecting two surfaces.

1. Start the **Round Tool** from the feature toolbar.
2. Press CTRL and select the two surfaces.
3. Edit the radius value to 3.
4. Click **Complete Feature**. Notice that the round spans the gap.
5. Edit the definition of **Round 1**.
6. In the dashboard, select the **Pieces** tab.
   
   o Edit **Piece 2** to be **Excluded** in the drop-down list.

7. Click **Complete Feature ✔**. Notice that the round no longer spans the gap.

---

**Task 2. Create rounds on another block.**

1. Click **Open ✔**, select SURF-SURF_2.PRT, and click **Open**.

2. Start the **Round Tool 🔄**.

3. Press CTRL and select the two surfaces.

4. Edit the radius value to **4**.

5. Click **Complete Feature ✔**.
6. Notice that the round engulfs the existing material.

This completes the procedure.

13.5 Creating Full Rounds

Full rounds replace a surface with a round that is tangent to the surface it replaces. You can create full rounds either by selecting a pair of edges or a pair of surfaces. If a pair of edges is selected, the system initially creates individual rounds on each edge, and can be quickly converted to a full round either from the dashboard or by right-clicking. If a pair of surfaces is selected, a third surface must also be selected as the surface to remove with the creation of the round.

In either case, the full round is constructed with a rounding surface forming a tangent connection between the selected references. If the selected references have adjacent tangent geometry, the round automatically propagates around that geometry.
In the upper figure, the full round was created by selection of two edges. The edges selected are highlighted on the left, and the resulting round is shown on the right. This round is removing material. In the lower figure, the full round was created by selecting three surfaces. The surfaces selected are highlighted on the left, and the resulting round is shown on the right. This round is adding material.

**Procedure: Creating Full Rounds**

**Scenario**
Create full rounds on two blocks.

1. Start the Round Tool from the feature toolbar.
2. Press CTRL and select the two edges.
3. Right-click and select Full round.
4. Click Complete Feature. Notice that the round removes material.

5. Start the Round Tool.
6. Press CTRL and select the two edges.
7. In the dashboard, select the Sets tab and click Full round.
8. Click Complete Feature. Notice that the round adds material.
Task 2. Create rounds on a block by selecting surfaces.

1. Click Open, select ROUND_FULL_2.PRT, and click Open.

2. Start the Round Tool.

3. Press CTRL and select the two surfaces.

4. Press CTRL and select the bottom cut surface.

5. Click Complete Feature.
6. Start the **Round Tool**.

7. Press CTRL and select the two surfaces.

8. Press CTRL and select the top outer surface.

9. Click **Complete Feature**.
This completes the procedure.

13.6 Creating Round Sets

Round features can contain multiple sets of references within a single round feature. When references for a round are selected, they can be selected as being in the same set, or in additional sets. Each round set can have different radius values or have been created differently, for example, a full round versus a round created by selecting surfaces. You can add new sets to a round using the dashboard, by right-clicking in the graphics window, or simply by selecting a new reference on the model. When you create a new round set, you can see the rounds from the other sets in the same feature in their previewed state.

In the figure, all three rounds are created within the same round feature. Each round is from a different set. The round in the left image was created by selecting a surface and edge. The round in the middle image was created by selecting an edge, and the round on the right is a full round. Notice also that the rounds are different radius values.

Round sets are important for two reasons:
1. Simplification — Round sets enable you to decrease the number of features in the model tree.
2. Transitions — Round sets enable you to manually specify the appearance of the transitional surface where the round sets intersect.

**Round Set Selection Guidelines**

When an edge is selected for rounding, the following two guidelines determine which set a round belongs to:

- Selecting edges with CTRL pressed causes rounds to be added to the same set.
- Selecting edges without CTRL pressed causes a round to be created in a new set.

**Procedure: Creating Round Sets**

**Scenario**
Create different round sets in a round feature.

**Task 1. Create three round sets in a single round feature.**

1. Start the Round Tool from the feature toolbar.
2. Select the edge.
3. Edit the radius value to 2.
4. Right-click and select Add set. Notice that the first round remains previewed.
5. Press CTRL and select the surface and edge.

6. Edit the radius value to 6.5.

7. In the dashboard, select the Sets tab.
   - Click *New set*. Notice that the previous two rounds are still previewed.
   - Press CTRL and select the two edges.

8. Click **Full round** from the dashboard.

9. In the Sets tab, select **Set 2**.

10. Edit the Radius value from **6.5** to **5**.
11. Click **Complete Feature ✓**.

12. Notice the single round feature created in the model tree.

This completes the procedure.

### 13.7 Creating Chamfers by Selecting Edges

Similar to round features, chamfers add or remove material by creating a beveled surface between adjacent surfaces and edges selected as references. You can create chamfers by selecting an edge or a combination of edges. Each edge that you select will be chamfered. Like rounds, if the selected edge for chamfering has adjacent tangent edges, by default, the chamfer automatically propagates around those tangent edges.

In the figures, the edges selected for chamfering are highlighted on the left. The resulting chamfers are shown on the right. Note that because the bottom figure's edges are tangent to other edges, the chamfer feature is automatically created on the tangent edges.
Procedure: Creating Chamfers by Selecting Edges

Scenario
Create chamfers on an L-Block and an Oval block by selecting edges.

Task 1. Create chamfers on an L-Block.
1. Start the Edge Chamfer Tool from the feature toolbar.
2. Press CTRL and select the two edges.
3. Edit the D value to 1.75.
4. Click Complete Feature.
5. Notice that the left chamfer adds material, while the right chamfer removes material.
Task 2. Create tangent chamfers on an oval block.

1. Click Open, select CHAMFER-EDGE_2.PRT, and click Open.

2. Click Edge Chamfer Tool.

3. Select the edge.

4. Drag the D value to 3.

5. Click Complete Feature.

6. Start the Edge Chamfer Tool.
7. Select the edge.

8. Edit the D value to 1.

9. Click **Complete Feature** ✓.

10. Notice that the inner chamfer adds material, while the outer chamfer removes material.

11. Also notice that even though just two edges were selected, all edges tangent to the selected edges were also chamfered.

This completes the procedure.
13.8 Analyzing Basic Chamfer Dimensioning Schemes

There are several different dimensioning schemes available when creating chamfers:

- **D x D** — Size of chamfer is defined by one dimension, as shown by the upper-right chamfer.
- **D1 x D2** — Size of chamfer is defined by two dimensions, as shown by the upper-left chamfer.
- **Angle x D** — Size of chamfer is defined by a linear and angular dimension, as shown by the lower-left chamfer.
- **45 x D** — Size of chamfer is defined by a linear dimension at a 45-degree angle, as shown by the lower-right chamfer. This type is only valid for perpendicular surfaces.

You can edit the chamfer dimensioning scheme either by using the dashboard or by right-clicking in the graphics window and then selecting the new scheme.

**Procedure: Analyzing Basic Chamfer Dimensioning Schemes**
**Scenario**
Create different chamfer dimensioning schemes on a block.

![Cham_Dim-Schemes]
[dt:dim-schemes.prt]

**Task 1. Create four chamfer dimensioning schemes on a block.**

1. Start the **Edge Chamfer Tool** from the feature toolbar.
2. Select the edge.
3. Drag the D value to 7.
4. Click **Complete Feature**.
5. Start the **Edge Chamfer Tool**.
6. Select the edge.
7. In the dashboard, edit the dimensioning scheme to D1 x D2.
8. Edit the D1 value to 7 and the D2 value to 7.
9. Click **Complete Feature**.
10. Start the **Edge Chamfer Tool**.

11. Select the edge.

12. In the dashboard, edit the dimensioning scheme to **Angle x D**.

13. Edit the Angle value to 45 and the D value to 7.

14. Click **Complete Feature**.
15. Start the **Edge Chamfer Tool** 🔄.

16. Select the edge.

17. In the dashboard, edit the dimensioning scheme to **45 x D**.

18. Edit the D value to **7**.

19. Click **Complete Feature ✓**.

20. Orient to the **FRONT view** orientation.

21. Select all four Chamfer features, right-click, and select **Edit**. Notice that all four chamfers are the same geometry, but different dimensioning schemes.
This completes the procedure.

13.9 Creating Chamfer Sets

Chamfer features can contain multiple sets of references within a single chamfer feature. When references for a chamfer are selected, they can be selected as being in the same set, or in additional sets. Each chamfer set can have different D values or could be created with a different dimensioning scheme, for example, a D x D chamfer versus an Angle x D chamfer. You can add new sets to a chamfer using the dashboard by right-clicking in the graphics window, or simply by selecting a new reference on the model. When you create a new chamfer set, you can see the chamfers from the other sets in the same feature in their previewed state.

In the figure above, all three chamfers are created within the same chamfer feature but with different dimensioning schemes. Each chamfer is from a different set. The D x D chamfer in the left image was created by selecting an edge. In the middle image, the Angle x D chamfer was created by selecting an
edge, and the D1 x D2 chamfer on the right was created by selecting a different edge. Notice also that the chamfers are different D values.

Chamfer sets are important for two reasons:

1. **Simplification** — Chamfer sets enable you to decrease the number of features in the model tree.
2. **Transitions** — Chamfer sets enable you to manually specify the appearance of the transitional surface where the chamfer sets intersect.

**Chamfer Set Selection Guidelines**

When an edge is selected for chamfering, the following two guidelines determine which set a chamfer belongs to:

- Selecting edges with CTRL pressed causes chamfers to be added to the same set.
- Selecting edges without CTRL pressed causes a chamfer to be created in a new set.

**Procedure: Creating Chamfer Sets**

**Scenario**
Create different chamfer sets in a chamfer feature.

Task 1. Create three chamfer sets in a single chamfer feature.

1. Start the **Edge Chamfer Tool** from the feature toolbar.
2. Select the edge.
3. Drag the D value to 2.
4. Select the next edge. Notice that the first chamfer remains previewed.

5. Edit the chamfer dimensioning scheme to **Angle x D**.

6. Edit the **Angle** value to 19 and the **D** value to 6.5.

7. In the dashboard, select the **Sets** tab.
   - Click **New set**. Notice that the previous two chamfers are still previewed.
   - Select the edge.
   - Edit the chamfer dimensioning scheme to **D1 x D2**.
   - Edit the **D1** value to 3 and the **D2** value to 1.75.
8. Click **Complete Feature ✔️**.

This completes the procedure.
Check Your Knowledge

1. True or False? Rounds add or remove material by creating smooth transitions between existing geometry.

   A - True
   
   B - False

2. Which statement regarding rounds is incorrect?

   A - You can select an edge for rounding.
   
   B - By default, if you select an edge that has adjacent tangent edges, the round does not automatically propagate round those tangent edges.
   
   C - Rounds are constructed tangent to the surfaces adjacent to the selected edges.
   
   D - You can select a combination of edges for rounding.
   
   E - Both A and D.

3. Which of the following statements regarding rounds created by selecting a surface and edge are correct?

   A - The round need not pass through the selected edge.
   
   B - The round must pass through the selected edge.
   
   C - The round is constructed tangent to the selected surface.
   
   D - The round does not need to be tangent to the selected surface.
   
   E - Both B and C.
   
   F - Both B and D.
   
   G - Both A and D.

4. Which statement regarding rounds created by selecting two surfaces is incorrect?

   A - The resulting round cannot span gaps.
B - The resulting round can engulf existing geometry.

C - The resulting round can be more robust in cases where rounds created by selecting edges may fail.

D - Both A and B.

5. True or False? Full rounds replace a surface with a round that is tangent to the surface it replaces.

A - True

B – False
Module 14

Group, Copy, and Mirror Tools

Module Overview

Pro/ENGINEER offers many tools to duplicate features and parts to increase efficiency.

In this module, you learn how to create local groups of features. You also learn how to use the Copy tool to create a single instance of multiple features or groups. Finally, you learn how to use the Mirror tool to mirror features and parts to create symmetrical models.
14.1 Creating Local Groups

In Pro/ENGINEER, you can collect features together into a local group. A local group enables you to perform an operation on multiple features at once. You can group features either by clicking **Edit > Group** from the main menu or by selecting features, right-clicking, and selecting **Group**. You can also ungroup features by right-clicking. Some facts about local groups are:

- The features that you group must be sequential in the model tree.
- When you group features, they nest under the name of the group in the model tree.
- You can delete or suppress features individually within a group.
- You can drag and drop features into or out of a group.

Reasons for Creating Local Groups

There are numerous reasons for creating local groups:

- You can copy or pattern multiple features as one by patterning or copying the local group.
- You can select all features within the local group as one.
- When editing, you can view the dimensions of all features in the local group at one time.
- You can use local groups to organize or collapse the model tree.

**Procedure: Creating Local Groups**

**Scenario**

Group and ungroup features in a part model.
Task 1. Group and ungroup features in a part model.

1. Press CTRL and select Extrude 2 and Hole 1.

2. Right-click and select Group.

3. Expand Group LOCAL_GROUP in the model tree. Notice both features in the group.

4. Right-click Group LOCAL_GROUP and select Ungroup.

5. Press CTRL and select Extrude 2, Hole 1, Hole 2, and Round 1.

6. Right-click and select Group.

7. Right-click and select Edit. Notice that you see the dimensions from all features in the group.

8. Click in the background of the graphics window to de-select all features.

9. Select the round feature from the model as shown.
10. Right-click and select **Select Group**. Notice all features in the group are selected.

11. In the model tree, expand **Group LOCAL_GROUP** and expand feature **Hole 2**. Notice the embedded datum axis **A_2**.

12. Right-click on **Hole 2** and select **Delete**.

   - In the Delete dialog box, ensure that the **Keep embedded datum features** check box is selected.
   - Click **OK** to delete the hole but keep the datum axis.

13. Click **Axis Display**. Notice the axis remains.
This completes the procedure.

14.2 Copying and Pasting Features

Copy and paste enable you to quickly duplicate a feature or group of features. Each copy and paste operation creates a single copy of the selected feature or features. When the new feature is placed with paste, the primary reference is cleared and the system awaits selection of a new reference. However, depending on the feature type, the system maintains the reference type, dimensioning scheme, and the same options as the original. The copied feature is independent of the original.
In the upper figure, a hole is copied and pasted. Once the placement surface is selected, you can place the new hole in a new location on the new placement surface. Notice that the hole diameter and depth options are carried over to the copy.

In the lower figures, an extrude feature is copied and pasted. You must specify a new sketch and reference plane and enter Sketcher mode. The system places the copied sketch on the cursor, as shown in the lower-left figure, and you can drop it into location and edit dimensions appropriately. The copied extrude feature maintains feature type, options, and depth.

You can also copy and paste rounds. When doing so, the round reference types, size, and options, are maintained. You must select new corresponding references.

**Procedure: Copying and Pasting Features**

**Scenario**
Copy and paste features in a part model.

**Task 1. Copy and paste a hole feature in a part model.**

1. Select **Hole 1** and click **Copy** from the main toolbar.
2. Click **Paste** from the main toolbar.
3. Select the approximate hole location on the front surface.
4. Right-click and select **Offset References Collector**.
5. Press CTRL and select the top and right surfaces.

6. Edit the offset from the top surface to 1.5 and edit the offset from the right surface to 3.

7. Click Complete Feature.

---

**Task 2. Copy and paste an extrude feature in a part model.**

1. Select Extrude 2 and click Copy.

2. Click Paste.

3. Right-click and select Edit Internal Sketch.

4. Select the right surface as the Sketch Plane.

5. In the Sketch dialog box, edit the Orientation to Bottom and click Sketch.

6. The sketch is attached to your mouse. Select the approximate placement.
7. Edit the dimensions.

8. Click **Done Section ✓**.

9. Orient to the **Standard Orientation**.

10. Click **Complete Feature ✓**.
This completes the procedure.

14.3 Moving and Rotating Copied Features

Moving and Rotating Copied Features

When copying features in a part model, you can use the Paste Special option to apply move and rotate options to the resulting copied feature.

- **Move the copied feature** — Linearly translate the copied feature. Specify a direction reference such as a surface, datum plane, edge, or axis, and enter the translation distance value. The copied feature moves normal to a plane or surface, and along an edge or axis. In the upper figure, the oval copied protrusion moves normal to datum plane DTM1 a distance of 3.

- **Rotate copied feature** — Angularly rotate the copied feature. Specify a direction reference such as an edge or axis, and enter the angular rotation value. The copied feature rotates around the edge or axis. In the middle figure, the oval copied protrusion rotates around datum axis AXIS at an angle of 45°.

You can also apply multiple move and rotate operations to the same copied feature. For example, you may choose to move the feature in one direction and rotate it about an axis, as shown in the lower figure. Or you may choose to move the feature in one direction and then move it further in another direction.
Creating Dependent Copies

When you copy a feature, the default dependent copy option is to make the copied feature’s dimensions and section sketch dependent on those of the original. That is, all the dimensions of the original feature become shared between the original feature and copied feature. Therefore, when you edit the value of a shared dimension, both features update simultaneously.

Editing the Dependence of Copies

There are two different ways you can edit the dependency of a dependently copied feature:

- Break the dependence of one of the copied feature dimensions by selecting the dimension, right-clicking, and selecting Make Dim Indep. All other aspects of the copied feature remain dependent on the original.
- Break the dependence of the copied feature section by selecting the copied feature, right-clicking, and selecting Make Sec Indep. The copied feature depth is still dependent on the original.

Procedure: Moving and Rotating Copied Features

Scenario
Move and rotate copied features in a part.

Task 1. Move and rotate copied features.

1. Select Extrude 2.
2. Click Copy from the main toolbar.
3. Click Paste Special from the main toolbar.
4. In the Paste Special dialog box, select the Apply Move/Rotate transformations to copies check box and click OK.
5. Select datum plane DTM1 and edit the offset value to 3.
6. Click Complete Feature.
7. With **Moved Copy 1** still selected, click **Copy** and click **Paste Special**.

8. In the Paste Special dialog box, clear the **Make copies dependent on dimensions of originals**, select the **Apply Move/Rotate transformations to copies** check box, and click **OK**.

9. In the dashboard, click **Rotate**.

10. Select datum axis **AXIS** and edit the offset angle to **45**.

11. Click **Complete Feature**.

12. With **Moved Copy 2** still selected, click **Copy** and click **Paste Special**.
13. In the Paste Special dialog box, clear the **Make copies dependent on dimensions of originals**, select the **Apply Move/Rotate transformations to copies** check box, and click **OK**.

14. Select datum plane **RIGHT** and edit the offset to **1**.

15. In the dashboard, select the **Transformations** tab and click **New Move**.

16. Edit the move type to **Rotate**, select datum axis **AXIS**, and edit the offset angle to **45**.

17. Click **Complete Feature ✔**.

---

**Task 2. Edit dimensions and dependency of moved and rotated features.**

1. Select **Extrude 2**, right-click, and select **Edit**.

2. Edit the feature height from **1** to **2** and click **Regenerate ✔**.
3. Expand **Moved Copy 1** and select **Extrude 2 (2)**.

4. Right-click and select **Edit**.

5. Select the **1** width value, right-click, and select **Make Dim Indep**.

6. In the dialog box, click **Yes** to make an independent dimension.

7. Click in the background twice to de-select all features.

8. Right-click **Extrude 2 (2)** and select **Edit**.

9. Edit the feature width from **1** to **1.5** and click **Regenerate**.

This completes the procedure.

### 14.4 Mirroring Selected Features

You can mirror selected features or a group of features about a plane, and have the mirrored features be independent or dependent on the original features. In the example on the slide, we have three oval protrusions in a group, as shown in the left image of the upper figure. The group is selected and mirrored dependently about datum plane RIGHT, as shown in the right image of the upper figure. Next, the original group and the mirrored group are selected, and both are mirrored about datum plane FRONT independently, as shown in the right image of the bottom figure. Because this second mirror was done independently, the original geometry height can be modified, and only the dependently mirrored geometry height updates.
**Procedure: Mirroring Selected Features**

**Scenario**
Mirror selected features both independently and dependently.

---

**Task 1. Mirror selected features and edit the extrude height.**

1. Press CTRL and select **Extrude 2, Moved Copy 1, and Moved Copy 2**.

2. Start the **Mirror Tool** from the feature toolbar.

3. Select datum plane RIGHT.

4. In the dashboard, select the **Options** tab and notice the mirror will be dependent.

5. Click **Complete Feature**.

6. With the mirror feature still selected, press CTRL and also select **Extrude 2, Moved Copy 1, and Moved Copy 2**.

7. Start the **Mirror Tool**.

8. Select datum plane FRONT.

9. In the dashboard, select the **Options** tab and clear the **Copy as dependent** check box.
10. Click **Complete Feature**.

11. In the model tree, right-click **Extrude 2** and select **Edit**.

12. Edit the height from 1 to 2.

13. Click **Regenerate**.

This completes the procedure.

### 14.5 Mirroring All Features

To mirror all features, you simply select the part node in the model tree (the name of the model at the top of the tree) and then mirror all the features in the model at one time. This enables you to create one half of a model and then
mirror it to complete the entire part. A single mirror feature is created, which is dependent on the original side of the model.

The mirror feature mirrors all features that come before it in the model tree. Features that change on the original side of the model update on the mirror side. Features inserted before the mirror feature are mirrored to the opposite side. Features created after the mirror are not mirrored.

When you mirror all features, this includes all datum planes. The resulting mirrored datum planes retain the same name as their originals, except that the mirrored datum planes have an "_1" suffix added to their names. For example, if you mirror all features, which includes datum plane TOP, the corresponding mirrored datum plane name is TOP_1.

Procedure: Mirroring All Features

Scenario
Mirror all part features about a datum plane.

Task 1. Mirror all part features about a datum plane.

1. In the model tree, select the Mirror 1 feature.

2. Expand the Mirror 1 feature. Notice it contains a hole and extrude feature.
3. In the model tree, select the part node MIRROR_ALL_FEATURES.PRT.

4. Start the Mirror Tool from the feature toolbar.

5. Select datum plane RIGHT.

6. Click Complete Feature ✓.

7. In the model tree, right-click on Hole 1 and select Edit.

8. Edit the hole diameter from 16 to 20.

9. In the model tree, select Extrude 3, right-click, and select Edit.

10. Edit the width from 35 to 40.
11. Click Regenerate Notice that all four hole and extrude features have updated.

12. Click Named View List and select 3D.

13. Start the Round Tool and select the right vertical edge.

14. Edit the radius to 8 and click Complete Feature.

15. Notice that the round feature is not mirrored.

This completes the procedure.

14.6 Creating Mirrored Parts

You can create a mirrored copy of a part directly within Pro/ENGINEER. There are two different types of mirrored parts that can be created:
• Mirror geometry only — Mirrors geometry without the structure of the original part. The model tree contains one mirrored feature in the resulting mirrored part.

• Mirror geometry with features — Mirrors geometry with the original part feature structure. The geometry of the resulting mirrored part is not dependent on the geometry of the original model.

When creating a new mirrored part, you must specify the part name for the new part. If you mirror a part using the Mirror geometry only type, you must also specify whether the resulting mirrored part is dependent on the original or not. This option is only available for the Mirror geometry only mirror type. You can also preview the mirrored part before it is actually created.

You can also mirror an entire assembly using File > Mirror Assembly.

Procedure: Creating Mirrored Parts

Scenario
Mirror a part within Pro/ENGINEER.

Task 1. Mirror a part.

1. Notice that the part is asymmetric. You need to create an equivalent left-handed part.
2. Click **File > Mirror Part** from the main menu.

3. In the Mirror part dialog box, accept the defaults for Mirror type and Dependency control, and type **MIRROR_PART_LH** as the New Name.

4. In the Mirror part dialog box, select the **Preview** check box.
5. Click **OK** from the Mirror part dialog box. Notice that the system determines the mirror plane, as you were never prompted for it.

6. Spin the new model as shown.

7. Arrange the two Pro/ENGINEER windows on your desktop to compare parts.

This completes the procedure.
Check your Knowledge

1. What is not a reason for grouping items?
   - A - You can copy or pattern multiple features as one.
   - B - You can select all grouped items as one item.
   - C - It can help keep the model tree organized.
   - D - You can see parent/child relationships.

2. When pasting a copied extrude feature, the resulting pasted feature...
   - A - must be placed on the same planar surface as the original.
   - B - maintains the same dimensioning scheme as the original.
   - C - is totally dependent upon the original feature.
   - D - can be switched to a revolve feature.

3. Which statement regarding Paste Special is incorrect?
   - A - Copies can be made dependent or independent.
   - B - You can copy either a feature or group of features.
   - C - You can apply move or rotate operations, but only one operation is allowed per paste special operation.
   - D - You can edit the dependence of the resulting pasted feature.
   - E - Both A and D.

4. True or False? You can mirror features about a curved surface.
   - A - True
   - B - False

5. True or False? One of the biggest benefits to mirroring all features in a part is that it enables you to create one half of a model and then mirror it to complete the entire part.
   - A - True
   - B - False
Module 15

Creating Patterns

Module Overview

Patterning features and components is yet another way to quickly duplicate features to increase efficiency.

In this module, you learn how to pattern features linearly and angularly, as well as learn how to increment dimensions while patterning. You also learn how to Reference pattern features and components. Finally, you learn how to delete patterns and pattern members.
15.1 Direction Patterning in the First Direction

Patterning Features Theory

The Pattern tool enables you to quickly duplicate a feature, group of features, or pattern of features. When you create a pattern, you create instances of the selected feature by varying some specified dimensions. The feature selected for patterning is called the pattern leader, while the patterned instances are called pattern members. Each pattern member is dependent on the original feature, or pattern leader. The pattern leader is always the first member in an expanded pattern feature in the model tree. In the graphics window, the pattern leader’s instance “dot” border is always bolder than the other pattern members, as shown in the upper figure. In the lower figure, the width of the pattern leader has been modified between the images third from the left and fourth from the left. Consequently, all pattern members’ widths have been updated as well.

Direction Patterning in the First Direction Theory

The direction pattern enables you to pattern features in a given direction. The following items are required to create a direction pattern in one direction:

- Specify a First Direction reference — The pattern extends in a direction based on the reference selected. If you select a plane or surface, the pattern extends normal to the reference, and if you select a linear curve, edge, or axis, the pattern extends along the reference. You can also flip the direction the pattern extends by 180 degrees. In the figures, the first direction reference specified is datum plane FRONT.

- Specify the number of pattern members in the first direction — Type the number of members in either the dashboard or the graphics window. The number of pattern members includes the pattern leader. In the lower figure, the left-most image has four pattern members, while in the image second-from-left, the number of pattern members is six.
Specify the increment in the first direction — The increment is the spacing between pattern members. You can edit the increment in the dashboard, the graphics window, or by dragging the drag handle.

Incrementing Additional Dimensions

You can also increment additional dimensions in the first direction at the same time to create a "varying" pattern. The following items are required to increment additional dimensions in the first direction:

- Select the dimension to be incremented from the pattern leader — The pattern leader displays with all dimensions used to create the feature.
- Specify the increment value — In the lower figure, the extrude feature height was incremented 0.5. Consequently, each pattern member's height increases 0.5 over the previous pattern member.

Procedure: Direction Patterning in the First Direction

Scenario
Direction pattern an extrude feature in one direction.

Task 1. Direction pattern an extrude feature.

1. Select Extrude 2 and start the Pattern Tool from the feature toolbar.

2. In the dashboard, edit the pattern type to Direction.

3. Select datum plane FRONT and click Flip First Direction.

4. Edit the number of members to 4 and edit the spacing to 2.

5. Click Complete Feature.
6. With the Pattern feature still selected, right-click and select **Edit**.

7. Edit the number of patterned extrudes from **4** to **6**.

8. Click **Regenerate**.

9. Edit the definition of **Pattern 1**.

10. In the dashboard, select the **Dimensions** tab.

    - Click in the **Direction 1** Dimension collector.
    - Select the **1** height dimension and edit the increment to **0.5**.
You can also drag the increment handle to edit the increment.

11. Click **Complete Feature**.

12. De-select all features.
13. In the model tree, expand the pattern feature.

14. Select the pattern leader, right-click, and select Edit.

15. Edit the width from 2 to 3.

16. Click Regenerate.

This completes the procedure.

15.2 Direction Patterning in the Second Direction

Patterning Features Theory

The Pattern tool enables you to quickly duplicate a feature, group of features, or pattern of features. When you create a pattern, you create instances of the selected feature by varying some specified dimensions. The feature selected for patterning is called the pattern leader, while the patterned instances are called pattern members. Each pattern member is dependent on the original feature, or pattern leader.

Direction Patterning in the Second Direction Theory

The direction pattern enables you to pattern features in two directions. The following items are required to create a direction pattern in two directions:
Specify the First and Second Direction references — The pattern extends in the directions based on the references selected. If you select a plane or surface, the pattern extends normal to the reference, and if you select a linear curve, edge, or axis, the pattern extends along the reference. You can also flip the direction the pattern extends by 180 degrees. In the figures, the first direction reference specified is datum plane RIGHT, and the second direction reference specified is datum plane FRONT.

Specify the number of pattern members in the First and Second Directions — Type the number of members in either the dashboard or the graphics window. The number of pattern members can be different for each direction. The number of pattern members includes the pattern leader. In the figures, the first direction has four pattern members, while the second direction has five pattern members.

Specify the increment in the First and Second Directions — The increment is the spacing between pattern members. You can edit the increment in the dashboard, the graphics window, or by dragging the drag handle. Again, the increment can be different between the first and second directions. In the figures, the first direction increment is 2.5, while the second direction increment is 2.0.

Incrementing Additional Dimensions

You can also increment additional dimensions in the first or second direction, or both, at the same time to create a 'varying' pattern. The following items are required to increment additional dimensions in the first and second directions:

- Select the dimension to be incremented from the pattern leader — The pattern leader displays with all dimensions used to create the feature. The
dimension selected can be different for each direction. Note also that you can select multiple dimensions for each direction if desired.

- Specify the increment value — Again, the increment value for each direction can be different. In the lower-right figure, the extrude feature width was incremented by -0.2 in the first direction, and the extrude feature height was incremented 0.5 in the second direction. Consequently, each pattern member’s width decreases by 0.20 in the first direction and the height increases 0.5 in the second direction over the previous pattern member.

**Procedure: Direction Patterning in the Second Direction**

**Scenario**
Direction pattern an extrude feature in two directions.

**Task 1. Direction pattern an extrude feature.**

1. Press CTRL, and select Extrude 2 and Round 1.
2. Right-click and select Group.
3. Rename the group to OVAL.
4. Select Group OVAL and start the Pattern Tool from the feature toolbar.
5. In the dashboard, edit the pattern type to Direction.
6. Select datum plane RIGHT as the first direction reference.
7. Edit the number of members to 4 and edit the spacing to 2.50.
8. In the dashboard, click in the **Direction 2 Reference** collector.
   - Select datum plane FRONT as the second direction reference.
   - Click **Flip Second Direction**.
   - Edit the second direction number of members to 5 and edit the second direction spacing to 2.

9. Click **Complete Feature**.
10. Edit the definition of Pattern 1.

11. In the dashboard, select the Dimensions tab.
   
   - Click in the Direction 1 Dimension collector.
   - Select the 2 extrude width dimension and edit the increment to -0.20.
   - Press CTRL and select the R0.1 radius dimension and edit the increment to 0.075.

12. In the Dimensions tab of the dashboard, click in the Direction 2 Dimension collector.

13. Select the 1 extrude height dimension and edit the increment to 0.50.
14. Click **Complete Feature ✓**.

15. In the model tree, expand the pattern feature.

16. Select the pattern leader, right-click, and select **Edit**.

17. Edit the width from **1** to **0.75**.

18. Click **Regenerate**.

---

14. Click **Complete Feature ✓**.

15. In the model tree, expand the pattern feature.

16. Select the pattern leader, right-click, and select **Edit**.

17. Edit the width from **1** to **0.75**.

18. Click **Regenerate**.
This completes the procedure.

15.3 **Axis Patterning in the First Direction**

**Patterning Features Theory**

The Pattern tool enables you to quickly duplicate a feature, group of features, or pattern of features. When you create a pattern, you create instances of the selected feature by varying some specified dimensions. The feature selected for patterning is called the pattern leader, while the patterned instances are called pattern members. Each pattern member is dependent on the original feature, or pattern leader.

**Axis Patterning in the First Direction Theory**

The axis pattern enables you to pattern features radially about a specified axis. The following items are required to create an axis pattern in one direction:

- Specify the axis reference — The pattern extends angularly about the selected reference axis. You can flip the angular direction the pattern
extends from clockwise to counterclockwise. In the figures, the axis reference specified is datum axis AXIS.

- Specify the number of pattern members in the first direction — Type the number of members in either the dashboard or the graphics window. The number of pattern members includes the pattern leader. In the lower figures, there are six pattern members.
- Specify the angular spacing — Specified in degrees, you can edit the angular spacing in the dashboard, the graphics window, or by dragging the drag handle.

There are two additional optional settings that you can use when creating axis patterns:

- Set Angular Extent — This option automatically spaces the pattern members equally about the axis reference. You can also select values of 90, 180, 270, and 360 degrees from the drop-down list, or type in the desired angular extent. The range is -360 to +360 degrees. The angular extent value will supercede the angular spacing. In the figures, the angular extent has been set to 360 degrees.
- Member orientation — Determines how the pattern members are to be oriented about the axis reference. With the check box **Follow axis rotation** selected by default, pattern members are oriented such that the relationship between the pattern leader and axis is maintained for each pattern member. In the lower figure, the middle image is set to follow axis rotation. With the check box for this option cleared, all pattern members have a constant orientation that is the same as the pattern leader. In the lower figure, the left-most image shows all members having a constant orientation.

**Incrementing Additional Dimensions**

You can also increment additional dimensions in the first direction at the same time to create a "varying" pattern. The following items are required to increment additional dimensions in the first direction:

- Select the dimension to be incremented from the pattern leader. The pattern leader displays with all dimensions used to create the feature.
- Specify the increment value — In the lower figure, the extrude feature length was incremented 0.3 in the right-most image. Consequently, each pattern member's length increases 0.3 over the previous pattern member.

**Procedure: Axis Patterning in the First Direction**

**Scenario**

Axis pattern an extrude feature in one direction.
Task 1. Axis pattern an extrude feature.

1. Select **Extrude 2** and start the **Pattern Tool** from the feature toolbar.

2. In the dashboard, edit the pattern type to **Axis**.

3. Select datum axis **AXIS**.

4. Edit the number of members to **6** and edit the angle increment to **45**.

5. In the dashboard, click **Set Angular Extent**.

6. Edit the Angular Extent value from **360** to **90**.
7. Edit the Angular Extent value back to **360**.

8. Click *Complete Feature ✔️*. 

![Diagram](image)

9. Edit the definition of **Pattern 1**.

10. In the dashboard, select the **Options** tab.

    - Clear the **Follow axis rotation** check box.

11. Click *Complete Feature ✔️*. 

    ![Diagram](image)

12. Edit the definition of **Pattern 1**.

13. In the dashboard, select the **Dimensions** tab.
14. Click **Complete Feature ✓**.

15. Edit the definition of **Pattern 1**.

16. In the dashboard, click **Flip Pattern Direction ✓**.

17. Click **Complete Feature ✓**.
This completes the procedure.

15.4 Axis Patterning in the Second Direction

Axis Patterning in the Second Direction Theory

The axis pattern enables you to pattern features radially and outward from a specified axis. The following items are required to create an axis pattern in those two directions:

- Specify the axis reference — The pattern extends angularly about the selected axis reference in the first direction and radially outward from the axis in the second direction. You can flip the angular direction the pattern extends from clockwise to counterclockwise. In the figures, the axis reference specified is datum axis AXIS.

- Specify the number of pattern members in the first and second directions — Type the number of members in either the dashboard or the graphics window. The number of pattern members can be different for each direction. The number of pattern members includes the pattern leader. In
the figures, the first direction has eight pattern members, while second
direction has three pattern members.

- Specify the angular spacing in the first direction — Specified in degrees,
you can edit the angular spacing in the dashboard, the graphics window,
or by dragging the drag handle.
- Specify the radial spacing in the second direction — This increment is the
spacing between pattern members outward from the axis reference.
Again, you can edit the increment in the dashboard, in the graphics
window, or by dragging the drag handle. In the figures, the spacing
increment is 2.5.

There are two additional optional settings that you can use when creating axis
patterns:

- Set Angular Extent — This option automatically spaces the pattern
members equally about the axis reference. You can also select values of
90, 180, 270, and 360 degrees from the drop-down list, or you can type the
desired angular extent. The range is -360 to +360 degrees. The angular
extent value will supercede the angular spacing. In the figures, the
angular extent has been set to 360 degrees.
- Member orientation — Determines how the pattern members are to be
oriented about the axis reference. With the check box Follow axis rotation
selected by default, pattern members are oriented such that the
relationship between the pattern leader and axis is maintained for each
pattern member. In the lower figure, the middle image is set to Follow axis
rotation. With the check box for this option cleared, all pattern members
have a constant orientation that is the same as the pattern leader. In the
lower figure, the left-most image shows all members having a constant
orientation.

Incrementing Additional Dimensions

You can also increment additional dimensions in the first or second direction, or
both, at the same time to create a "varying" pattern. The following items are
required to increment additional dimensions in the first and second directions:

- Select the dimension to be incremented from the pattern leader. The
pattern leader displays with all dimensions used to create the feature. The
dimension selected can be different for each direction. Note also that
you can select multiple dimensions for each direction if desired.
- Specify the increment value — Again, the increment value for each
direction can be different. In the lower figure, right-most image, the left
hole diameter was incremented by 0.075 in the first direction, and the right
hole diameter was incremented 0.25 in the second direction along with
the extrude height incremented by 1. Consequently, each pattern
member's left hole diameter increases by 0.075 in the first direction and
the right hole diameter increases 0.25 in the second direction with the extrude height increasing 1 over the previous pattern member.

**Procedure: Axis Patterning in the Second Direction**

**Scenario**
Axis pattern an extrude feature in two directions.

**Task 1. Axis pattern an extrude feature.**

1. Press CTRL, and select **Extrude 2, Hole 1**, and **Hole 2**.
2. Right-click and select **Group**.
3. Rename the group to **OVAL**.
4. Select **Group OVAL** and start the **Pattern Tool** from the feature toolbar.
5. In the dashboard, edit the pattern type to **Axis**.
6. Select datum axis **AXIS** as the pattern center.
7. Edit the number of members in the first direction to **8**.
8. Click **Set Angular Extent** in the dashboard.
9. Edit the number of members in the second direction to 3, and edit the spacing value to 2.5.

10. Click **Complete Feature ✓**.

11. Edit the definition of **Pattern 1 of OVAL**.

12. In the dashboard, select the **Options** tab.

   ○ Clear the **Follow axis rotation** check box.

13. Click **Complete Feature ✓**.
14. Edit the definition of **Pattern 1 of OVAL**.

15. In the dashboard, select the **Options** tab and select the **Follow axis rotation** check box.

16. In the dashboard, select the **Dimensions** tab.
   - Zoom in on the pattern leader.
   - Click in the **Direction 1** Dimension collector.
   - Select the 0.25 left hole diameter dimension and edit the increment to 0.075.

17. In the Dimensions tab of the dashboard, click in the **Direction 2** Dimension collector.
   - Select the 0.25 right hole diameter dimension and edit the increment to 0.25.
   - Press CTRL, select the 1 height dimension, and edit the increment to 1.
18. Click **Complete Feature ✓**.

19. Orient to the **Standard Orientation**.

This completes the procedure.

### 15.5 Direction Patterning with Multiple Direction Types

The Direction Pattern option enables you to pattern using different direction types for the first and second directions. By default, both first and second directions are set to translate. However, you may specify either **Translate**, **Rotate**, or **Coordinate System** for the first and second directions independently.
This capability enables you to capture translation and rotation within in a single pattern. Alternatively, you can create a pattern of a pattern to accomplish similar results.

In the figures, a translation is used as the first direction, and a rotation is used for the second direction.

**Procedure: Direction Patterning with Multiple Direction Types**

**Scenario**
Direction pattern a group in two directions, using different direction types.

<table>
<thead>
<tr>
<th>Pattern_Mult_Dir</th>
<th>pattern_mult_dir.prt</th>
</tr>
</thead>
</table>

**Task 1. Direction pattern a group, translating in the first direction, and rotating in the second direction.**

1. Select Group OVAL and start the **Pattern Tool**.

2. Select **Direction** as the type.
3. Select Translate if necessary, for the first direction.

4. Select datum plane DTM1 as the first direction reference.

5. Edit the number of members to 3 and edit the spacing to 3.

6. In the dashboard, click in the second direction reference collector.

7. Click Rotate.

8. Select datum axis A_1 as the second direction reference.

9. Click Flip Second Direction.
10. Edit the second direction number of members to 3 and edit the second direction spacing to 30 degrees.

11. Click Complete Feature.

Similar results could be created by first creating a direction pattern, and then creating an axis pattern of the first pattern.

This completes the procedure.
15.6 Creating Reference Patterns of Features

Creating Reference Patterns of Features Theory

A Reference pattern patterns a feature "on top of" any other patterned feature. If you create a new feature on the pattern leader of another pattern, you can Reference pattern that new feature. In the upper-right figure, an extrude feature was created and patterned. A cut and round feature were then created on the pattern leader extrude feature. Consequently, the cut and round feature can be Reference patterned. If the quantity or spacing of the underlying pattern is updated, the quantity or spacing of the reference pattern is automatically updated, too.

Depending on how the features were created, there are three different Reference pattern types that can be created:

- **Feature** — The Reference pattern references an existing feature pattern. In the lower figure, left image, the round feature is being Reference patterned based on the existing axis pattern.
- **Group** — The Reference pattern references either a group or existing pattern of a pattern. In the lower figure, middle image, an axis pattern is then direction patterned, resulting in a pattern of a pattern. The round feature is Reference patterned based on the axis pattern that was patterned.
- **Both** — The Reference pattern references both an existing feature pattern and a group pattern. In the lower figure, right image, the round is Reference patterned around both the feature pattern (axis pattern) and the group pattern (the pattern of the axis pattern).
When creating a Reference pattern of a sketch-based feature (such as extrude), you must either Reference pattern the sketch first, group the sketch and sketch-based feature together, or use an internal (unlinked) sketch. To simplify Reference pattern creation, an internal (unlinked) sketch is recommended. Reference patterns of other feature types, such as rounds or holes, are not an issue.

**Procedure: Creating Reference Patterns of Features**

**Scenario**
Create Reference patterns of features in a part model.

**Task 1. Reference pattern a group.**

1. In the model tree, press CTRL and select OVAL_CUT and ROUND_2.

2. Right-click and select **Group**.

3. With the group still selected, start the **Pattern Tool** from the feature toolbar. Notice the default pattern type is Reference pattern.

4. Click **Complete Feature**.
Task 2. Direction pattern AXIS_PATTERN and Reference pattern a round feature.

1. Orient to the Standard Orientation.

2. In the model tree, select AXIS_PATTERN and start the Pattern Tool.

3. In the dashboard, edit the pattern type to Direction.

4. Select datum plane FRONT and click Flip First Direction.

5. Edit the number of members to 3 and edit the spacing to 50.

6. Click Complete Feature.

7. Select ROUND_1.

8. Start the Pattern Tool. Notice the default pattern type is Reference pattern and that the default Reference type is Feature. Also notice that the reference pattern only occurs on the axis pattern.
9. In the dashboard, edit the Reference type to **Group**. Notice that the round only patterns once per direction pattern group.

10. In the dashboard, edit the Reference type to **Both**. Notice that the round patterns on each member of the axis pattern as well as each member of the direction pattern of the axis pattern.

11. Click **Complete Feature ✔️**.
This completes the procedure.

15.7 Creating Reference Patterns of Components

Reference patterns can also be used at the assembly level. For example, if a bolt is assembled into a hole which is a pattern leader of a pattern of holes, the bolt can be Reference patterned, as shown in the upper-right and lower-left figures. To do this, a component is placed into each member of the underlying pattern. If the number of patterned holes changes, the number of patterned bolts updates accordingly, as shown in the lower-right figure.
Procedure: Creating Reference Patterns of Components

Scenario
Reference pattern the bolts in the assembly.

Task 1. Reference pattern the bolts in the assembly.

1. In the model tree, select each component to highlight it in the graphics window.

2. Select the last BOLT_8.PRT in the model tree.

3. Start the Pattern Tool from the feature toolbar.

4. Click Complete Feature.

5. Select the upper BOLT_8.PRT from the graphics window.

6. Start the Pattern Tool.

7. Click Complete Feature.
8. In the model tree, expand BASE.PRT.

9. Right-click **Pattern 4 of EAR** and select **Edit**.

10. Edit the number of pattern members from **6 LOCAL GROUPS** to **8 LOCAL GROUPS**.

11. In the model tree, expand COVER.PRT.

12. Right-click **Pattern 1 of Extrude 4** and select **Edit**.

13. Edit the number of pattern members from **6 EXTRUDES** to **8 EXTRUDES**.

14. Click **Regenerate**. Notice that the number of Reference patterned bolts also increases to 8.

This completes the procedure.
15.8 Deleting Patterns or Pattern Members

You have three options available when it comes to deleting patterns or members of a pattern:

- **Delete the pattern and the original feature** — You can select the pattern, right-click, and select the Delete option to delete the pattern in addition to the original feature used to create the pattern. Note also that any other patterns that reference this feature will be deleted as well. In the upper-right figure, the extrude feature and pattern are to be deleted. The system is showing that the reference pattern that consists of the cut and round will also be deleted.

- **Delete the pattern** — You can select the pattern, right-click, and select the Delete Pattern option to delete the pattern, leaving the original feature intact, as shown in the lower-left figure. Note that the reference pattern that consists of the cut and round is also updated automatically.

- **Disable individual members of a pattern or reference pattern** — When previewing a pattern or Reference pattern, each pattern instance is represented by a black "dot." If any of the pattern preview "dots" are selected, their display changes to white, which disables that particular member of the pattern. To restore the pattern member, click the white dot at any time while redefining the pattern. In the lower-right figure, the second and fourth pattern members have been disabled. Notice that the reference pattern has updated automatically.

**Procedure: Deleting Patterns or Pattern Members**
Scenario
Delete patterns and pattern members.

Task 1. Delete patterns and disable pattern members.

1. In the model tree, right-click OVAL_PATTERN select Delete, and click OK from the Delete dialog box.

2. Notice that all features are deleted in addition to all features of the REF_PATTERN Reference pattern.

3. Click Undo.

4. Edit the definition of REF_PATTERN.

5. Click on the black dots for members 2 and 4 to disable those members.

6. Click Complete Feature.
7. In the model tree, right-click REF_PATTERN and select **Delete Pattern**.

8. In the model tree, right-click OVAL_PATTERN and select **Delete Pattern**. The original instance is still intact.

---

**Task 2. Delete and disable more patterns and pattern members.**

1. Orient to the **Standard Orientation**.

2. Edit the definition of ROUND_REF_PATTERN.

3. Click on the top black dot for each patterned cluster to disable them.

4. Click **Complete Feature ✔️**.
5. In the model tree, right-click ROUND_REF_PATTERN and select **Delete Pattern**.

6. Right-click on ROUND_1, select **Delete**, and click **OK** from the Delete dialog box.

7. In the model tree, expand PATTERN_OF_AXIS_PATTERN.

8. Edit the definition of AXIS_PATTERN.

9. Click on the top black dot to disable that member.

10. Click **Complete Feature ✓**.
11. Edit the definition of PATTERN_OF_AXIS_PATTERN.

12. Click on the top, bottom, left, and right center black dots to disable those cluster members.

13. Click **Complete Feature ✓**.

This completes the procedure.
Check your Knowledge

1. When creating a direction pattern, which of the following references cannot be selected to denote the direction?
   
   A - Datum plane
   B - Flat surface
   C - Curved surface
   D - Edge or axis
   E - Linear curve
   F - Both D and E

2. True or False? It is not necessary to specify a reference for the second direction of a direction pattern. You can specify that the second direction be normal to the first direction.
   
   A - True
   B - False

3. True or False? An Axis pattern enables you to create patterns in a linear direction.
   
   A - True
   B - False

4. Which option enables you to equally space pattern members about the axis reference?
   
   A - Set Angular Extent
   B - Member Orientation
   C - Number of pattern members
   D - Specify the angular spacing
   E - Both C and D
5. In order to Reference pattern a feature, where in the existing pattern must you create the feature?

   A - Any pattern member
   B - The pattern leader
   C - An existing pattern is not required
   D - Both A and B
Module 16

Measuring and Inspecting Models

Module Overview

You can set up your models with a system of units and a density value for the material type. Then you can create various types of analyses, such as measuring distances, angles, and surface areas. You can also calculate mass properties and perform interference checks on assemblies. These analyses can be useful to extract data from a model, or to determine whether the model meets the required design intent.
16.1 Viewing and Editing Model Properties

Viewing and Editing Model Properties Theory

The Model Properties dialog box provides common locations for viewing and editing model properties in several categories. Each line item in the dialog box provides basic information at a glance.

Some properties can be expanded by clicking Expand to display additional information.

Clicking Info produces a separate information window with more detailed information.

To create or edit any of the properties, click the change link in the dialog box. The appropriate dialog box for that property then appears.

Several of the model properties listed in this dialog box can be accessed through other menus or dialogs.

The following is a list of the properties contained in the Model Properties dialog box, which is accessed by clicking File > Properties.

- Materials
  - Material
  - Units
  - Accuracy
  - Mass Properties
- Relations, Parameters, and Instances
  - Relations
  - Parameters
  - Instance
- Features and Geometry
  - Tolerance
  - Names
- Tools
  - Flexible
  - Shrinkage
  - Simplified Representation
  - Pro/Program
  - Interchange
- Model Interfaces
  - Reference Control
16.2 Investigating Model Units

Investigating Model Units

A model's units are typically derived from a specific model template that was chosen when you first began creating a part model. Pro/ENGINEER's default system of units is English, specifically \texttt{in\_lbm\_sec}. For all new models created in PTC courses, the units are \texttt{mm\_kg\_sec}.

There are several unit systems available, including:

- Centimeter Gram Second (CGS)
- Foot Pound Second (FPS)
- Inch Pound (mass) Second (IPS)
- Inch Pound (force) Second (IPS)
- Meter Kilogram Second (MKS)
- Millimeter Kilogram Second (mmKs)
- Millimeter Newton (force) Second (mmNs)

If none of these default unit systems are desirable, you can customize your own unit system using any combination of units. Any analyses performed on a model are reported in the current model units.

You can change the units for a model by using the Units Manager dialog box, which you can access by clicking \texttt{change} in the Units row of the Materials section of the Model Properties dialog box. When you switch from one set of units to another, you must specify how the dimensions are to be handled. There are two different methods that you can choose from:

- Convert dimensions — Causes the model to retain its same size when the system of units is modified. The dimension values update accordingly based on your decision. In the lower-left figure the diameter of the socket is 25.4mm. The system of units is converted from Metric to English, and therefore the English diameter is now 1in (the same size).
- Interpret dimensions — Causes the model change size based on the system of units specified. The dimension values remain the same. In the lower-right figure, the diameter of the socket is 1 in. The system of units is interpreted from English to Metric, and therefore the Metric diameter is now 1mm (the same value).

The same systems of units are available for assemblies, also.

Procedure: Investigating Model Units
Scenario
Investigate the model units in a model.

Task 1. Investigate the model units of a model.

1. Double-click the outer cylindrical model surface. Notice the main outer diameter is 25.4.

2. Click File > Properties from the main menu to access the Model Properties dialog box.

3. Notice the current unit system for the model.
4. In the Materials section, click **change** in the Units row.

5. Again, notice the current unit system in the Units Manager dialog box and view the Description.

6. In the Units Manager dialog box, select the **Inch Ibm Second** system of units and click **Set**.
   - In the Changing Model Units dialog box, select the **Convert dimensions** option, if necessary.
   - Click **OK > Close > Close**.
7. Click **Refit** if necessary and click in the background.

8. Double-click the outer cylindrical model surface. Notice the main outer diameter is now 1.

The model is the same size. The diameter changed from 25.4 millimeters to 1 inch.
9. Click **File > Properties**.

10. In the Materials section, click **change** in the Units row.

11. In the Units Manager dialog box, select the **millimeter Kilogram Sec** system of units and click **Set**.

12. In the Changing Model Units dialog box, select the **Interpret dimensions** option and click **OK > Close > Close**.

![Changing Model Units dialog box]

13. Click **Refit** and click in the background.

14. Double-click the outer cylindrical model surface. Notice the main outer diameter is still 1.

   📰 The model is now much smaller. The diameter changed from 1 inch to 1 millimeter.

This completes the procedure.
16.3 Analyzing Mass Properties

You can view a model's mass properties within the Materials section of the Model Properties dialog box. You can also calculate the mass properties by clicking **Analysis > Model > Mass Properties** from the main menu. Before you can calculate accurate mass properties for a model, however, its density must be defined. A mass properties calculation is dependent upon the density entered for a given model. If the density is updated for a model and its mass properties are recalculated, the results update.

When the system performs a mass properties analysis, the following mass property information is calculated:

- Volume
- Surface Area
- Density
- Mass
- Center of Gravity — The center of gravity (COG) is displayed on the model as a coordinate system with axes 1, 2, and 3, as shown in the lower figure.

You can also perform mass properties analyses on assemblies. However, you must first configure the density of each part model.

**Mass Properties Analysis Options**

There are three options available when performing a mass properties analysis:
• Quick — Enables you to compute mass properties without saving the analysis or creating a mass properties feature in the model tree.
• Saved — Enables you to save the mass properties analysis for future use. You can specify a unique name for the analysis so it means something to you at a later time. You can retrieve the saved analyses by clicking Analysis > Saved Analysis from the main menu.
• Feature — Enables you to save the mass properties analysis as a feature in the model tree.

**Procedure: Analyzing Mass Properties**

**Scenario**
Analyze the mass properties in models.

**Task 1. Analyze the mass properties of a model.**

1. Click **File > Properties** from the main menu.

2. In the Model Properties dialog box, click **Expand** in the Mass Properties row in the Materials section.

3. Notice that the density is specified as $3.613 \times 10^4$.

<table>
<thead>
<tr>
<th>Calculation source</th>
<th>Geometry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Origin for calculation</td>
<td>PRT_CSYS_DEF</td>
</tr>
<tr>
<td>Used density</td>
<td>3.6127292e+04</td>
</tr>
</tbody>
</table>

4. In the Materials section, click **change** in the Mass Properties row.

5. In the Setup Mass Properties dialog box, edit the Density to **0.285**, the density of steel, and click **OK**.
6. Notice the updated density value in the Model Properties dialog box.

<table>
<thead>
<tr>
<th>Calculation source</th>
<th>Geometry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Origin for calculation</td>
<td>PRT_CSYS_DEF</td>
</tr>
<tr>
<td>Used density</td>
<td>0.285</td>
</tr>
</tbody>
</table>

7. In the Materials section, click **Info** in the Mass Properties row.


10. Click **Close** from the Model Properties dialog box.
Task 2. Analyze the mass properties in an assembly.

1. Click Open, select VALVE.ASM, and click Open.

2. Click Analysis > Model > Mass Properties.

3. Click Preview Analysis from the Mass Properties dialog box.

4. Notice the values for volume, surface area, density, mass, and center of gravity.

---

VOLUME = 3.6396938e-01 INCH³
SURFACE AREA = 6.766281e+00 INCH²
DENSITY = 2.6500000e-01 POUND / INCH³
MASS = 1.0373127e-01 POUND

CENTER OF GRAVITY with respect to _MASS-P:
X  Y  Z  0.0000000e+00  0.0000000e+00

INERTIA with respect to _MASS-PROPS coord:

INERTIA TENSOR:
Ixx Ixy Ixz  3.3830855e-02  0.0000000e+00
Iyx Iyy Iyz  0.0000000e+00  3.3830856e-02
Izx Izy Izz  0.0000000e+00  0.0000000e+00
5. Notice the center of gravity 1-2-3 coordinate system location.

6. Click **Accept** from the Mass Properties dialog box.

This completes the procedure.

16.4 Measuring Models

**Measuring Diameters**

You can measure the diameter of a cylindrical surface. Surfaces can include those created by revolving a sketched entity, extruding a sketched arc, extruding a sketched circle, or round features. When measuring a diameter, you select the surface you wish to measure, and Pro/ENGINEER displays the measurement. The entity you select is called the surface reference. In the lower figure, the diameter of the cylindrical surface is 14.

You can also measure the diameter at a selected point on a surface. This measurement is good for surfaces with non-constant diameter.

**Measuring Area**
You can measure the area of a surface, quilt, facet, or the entire model. The entity you select is called the geometry reference. You can also select a direction reference to project the area onto a two-dimensional plane.

**Measuring Length**

You can measure the length of curves or edges on a model. Simply select an edge or curve to display its length. You can also measure an edge chain. Pro/ENGINEER will report the total length of all selected edges, as shown by the red highlighted edges in the lower figure.

**Measuring Angles**

You can measure the angle between two entities. These two entities are called the “From” reference and the “To” reference, and can consist of surfaces, planes, or edges. You can also specify the direction reference, which projects the angle of the entities onto a two-dimensional plane. When measuring angles, you can optionally modify the Plot Scale and Plot Range that Pro/ENGINEER uses to display the measurement. Scale enables you to adjust the scale of the arrows using the wheel button, specifying the required scale, or by dragging the scale handle. Range enables you to display the angle from 0–360 degrees or from +/- 180 degrees.

![Measuring an Angle](image)

**Measuring Distances**

You can measure the distance between two references. These two references are called the “From” reference and the “To” reference. You can select points and vertices, edges and curves, surfaces and planes, and axes and coordinate systems.

You can also measure the distance in a projected direction. There are two types of projected distances that can be measured:
- **Direction Reference** — Enables you to measure a distance projected in the direction of a selected reference. In the lower figure, the distance between two vertices, 24.9280, is projected along the model's side planar surface for a value of 21. Measuring projected distances is beneficial because it enables you to easily select a direction reference instead of having to create specific geometry in order to create the measurement.
- **View Plane** — Enables you to measure the projected distance based upon the orientation of the part in the graphics window.

**Measurement Options**

There are three options available when measuring geometry on models:

- **Quick** — Enables you to compute measurements without saving the analysis or creating a measurement feature in the model tree.
- **Saved** — Enables you to save the measurement for future use. You can specify a unique name for the measurement analysis so it means something to you at a later time. You can retrieve the saved analyses by clicking **Analysis > Saved Analysis** from the main menu.
- **Feature** — Enables you to save the measurement as a feature in the model tree.

**Procedure: Measuring Models**

**Scenario**
Measure different parts of a model.

**Task 1. Measure different parts of a model.**

1. Click **File > Properties** from the main menu.

2. Under the Materials section of the Model Properties dialog box, notice the units that are set.
   - Click **Close**.
3. Click **Analysis > Measure > Diameter** from the main menu.

4. In the Diameter dialog box, edit the measurement type to **Quick** from the drop-down list if necessary.

5. Select the curved model surface. Notice the diameter is **14 mm**.

6. Click **Accept** from the Diameter dialog box.

7. Click **Analysis > Measure > Area** from the main menu.

8. Select the flat model surface. Notice the surface area is **478.819 mm²**.

9. Click **Accept** from the Area dialog box.
10. Click **Analysis > Measure > Length** from the main menu.

11. Select the left-most edge. Then press **SHIFT** and select two other edges. Notice the length is **35.2539** mm.

12. Click **Accept ✔️** from the Length dialog box.

13. Click **Analysis > Measure > Angle** from the main menu.

14. Select the left surface, then select the right surface. Notice the angle is **27.5268** degrees.

15. In the Angle dialog box, activate the Direction collector and select the top surface. Notice the projected angle is now **332.473** degrees.

16. Click **Accept ✔️** from the Angle dialog box.
17. Click **Analysis > Measure > Distance** from the main menu.

18. Select the two vertices. Notice the distance is **24.9280** mm.

19. Right-click and select **Direction Collector** and select the right surface. Notice the projected distance is now **21 mm**.

20. Click **Accept** from the Distance dialog box.
This completes the procedure.

16.5 Creating Planar Part Cross-Sections

Creating Planar Part Cross-Sections Theory

You can create new planar part cross-sections using the Xsec tab of the view manager. Simply select a datum plane or planar surface on a model and the cross-section is created on that plane.
Cross-Section Display Options

There are three different display options for cross-sections:

- Visibility — Toggles the cross-section display on or off. In the upper-right figure, the cross-section display is enabled.
- Set Active — Sets the active cross-section, with the default selection as No Cross Section. When a cross-section is set as active, the model geometry is clipped at that section location. In the lower-left figure, a cross-section is set as the active section.
- Flip — Flips the geometry side that is clipped about the active section.

Editing Cross-Sections

There are numerous editing operations that you can perform on cross-sections, including the following:

- Redefine — Enables you to redefine a cross-section's hatching spacing and angle. Spacing options include Half, which halves the spacing, Double, which doubles the spacing, and Value, which enables you to specify a spacing value. Angle values range from 0 to 150 degrees at intervals of 30 and 45 degrees.
- Remove — Enables you to delete a cross-section from a model.
- Rename — Enables you to rename the cross-section name.
- Copy — Enables you to copy a cross-section from another model and specify a new reference.
- Description — Enables you to add a text description to a cross-section.

Performing a Cross-Section Mass Properties Analysis

You can analyze a model's mass properties at a cross-section. Results include area, center of gravity, and inertia.

Procedure: Creating Planar Part Cross-Sections

Scenario
Create a planar cross-section in a model.

Task 1. Create a planar cross-section in a model.

1. Start the View Manager.
2. In the View Manager, select the **Xsec** tab.

   - Click **New** and press ENTER to accept the default name.
   - Accept the default options and click **Done** from the menu manager.
   - Select datum plane **FRONT**.

3. In the view manager, double-click **Xsec0001** to make it the active section.

4. In the view manager, right-click **Xsec0001** and select **Visibility**. Notice the eyeball icon.
5. In the view manager, click **Options > Flip** to flip the side that is displayed.

6. Click **Options > Flip** to flip the display back.

7. In the view manager, click **Edit > Redefine** and select **Hatching** from the menu manager.
   - Click **Spacing > Half** from the menu manager.
   - Click **Angle > 60**.
   - Click **Done > Done/Return**.
8. In the view manager, double-click No Cross Section. Notice that the section is still visible but the clipping has been toggled off.

9. In the view manager, right-click Xsec0001 and select Visibility to toggle it off. Notice the eyeball icon disappears.

10. Click Close.
11. Click **Analysis > Model > X-Section Mass Properties** from the main menu.

12. In the Cross Section Properties dialog box, edit the Name to **XSEC0001**. The analysis is performed at the cross-section location.

13. Click **Accept**.

   - **AREA = 1.5766124e+03 MM^2**
   - **CENTER OF GRAVITY with respect to _XSEC0001 coordinate frame:**
     - X: 0.0000000e+00, Y: -2.2797490e+00 MM
   - **INERTIA with respect to _XSEC0001 coordinate frame:** (MM^4)
     - **INERTIA TENSOR:**
       - ix: 2.0735728e+05, iy: 0.0000000e+00, iz: 6.9886367e+05
   - **POLAR MOMENT OF INERTIA: 9.0422033e+05 MM^4**
   - **INERTIA at CENTER OF GRAVITY with respect to _XSEC0001 coordinate**

This completes the procedure.
16.6 Measuring Global Interference

You can calculate interferences between components in an assembly. There are two different setup options available when computing global interference:

- Parts only — Interference is checked between all parts, regardless of which sub-assembly, if any, they belong to.
- Sub-assembly only — Interference is checked between all sub-assemblies in the top level assembly without determining whether individual parts within the sub-assembly interfere.

When components interfere, the geometry of one part is embedded in another part. The system displays the interference between these two components as a pair in the Global Interference dialog box. Selecting the interfering pair in the dialog box causes the components to be highlighted in the graphics window, as shown in the figures. There are two different computational methods available for computing interferences:

- Exact — When selecting the interfering pair, in addition to highlighting the interfering components, the system also highlights the interfering volume shared between the two components. In addition, the volume of interference is calculated and displayed in the dialog box, as shown in the upper figure.
- Quick — When selecting the interfering pair, in addition to highlighting the interfering components, the system highlights the approximate interfering volume with a plus symbol in the graphics window, as shown in the lower figure. The volume of interference is not calculated.

Analysis Options
There are three options available when computing global interference on models:

- **Quick** — Enables you to compute global interference without saving the analysis or creating a feature in the model tree.
- **Saved** — Enables you to save the analysis for future use. You can specify a unique name for the global interference analysis so it means something to you at a later time. You can retrieve the saved analyses by clicking **Analysis > Saved Analysis** from the main menu.
- **Feature** — Enables you to save the global interference analysis as a feature in the model tree.

**Procedure: Measuring Global Interference**

**Scenario**
Measure global interferences in an assembly.

**Task 1. Measure global interferences in an assembly.**

1. Click **Analysis > Model > Global Interference** from the main menu.

2. Click **Preview Analysis** from the Global Interference dialog box.
   - Notice the four interfering pairs. Select each pair to see the highlighting, and notice the volume of interference.
   - Click **Accept**.

3. In the model tree, right-click BODY.PRT and select **Activate**.
   - Expand BODY.PRT and expand the second **Pattern (Hole)**.
4. In the model tree, right-click INTERFERENCE.ASM and select Activate.

5. Click Analysis > Model > Global Interference.

6. Click Preview Analysis.

   a. Notice that there is only one interference pair.
   b. Click Accept.

7. In the model tree, right-click BODY.PRT and select Activate.

   a. Edit the diameter of Hole id 37 from 49 to 51 and click Regenerate.
8. In the model tree, right-click INTERFERENCE.ASM and select **Activate**.

9. Click **Analysis > Model > Global Interference**.

10. Click **Preview Analysis**.

   - Notice that there are now no interfering parts, as shown in the message window.
   - Click **Accept**.

This completes the procedure.
Check your Knowledge

1. Which measurement type is invalid?

   A - Diameter
   B - Area
   C - Circumference
   D - Radius
   E - Angle
   F - Distance
   G - Both C and D

2. Which option is a valid cross-section display option?

   A - Visibility
   B - Explode
   C - Set Active
   D - Flip
   E - All of the above
   F - A, C, and D

3. For all new models created in PTC courses, the units are set to...

   A - Millimeter Kilogram Second
   B - Centimeter Gram Second
   C - Inch Pound Second
   D - Foot Pound Second
4. True or False? The main difference between an exact global interference analysis and a quick global interference analysis is that the exact analysis calculates the volume of interference between interfering components.

A - True  
B - False

5. Which of the following is FALSE regarding the Model Properties dialog box?

A - You can view or edit model units.  
B - You can view or edit mass properties.  
C - You can change the saved file location of the model.  
D - You can access the relations dialog box.
Module 17

Assembling with Constraints

Module Overview

Most commercial product designs consist of numerous components. Pro/ENGINEER enables you to create an assembly, into which you can assemble multiple components. Constraints locate the components within the assembly, both manually and automatically.
17.1 Understanding Assembly Theory

There are multiple methods to assemble components using Pro/ENGINEER. Assembling components with constraints is one of the primary methods used to create Pro/ENGINEER assemblies.

Like part models, all new assembly models share several characteristics in common. By creating your assembly models from standardized templates, you can save time by not repeatedly defining company standard information. This standard template enables all engineers to have a consistent starting point. After you create and name the new assembly, you can begin adding parts to the assembly. Similar to part models having design intent, assemblies also contain design intent. Assembly design intent is based upon which component is assembled first, and the constraints that you use during the assembly process. Design intent is important because it means that your assembly updates in a predictable manner when edited and regenerated.

All characteristics that hold true for assemblies also hold true for sub-assemblies. In fact, a sub-assembly is nothing more than an assembly that is assembled into another assembly.

Pro/ENGINEER has several types of constraints, such as Mate, Align, and Insert. Use of these constraints is made easier by using the Automatic option, which enables Pro/ENGINEER to automatically determine the constraint type based upon the orientation and position of the component and the references you select.

Every assembled component has a Placement node in the model tree that can be expanded to view the constraints used in that
Assembling with component interfaces is a second method when assembling components. This method is especially useful when assembling common components because it can significantly cut the number of selections that you make when constraining a component. By using component interfaces, you save the referenced interfaces on the common part. Then, when you place the common part, you only need to select the assembly references.

17.2 Creating New Assembly Models

Assemblies are composed of parts and other sub-assemblies that you bring together. You can create new assembly models within Pro/ENGINEER either by using **File > New**, or by clicking **New**. You can type the name of the assembly and choose whether you want to use a default template or a template at all. Unless you choose the Empty template, the new assembly displays in the graphics window with some sort of default datum features.

Using Templates

New assemblies should be created using a template. Assembly templates are similar to part templates in that they enable you to create a new assembly with predefined general information. Your company will likely have created customized templates to be used, as they contain your company’s standards. Using a template to create a new assembly is beneficial because it means that regardless of who created it, the assembly contains the same consistent set of information, including:

- **Datums** — Most templates contain a set of default datum planes and default coordinate system, all named appropriately.
- **Layers** — When every assembly contains the same layers, management of both the layers and items on the layer is easier.
- **Units** — Most companies have a company standard for units in their assemblies. Creating every assembly with the same set of units ensures that no mistakes are made.
- **Parameters** — Every assembly can have the same standard meta data information.
- **View Orientations** — Having every assembly contain the same standard view orientations aids the modeling process.

Creating Parameters

Parameters are meta data information that can be included in an assembly template or created by a user in his or her own part or assembly. Parameters are
important because they enable you to add additional information into part and assembly models. Parameters can have several uses:

- Parameters can drive dimension values through relations, or be driven by relations.
- Parameters can be used as a column in a family table. For example, the parameter Cost might have a different value for each instance.
- Parameter values can be reported in Drawings, or viewed with data management tools such as Pro/INTRALINK or Windchill solutions.
- User parameters can be added at the model level (part, assembly, or component) or to a feature or pattern.

You can create parameters that accept the following types of values:

- Real Number — Any numerical value. For example 25.5, 1.666667, 10.5E3, and PI.
- Integer — Any whole number. For example 1, 5, and 257.
- String — Any consecutive sequence of alphanumeric characters (letters or numbers).
- Yes/No — Accepts either the YES or NO value.

**Procedure: Creating New Assembly Models**

**Scenario**
Create new assembly models.

Task 1. Create a new assembly using the default template.

1. Click **File > New** from the main menu.
   - Select **Assembly** as the Type and **Design** as the Sub-type.
   - Edit the Name to **new_assembly**.
   - Notice that **Use default template** is selected.
   - Click **OK**.

2. Explore the default datum features created in the graphics window and model tree.
3. In the model tree, click Show and select Layer Tree. Notice the default layers.

4. Click File > Properties from the main menu to access the Model Properties dialog box.

5. Notice the units that are set.

6. Click Close.

7. Click Tools > Parameters from the main menu.

8. In the Parameters dialog box, click in the Description parameter Value field.

   - Edit the value to NEW ASSEMBLY and press ENTER.
   - Click New Parameter and edit the Name to PURCHASED.
   - Edit the Type to Yes No and notice the default Value of NO.
   - Click New Parameter and edit the Name to ASSY_NUMBER.
   - Edit the parameter type to Integer.
   - Click in the Value field and edit the number to 596289.
   - Click OK.

9. Click Named View List. Notice the default view orientations.

10. Click Named View List again to close it.
Task 2. Create a new assembly by selecting a different template.

1. Click **New** from the main toolbar.
   - Select **Assembly** as the Type and **Design** as the Sub-type.
   - Edit the Name to **select_template**.
   - Clear the **Use default template** check box.
   - Click **OK**.

2. In the New File Options dialog box, select the **inlbs_asm_design** template.
   - Click **OK**.

3. Again, notice the datum features.

4. Click **File > Properties**.

5. Notice the units that are set.

6. Click **Close**.
This completes the procedure.

### 17.3 Understanding Constraint Theory

You can assemble components using constraints. Constraints determine how a part is located within an assembly. There are many different types of constraints that you can use to assemble components.

Most constraints are applied between parts within an assembly. They specify the relative position of a pair of references. The system adds constraints one at a time. Use placement constraints in combinations to specify both placement and orientation. It is important to choose your constraints based on the design intent of your assembly, so that when you edit a dimension on a part, the assembly reacts as predicted.

When you create a constraint, its references are highlighted on the models and the Constraint Type is displayed. For most constraints it is necessary that you select two references, a component reference on the component being
placed, and an assembly reference from an item in the assembly. When the first reference has been selected, a red, dashed line connects the first selected reference to your cursor until you select the second reference, as shown in the lower-left figure.

When multiple constraints are created, the active constraint is highlighted in a light orange box. For example, in the upper-right figure the top Insert constraint is the active constraint. To activate a different constraint, simply select the displayed name or select it from the Placement tab in the dashboard. You can then right-click to perform a desired action.

You can also double-click a constraint’s tag in the graphics window to edit the constraint, as shown in the lower-right figure. Editing options include switching the constraint type, changing the constraint orientation, and viewing as well as deleting the constraint’s placement references.

You can toggle **Constraints To Connections** in the dashboard to convert existing connections to constraints within an assembly.

### 17.4 Understanding Assembly Constraint Status

You can assemble a component into an assembly by using placement constraints. Constraints determine how a part is located within an assembly. As constraints are added, a component becomes further and further constrained and goes through a range of constraint status, which is displayed in the dashboard. The constraint status range includes:

- **No Constraints** — No constraints have been added to the component being assembled, as shown in the upper-right figure.
- **Partially Constrained** — At least one constraint has been applied to the component being assembled, but not enough constraints have been added to render the component fully constrained. That is, the orientation of the component can still be changed, so its position is open to...
interpretation. The left-most image in the lower figure shows the component Partially Constrained. The preview color of partially constrained components is light yellow.

- **Fully Constrained** — Enough constraints have been applied to the component being assembled that it cannot move. Ideally, when you complete the component placement, the component should be fully constrained. The right-most image in the lower figure is Fully Constrained. The preview color of fully constrained components changes from a lighter yellow to a darker yellow.

- **Constraints Invalid** — Two constraints conflict with how they are trying to place the component in the assembly. If this condition arises you must edit or delete one or more constraints to eliminate the conflict.

### Allowing Assumptions

The Allow Assumptions option can become available when placing a component in an assembly. When this option is selected, the system makes additional constraint assumptions to help fully constrain the component. If you clear this check box, the system returns the status to Partially Constrained. If you properly further constrain a component that is fully constrained with Allow assumptions enabled, the Allow Assumptions option will disappear and just be Fully Constrained, as there is no longer a need for the system to make assumptions. The middle image of the lower figure is Fully Constrained as long as the Allow Assumptions option is enabled. If the Allow Assumptions check box is cleared, the component is no longer Fully Constrained, as it can rotate. Either an additional constraint would need to be added or the Allow Assumptions check box would need to be selected.

### Leaving Components Packaged

If you complete the component placement when the status reads Partially Constrained, the system will leave the component packaged only, and the message window will alert you to this. An open square symbol also displays in the model tree next to the packaged component. You can drag components that are packaged based on their partial constraints.

### 17.5 Assembling Components using the Default Constraint

The Default constraint enables you to align the internal system-created coordinate system of the component to the internal system-created coordinate system of the assembly. The system places the component at the assembly origin, as shown in the left figure. Because the internal system coordinate system is used, no references are specified, and no parent-child references are created. It is a standard practice to assemble the initial assembly component using a Default constraint, as shown in the right figure.
Procedure: Assembling Components using the Default Constraint

Scenario
Assemble a component using the Default constraint.

Task 1. Assemble BODY.PRT using the Default constraint.

1. Click Assemble from the feature toolbar.
2. In the Open dialog box, select component BODY.PRT and click Open.
3. Notice the component is light yellow. Notice also in the dashboard that the constraint STATUS says No Constraints.
4. In the dashboard, select Default from the drop-down list.
5. Notice that the constraint STATUS now says Fully Constrained.
6. Notice the component is now dark yellow.
7. Click Complete Component.
8. Notice that the color is now the actual component color.
9. View the model tree and notice the assembled component.

This completes the procedure.

17.6 Analyzing Basic Component Orientation

When assembling a component, you can reorient it with respect to the assembly. Reorienting the component closer to its assembly location aids in its assembly by making it easier to select references. When you use the Automatic option, the system is better able to determine the correct placement constraints to use.

You can reorient the component according to the constraints that have been applied to it. As constraints are applied the degrees of freedom are reduced, further limiting how the component can be moved.

The following types of component reorientation operations are available:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Keyboard and Mouse Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operation</td>
<td>Keyboard and Mouse Selection</td>
</tr>
<tr>
<td>---------------</td>
<td>------------------------------</td>
</tr>
<tr>
<td>Component Drag</td>
<td><img src="image1" alt="Keyboard and Mouse Selection" /></td>
</tr>
<tr>
<td>Spin</td>
<td><img src="image2" alt="Keyboard and Mouse Selection" /></td>
</tr>
<tr>
<td>Operation</td>
<td>Keyboard and Mouse Selection</td>
</tr>
<tr>
<td>-----------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Alt Key" /></td>
</tr>
<tr>
<td>Pan</td>
<td><img src="image" alt="Ctrl Key" /></td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Alt Key" /></td>
</tr>
</tbody>
</table>
**Procedure: Analyzing Basic Component Orientation**

**Scenario**
Use component orientation controls on a component in an assembly.

- Click **Assemble** from the feature toolbar.
- In the Open dialog box, select component SHAFT.PRT and click **Open**.
- Notice the component is light yellow. Also notice the component orientation and location in the assembly.

**Task 1. Use component placement controls on the SHAFT.PRT.**

1. Click **Assemble** from the feature toolbar.
2. In the Open dialog box, select component SHAFT.PRT and click **Open**.
3. Notice the component is light yellow. Also notice the component orientation and location in the assembly.

4. Press CTRL + ALT and middle-click to spin the component and orient it vertically.
5. Press CTRL + ALT and right-click to pan the component and move it to the position above the top hole in BODY.PRT.

6. Click **Complete Component ✓**.

7. Notice that the color is now the actual component color.

8. Notice also the symbol next to SHAFT.PRT in the model tree. This symbol is an indicator that the component has been packaged only.
This completes the procedure.

17.7 Constraining Components using Insert

The Insert constraint enables you to insert one revolved surface into another revolved surface, making their respective axes coaxial. For example, you can create an Insert constraint to match a shaft to the hole, as shown in the figure. This constraint is especially useful when axes are unavailable or inconvenient for selection. Keep in mind the Insert constraint only constrains surfaces coaxial, and does not "slide" one component into another.
Procedure: Constraining Components using Insert

Scenario
Assemble components using the Insert constraint.

Task 1. Assemble the SHAFT.PRT using Insert constraints.

1. Edit the definition of SHAFT.PRT. Notice the constraint STATUS is No Constraints.

2. In the dashboard, select Insert from the drop-down list.

3. Select the shaft on SHAFT.PRT and the hole on BODY.PRT.

4. Notice that the component snaps to its new location. Also notice the constraint STATUS is now Partially Constrained.

5. Click Complete Component ✅.
Task 2. Assemble the COVER.PRT using Insert constraints.

1. Unhide COVER.PRT.

2. Edit the definition of COVER.PRT. The constraint STATUS is Partially Constrained.

3. In the dashboard, select the Placement tab.
   - Click New Constraint.
   - Select Insert as the Constraint Type.

4. Select one set of matching inner hole surfaces, one on COVER.PRT and one on BODY.PRT.
Normally you would not edit the component definition and add additional constraints. This Procedure is performed like this so you can fully understand the Insert constraint.

5. Press CTRL + ALT + middle-drag to spin the component out of the way.

6. In the Placement tab, click **New Constraint** and select **Insert**.

7. Select the second set of matching inner hole surfaces, one on COVER.PRT and one on BODY.PRT.

8. Notice that the component snaps to its new location. Also notice the constraint STATUS is now Fully Constrained.

9. Click **Complete Component**.
This completes the procedure.

17.8 Constraining Components using Mate Coincident

The Mate Coincident constraint enables you to position two planar surfaces or datum planes to lie in the same plane (coplanar), and to face each other, as shown in the upper-right figure. If datum planes are mated Coincident, their brown (positive) sides face each other. Using the Mate Coincident constraint, you can also select pairs of conical surfaces, which makes the surfaces coincident and coaxial in one step, as shown in the lower-right figure. When components are mated Coincident to one another, it is the same as assigning an offset value of zero, except that an offset value is not created for editing. The components can be positioned in any location as long as their normals face each other.

Datum planes have positive and negative sides designated by color. If you rotate a model with datum planes displayed, look
closely to see that the colors are brown and gray.

If two planar surfaces are mated Coincident, you can use the Change Constraint Orientation option in the dashboard to convert the Mate Coincident constraint into an Align Coincident constraint. You can also double-click the Mate constraint tag in the graphics window and edit the constraint type to an Align constraint.

**Procedure: Constraining Components using Mate Coincident**

**Scenario**
Assemble components using the Mate coincident constraint.

**Task 1. Assemble the SHAFT.PRT using a Mate coincident constraint.**

1. Edit the definition of SHAFT.PRT. Notice the constraint STATUS is Partially Constrained.

2. In the dashboard, select the Placement tab.
   - Click New Constraint.
   - Select Mate as the Constraint Type.
   - Verify the offset is set to Coincident.

3. Select the flat surfaces on SHAFT.PRT and BODY.PRT.
4. Notice that the component snaps to its new location. Also notice the constraint STATUS is now Fully Constrained with Allow Assumptions enabled.

5. Click **Complete Component ✔**.

Normally you would not edit the component definition and add additional constraints. This Procedure is performed like this so you can fully understand the Mate Coincident constraint.

---

**Task 2. Assemble ARM.PRT using a Mate coincident constraint.**

1. Unhide ARM.PRT.

2. Edit the definition of ARM.PRT. The constraint STATUS is No Constraints.

3. Reorient ARM.PRT.
4. In the dashboard, select **Mate** as the Constraint Type.

5. Verify that the Offset is **Coincident**.

6. Select the inner conical surface on ARM.PRT and the conical surface on SHAFT.PRT.

7. The resulting ARM.PRT orientation may vary based on how it was reoriented.

8. Notice that the component snaps to its new location. Also notice the constraint STATUS is now Fully Constrained.

9. Click **Complete Component**.
This completes the procedure.

17.9 Constraining Components using Align Coincident

The Align Coincident constraint enables you to make two planar surfaces or datum planes lie in the same plane (coplanar) and face in the same direction. Align can also be used to make two axes coaxial, or two points or edges coincident, but the selected references must be of the same type, for example, plane-to-plane, axis-to-axis, and so on. With Align constraints, the surfaces or the brown sides of datum planes, face the same direction instead of facing each other as when mated.

When components are aligned coincident to one another, it is the same as assigning an offset value of zero, except that an offset value is not created for editing. The components can be positioned in any location as long as their normals face in the same direction.
Datum planes have positive and negative sides designated by color. If you rotate a model with datum planes displayed, look closely to see that the colors are brown and gray.

If two planar surfaces are aligned coincident, you can use the Change Constraint Orientation option in the dashboard to convert the Align constraint into a Mate constraint. You can also double-click the Align constraint tag in the graphics window and edit the constraint type to a Mate constraint.

**Procedure: Constraining Components using Align Coincident**

**Scenario**
Assemble components using the Align coincident constraint.

**Task 1. Select surfaces with an Align coincident constraint.**

1. Edit the definition of SHAFT.PRT.
2. Double-click the Mate constraint to activate it.
3. Right-click in the graphics window and select Clear.
4. Edit the constraint from Mate to Align in the dialog box and verify the Offset is Coincident.
5. Select the flat surfaces on SHAFT.PRT and BODY.PRT.
6. Notice that the component snaps to a new location.
7. Click **Complete Component** 🔄.

Normally you would not edit the component definition and add additional constraints. This Procedure is performed like this so you can fully understand the Align Coincident constraint.

---

**Task 2. Select datum planes with an Align coincident constraint.**

1. Unhide ARM.PRT.

2. Edit the definition of ARM.PRT. The constraint STATUS is Fully Constrained.

3. In the dashboard, select the **Placement** tab and click **New Constraint**.

   o Select **Align** as the Constraint Type and verify the Offset is **Coincident**.

4. Reorient ARM.PRT to face approximately toward the front.
5. Click **Plane Display** to enable their display.

6. Select datum plane TOP in ARM.PRT and datum plane RIGHT in SHAFT.PRT.

7. Click **Change Constraint Orientation**.

8. Click **Change Constraint Orientation** again.

9. Click **Complete Component**.

10. Click **Plane Display**.

1. Unhide PLATE.PRT and click **Axis Display**.

2. Edit the definition of PLATE.PRT. The constraint STATUS is Partially Constrained.

3. In the dashboard, select the **Placement** tab and click **New Constraint**.
   - Select **Align**, and verify the Offset is **Coincident**.

4. Select datum axis A_1 in PLATE.PRT and datum axis A_5 in SHAFT.PRT.

5. In the dashboard, click **New Constraint**, select **Align**, and verify the Offset is **Coincident**.
6. Select datum axis A_2 in PLATE.PRT and datum axis A_4 in SHAFT.PRT. The constraint STATUS is Fully Constrained.

7. Click Complete Component ✔.

8. Click Axis Display ▶.

9. Select BODY.PRT and click View > Display Style > Transparent from the main menu.

10. Spin the model and inspect the assembly.

This completes the procedure.

17.10 Constraining Components using Align and Mate Offset

The Align and Mate Offset constraints enable you to specify an offset value between selected surfaces or datum planes. The Align and Mate Offset constraints are the same as the Align and Mate Coincident constraints, respectively, except that the selected references can be offset from one another versus coplanar.

When you use Align and Mate Offset, the system sets the current offset direction as the positive offset direction. To offset in the opposite direction, either drag the location handle to the other side of the selected Mate/Align assembly reference or edit the offset to a negative value. The component moves to the opposite
side, and this offset direction is now set as the positive offset direction. If components are Align or Mate Offset to one another with an offset value of zero, it is the same as aligning or mating Coincident, respectively, except that an offset value is available for editing. You can manually edit the Offset option from Offset to Coincident to Oriented.

If two planar surfaces are Align or Mate Offset, you can use the **Change Constraint Orientation** option in the dashboard to convert the Align Offset constraint into a Mate Offset constraint and vice versa. You can also double-click the Align constraint tag in the graphics window and edit the constraint type to a Mate constraint, and vice versa.

**Procedure: Constraining Components using Align and Mate Offset**

**Scenario**
Redefine component constraints from coincident to offset.

**Task 1. Edit Mate and Align Coincident constraints to Offset.**

1. Edit the definition of SHAFT.PRT.
2. Select the **Align** constraint and view the currently selected references.
3. In the dashboard, edit the Offset from **Coincident** to **Offset**.

4. Drag the drag handle down to an offset value of **3**, and notice the Offset value in the dashboard.

5. Edit the Offset value from **3** to **-7**.

6. In the dashboard, click **Change Constraint Orientation** to change the Align Offset constraint to a Mate Offset constraint.

7. Click **Change Constraint Orientation** again.

8. In the dashboard, select the **Placement** tab.
9. Orient the assembly to the **Standard Orientation** and select the surfaces on SHAFT.PRT and BODY.PRT.

10. Edit the Offset to **Offset** and drag the drag handle upwards to an offset value of 2.

11. In the dashboard, click **Change Constraint Orientation** to change the Mate Offset constraint to an Align Offset constraint.
12. In the dashboard, click **Change Constraint Orientation** again.

13. Click **Complete Component**.

This completes the procedure.
17.11 Constraining Components using Align and Mate Oriented

The Align and Mate Oriented constraints enable you to force a selected datum plane or surface into a particular orientation without regard to an offset value. The Align Oriented constraint forces selected surfaces or datum planes to face in the same direction, as shown in the right figure. The Mate Oriented constraint forces selected surfaces or datum planes to face each other, as shown in the left figure. The Align and Mate Oriented constraints are similar to the Align and Mate Coincident constraints, respectively, except that the selected references do not have to be coplanar.

You can use the Change Constraint Orientation option in the dashboard to convert the Align Oriented constraint into a Mate Oriented constraint and vice versa. You can also double-click the Align constraint tag in the graphics window and edit the constraint type to a Mate constraint, and vice versa.

**Procedure: Constraining Components using Align and Mate Oriented**

**Scenario**
Add an Align Oriented constraint to properly orient a component.

**Task 1. Add an Align Oriented constraint to the SHAFT.PRT.**
1. Edit the definition of SHAFT.PRT. Notice the constraint STATUS is Fully Constrained.
2. Notice also the current shaft orientation.

3. In the dashboard, select the **Placement** tab and clear the **Allow Assumptions** check box. The constraint STATUS is now Partially Constrained.
   - Click **New Constraint**.
   - Edit the Constraint Type to **Align** and edit the Offset to **Oriented**.

4. Select the flat surface on SHAFT.PRT and select the flat front surface on BODY.PRT.
5. Notice that the SHAFT.PRT has changed orientation and that the constraint STATUS is again Fully Constrained.

6. In the Placement tab, click **Flip** to switch the Align Oriented constraint to a Mate Oriented constraint. Notice that the shaft has flipped its orientation direction.
7. In the Placement tab, edit the Mate constraint back to **Align** in the drop-down list.

8. Click **Complete Component**.

9. Notice that since ARM.PRT is assembled to SHAFT.PRT, its orientation updates accordingly.

This completes the procedure.
17.12 Constraining Components using Align and Mate Angle

The Align and Mate Angle constraints enable you to specify a rotation angle between planes. The Align Angle and Mate Angle constraints are only available after a constraint that aligns axes or edges is created, or an Insert constraint is created. The component then rotates about those aligned axes or edges at an Angle Offset value that you specify.

You can use the Change Constraint Orientation option in the dashboard to convert the Align Angle constraint into a Mate Angle constraint and vice versa. You can also double-click the Align constraint tag in the graphics window and edit the constraint type to a Mate constraint, and vice versa.

Depending upon where you look in the interface, the Align Angle and Mate Angle constraints are also displayed as Align and Mate constraints with an Angle Offset specified as the Offset.

**Procedure: Constraining Components using Align and Mate Angle**

**Scenario**
Add an Align Angle constraint to properly orient a component.
Task 1. Add an Align Angle constraint to the SHAFT.PRT.

1. Edit the definition of SHAFT.PRT. Notice the constraint STATUS is Fully Constrained.

2. In the dashboard, select the Placement tab and clear the Allow Assumptions check box. The constraint STATUS is now Partially Constrained.
   - Click New Constraint.
   - Edit the Constraint Type to Align and edit the Offset to Coincident.

3. Select the flat surface on SHAFT.PRT and select the flat front surface on BODY.PRT.

4. Notice the Offset has changed automatically to Angle Offset, there is now an angle value, and that the constraint STATUS is again Fully Constrained.

5. Edit the angle value to -30.
6. In the Placement tab, click **Flip** to switch the Align Angle constraint to a Mate Angle constraint. Notice that the shaft has flipped its orientation direction.
7. In the Placement tab, edit the Mate constraint back to Align in the drop-down list.

8. Click Complete Component.

9. Select SHAFT.PRT, right-click, and select Edit. Notice the angle value is an assembly dimension.

10. Edit the angle value to 45 and click Regenerate.

11. Select SHAFT.PRT, right-click, and select Edit.
12. Edit the angle value to **-45** and click **Regenerate**.

This completes the procedure.

### 17.13 Constraining Components using the Automatic Option

When you assemble a component, the default Constraint Type is the Automatic option. With the Automatic option, the system automatically determines the constraint type and offset that is created when you select a reference pair. The following items influence the constraint type and offset created:

- **The references selected** — The references you select can automatically eliminate a particular constraint type that can be created.
The component’s location — In the upper figure, if the component is located above the area it is to be assembled to when references are selected, a Mate Offset constraint is created. If the component is located along the side at approximately the same height as its desired final placement location when references are selected, the system creates a Mate Coincident constraint.

The component’s orientation — In the lower figures, when the component is oriented in such a way that the selected references face the same direction, the system automatically creates an Align constraint. When the selected references face each other the system creates a Mate constraint.

For example, you can always go back and manually edit the constraint type, from Mate to Align, or you can manually edit the offset option from Offset to Coincident.

In between the creation of constraints, you can further reorient the component to refine its position. This can help the system more accurately determine the next constraint type and offset, or it may help you select the next set of references easier. Of course, the created constraints dictate how the component moves.

When you select a reference pair, the system automatically creates a constraint. At this point, the system waits for you to select a second reference pair to create a second constraint. The system automatically keeps creating new constraints until the component is Fully Constrained.

Procedure: Constraining Components using the Automatic Option

Scenario
Use the Automatic option to assemble components.

Task 1. Use the Automatic option to assemble components.

1. Click Assemble from the feature toolbar.

2. In the Open dialog box, select component BODY.PRT and click Open.

3. Right-click and select Default Constraint.

4. Click Complete Component ✓.
5. Click **Assemble**.

6. In the Open dialog box, select component SHAFT.PRT and click **Open**.

7. Reorient SHAFT.PRT approximately. Notice the Constraint Type is set to **Automatic**.

8. Select the two surfaces to create an Insert constraint.
9. Reorient SHAFT.PRT by pulling it up and out of BODY.PRT if necessary.

10. Select the two surfaces to create a Mate constraint.

11. Right-click the drag handle and select **Coincident**.
12. In the dashboard, select the **Placement** tab and notice the Insert and Mate constraints, as well as the Fully Constrained STATUS and Allow Assumptions.

13. Click **Complete Component ✔**.

14. Click **Assemble**, select COVER.PRT, and click **Open**.
15. Reorient COVER.PRT approximately. Notice the Constraint Type is set to Automatic.

16. Select the two surfaces to create a Mate constraint.

17. If necessary, right-click on the drag handle and select Coincident.

18. Select the two surfaces to create an Insert constraint.

19. Notice the constraint STATUS is Fully Constrained but the component orientation is not correct.
20. Right-click and select **New Constraint**.

21. Select the two surfaces to create another Insert constraint.

22. Notice the constraint STATUS is Fully Constrained and the orientation is correct.

23. Click **Complete Component ✓**.
This completes the procedure.

17.14 Utilizing the Accessory Window

When assembling components, you can use the accessory window. The accessory window displays only the incoming model, enabling you to manipulate the component individually to facilitate reference selection. You can toggle the accessory window on or off using the Show In Separate Window icon. The accessory window can be used in the following instances:

- Component placement — The accessory window can be particularly beneficial if you are assembling a very small component into a very large assembly.
• Data sharing
• Sheetmetal forms

When the accessory window is toggled on, you can choose whether or not to display the incoming model in the graphics window by toggling the **Show In Assembly Window** icon. Of course, you can select references on the incoming model in either the accessory window or the graphics window, depending on where it is displayed.

The accessory window can be docked or undocked. If docked, it appears within the Pro/ENGINEER graphics window, and always in front, preventing “lost windows”. You can drag the window to a different location within the graphics window or resize it like any other conventional window. When the accessory window is docked, the model tree pane splits and displays the incoming model's model tree at the lower portion. The accessory window model tree supports layer tree functionality.

If the accessory window is undocked, the incoming model's model tree will display in that window. The undocked accessory window model tree supports layer tree functionality, also. You can undock the accessory window using a configuration option.

**Accessory Window Config Options**

The following configuration options determine the accessory window behavior:

- **accessory_window_display** — Controls the display of the accessory window. Options include:
  - docked — Places the accessory window as a separate window within the graphics window.
  - undocked — Places the accessory window as a separate window in addition to the Pro/ENGINEER window. This option is equivalent to the “old” separate window.
- **comp_assemble_start** — Sets the initial assembly placement behavior when assembling a new component. Options include, but are not limited to:
  - default — Displays the incoming model in the main graphics window only.
  - constrain_in_window — Displays the incoming model in the accessory window only.

**Procedure: Utilizing the Accessory Window**

**Scenario**
Use the accessory window to assemble the BOLT.PRT components.
Task 1. Use the accessory window to assemble the BOLT.PRT components.

1. Click Assemble.

2. In the Open dialog box, double-click BOLT.PRT.

3. Notice the component is in the main graphics window.

4. In the dashboard, click Show In Separate Window.

5. Notice that BOLT.PRT is now in both the graphics window and the docked accessory window.

6. Notice that the BOLT.PRT model tree displays at the bottom of the existing model tree pane.
7. In the accessory window, zoom in on BOLT.PRT.

8. Reorient BOLT.PRT and select the flat surface.

9. Select the flat PLATE.PRT surface to create the Mate constraint.

10. Select the shaft on BOLT.PRT.

11. Select the upper hole surface on SHAFT.PRT to create the Insert constraint.

12. Click **Complete Component ✓**.
13. Click **Assemble**.

14. In the Open dialog box, double-click BOLT.PRT.

15. Notice that BOLT.PRT displays in both the graphics window and the docked accessory window.

16. In the dashboard, click **Show In Assembly Window** to toggle it off.

17. Notice that BOLT.PRT now only displays in the accessory window.

18. Select the flat surface on BOLT.PRT.
19. Select the flat PLATE.PRT surface to create the Mate constraint.

![Image of Mate constraint being created on a model]

20. Select the shaft on BOLT.PRT.

21. Select the lower hole surface on SHAFT.PRT to create the Insert constraint.

![Image of Insert constraint being created on a model]

22. In the dashboard, click Show In Assembly Window to toggle it on.

23. In the dashboard, click Show In Separate Window to toggle it off.

24. Click Complete Component.
This completes the procedure.
Check your Knowledge

1. True or False? Creating new assemblies using standard templates can save time by not repeatedly having to define company standards information.
   
   A - True
   
   B - False

2. When is the Default constraint most commonly used?
   
   A - Assembling the first component
   
   B - Assembling the last component
   
   C - Assembling the components between the first and last component
   
   D - All of the above

3. Reorienting a component with respect to the rest of the assembly uses which of the following keys on your keyboard in conjunction with the mouse?
   
   A - SHIFT
   
   B - CTRL
   
   C - ALT
   
   D - Both A and B
   
   E - Both B and C

4. True or False? When two surfaces are constrained using Align Coincident, they are facing in the same direction with an equivalent offset value of zero.
   
   A - True
   
   B - False

5. True or False? The Align Angle and Mate Angle constraints are only available after a constraint that aligns axes or edges is created, or an Insert constraint is created.
   
   A - True
   
   B – False
Module 18

Assembling with Connections

Module Overview

Many product designs include both static and dynamic components. Pro/ENGINEER enables you to assemble dynamic components using several connection types.

In this module, you learn how to assemble components using connections and how to simulate motion.
18.1 Understanding Connection Theory

A mechanical connection is a method of constraining components so they form a joint. Joint connection examples include Sliders, Pins, and Cylinders. Creating a Joint connection is similar to creating Assembly constraints between components. Joint connections enable you to create true-to-life connections between components so you can simulate motion between moving parts. For example, you can create a slider joint between an engine cylinder and the piston head so the piston head can translate within the cylinder.

Creating Connections

The procedure to create a Joint constraint is similar to the procedure to create constraints between fixed assembled components. Use the following method to create a Joint constraint.

- Assemble a component into the assembly.
- Click the Connections list in the dashboard.
- Select the connection type.
- Select the appropriate references.

You can use Constraints To Connections in the dashboard to convert existing constraints to connections.

18.2 Dragging Connected Components

One method of testing your assembly connections is to drag the assembly through its range of motion. To drag an assembly, click Drag Components and then click a part model. You can select edges, points, axes, datum planes, or surfaces to initiate the dragging movement.
The components move according to the connections that have been applied. The selected entity is always positioned as close as possible to the cursor location while the rest of the components stay connected to each other.

![Dragging Assembly Components](image1)

![Viewing a Snapshot](image2)

To quit dragging, you can either middle-click to return the components to their original position before dragging, or you can click to leave the components at their current position. The default option when dragging components is Point Drag, shown in the upper figure, although you can also Body Drag.

Creating Snapshots

After you move connected components to a desired position, you can create snapshots of that particular location in the graphics window. Snapshots enable you to return the assembly components to a particular position. You can create multiple snapshots and quickly move the assembly to specific positions by activating each snapshot.

**Procedure: Dragging Connected Components**

**Scenario**
Drag connected components and take snapshots.

---

**Task 1. Drag connected components.**

1. Click **Drag Components** from the main toolbar and select the lower-right corner of CRANK_4.PRT.
2. Move the cursor in a circular motion to see the motion created by the connections.

3. Click to stop the motion.

**Task 2. Create snapshots while dragging components.**

1. In the Drag dialog box, expand the Snapshots area.

2. Click the corner of CRANK_4.PRT and move the connected components until ROD_2_4.PRT is fully extended to the left. Click again to stop the motion.

3. In the Drag dialog box, click **Take Snapshot**.

4. Click the corner of CRANK_4.PRT again and move the connected components until ROD_2_4.PRT is fully extended to the right. Click again to stop the motion.

5. In the Drag dialog box, click **Take Snapshot**.
6. In the Drag dialog box, double-click **Snapshot1** to activate it. Notice that ROD_2_4.PRT is fully extended to the left.

7. In the Drag dialog box, double-click **Snapshot2** to activate it. Notice that ROD_2_4.PRT is fully extended to the right.

8. Click **Close** from the Drag dialog box.

This completes the procedure.

### 18.3 Assembling Components using the Slider Connection

Slider connections are used to enable translation along a single axis. For example, an elevator door is representative of a Slider connection, as it slides back and forth in one direction and is unable to rotate about any axis. A piston in an engine is another example of a Slider connection. In the figures, the hedge trimmer blade is yet another example of a Slider connection.

Slider connections require two constraint rules that limit their degrees of freedom in a single direction. These two constraint rules are:

- **Axis Alignment**
- **Rotation Reference**
- Axis Alignment — The axes or cylindrical surfaces you select as references determine the axis of free translation.
- Rotation Reference — The datum planes or planar surfaces you select with the axis alignment restrict all rotational movement.

**Procedure: Assembling Components using the Slider Connection**

**Scenario**
Assemble components using the Slider connection.

![Slider Connection](image.png)

**Task 1. Assemble BLADE_2.PRT using a Slider connection.**

1. Orient to the 3D orientation.
2. Click **Assemble** from the feature toolbar.
3. In the Open dialog box, select BLADE_2.PRT, and click **Open**.
4. In the dashboard, edit the Connection from **User Defined** to **Slider**.
5. Select datum axis A_2 on BLADE_2.PRT and datum axis A_3 on HOUSING.PRT as the Axis alignment of the Slider connection.

![Axis alignment](image.png)

6. Select datum plane RIGHT on BLADE_2.PRT and datum plane RIGHT on HOUSING.PRT for the Rotation of the Slider connection.
7. In the dashboard, click **Change Constraint Orientation** to flip the component.

8. Click **Complete Component**

9. Click **Plane Display** and **Axis Display** to disable their display.

10. Click **Drag Components** from the main toolbar and select **BLADE_2.PRT**.
11. Move the cursor to notice the range of motion created by the Slider connection. Click to place BLADE_2.PRT.

12. Click Close from the Drag dialog box.

This completes the procedure.

18.4 Assembling Components using the Pin Connection

Pin connections are used to enable rotation about a single axis. For example, a hinge on a door uses a Pin connection. A crankshaft in an engine is another example.

Pin connections require two constraints (rules) that limit their degrees of freedom about a single axis. These two constraint rules are:

- Axis Alignment — The axes or cylindrical surfaces you select as references determine the axis of free rotation.
- Translation Reference — The datum planes or planar surfaces you select with the axis alignment restrict translational movement in the axis direction.
Procedure: Assembling Components using the Pin Connection

Scenario
Assemble components using the Pin connection.

Task 1. Assemble ROD_2_2.PRT using a Pin connection.

1. Click Assemble from the feature toolbar.
2. In the Open dialog box, select ROD_2_2.PRT, and click Open.
3. In the dashboard, edit the Connection from User Defined to Pin.
4. Select the small hole surface on ROD_2_2.PRT and the cylindrical surface on BLADE_2_2.PRT as the Axis alignment of the Pin connection.
5. Select the back side surface of ROD_2_2.PRT and the front surface of BLADE_2_2.PRT for the Translation of the Pin connection.
6. Click Complete Component
7. Click Drag Components from the main toolbar and select ROD_2_2.PRT.

8. Move the cursor to notice the range of motion created by the Pin connection. Also notice the motion of BLADE_2_2.PRT due to the Slider connection. Click to place ROD_2_2.PRT.

9. Click Close from the Drag dialog box.

This completes the procedure.

18.5 Assembling Components using the Cylinder Connection

Cylinder connections are used to enable both rotation and translation about a specific axis. For example, aligning a pen cap over a pen is a Cylinder connection. While holding the pen cap aligned with the pen, you can rotate the pen cap and slide it along the axis of the pen.
Cylinder connections require only one constraint rule that limits their degrees of freedom about a specific axis. The constraint rule is:

- **Axis Alignment** — The axes or cylindrical surfaces you select as references determine the axis of free rotation and translation.

Cylinder connections are often used in situations in which you do not want to overconstrain a component. In the hedge trimmer example, a Pin connection between the connecting rod and the blade keeps the connecting rod from sliding in and out of the journal. As a result, a Cylinder connection is suitable to constrain the other end of the connecting rod to the crankshaft.

**Procedure: Assembling Components using the Cylinder Connection**

**Scenario**
Assemble a component using the Cylinder connection.

![Cylinder connection](image)

**Task 1. Redefine ROD_2_3.PRT and add a Cylinder connection.**

1. Edit the definition of ROD_2_3.PRT.
2. In the dashboard, select the **Placement** tab.
   - Click **New Set**.
   - Select the new Pin connection, and edit its type to **Cylinder**.
3. Select the large hole surface on ROD_2_3.PRT and the cylindrical journal surface on CRANK_3.PRT as the Axis alignment of the Cylinder connection.

4. Click **Complete Component**

This completes the procedure.

### 18.6 Analyzing Collision Detection Settings

Pro/ENGINEER has real-time collision detection, enabling you to check for interferences between parts as you drag a mechanism assembly through its range of motion. Collision detection, by default, is turned off when you drag components in a mechanism assembly. However, you can enable two different types of collision detection:

- **Global Collision Detection** — Checks for any kind of collision in the entire assembly.
- Partial Collision Detection — You specify the components between which to check for interference.

There is also an option to ring the Message Bell when a collision occurs between components. The component areas that interfere with each other display in reddish-pink, as shown in the upper figure. You can then fix the interferences by modifying the models. In the lower figure, the housing has been modified so the connecting rod no longer interferes.

To enable stop when colliding or push objects on collision functionality, you must set the config.pro option `enable_advance_collision` to yes.

**Procedure: Analyzing Collision Detection Settings**

**Scenario**
Analyze collision detection settings.

**Task 1. Analyze an assembly for interference by dragging its components.**

1. Select HOUSING_5.PRT and click View > Display Style > Transparent.
2. Orient to the 3D2 view orientation.
3. Zoom in on HOUSING_5.PRT.

4. Click **Tools > Assembly Settings > Collision Detection Settings** from the main menu.

5. In the Collision Detection Settings dialog box, select the **Global Collision Detection** option and verify that the **Ring Message Bell when Colliding** check box is selected.

   - Click **OK**.

6. Click **Drag Components** and drag the components by selecting the hex-shaped geometry.

7. Notice the highlighted interfering geometry. The HOUSING_5.PRT is too short. Click **Close** from the Drag dialog box.

8. Select HOUSING_5.PRT, right-click, and select **Activate**.
9. In the graphics window, right-click to query and select Extrude 1. Right-click and select Edit.

10. Edit the 51 dimension to 56 and click Regenerate.

11. Activate COLLISION_DETECT.ASM.

12. Click Drag Components and drag the components by selecting the hex-shaped geometry again. There is no longer a collision, as the interference has been fixed.

   - Click Close.

This completes the procedure.
Check your Knowledge

1. Which of the following is an example of an assembly joint connection?
   A - Slider
   B - Insert
   C - Pin
   D - Cylinder
   E - Mate
   F - All of the above
   G - A, C, and D

2. True or False? Slider connections are used to enable rotation about a single axis.
   A - True
   B - False

3. True or False? Pin connections are used to enable rotation along a single axis.
   A - True
   B - False

4. The Cylinder connection is...
   A - used to enable translation only.
   B - used to enable rotation only.
   C - best used in situations where you do not want to over constrain a component.
   D - best used in situations where you want to tightly constrain a component.
5. When dragging assembly components, Snapshots are used to...

   A - capture images which can be exported from Pro/ENGINEER.
   B - freeze components to keep them from moving further.
   C - limit the range of motion of translated components.
   D - return assembly components to a particular location.
Module 19

Exploding Assemblies

Module Overview

Explode states enable you to capture assembly parts in various states of assembly/disassembly. These states can be easily referenced when creating drawings and assembly/disassembly procedures.

In this module, you learn how to create assembly explode states and create explode lines between exploded components. You also learn how to animate explode states.
19.1 Creating and Managing Explode States

You can use explode states to quickly reposition components in 3-D space, and save these assembly/disassembly views using the view manager Explode tab. Explode states can be selected when placing a drawing view or they can be used to create assembly/disassembly procedures. You can toggle an explode state on or off, and you can create multiple explode states.

Specifying the Motion Type and Movement Reference

Before you can explode components from an assembly, you must specify the Motion type and Movement Reference.

- **Motion type** — Specify the type of motion that a selected component will follow. Motion types include:
  - **Translate Component** — Linearly moves the selected component. This is the default motion type.
  - **Rotate Component** — Rotates the selected component about a specified Movement Reference.
  - **Copy Position** — Copies the exploded position from the selected component to other components. This option is available in the Options tab of the dashboard.
  - **Toggle Explode Location** — Toggles the placement location of the selected component between its original location and its current location. You can use this option to reset a component's position.

- **Movement Reference** — Specifies the reference to define the direction of movement of the selected component. This reference is required when
rotating components, but it is optional for translating components if you require a different direction than the three default directions. Available reference types include all datum features, planar surfaces, edges, and vertices. You can also click **View Plane** from the dashboard, which enables you to explode components parallel to the screen in the assembly's current orientation.

Exploding Components

Once the Motion type and Movement Reference have been defined, you can select the components you wish to explode. There are three methods available:

- **Move one component** — Move a single component in an assembly or sub-assembly by selecting it.
- **Move many components** — Press CTRL and select multiple components to move them all at once.
- **Move with Children** — In the Options tab of the dashboard, you can select the **Move with Children** check box. This option enables you to select a component to explode, and move its children along with it.

When you select a component, a coordinate system displays at that location. You can cursor over any of the three axes and drag to explode the component in that direction.

You can also specify the Motion increment of the component you are exploding. The default Motion increment value is **Smooth**, meaning that the components will explode smoothly and you can drop them at any relative position. You can also increment values of 1, 5, or 10 from the drop-down list, or you can type in your own increment value. The increment value is in the same units as the assembly. For example, if the assembly units are millimeters, then for an increment value of 10, the component will explode in 10 millimeter increments, snapping to each increment.

Additional Explode State Facts

When using the explode functionality, keep in mind the following:

- If you explode a sub-assembly in the context of a higher-level assembly, the system does not explode the components in the sub-assembly.
- You do not lose the explode state when you unexplode an assembly. The system retains the information so the components have the same explode position if you explode again.
- All assemblies have a Default Explode state, which the system creates automatically from the defined component placement constraints.
- Multiple occurrences of the same sub-assembly can have different explode states.
Procedure: Creating and Managing Explode States

Scenario
Create and manage explode states.

Explode_States explode.asm

Task 1. Create explode state Exp0001.

1. Start the View Manager from the main toolbar.

2. In the View Manager dialog box, select the Explode tab.
   - Click New and press ENTER to accept the default name.
   - Click Close.

3. Notice the note in the graphics window.

4. Click View > Explode > Edit Position from the main menu.

5. In the dashboard, verify that Translate Component is selected.

6. Select SHAFT.PRT.

7. Cursor over the X-axis and drag upwards to explode the component.
8. Select ARM.PRT.

9. Cursor over the Y-axis and drag upwards to explode the component.
10. In the dashboard, select the **Options** tab and select the **Move with Children** check box.

11. Select COVER.PRT, cursor over the X-axis, and drag upwards. Notice that the bolts explode with it.

12. Select the pattern leader BOLT.PRT, cursor over the X-axis, and drag upwards to explode all three bolt members.

13. In the graphics window, right-click and select **Motion Reference**.

14. Select the front, planar surface of BODY.PRT.

15. Select PLATE.PRT, cursor over the X-axis, and drag to the left.
16. In the Options tab, clear the **Move with Children** check box.

17. Select the **References** tab.

18. Right-click the Movement Reference and select **Remove**.

19. Click in the **Components to Move** collector.

20. Select one BOLT.PRT, press CTRL, and select the second BOLT.PRT member.

21. Cursor over the X-axis, and drag the bolts to the left.

22. Click **Complete Feature** from the dashboard.
23. Start the View Manager, right-click Exp0001, and select Save.

24. Click OK from the Save Display Elements dialog box.

25. Click Close from the view manager.

This completes the procedure.

19.2 Creating Explode Lines

You can create cosmetic explode lines to show how exploded components align when the assembly is unexploded. Explode lines automatically update to changes in position made to the exploded components they reference. Creating new explode lines or editing existing explode lines causes the explode state to be modified, and you can save the modified explode state in the view manager Explode tab.

You can create an explode line in an explode state by specifying a reference on two different components. You can select surfaces, edges, or curves as references on the components. The explode line is then created between the two selected references and displays in the model tree as an Offset Line.

Explode lines are also known as Offset lines.

Editing Explode Lines
You can edit existing explode lines by selecting the explode line and clicking **Edit Explode Line** from the Explode Lines tab in the dashboard. You can also right-click and select **Edit Explode Line**. You can perform the following edit operations on an explode line:

- **Edit the explode line length** — You can extend or shorten the ends of an explode line by dragging the handle at the desired end.
- **Add Jogs** — Select the explode line location where you want to create the jog, right-click, and select **Add Jog**. You can then drag the jog to its desired location. You can delete the jog by right-clicking its handle and selecting **Remove Jog**.

### Modifying Explode Line Style

You can modify the style of existing explode lines by selecting the explode line and either clicking **Edit Line Styles** from the Explode Lines tab in the dashboard, or by right-clicking in the graphics window and selecting **Modify Line Style**. You can modify the line style to be Hidden, Geometry, Leader, Cut Plane, Phantom, or centerline. You can also modify the Line Font and Line Color. You can always restore the default line style by selecting the explode line and clicking **Default Line Style** from the Explode Lines tab in the dashboard.

### Removing Explode Lines

You can remove explode lines by selecting the explode line and then clicking **Remove Explode Line** from the Explode Lines tab in the dashboard. You can
also right-click and select **Remove Explode Line**. You can press CTRL and select multiple explode lines at once.

**Procedure: Creating Explode Lines**

**Scenario**
Create explode lines between exploded components.

**Task 1. Create offset lines between exploded components.**

1. Start the **View Manager** from the main toolbar.

2. In the View Manager dialog box, select the **Explode** tab.

   - Right-click **Exp0001** and select **Explode**.
   - Notice the note in the graphics window.
   - Leave the view manager open.

3. Right-click **Exp0001** and select **Edit Position**.

4. Click **Create Explode Line**.

5. Edit the selection filter to **Surface**.
6. Zoom in and select the surfaces on COVER_2.PRT and ARM_2.PRT.

7. Click **Apply** from the Cosmetic Offset Line dialog box to create the explode line.

8. Select the inner hole surface on COVER_2.PRT and the outer surface on the corresponding BOLT_2.PRT, and click **Apply** to create the explode line.

9. Create explode lines for the other two BOLT_2.PRT components.

10. Select the inner hole surface on COVER_2.PRT and the outer surface on the SHAFT_2.PRT tip and click **Apply** to create the explode line.
11. Select the inner hole surface on BODY_2.PRT and the outer surface on SHAFT_2.PRT and click **Apply** to create the explode line.

12. Select the upper bolt hole surface on PLATE_2.PRT and the corresponding outer surface on BOLT_2.PRT, and click **Apply** to create the explode line.

13. Create another explode line for the second plate bolt.
14. Select the inner surface of BODY_2.PRT.

15. Query select the back surface of PLATE_2.PRT in approximately the center and click **Apply**.

16. Click **Close** from the Cosmetic Offset Line dialog box and click **Complete Feature** from the dashboard.

17. In the view manager, right-click **Exp0001**, select **Save**, and click **OK**.

18. Click **Close**.
This completes the procedure.

19.3 Animating Explode States

You have the option of animating your explode states for both exploding and unexploding operations. The system animates the movement of components from their start to end positions in the explode state. To enable animation, click View > Display Settings > Model Display from the main menu and select the Enable check box under the Animation while exploding section.
You can also control the following options:

- **Maximum seconds** — Sets the duration of time the system takes to explode or unexplode the assembly.
- **Follow explode sequence** — If enabled, this option causes the components to explode or unexplode in the order they were moved when creating the explode state, and following the drag motions you used. If this option is de-selected, the system uses the shortest distance to move the components, and all components are moved at once, regardless of the order they were moved when creating the explode state.

Explode lines appear at the end of the animation when exploding, and display until the end of the animation while unexploding.

**Animated Explode State Config Options**

The following configuration options determine the default animated explode state behavior:

- **animate_explode_states** — Controls whether explode states are animated. This option is set to yes by default.
- **explode_animation_max_time** — Sets the default duration of time the system takes to explode or unexplode the assembly.

**Procedure: Animating Explode States**

**Scenario**
Animate an explode state in an assembly.

**Task 1. Animate an explode state in an assembly.**

1. Click **View > Display Settings > Model Display** from the main menu.

2. In the **Animation while exploding** section of the Model Display dialog box, notice that the **Enable** check box is selected.
   
   - Type 10 as the value for Maximum seconds.
   - Click **Apply > OK**.
3. Start the View Manager from the main toolbar and select the Explode tab.
   - Right-click explode state Exp0001 and select Explore.

4. Notice that all components begin exploding at once.

5. Notice that the explode lines appear at the end of the sequence.

6. In the View Manager dialog box, right-click Exp0001 and select Explore to unexplode the assembly.

7. Notice that all components unexplode at once.

8. Notice that the explode lines display until the end of the sequence.
9. Click **View > Display Settings > Model Display**.

10. In the Animation while exploding section of the Model Display dialog box, select the **Follow explode sequence** check box.

   - Click **Apply > OK**.

11. In the View Manager dialog box, right-click **Exp0001** and select **Explode**.

12. Notice that the components explode in order.
13. In the View Manager dialog box, right-click Exp0001 and select **Explode** to unexplode the assembly.

14. Notice that all components unexplode in order.

15. Click **Close** from the View Manager dialog box.
This completes the procedure.
Check your Knowledge

1. True or False? Offset lines automatically update to changes in position made to the exploded components they reference.
   
   A - True
   
   B - False

2. When creating an explode state, how can you select multiple components to move?
   
   A - Select the Move Many option.

   B - Press CTRL and select multiple components.

   C - Select the Move with Children option.

   D - B and C.

   E - All of the above.

3. Which statement best describes the result of enabling the Follow Explode Sequence option when animating explode states?
   
   A - The components explode or unexplode in the order they were moved when creating the explode state, and follow the drag motions used.

   B - The system uses the shortest distance to move the components, and all components are moved at once, regardless of the order in which they were moved when creating the explode state.

   C - The components move according to the created explode lines, in the order the explode lines were created.

4. True or False? An explode state is only available when viewing 3-D models and cannot be used within 2-D drawings.

   A - True

   B – False
Module 20

Drawing Layout and Views

Module Overview

Drawings are used for documenting the production design of parts and assembly models. They typically contain two-dimensional and three-dimensional model views, as well as dimensions, notes, and Bills of Materials. Drawings are frequently used in the manufacture of product designs. This module focuses on the creation of drawings and the layout of drawing views.

There are two methods for creating drawings. In the first method, you manually place views onto a drawing. In the second method, you use a drawing template to automatically populate the drawing with predefined information. Typically, a combination of these methods is used: manually placing views on drawings that were started using a drawing template.
20.1 Analyzing Drawing Concepts and Theory

Once a part or assembly has been modeled, it is usually necessary to document that part or assembly by creating a 2-D drawing of it. Often, a 2-D drawing is the final deliverable at a company. The 2-D drawing usually contains parametric 2-D or 3-D views of the 3-D part or assembly, dimensions, and a title block. The drawing may also contain notes, tables, and further design information. Not every company requires that a drawing be created of a model.

A drawing is bi-directional. If a change is made to a model, a drawing that displays that model automatically updates to reflect that change. Conversely, if a change is made to a model in the drawing, the model automatically updates as well.

20.2 Understanding the Drawing Ribbon User Interface

The Drawing mode has been reorganized into a ribbon-style user interface. A cross between a tabbed dialog box and a toolbar, the ribbon appears above the graphics window. The ribbon organizes and configures the user interface by:

- Organizing the current task into a series of tabs.
  - The tabs represent a task in the typical drawing creation workflow.
  - Each tab contains groups of icon commands.
- Setting up the selection scope.
  - By default, you can only select items that pertain to the selected tab. For example, you cannot select an annotation (detail item) when the Layout tab (for drawing views) is active.
    - You can select out-of-context items by pressing the ALT key. However, the available actions will be limited compared to what is available within the appropriate tab.
  - The available selection filters correspond to the active tab.
  - The Drawing Tree updates to display only items that pertain to the active tab.
Ribbon User Interface Structure

Within each tab in the ribbon, icon commands are organized into groups. Depending on the available screen space, less common options may be accessed by clicking a down arrow to reveal additional commands.

Customizing the Ribbon User Interface

The ribbon user interface can be customized to control icon display and placement. When in the Customize Screen function, right-click on ribbon icons for the following options:

- Icon display size — Icons can be set to display as large or small.
- Icon and text — Commands can be displayed as a large or small icon with text, icon only, or text only.
- Command priority — Commands can be reordered within their group to place frequently used options in easy reach. However, you cannot move commands between groups.

20.3 Creating New Drawings and Applying Formats

Creating New Drawings Theory

You can create new drawings within Pro/ENGINEER either by clicking File > New, or by clicking New, selecting the Drawing option, and then editing the drawing Name. You must also specify whether to use a default template. This topic focuses on drawing creation when a default template is not used.

You must specify the Default Model to be used in the drawing.
The Default Model is the model that is used in your drawing when you start placing views. You can add additional models to the drawing at a later time. If you have models open in Pro/ENGINEER when a new drawing is created, the model that is in the active window at the time of drawing creation is automatically set as the Default Model.

You must also specify the drawing Orientation, whether Portrait, Landscape, or Variable. If you select Portrait or Landscape, you can choose between numerous standard, predefined drawing sizes. If you select Variable, you must specify the desired drawing size width and height, in units of either inches or millimeters. A C size drawing is shown in the upper figure.

Using Drawing Formats

When creating a new drawing you must also decide whether a format is to be used in the new drawing. A drawing format contains 2-D items that typically include boundary lines, referencing marks, tables, and text. A format has an extension of *.frm, and is created in Format mode. A format is then applied to a drawing. Your company will likely have created customized formats to be used, as they typically contain your company's logo, title block, and tolerancing standards. In the lower figure, a C size drawing is shown with a format having been applied.

If you specify a format during drawing creation you do not specify an orientation or size, as these parameters are determined during format creation and carry into the drawing.

Adding and Changing Formats

You can decide whether to add a format at the time of drawing creation or at a later time. To add a format to a drawing after the drawing has been created, you can either click Sheet Setup from the Document group in the Layout tab, or you can click File > Sheet Setup from the main menu. You can also double-click the drawing size that is displayed along the bottom of the graphics window. You can then select your desired format, or replace an existing format with a different format.

Procedure: Creating New Drawings and Applying Formats

Scenario
Create a new drawing and apply different formats to it.
Task 1. Create a new drawing and apply different formats to it.

1. Click **New** from the main toolbar.
   - In the New dialog box, select **Drawing** as the Type.
   - Edit the Name to **new_drawing**.
   - Clear the **Use default template** check box and click **OK**.

2. In the New Drawing dialog box, click **Browse** to specify the Default Model.
   - Select **ANGLE_GUIDE.PRT** and click **Open**.
   - Edit the Standard Size to **A** in the drop-down list.
   - Click **OK**.

3. Notice the text below the sheet that displays the drawing scale, type, name, and drawing size.
4. Click **Sheet Setup** from the Document group in the Layout tab.

5. In the Sheet Setup dialog box, edit the Format from **A Size** to **C Size** in the drop-down list.
   - Click **OK**.

6. Click **File > Sheet Setup**.

7. In the Sheet Setup dialog box, click the **C Size** format to activate the field. Click **Browse** from the drop-down list.
   - In the Open dialog box, click **Working Directory**.
   - Select **c_format_generic.frm** and click **Open**.
   - Click **OK**.

8. In the input window, type your first initial, followed by your surname, and press ENTER.

9. Notice that the text at the bottom has updated again. Also notice the new format which contains a border and title block.

10. Zoom in on the title block.
11. Click Refit.

This completes the procedure.

20.4 Creating and Orienting General Views

When you create a drawing, the first view added to a drawing is a general view. A general view is usually the first of a series of views to be created. When you create or edit a general view in a drawing, the Drawing View dialog box appears displaying the View Type category.

You can edit the following attributes of a general view in the View Type category:

- **View name** — The view name displays in the drawing tree and when you cursor over the view in the graphics window. It also displays in the Layer tree when selecting the active layer object.
- **View type** — If there is more than one general view on the drawing, you can edit the view type from general to a different view type. This option is only available when editing an existing general drawing view.
- **View orientation** — Determines the orientation of the view in the drawing. You can set the view orientation using model view names that are created in the model itself. These are the same model views that are found in the model's saved view list and view manager. A general view can be placed in any orientation.

**Procedure: Creating and Orienting General Views**

**Scenario**
Create and orient general views.
**Task 1. Create a 2-D general view.**

1. Click **General** from the Model Views group in the Layout tab.

2. Click in the middle of the drawing to place the view.

3. In the Drawing View dialog box, edit the name to **SHAFT_SIDE**.

4. Notice the default view of the model. Also notice the model views available in the Drawing View dialog box. These came from the model.

5. In the Drawing View dialog box, select Model view name FRONT, and click **Apply**.
   - Click **Repaint**.
   - Select Model view name LEFT and click **Apply**.
   - Select Model view name RIGHT and click **OK**.

6. De-select the **SHAFT_SIDE** view.

**Task 2. Create a 3-D general view.**

1. Right-click in the drawing and select **Insert General View**.

2. Click in the upper-right of the drawing to place the view.

3. In the Drawing View dialog box, edit the name to **SHAFT_DEFAULT**.

4. Notice the model views available in the Drawing View dialog box.
5. In the Drawing View dialog box, select Model view name 3D, and click Apply.

6. In the Drawing View dialog box, select Model view name Default Orientation, and click OK.

This completes the procedure.


20.5 Utilizing the Drawing Tree

Utilizing the Drawing Tree Theory

Drawing elements are shown in a hierarchical tree similar to the model tree. The drawing tree changes its display to match the current drawing task, based on the tab selected in the drawing ribbon. The drawing tree enables you to visualize the items in the drawing, and also enables you to right-click them for access to additional various options.

Keep in mind the following when working with the drawing tree:

- The drawing tree appears above the model tree. Each can be independently resized or collapsed.
- The drawing tree or the model tree can be toggled to display the layer tree.

Procedure: Utilizing the Drawing Tree

Scenario
Explore ways to utilize the drawing tree.

Task 1. Navigate through the drawing, exploring the drawing tree.

1. Select the Layout tab from the drawing ribbon if necessary.
   - Notice that in the drawing tree the active sheet is shown.
   - Also notice the views are shown in the tree.

The views in this drawing have been renamed for easy recognition in the drawing tree.
2. Right-click FRONT and view the available options.

3. Select **Auxiliary** to locate this view.

4. Select the **Table** tab from the drawing ribbon.
   - Notice the drawing tree updates.

5. Select **Table 3** to locate it.
   - Right-click **Table 3** and view the available options.
6. Select the **Annotate** tab from the drawing ribbon.
   - Notice the drawing tree updates.

7. Expand the FRONT node and the **Annotations** node in the drawing tree.
   - Notice the various shown and erased dimensions.

8. Select the HOLE_DIA dimension to locate it.
   - Right-click and view the available options for this shown dimension.
9. Select the d21 dimension to locate it.
   - Right-click and view the available options for this erased dimension.

10. Expand the RIGHT node and the Datums node in the drawing tree.
    - Notice the various shown and erased axes.
11. Select the CYL axis to locate it.
   - Right-click and view the available options for this axis.

This completes the procedure.

### 20.6 Managing Drawing Sheets

#### Managing Drawing Sheets Theory

Drawings have at least one sheet. When additional sheets are created, you use the sheet tabs and sheet dialog boxes to manage multiple sheets.

The most common sheet functions can be accessed using the sheet tabs area, located below the drawing status text. Using the sheet tabs, you can:
- Preview a sheet by placing the cursor over the tab.
- Select a sheet tab to activate the desired sheet.
- Create and Delete sheets.
- Reorder the sheets by dragging a sheet tab.
- Rename a sheet.
- Right-click a sheet for additional options.

Within the Layout tab of the drawing ribbon, you can click **Move/Copy Sheets** from the document group. The move or copy sheets dialog box enables you to:

- Move the current sheet to the selected location.
- Insert a copy of the current sheet to the selected location.

Within the Layout tab of the drawing ribbon, you can click **Sheet Setup** from the document group. The Sheet Setup dialog box enables you to:

- Specify the drawing Format.
- Change sheet Size.
- Change sheet Orientation.

**Procedure: Managing Drawing Sheets**

**Scenario**
Manipulate sheets in a drawing.

**Task 1. Use different tools to manipulate sheets in a drawing.**

1. Select the **Sheet 1** sheet tab to activate it if necessary.

2. Notice the drawing tree updates for this sheet.
3. Place the cursor over the Sheet 2 tab to view the thumbnail preview.

4. Select the **Sheet 2** sheet tab to activate it.

5. Notice the drawing tree updates for this sheet.

6. Click **New Sheet** 📑.
7. Double-click the Sheet 1 sheet tab, type CYL, and press ENTER.

8. Right-click the Sheet 2 sheet tab and view the available options.
   - Select Rename, type ANG and press ENTER.

9. Select the NEW sheet tab to activate it.

10. From the Document Group in the ribbon, click Move/Copy Sheets.

    - Select ANG if necessary.
    - Select the Create a Copy check box.
    - Click OK and press ENTER to create Sheet 4.

11. Select the Sheet 4 sheet tab to activate it.
12. Select the **NEW** sheet tab to activate it.

13. From the Document Group in the ribbon, click **Sheet Setup**.

- Select the current format to activate the drop-down list.
- Select **Browse** from the drop-down list.
- Select **afrm** then click **Open** and **OK**.
- Click **Remove All** and **Yes**.

This completes the procedure.

### 20.7 Adding Drawing Models

When you create a drawing you typically specify the drawing model to be used in the drawing. Views placed in the drawing are of this specified drawing model. However, you can add additional drawing models to the drawing. This enables drawing views and information from multiple models to be captured in a single drawing.
The system adds information to the drawing from the active model. The active model is displayed at the bottom of the graphics window and in the model tree. You can switch between drawing models and set the active one using the Set Active Model/Rep icon from the model tree, by clicking Drawing Models from the Document group of the Layout tab in the drawing ribbon, or by right-clicking a view of a drawing model that is not the active model and selecting Set/Add Drawing Model. You can also double-click the active component name at the bottom of the graphics window.

You must use the Drawing Models icon and subsequent menu manager to add new models, however. The lower-left figure displays the menu manager. You must also delete drawing models from the drawing through the view manager. You can only delete a drawing model if there are no views using it, however, and each drawing must contain minimum one drawing model.

**Procedure: Adding Drawing Models**

**Scenario**
Add drawing models and sheets to a drawing.

**Task 1. Add the CYLINDER_BRACKET.PRT to the drawing.**

1. At the bottom of the graphics window, notice that SHAFT is the active model.
2. Notice that the model tree displays SHAFT.PRT.
3. Click Drawing Models from the Document group of the Layout tab.
4. In the menu manager, click Add Model.
5. Select CYLINDER_BRACKET.PRT and click Open. At the bottom of the graphics window notice that CYLINDER_BRACKET is now the active model.
6. Notice that the model tree displays CYLINDER_BRACKET.PRT.
7. Click **New Sheet**.

8. In the input window, type your first initial, followed by your surname, and press ENTER. Sheet number 2 is added to the drawing. Notice the model name in the title block.

9. Click **General** from the Model Views group in the Layout tab.

10. Click in the drawing to place the general view.

11. In the Drawing View dialog box, select FRONT as the Model view name and click **OK**.
Task 2. Add the ANGLE_GUIDE.PRT to the drawing.

1. Click **Drawing Models**.

2. In the menu manager, click **Add Model**.

3. Select ANGLE_GUIDE.PRT and click **Open**. At the bottom of the graphics window notice that ANGLE_GUIDE is now the active model and that ANGLE_GUIDE.PRT displays in the model tree.

4. Click **New Sheet**.

5. In the input window, type your first initial, followed by your surname, and press ENTER. Sheet number 3 is added to the drawing. Notice the model name in the title block.

6. Click **General**.

7. Click in the drawing to place the general view and click **OK**.
Task 3. Set a different active drawing model.

1. In the model tree, click Set Active Model/Rep and select SHAFT.PRT > Master Rep.

2. The SHAFT is now the active model.

3. Click General, click in the drawing to place the general view, and click OK.

4. Click Drawing Models.
5. In the menu manager, click Set Model > CYLINDER_BRACKET > Done/Return.

This completes the procedure.

20.8 Creating Projection Views

A Projection view is an orthographic projection of another view's geometry along a horizontal or vertical direction from the parent view. The orientation of the projection view is always 90° from the parent view, and its scale is dependent on the parent view. If the orientation of the parent view is updated, the orientation of the child projection views also updates.

You can either insert projection views by clicking Projection from the Model Views group in the Layout tab, or by selecting a drawing view, right-clicking, and selecting Insert Projection View. In either case, you must specify the parent view from which the projection view projects. When you create a projection view it is given a default name that is based on the direction of projection.

The default projection type for projection views is third angle. If desired, the projection type can be changed to first angle.

You can also project 3-D general views.

Procedure: Creating Projection Views

Scenario
Create projection views in a drawing.

Task 1. Create two projection views on sheet 1.

1. Click Projection from the Model Views group of the Layout tab.

2. Select the front view, move the cursor up, and click to place the new projection view. Notice the yellow rectangle that snaps to your cursor until you click to place the view.

3. Select the front view, right-click, and select Insert Projection View.

4. Move the cursor to the right and click to place the new projection view.
Task 2. Create three projection views on sheet 3.

1. Select the **Sheet 3** sheet tab to activate it.

2. Select the shaft_side drawing view, right-click, and select **Insert Projection View**.

3. Move the cursor up and click to place the new projection view.

4. Select the shaft_side drawing view, right-click, and select **Insert Projection View**.

5. Move the cursor to the left and click to place the second new projection view.

6. Select the shaft_side view, right-click, and select **Insert Projection View**.

7. Move the cursor to the right and click to place the third new projection view.
This completes the procedure.

20.9 Creating Cross-Section Views

You can add cross-sections to drawing views using the Sections category of the Drawing View dialog box. When you specify that you want to add a section to a drawing view, a list of available cross-sections displays in a drop-down list. This list of available cross-sections comes from the 3-D model itself. You can only select valid cross-sections for a given drawing view. A valid cross-section is one that is parallel to the screen when placed in the view.

A cross-section displays in a drawing view with a set of Xhatching. You can edit the following attributes of the Xhatching lines.
• Spacing — For spacing, you can select either Half or Double from the menu manager. Each time you select half or double the spacing between Xhatching lines halves or doubles, respectively. You can also type a spacing value for the Xhatching lines. In the upper image of the lower-right figure, the spacing has been changed to a value of 0.15. In the lower image, the spacing has been changed to a value of 0.6.

• Angle — For angle, you can select a Xhatching line angle in 30 or 45 degree increments between 0 and 150 degrees. You can also type an angle value. In the lower image of the lower-right figure, the Xhatching line angle has been modified from 45 degrees to 120 degrees.

In addition to creating a section view, you can optionally add section arrows to any view that is perpendicular to the section view. In the lower-left figure, the arrows were added to the drawing view. The direction that the arrows point indicates the direction of material to keep in the section view. You can flip this material direction if desired.

**Procedure: Creating Cross-Section Views**

**Scenario**
Add a cross-section view to a drawing.

![Section Views](section_views.drw)

**Task 1. Add cross-section A to a view in a drawing.**

1. In the model tree, right-click on SHAFT.PRT and select **Open**.

2. Start the **View Manager** and select the **Xsec** tab.

3. Right-click section **A** and select **Visibility**. Notice the cross-section.

4. Click **Close** from the View Manager.

5. Click **Close Window** to return to the drawing.
6. Select the lower, center, shaft_side view. Right-click and select Properties.

7. In the Drawing View dialog box, select the Sections category and select the 2D cross-section option.
   - Click Add Section and select A from the drop-down list.
   - Click OK.

8. Click in the background to de-select the view.

9. In the section view, select the Xhatching, right-click, and select Properties.

10. In the menu manager, click Spacing > Half > Done.
11. De-select the X-hatching.

12. Select the cross-section view, right-click, and select **Add Arrows**.

13. Select the top projection view to place the arrows.

14. Select the arrows, right-click, and select **Flip Material Removal Side**.

15. Right-click and select **Flip Material Removal Side** to flip the material removal direction back.

This completes the procedure.
20.10 Creating Detailed Views

A detailed view is a small portion of a model shown enlarged in another view. A reference note and border is included on the parent view as part of the detailed view setup. The orientation of the detailed view is the same as its parent, but the detail view is typically assigned a much larger scale than the parent view.

You must define the following when creating a detailed view:

- **Location** — Select a location on the drawing where the resulting detailed view is to be placed. Like any other view, you can always move the drawing view at a later time.
- **Spline** — Select a center point in an existing drawing view that you want to enlarge in the detailed view. You must then sketch a spline around the area of the view that you want enlarged in the resulting detailed view. You do not have to worry about sketching a perfect shape because the spline is automatically converted into a boundary shape. The default boundary shape is a circle, although you can change the boundary to an ellipse, Horizontal/Vertical ellipse, an ASME 94 Circle, or leave it as a spline. In the lower-right figure, the boundary shape is a circle.

You may also define the following optional items when creating a detailed view:

- **View name** — Provide a different detailed view name. The View name of the detailed view is displayed in the detail note, as shown in the lower-right figure. The View name is also displayed under the detailed view, as shown in the lower-left figure.
- **Scale** — You can specify the scale of the resulting detailed view.
- **Xhatching (if applicable)** — If you create a detailed view for a drawing view that contains a cross-section, you can edit the Xhatching to something different than the parent cross-section view if desired by selecting **Det Indep** from the menu manager when editing the Xhatching properties. The default detailed view Xhatching is governed by the parent.
Procedure: Creating Detailed Views

Scenario
Create a detailed view in a drawing.

Task 1. Create a detailed view in a drawing.

1. Click Detailed from the Model Views group in the Layout tab.

2. In the section view, select the center point for the detailed view.

3. Click points to create a spline curve around the SHAFT.PRT end. Do NOT close the spline curve when sketching it. Instead, leave a “gap.”

4. Middle-click to complete the spline curve.
5. Select a point in the top left of the drawing to place the detail view.

6. Click in the background to de-select the view.

7. Press ALT and select the detailed view note.

8. Still pressing ALT, double-click the **3.000** scale on the view, type **4**, and press ENTER.

9. Click in an empty area of the graphics window to de-select the scale value.
This completes the procedure.

### 20.11 Creating Auxiliary Views

An Auxiliary view is a special type of projection view. Instead of being projected orthogonal, the auxiliary view is projected perpendicular to a selected planar reference (a datum plane), or projected along the direction of an axis. The resulting auxiliary view can be moved only along its angle of projection. In the figure, the datum plane is selected as the projection reference.

You may also edit the View name to a more meaningful name, as well as add projection arrows, as shown in the figure. The View name is displayed when projection arrows are created. The projection...
arrows can also be moved individually with respect to the auxiliary view. Projection arrows can be displayed as either single or double arrows.

20.12 Creating New Drawings using Drawing Templates

Like part and assembly templates, a drawing template provides you with a starting point to create your drawings. You use drawing templates when you want to create a standardized drawing. Drawing templates can automatically create views, set the desired view display and view options, display formats, and show model dimensions based on the template. You can configure Pro/ENGINEER to use a default drawing template when creating a new drawing, or you can select a different one. A drawing template is shown in the upper figure, while a drawing created using the drawing template is shown in the lower figure.

The views created within a drawing that uses a template are determined from the model’s view orientations. You should consider drawing view orientations when creating your models.

Drawing templates contain three basic types of information for creating new drawings:

1. The first type is basic information that makes up a drawing but is not dependent on the drawing model, such as sheet size, notes, symbols, formats, and so forth. This information is copied from the template into the new drawing.
2. The second type is representative “view symbols,” which contain the options used to configure drawing views and the actions that are performed on that view. The instructions in the template are used to build a new drawing that references a model to place various views in specific orientations and view states.
3. The third type is a parametric note. Parametric notes are notes that update to new drawing model parameters and dimension values. When a drawing is created from a template, the parametric notes update with the proper information from the models used in the drawing.

Drawing Template Uses

You can use drawing templates to define the layout of views, set view display, define tables, place symbols and notes, show dimensions, and create snap lines. A drawing template can also be customized with your company formats and standards. This enables you to automatically create drawings in a fraction of the time it would take to sketch them.
For example, you can create a template for a machined part versus a cast part. The machined part template could define the views that are typically placed for machined part drawings, set the view display of each view (for example, show hidden lines), place company standard machining notes, and automatically create snap lines for placing dimensions.

**Procedure: Creating New Drawings using Drawing Templates**

**Scenario**
Create a new drawing using a drawing template.

1. Rotate CYLINDER_BRACKET.PRT to familiarize yourself with its shape.
2. Click Close Window.
3. Click New from the main toolbar.
   - In the New dialog box, select Drawing as the Type.
   - Edit the Name to new_drawing.
   - Verify that the Use default template check box is selected.
   - Click OK.
4. In the New Drawing dialog box, notice that the Default Model is CYLINDER_BRACKET.PRT because it is still in session. You could browse and specify a different Default Model.
5. Notice the Template specified is drawing_template, as this is the configured default template.
6. Click **OK** from the New Drawing dialog box.

7. In the input window, type your first initial, followed by your surname, and press **ENTER**.

8. Zoom in on the title block.

9. Pan to the different drawing views, zooming in and out as desired.

10. Click **Refit**.

11. Notice the three template view names in the drawing tree.

This completes the procedure.
20.13 Modifying Drawing Views

Modifying Drawing Views Theory

When a view is placed on a drawing, there are a variety of operations that can be performed to change how the view displays. In most cases, you can modify a view that has already been placed on a drawing. The following are different types of operations that can be performed on views in a drawing.

Moving Views

By default, when views are placed on a drawing they cannot be moved. They are locked to the drawing. You can unlock drawing views for movement in the drawing by selecting a view, right-clicking, and toggling the Lock View Movement option. The toggle for locking view movement is a system setting rather than an individual drawing view setting. If one view is unlocked, all views are unlocked.

Once views are unlocked, a drawing view can be moved according to any parent/child relationships that exist between views. Since a general view has no parent views, it can be moved anywhere on the drawing. When a general view is moved, any child views move accordingly. A child view, on the other hand, can only move according to the angle of projection from the parent view.

Deleting Views

You can delete views from a drawing. All items associated with the deleted drawing view including child views are also deleted. For example, if you delete a general view that has three child projection views, the child projection views must also be deleted. The system highlights child views that are to be deleted, as shown in the lower-right figure.
Modifying Drawing View Properties

The following are two types of drawing view properties that can be modified:

- **Scale** — Is modified in the Scale category of the Drawing View dialog box. In most cases, the scale of a placed view is specified as the default scale for the sheet, or the sheet scale. You can also define a custom scale for a drawing view that makes it larger or smaller than the defined sheet scale. If a custom scale is defined, it is listed under the drawing view, as shown in the upper figure. Note that for some drawing views, such as a projection view, you cannot specify a custom scale because the drawing view scale is dependent upon its parent view.

- **View Display** — Is modified in the View Display category of the Drawing View dialog box. Three view display options that can be modified include:
  - Display style — Controls the display of the entire view. Options include Follow Environment, Wireframe, Hidden, No Hidden, and Shading. The Follow Environment display style may vary from company to company depending upon how the default display style is defined. In the upper figure, the display style was edited from No Hidden to Shading.
  - Tangent edges display style — You can define how tangent edges display within the drawing. Options include Default, None, Solid, Dimmed, Centerline, and Phantom.
  - Colors come from — For display styles other than shading, you can define where the colors for the drawing view geometry lines come from. The default option is that the colors are defined based on the drawing. You can specify that the colors come from how they are defined in the model.

Editing the Sheet Scale

You can also edit the sheet scale at the bottom of the graphics window. The sheet scale value edits the scale of the active model only. When you edit the sheet scale of the active model, any drawing views of that active model on that sheet update their scale based on the new value. In the lower-left figure, the sheet scale was increased from 1 to 1.75.

Editing the Sheet Scale
Procedure: Modifying Drawing Views

Scenario
Modify views in a drawing.

Task 1. Modify the views on sheet 1 of the drawing.

1. Select the front general view, right-click, and de-select Lock View Movement.

2. With the front view still selected, click and drag down and to the left. Notice that the two projection view children move along with the general view parent.

3. With the general front view still selected, press CTRL and select the two projection views.

4. Right-click and select Properties.

5. In the Drawing View dialog box, edit the Display style to Hidden and click OK.
**Task 2. Modify the views on sheet 2 of the drawing.**

1. Select the **Sheet 2** sheet tab to activate it.

2. Click **Set Active Model/Rep** and select **ANGLE_GUIDE.PRT > Master Rep**.

3. In the bottom left of the graphics window, double-click the scale, edit it to **1.25**, and press ENTER.

4. Click in the background to de-select the scale.

5. Press **CTRL** and select the two 2-D views.

6. Right-click and select **Properties**.

7. In the **Drawing View** dialog box, edit the Tangent edges display style to **Phantom** and click **OK**.
Task 3. Modify the views on sheet 3 of the drawing.

1. Select the Sheet 3 sheet tab to activate it.

2. Select the top view and move it further up in the drawing.

3. Select the lower, center shaft side view, right-click, and select Delete.
   The three child projection views highlight in purple boxes.

4. Click Yes from the Confirmation dialog box.

5. Click Undo.
6. Select the 3-D general shaft_default view, right-click, and select Properties.

7. In the Drawing View dialog box, select the Scale category, select the Custom scale option, edit the value to 2, and click Apply.

8. In the Drawing View dialog box, select the View Display category, edit the Display style to Shading and click OK.

This completes the procedure.

20.14 Creating Assembly and Exploded Views

Creating Assembly Views

Similar to creating part drawings, you can also create assembly drawings that display assembly views. When creating a new drawing, simply make an assembly the default model or add it as a drawing model to an existing drawing. With an assembly set as the active model you can add views of the entire assembly without having to add each of its individual components.

If your company requires that assembly drawings display individual components on different sheets, you must add each component as a drawing model.

When placing an assembly view, you are prompted to select a combined state. A combined state is a combination of various state representations created in the 3-D model using the All tab of the view manager. For example, you can create a combined state in the 3-D model that consists of a specific orientation,
a specific explode state, and a specific style state. When the combined state is selected, the view displays with all three state representations enabled. For this topic, you should specify no combined state.

**Creating Assembly Exploded Views**

Exploded views are used to illustrate assembly and disassembly (taking a product apart). With exploded views, you can create customized drawings based on 3-D models; these views can display information needed by manufacturing personnel to produce your product, or they can be used as a general reference.

To display an assembly view in an exploded state, select the **Explode components in view** check box in the View States category of the Drawing View dialog box. You must then select the desired saved explode state or the default exploded state previously created in the 3-D assembly model. You can add an exploded view of an assembly without having to explode it in Assembly mode. If an exploded view is edited on the drawing, the explode state in the 3-D model is not affected. However, if the explode state is edited in the 3-D model, the associated exploded drawing view updates.

Exploded views also typically contain explode lines, created in the 3-D model. In addition, BOM Balloons and a table indexing the parts can also be added to the drawing; this enables people to easily reference the component information.

---

**Procedure: Creating Assembly and Exploded Views**

**Scenario**
Create assembly and exploded views in a drawing.
Task 1. Create a new drawing from template and add an assembly view.

1. Click New, select Drawing, edit the name to explode_view, and click OK.

2. In the New Drawing dialog box, click Browse, select VALVE.ASM, and click Open.
   - Verify that Use template is specified, and that the template to be used is drawing_template.
   - Click OK.

3. In the input window, type your first initial, followed by your surname, and press ENTER.

4. If necessary, double-click the sheet scale value, edit it to 1, and press ENTER.

5. Right-click and select Insert General View.

6. Select No Combined State and click OK.

7. Click near the upper-right corner to place the view.

8. In the Drawing View dialog box, select Default Orientation as the Model view name, and click OK.
### Task 2. Insert a drawing sheet and add an exploded assembly view.

1. Click **New Sheet** ![New Sheet](image).

2. In the input window, type your first initial, followed by your surname, and press ENTER.

3. Right-click and select **Insert General View**.

4. Select **No Combined State** and click **OK**.

5. Click near the middle of the drawing to place the view.

6. In the Drawing View dialog box, select 3D as the Model view name, and click **Apply**.

7. Click **Repaint** ![Repaint](image).

8. In the Drawing View dialog box, select the **View States** category.
   - Select the **Explode components in view** check box, and select Assembly explode state EXP0001 from the drop-down list.
- Click **OK**.

This completes the procedure.
Check your Knowledge

1. True or False? If a change is made to a model, a drawing that displays that model updates to reflect that change.
   
   A - True
   B - False

2. Which item is not typically found in a drawing template?
   
   A - Drawing formats
   B - Drawing views
   C - View options
   D - Dimensions

3. True or False? The first view added to a drawing must be a general view.
   
   A - True
   B - False

4. Which characteristic of cross-section drawing views is true?
   
   A - The cross-sections come from the 3-D model.
   B - The drawing view's Xhatch characteristic can be edited.
   C - You must add arrows to a perpendicular view.
   D - You may flip the material direction displayed in the view.
   E - All of the above.
   F - A, B, and D only.
5. Which of the following can be performed from the Drawing Tree?

   A - Visualizing views, tables, and dimensions present on a drawing
   B - Inserting a Projection view
   C - Copying a Table
   D - Erasing or Deleting shown dimensions
   E - All of the above
Module 21

Creating Drawing Annotations

Module Overview

Drawing views alone are typically not sufficient to convey all the information needed to manufacture a given model. In this module, you learn how to show all the necessary detail that manufacturing needs to create production parts. This information includes dimensions, axes, notes, Bill of Materials (BOM) tables, and BOM Balloons.
21.1 Analyzing Annotation Concepts and Types

You can add additional detail to drawing views in the form of annotations to convey information needed to manufacture the part or components of the assembly. There are numerous annotations you can add to a drawing, including, but not limited to:

- **Dimensions** — Used to display measurements, distances, and depths between specific geometric entities on a drawing view. You can add both driving dimensions from the model, or create your own dimensions.
- **Axes** — Used to show the centers of holes or bolt circles.
- **Notes** — Add additional information to a drawing that may not be found in dimensions.
- **Tables** — Used to show additional drawing information in tabular format. Examples include names of optional components in an assembly, specific dimension values for part numbers in a common drawing, and cam lift values per degree.
- **BOM** — Used to show components in an assembly and their quantities.
21.2 Inserting a Bill of Materials Table

Bill of Materials (BOM) tables can be used to detail the location and number of parts included in the assembly for manufacturers.

BOM tables are typically created to be associative, so the table automatically updates whenever you add or delete a part to the assembly. You can create the tables manually or you can import them from a table file that was previously created and saved. BOM tables are created with repeat regions. A repeat region is a group of “smart” user-designated table cells that expand or contract to accommodate the amount of data that the model currently contains.

Showing BOM Balloons

You can also detail parts and assemblies with BOM balloons, which are circular callouts in an assembly drawing that display components listed in the BOM Table. As components are selected, the corresponding row in the table highlights for easy identification. The BOM balloons are tied to the bill of material table.

There are three different types of BOM balloons:

- Simple — Balloons that show only one report symbol, usually the index number from the table.
- With Qty — Balloons that are split to show the index number in one half of the balloon circle and the quantity of the part used in the assembly in the other half of the balloon circle.
- Custom — Enables you to specify a custom drawn symbol that you have created and stored.

Once BOM balloons have been added to the drawing, you can move them to their desired location. You can also automatically set the position and spacing of the balloons using snap lines or stagger increment values by selecting a balloon and either clicking Cleanup Balloons from the Balloons group in the Table tab, or right-clicking and selecting Cleanup BOM Balloons.

You can also edit the balloon leader so it attaches to a different location on the component it points to.

**Procedure: Inserting a Bill of Materials Table**

**Scenario**
Insert a bill of materials table in a drawing and display the BOM balloons.
**Task 1. Insert a bill of materials table in a drawing and display the BOM balloons.**

1. Select the **Table** tab from the drawing ribbon.

2. Click **Table From File** from the Table group.

3. In the Open dialog box, select **bom_table.tbl** and click **Open**.

4. Click in the upper-right of the drawing to place the table. Notice that the assembly components and their quantities are displayed in the table.

5. Click **BOM Balloons** from the Balloons group.


7. Click **Create Balloon > Show All > Done** from the menu manager.

8. Move the balloons as desired.
This completes the procedure.

## 21.3 Showing, Erasing, and Deleting Annotations

### Showing Annotations Theory

When you create a 3-D model, you simultaneously create various items useful for annotating the model in a drawing, such as dimensions and axes.

When creating a 2-D drawing you can select which information from the 3-D model to show in the drawing:

- **Dimensions**
  - Driving Dimension Annotation Elements
  - All Driving Dimensions or Strong Driving Dimensions
  - Driven Dimensions, Reference Dimensions, or Ordinate Dimensions
- **Geometric Tolerances**
- **Notes**
- **Surface Finishes**
- **Symbols**
- **Datums**
  - Set Datum Planes, Set Datum Axes, or Set Datum Targets
  - Axes

The Show Model Annotations dialog box is context sensitive. You can control which annotations display on the drawing and where they display based on how items are selected:
• Select a model from the model tree — Indicates all the selected item types for the model on the drawing. The items may appear in multiple views.
• Select features from the model tree — Indicates the selected item types for the selected features on the drawing. The items may appear in multiple views.
• Select a drawing view — Indicates all the selected item types within a particular drawing view.
• Select features from a particular drawing view — Indicates the selected item types for the selected features on the drawing, within the view in which the feature was selected. If an item is not appropriate to that view, it does not display.
• Select a component in a particular drawing view (Assembly Drawings only) — Indicates the selected item types for the selected component on the drawing, within the view in which the component was selected. If an item is not appropriate to that view, it does not display.

All of the possible items that can be shown based on the selected tab and selected items display in the drawing in a preview color. You can then select or de-select items to show by using the dialog box or by selecting from the drawing.

⚠️ When dimensions are shown, the system automatically arranges and spaces them apart. You can then adjust them further manually or by using the Cleanup Dimensions dialog box.

**Erasing and Deleting Annotations Theory**

If, at any point during drawing creation you decide that you no longer want certain shown items, you can erase or delete them. The differences between these two options are as follows:

• **Erase** — Temporarily removes the items from the display. The items are shown grayed out in the drawing tree.
  - Erased items can be returned to the display by right-clicking and selecting Unerase.

• **Delete** — Removes the items from the drawing.
  - Any item originating in the model is retained in the model, and can be shown again.
  - Any item created in the drawing, such as dimensions or notes are deleted and will need to be re-created.
To erase/delete items, you select them in the drawing, then right-click and select Erase or Delete. You can select items to erase or delete using the following methods:

- Select an individual item.
- Press CTRL and select multiple items.
- Use a selection filter to quickly select desired items.
- Select items from the drawing tree.

**Procedure: Showing, Erasing, and Deleting Annotations**

**Scenario**
Show and erase detail items in a drawing.

**Task 1. Show dimensions using different methods.**

1. Select the **Annotate** tab from the drawing ribbon.
2. Click **Show Annotations** from the Insert group.
   - Select the **Dimensions Tab**.
3. Select HOLE 2 from the model tree.
   - Notice dimensions appear in different views.
4. Select HOLE 2 from the top view.
   - Notice the dimensions now only appear in this view.
5. Click **Select All** and then click **Apply** from the dialog box.

6. Select the front view.

   To select a view, click within the view boundary, but not on model geometry.

7. Click **Select All**.
   - Click **OK** from the dialog box.
   - Notice the dimensions from both views are now shown.
   - Click the background to de-select all selected items.
8. Select the Sheet 2 tab to view sheet 2.

9. Select ANGLE_GUIDE.PRT from the model tree.

10. Click Show Annotations from the Insert group.

   o Click Select All.
   o De-select the d22 and d35 options from the dialog box
   o Click OK from the dialog box.
   o Click the background to de-select all selected items.
Task 2. Erase, unerase, and delete dimensions.

1. Press CTRL and select the 65 and 32.5 dimensions in the front view.
   - Right-click and select Erase.
   - Click the background to de-select all selected items.
2. Specify **Dimension** as the selection filter.
   - Drag to select all dimensions in the top view.
   - Right-click and select **Erase**.
   - Click the background to de-select all selected items.

3. Expand the Front view Annotations branch in the drawing tree.
   - Select **d5** then right-click and select **Unerase**.
   - Select **d25** then right-click and select **Delete**.
   - Select **d2** then right-click and select **Delete**.
4. Select ANGLE_GUIDE.PRT from the model tree.

5. Click **Show Annotations**.

   - Notice the deleted dimensions may be shown again.
   - Select **d25** to show it again.
   - Click **OK** from the dialog box.
   - Click the background to de-select all selected items.

---

**Task 3. Show datum axes using different methods.**
1. Click the **Sheet 3** tab to view sheet 3.

2. Click **Show Annotations**.
   
   - Select the **Datums Tab**.

3. Select the Front view.
   
   - Select axes A_4, A_5, and A_6 from the dialog box.
   - Click **Apply** from the dialog box.

4. Select the top view and click **Select All**.
   
   - Click **OK**.

This completes the procedure.

### 21.4 Cleaning Up Dimensions

You can use Pro/ENGINEER’s clean dimensions functionality to automatically perform the following tasks:

- Clean dimensions by view, or by selecting individual dimensions. You cannot clean angle or diameter dimensions.
- Offset dimensions from edges or view boundaries.
- Space dimensions in even increments.
- Create breaks in witness lines where they intersect other witness lines or draft entities.
- Automatically flip arrows on dimensions when they do not fit between witness lines.
- Center dimensions between witness lines.

The lower-left figure displays dimensions before the cleanup process has been performed, while the lower-right figure displays dimensions after the cleanup process has been performed.

Creating Snap Lines

When cleaning dimensions you have the option of creating snap lines with the offset dimensions. Objects snap to these lines, which are created at the specified offset value. The lower-right figure displays snap lines that were created during the dimension cleanup process. Even after the cleanup process has been performed, you can manipulate dimensions and snap them to the displayed snap lines. There are two important points to know about snap lines:

- Snap lines do not display in a printed drawing.
- You can delete snap lines after use.

**Procedure: Cleaning Up Dimensions**

**Scenario**
Clean up dimensions in a drawing.

**Task 1. Clean up dimensions on sheet 1.**

1. Select the **Annotate** tab from the drawing ribbon.
2. Select the front view, right-click, and select **Cleanup Dimensions**.

3. Accept all default options.

4. Click **Apply > Close**.

5. Notice the snap lines that were created, and that the dimensions have snapped to these lines.

---

Task 2. **Clean up dimensions on sheet 2.**

1. Select the **Sheet 2** sheet tab to activate it.

2. Press CTRL and select the top and front views.

3. Click **Cleanup Dimensions** from the Arrange group in the Annotate tab.

4. In the Clean Dimensions dialog box, edit the Offset to **0.625**.
   - Edit the Increment to **0.5**.
   - Clear the **Create Snap Lines** check box.
   - Click **Apply > Close**.
5. Notice that angle and diameter dimensions are not affected by the dimension cleanup process.

This completes the procedure.
21.5  Manipulating Dimensions

You can manually manipulate a dimension or dimensions to display them in the desired location. The following operations can be manually performed on dimensions:

- **Move dimensions** — Select a dimension and move it to a different location of the drawing view. Each dimension, when selected, displays a series of move handles, as shown in the lower figure. Clicking and dragging the different move handles yields different move results. The following move options are available:
  - **Move Dimension and Text** — Use the handle circled in blue in the lower figure to move both the dimension and the dimension text.
  - **Move Text** — Use either handle circled in green in the lower figure to move just the dimension text.
  - **Move Dimension** — Use the handle circled in yellow in the lower figure at either arrow tip to move the dimension.
  - **Move Witness Line** — Use the handle circled in orange in the lower figure to move the witness line. This handle is the one at the end of the witness line side that touches the model geometry.

- **Align Dimensions** — You can select multiple dimensions including linear, radial, and angular, and align them to one another. The selected dimensions align to the first dimension selected. Once the dimensions are selected, you can either right-click and select **Align Dimensions**, or you can click **Align Dimensions** from the Arrange group in the Annotate tab.

- **Flip Arrows** — You can flip arrows by right-clicking and selecting **Flip Arrows**, or you can right-click while dragging a dimension to toggle through the different arrow flipping options. For radius dimensions there are four different flip options available, for diameter dimensions there are three different flip options available, and for linear dimensions there are two different flip options available. In the upper figure you can view all the available arrow flipping options for radius dimensions.
• Move Item to View — Move dimensions from one drawing view to another. You can select the item to move, then either right-click and select **Move Item to View**, or click **Move to View** from the Arrange group in the Annotate tab.

• Edit Attachment — Specify a new attachment position for certain dimensions, a radius dimension, for example. The available new attachment positions highlight in all drawing views and enable you to select a new surface or edge. To edit the attachment, select the dimension, then right-click and select **Edit Attachment**.

**Procedure: Manipulating Dimensions**

**Scenario**
Experiment with the different dimension manipulation options.

![Manipulate_Dims](manipulate_dims.drw)

**Task 1. Manipulate dimensions in a drawing.**

1. Select the **Annotate** tab from the drawing ribbon.

2. In the top view, select the **51** dimension.

   o Click and drag the handle at the center of the dimension text shown in the top figure to move both the dimension and text.
   o Click and drag either the left or right handle around the text shown in the top figure to move the text up or down.
   o Click and drag either handle at the arrow head tips shown in the middle and lower figures to move the entire dimension left or right.
   o Click and drag the left handle at the end of the bottom witness line shown in the lower figure to move the witness line until it no longer touches the model.
3. With the 51 dimension still selected, right-click and select **Flip Arrows** as shown.

4. Right-click and select **Flip Arrows** to flip them back.

5. With the 51 dimension still selected, press CTRL and select the 33 dimension.
6. Right-click and select **Align Dimensions**.

7. Move the dimensions so they are properly centered between the other two dimensions.

8. In the top view, select the **12.65** diameter dimension.

9. Click and drag the far left handle to move the dimension and text. You can also click and drag the dimension itself.

10. Click and drag either of the handles around the text to move just the text left or right.

11. Right-click and select **Flip Arrows**.
12. In the front view, select the 12.65 diameter dimension.

13. Click Move to View from the Arrange group in the Annotate tab.

14. Select the top view.

15. In the front view, select the R22 dimension.

16. Right-click and select Flip Arrows.

17. Right-click and select Flip Arrows two more times.

18. Move the dimension and text upward until it snaps to the snap line.
This completes the procedure.

21.6 Creating Driven Dimensions

A driven dimension is created by the user. This type of dimension reports a value based upon the references selected when the dimension is created. That is, the dimension value is driven by the geometry selected, and therefore it is not possible to modify the value of a driven dimension. A driven dimension does not pass back to the model; it appears only within the drawing. A created dimension displays in the drawing tree differently than that of a shown dimension. In the right figure, the dimensions in the front view are created dimensions, while the dimensions in the top view are shown dimensions.

You can create a Standard driven dimension using Dimension New References from the Insert group in the Annotate tab, or by right-clicking and selecting Dimension - New References. The system creates a dimension based upon one or two selected references similar to how you create dimensions in Sketcher. The dimension's witness lines automatically clip to their selected references.
Driven Dimension Types

Standard driven dimension types include linear, angular, radial, diameter, or point-point dimensions.

When creating a driven dimension, you can select an edge, edge and point, two points, or a vertex. You can further filter what entities the dimension attaches to using the following attach type menu commands in the menu manager:

- **On Entity** — Attaches the dimension to the entity at the pick point, according to the rules of creating regular dimensions.
- **On Surface** — Attaches the dimension to the location selected on a surface.
- **Midpoint** — Attaches the dimension to the midpoint of the selected entity.
- **Center** — Attaches the dimension to the center of a circular edge. Circular edges include circular geometry such as holes, rounds, curves, and surfaces, and circular draft entities.
- **Intersect** — Attaches the dimension to the closest intersection point of two selected entities.
- **Make Line** — References the current X and Y-axes in the orientation of the model view.

Depending upon the selected references, you may have to further specify the type of dimension to be created. For example, you may be asked to specify whether the dimension you create is to be Horizontal, Vertical, Slanted, Parallel, or Normal to the selected references. If your selected references are arcs or circles, you must specify whether the dimension is to be created between the arc Centers, Tangent, or Concentric.

Adding Prefix and Postfix Text

You can add additional text to a dimension. Text can be added as a prefix or a postfix to the dimension value. For example, if a radius dimension is typical of all radii on the part, you can add the postfix `TYP` to the dimension.

**Procedure: Creating Driven Dimensions**

**Scenario**
Create a driven dimension in a drawing.

![DrivenDims] driven_dims.drw

**Task 1. Create a driven dimension in a drawing.**
1. Select the **Annotate** tab from the drawing ribbon.

2. Navigate to the top view in sheet 1.

3. Notice the 14 dimension that locates the holes from the center of the model. Manufacturing requires a dimension from the model edge.

4. Select the unwanted 14 dimension, right-click, and select **Properties**.

5. In the Dimension Properties dialog box, select the **Display** tab.
   - In the Postfix field, type **REF**.
   - Click **OK**.

---

You could also erase or delete the dimension rather than making it a reference dimension.
6. Click **Dimension New References** from the Insert group.

7. Select the right edge of the block and select the hole edge.

8. Middle-click to place the 19 dimension.

9. Click **Center** from the menu manager.

10. Click **Return** from the menu manager.
11. In the drawing tree, expand the **Annotations** node of the top drawing view.

- Select dimension **ad55** if necessary.
- Notice that both the dimension format and symbol are different.

This completes the procedure.

### 21.7 Inserting Notes

You can insert notes on a drawing to convey additional information. For example, you can insert a note stating that all sharp edges must be broken, as shown in the upper-right figure.

The following types of notes can be inserted:

- **No Leader** — Creates a free note.
- **With Leader** — Creates a note with a leader.
• ISO Leader — Creates a note with an ISO leader.
• On Item — Creates a note directly attached to an edge, surface, or datum point.
• Offset — Creates a note relative to a detail entity. If the detail entity is moved, the note moves with it.

Notes can be created horizontally, vertically, or at an angle, and you can specify the justification as Left, Center, or Right.

When you specify that the note has a leader, the following leader attach types are available:

• On Entity — Attaches the leader to selected geometry in a drawing view.
• On Surface — Attaches the leader to a selected location on the surface of a drawing view.
• Free Point — Attaches the leader to a location on the screen that you select.
• Midpoint — Attaches the leader to the midpoint of a specified entity.
• Intersect — Attaches the leader to the intersection of two entities.

You can also specify what the attach point of the leader looks like. Options include arrow head, dot, filled dot, no arrow, slash, integral, box, filled box, double arrow, and target. In the lower-right figure, the note was created with an arrow head leader.

**Procedure: Inserting Notes**

**Scenario**
Insert notes in a drawing.

Task 1. Insert notes in a drawing.

1. Select the Annotate tab from the drawing ribbon.
2. Click Note from the Insert group.
3. In the menu manager, click With Leader > Make Note > On Surface.
4. Select the cylindrical cut on the 3-D view.
5. Click Done from the menu manager.
6. Click on the drawing to specify the location for the note.

7. In the input window, type **CYLINDER SURFACE**.

8. Press ENTER twice to complete the note.

9. Select the **Sheet 2** sheet tab to activate it.

10. In the menu manager, click **No Leader > Make Note**.

11. Click below the 3-D view to specify the note location.

12. In the input window, type **BREAK ALL SHARP EDGES**.

13. Press ENTER twice to complete the note.
14. Click Done/Return from the menu manager.

This completes the procedure.

### 21.8 Analyzing Drawing Associativity

Due to Pro/ENGINEER's bi-directional associativity, a change made to a model automatically updates in a drawing and vice versa. Examples of drawing associativity include the following:

- If components are added or removed from an assembly, the BOM table in the assembly drawing automatically updates to reflect the new quantities.
- If a dimension is modified in a model, the matching shown drawing dimension is automatically updated along with the drawing view geometry.
- If a shown drawing dimension is modified, the dimension in the model as well as its geometry updates automatically.

Depending on your Pro/ENGINEER settings, it may be necessary to use Update Sheets from the Update group of the Review tab to refresh the display of all views in the active drawing sheet in order to see a change made at the model level. You can press CTRL and select multiple tabs across the bottom of the graphics window. Clicking Update Sheets then causes all selected drawing sheets' views to refresh.
Procedure: Analyzing Drawing Associativity

Scenario
Experiment with drawing associativity.

Task 1. Update the pattern member quantity in VALVE.ASM to view the drawing associativity.

1. Notice in the BOM table that the BOLT.PRT quantity is 6.

2. In the model tree, expand Pattern 1 of BOLT.PRT and notice that there are 4 pattern members.

3. In the model tree, right-click VALVE.ASM and select Open.

4. In the model tree, expand COVER.PRT.
   - Right-click Pattern (Hole) and select Edit.
   - Zoom in and edit the number of pattern members from 4 to 3.
   - Click Regenerate.

5. Click Window > ASSOCIATIVITY.DRW to return to the drawing.

6. Select the Review tab from the drawing ribbon.

7. Press CTRL and select Sheet 1, Sheet 2, and Sheet 3 from the sheet tabs area.

8. Click Update Sheets from the Update group.
9. Notice that the BOM quantity of BOLT.PRT has updated and that the view has changed as well.

<table>
<thead>
<tr>
<th>ITEM</th>
<th>NAME</th>
<th>CNT</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ARM</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>BODY</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>BOLT</td>
<td>5</td>
</tr>
<tr>
<td>4</td>
<td>COVER</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>PLATE</td>
<td>1</td>
</tr>
<tr>
<td>6</td>
<td>SHAFT</td>
<td>1</td>
</tr>
</tbody>
</table>

Task 2. Edit the dimension length to view the associativity in the drawing geometry and model.

1. Select the Sheet 3 sheet tab to activate it.
2. In the front view, select the 76 dimension.
3. Double-click the 76 dimension and edit it to 102.
4. Click Regenerate Model from the Update group.
5. Notice that the drawing view geometry has updated.
6. In the model tree, right-click ARM.PRT and select Open.

7. Right-click Protrusion id 21 and select Edit.

8. Edit the length from 102 to 84.

9. Click Regenerate.

10. Click Window > ASSOCIATIVITY.DRW to return to the drawing.

11. Notice that the dimension and drawing view geometry have updated to the new length value.

This completes the procedure.
21.9 Publishing Drawings

To create a hard copy deliverable of your drawing, you can select the Publish tab in the drawing ribbon. When the Publish tab is selected, the Navigator pane is automatically closed. You can then select the Print/Plot option to send the drawing to a printer or plotter.

When you select another tab in the drawing ribbon, the Navigator pane is automatically opened.

You can also export the drawing to one of the following electronic file formats:

- DXF
- PDF
- Medusa
- IGES
- STEP
- DWG
- Stheno
- SET
- CGM
- TIFF

Of course, any of these exported file formats can also be sent to a printer to generate a hard copy.

Regardless of the publish method specified for output, you can preview what the result will look like. Print Preview creates an accurate preview of the selected output type. It takes into account pen table mapping, line styles, line priorities, printer margins, and other settings. To preview the output you can click Preview from the Publish group.

You can also modify the default settings for the publish option specified using the Settings icon in the Publish group.

Procedure: Publishing Drawings

Scenario
Experiment with publishing drawings.

Task 1. Experiment with publishing drawings.
1. Select the **Publish** tab in the drawing ribbon.

2. Notice that the Navigator pane automatically collapsed.

3. Click **Preview** from the Publish group.

4. Click **Close Preview** from the Publish group.

5. Select the PDF publish option.

6. Click **Settings**.

7. In the PDF Export Settings dialog box, select **Current** for the Sheets to be exported.
   - Clear the **Open file in Acrobat Reader** check box.
   - Click **OK**.

8. Click **Export** from the Publish group.

9. In the Save a Copy dialog box, accept the defaults and click **OK**.

10. Select the **TIFF** publish option.

11. Click **Export**.

12. In the Save a Copy dialog box, accept the defaults and click **OK**.

13. Click **Yes** from the Confirmation dialog box.

This completes the procedure.
Check your Knowledge

1. True or False? When dimensions are shown, the system automatically arranges and spaces them apart.
   A - True
   B - False

2. The Show Annotations option can be used to show which of the following?
   A - Dimensions
   B - Notes
   C - Datums
   D - Geometric Tolerances
   E - All of the above

3. Which of the following dimension manipulation is not valid?
   A - Move dimensions
   B - Convert a driving dimension to driven dimension
   C - Align dimensions
   D - Flip arrows
   E - Move a dimension to another view
   F - Edit the attachment point of a dimension's leader

4. True or False? A driven dimension's value is driven by the selected geometry. Therefore, if the geometry is updated the dimension value automatically updates.
   A - True
   B - False
5. True or False? A BOM Table is manually created. The user must type the names of all components used within the assembly.

A - True
B - False
Module 22

Using Layers

Module Overview

Layers provide a means of organizing model items, such as features, datum planes, parts in an assembly, and even other layers, enabling you to perform operations on those items collectively. Layers enable you to simplify geometry selection by temporarily hiding or displaying specific model features or assembly components in the graphics window. Layers can also be used to perform actions, such as suppressing all the items in a layer at once.
22.1 Understanding Layers

What is a Layer?

A layer is a container object that enables you to organize features, parts in an assembly, and even other layers. You can create as many layers as you need and associate items with more than one layer.

Layer Uses

A layer enables you to collectively perform operations on items in a layer. Layers are most often used from a model management standpoint to control the amount of information displayed in the graphics window. This helps you to more easily perform the desired task at hand.

The two most common operations performed to items on a layer include:

- Hiding and Unhiding Layers — You can hide and unhide layers in parts and assemblies. This in turn hides or unhides the items on the layer. In the bottom figure the datum axes layer has just been hidden, and thus you cannot see any datum axes on the model. Hiding items on a layer may appear to be similar to suppressing those same items. However, there are significant differences:
  - When you suppress an item it is removed from the regeneration cycle of the model, whereas hiding an item just removes it from the graphics window.
  - A hidden item is still included in Pro/ENGINEER calculations such as mass properties analyses. A suppressed item is not included in calculations.

- Selecting Items on the Layer — Layers provide you with a means to easily select multiple items, instead of having to select them individually. While individual selection may appeal to you, if you need to select 82 out of 100 part axes, then you can understand that mass selection is beneficial and
saves time. Once the items in a layer are selected you can perform operations on them. Typical operations include deleting those items or suppressing/resuming them. However, you could also edit their display or add them to a simplified representation.

The Layer Tree

You use the layer tree to add items to layers and perform operations on layers. You can access the layer tree by clicking **Layers** from the main toolbar. This turns the layer tree on. Clicking the icon again turns the layer tree off. You can also click **Show** from the top of the model tree and select **Layer Tree**, or you can click **View > Layers** from the main menu to toggle the layer tree on and off. The top figure shows the layer tree.

Layer Types

There are three different types of layers that can be created in a model:

- **Default** — Layers can be included in part and assembly templates. If you use part and assembly templates containing default layers at your company, Pro/ENGINEER automatically associates different features of a model to specific default layers. Using default layers also causes all parts to have the same initial set of default layers. This enables you to use cascading layer control at the assembly level because each model has layers of the same name.
- **Automatic** — When you hide items in the model tree, those hidden items are automatically added to the Hidden Items Layer.
- **User-Created** — You can create your own layers in a model and add items manually to them.

22.2 Creating and Managing Layers

You can create layers manually by naming the layer and selecting geometry items or components to add from the model tree or the graphics window. This type of layer is useful for specific tasks. As a best practice, you should name the layer so other designers recognize the task.

When you create a layer the Layer Properties dialog box displays, as shown in the top figure. The dialog box displays the following information:

- **Name** — This is the name of the layer.
- **Contents** — The Contents tab displays the items that are included or excluded from the layer. Items that are included on the layer are displayed with a green “+” symbol in the Status column, while items that are excluded from the layer are displayed with a red “—” symbol in the
Status column. Items, when selected, are included on the layer if the **Include** button is turned on, while items are excluded from the layer if the **Exclude** button is turned on.

- **Rules** — The Rules tab displays the rules, if any, that are defined for the layer. Rules enable you to create layers based upon defined criteria. To create a layer based on a rule, you simply need to create a layer, name it, and define the rule. You can either define the rule within the Layer Properties dialog box, or you can save a rule from the Search Tool. In addition to being useful in specific tasks, this type of layer is excellent when creating templates. Layers that are created with rules display with a different icon than those layers that were created with no rules. In the lower-left figure, the layer does not contain any rules, while in the lower-right figure, the layer was created with a rule.

The Layer Properties dialog box also displays if you look at the layer properties of any existing layer by selecting the layer, right-clicking, and selecting **Layer Properties**.

You may also decide to make a layer the active layer. When a layer is made the active layer, all subsequently created features are automatically placed on the active layer. Note that a layer containing rules cannot be set as the active layer.

**Understanding Layer Status**

Whenever you hide or unhide any layer, you are modifying the layer status for that model. This new layer status is not automatically saved, even when the model is saved. Thus, it is necessary for you to save the layer status if you want it to be retained the next time the model is opened. You can save the layer status by clicking **View > Visibility > Save Status** from the main menu. You can also right-click in the layer tree and select **Save Status**.
If you save a model and forgot to save the layer status, the message window alerts you with a warning message, as shown here:

⚠️ WARNING: layer display status was not saved.
- MUFFLER has been saved.

You can also reset the layer status to the last saved status by clicking **View > Visibility > Reset Status** from the main menu or by right-clicking in the layer tree and selecting **Reset Status**.

### 22.3 Utilizing Layers in Part Models

You can add most any feature item in a part to a layer. However, when you hide the layer, only the non-solid geometry from the feature items added to the layer, such as datum features and surfaces, is hidden. For example, if you add a hole feature to a layer and hide the layer, as shown in the lower figure, the hole geometry still displays in the graphics window, but the hole axes associated with the hole feature are hidden.

![Hiding a Layer with Holes](image)

**Procedure: Utilizing Layers in Part Models**

**Scenario**

Use layers within part models.

**Task 1. Use layers within a part model.**

1. In the model tree, expand **Extrude 4**.
   - Press CTRL, select the five internal datum features, right-click, and select **Hide**.
2. At the top of the model tree, click Show and select Layer Tree.

3. Expand the Hidden Items layer. Notice that the five internal datum features you hid are now on this layer.

4. Select the 01__PRT_DEF_DTM_PLN layer, right-click, and select Hide.

5. Click Repaint.

6. Right-click in the layer tree and select New Layer.
   - Type OTHER_DATUMS as the Name.
   - Select DIM 1 and A_1 as items to add and click OK.
   - Right-click on the new layer and select Hide.
   - Click Repaint.
7. Right-click in the layer tree and select **New Layer**.
   - Type **TOP_HOLES** as the Name.
   - Select the four holes on top of the model and click **OK**.
   - Right-click on the new layer and select **Hide**.
   - Click **Repaint**.

8. In the layer tree, right-click on layer **TOP_HOLES** and select **Select Items**.

9. Right-click in the graphics window and select **Suppress**.

10. Click **OK** from the Suppress dialog box.

11. Click **Edit > Resume > Resume All**.
12. Click **Save** and click **OK**.

13. Notice the warning in the message window.

14. Click **View > Visibility > Save Status** from the main menu.

15. Click **Save** and click **OK**.

16. Notice that there was no warning this time.

This completes the procedure.

## 22.4 Creating Layer States

**Creating Layer States Theory**

You create Layer States in the view manager to record the hide/unhide status for all layers in a model. You can create an initial layer state upon opening a model, and then create different states to quickly toggle between.

Remember, the action of hiding a feature or component actually places the item on the Hidden Items layer. Therefore, layer states can be used with hidden items, without having to access the layer tree.

Layer states apply to any item that may be placed on a layer, such as:

- Features
- Components
- Drawing Views and Detail Items
**Procedure: Creating Layer States**

**Scenario**
Create layer states in assembly and part models.

---

**Task 1. Create layer states in an assembly.**

1. Start the View Manager.

2. Select the Layers tab.

3. Click **New** and press ENTER to create Layer_State001.

4. Click **New** from the View Manager, and press ENTER to create Layer_State002.

5. Press CTRL and select PISTON.PRT and PISTON_PIN.PRT from the model tree.

6. Right-click and select **Hide**.

7. Right-click Layer_State002 and select **Save**.

8. Click **OK**.
9. Double-click **Layer_State001** to enable it.

**Task 2. Create layer states in a part.**

1. Select **CONNECTING_ROD.PRT** from the model tree.

2. Right-click and select **Open**.

3. Click **Plane Display**.

4. Start the **View Manager**.

5. Select the **Layers** tab.

6. Click **New** and press ENTER to create **Layer_State001**.

7. Click **New** from the View Manager and press ENTER to create **Layer_State002**.

8. Select **DTM3** from the model tree.
9. Right-click and select **Hide**.

10. Right-click **Layer_State002** and select **Save**.

11. Click **OK**.

12. Click **New** from the View Manager and press ENTER to create **Layer.State003**.

13. Click **Layers**.

14. Select the **01__PRT_DEF_DTM_PLN** layer.

15. Right-click and select **Hide**.

16. Right-click **Layer_State003** and select **Save**.

17. Click **OK**.

18. Click **Repaint**.

19. Double-click **Layer_State002** to enable it.
20. Double-click **Layer_State001** to enable it.

This completes the procedure.

### 22.5 Utilizing Layers in Assembly Models

Similar to parts, you can hide non-solid geometry of assembly features including assembly datum features and surfaces. For example, if you create an assembly level hole, add it to a layer, then hide the layer, the hole geometry still displays, while the hole axis is hidden.

![Hiding a Layer with Assembly Components](image)

Unlike parts, you can also add components to layers in an assembly. If you add components to a layer and then hide the layer, the component geometry hides. In the bottom figure, the nut and bolt components were added to the HARDWARE layer and hidden. Notice that the components are removed from the display in the graphics window.

**Cascading Layer Control in Assemblies**

Layers in assemblies can provide you with cascading control. You can control a part level layer from an assembly if the part and assembly both contain a layer of the same name. When this circumstance occurs, you can edit the layer properties and layer display of each component individually, as shown in the upper-right figure.

The layer tree also displays a different layer icon for the common layer.

**Procedure: Utilizing Layers in Assembly Models**

**Scenario**

Use layers in assemblies.
Task 1. Use layers in assemblies.

1. Click Show from the model tree and select Layer Tree.

2. Expand the Hidden Items layer. Notice that there are three components in this layer that contain hidden items.

3. Expand each of these component layers.

4. Expand the 01___PRT_DEF_DTM_PLN layer.
   - Press CTRL and select the in BOLT.PRT and in NUT.PRT layers, right-click and select Hide.

5. Click Repaint.
6. In the layer tree, select the 01__ASM_DEF_DTM_PLN layer, right-click, and select **Hide**.

7. Click **Repaint**.

8. Right-click in the layer tree and select **New Layer**.

   - Type **HARDWARE** as the Name.
   - Select the NUT.PRT and BOLT.PRT components and click **OK**.
   - Right-click on the new layer and select **Hide**.
   - Click **Repaint**.
9. Right-click the HARDWARE layer and select **Unhide**.

10. Click **Repaint**.[

11. In the layer tree, right-click on layer HARDWARE and select **Select Items**.

12. Click **View > Display Style > Transparent**.

13. Click **Save**[ and click OK.


- **Showing part BOLT.**
- **WARNING: layer display status was not saved.**
- **LAYER has been saved.**

15. Click **View > Visibility > Save Status** from the main menu.

16. Click **Save**[ and click **OK**.

17. Notice that there was no warning this time.

This completes the procedure.
Check your Knowledge

1. Which of the following is not a characteristic of a layer?
   A - Layers are container objects that enable you to organize features and parts.
   B - Layers can be used to hide and unhide geometry.
   C - Layers can be used to select multiple items easily.
   D - Layers can be used to add new features to a model.

2. Which statement regarding layer status is valid?
   A - When you save a model, its layer status is automatically saved.
   B - You must manually save a model's layer status.
   C - Pro/ENGINEER alerts you with a warning message if you save a model and forget to save the layer status.
   D - Once you save a model's layer status, it cannot be reset.
   E - Both B and C.

3. True or False? When you hide a layer containing features in a part, only the non-solid feature geometry is hidden.
   A - True
   B - False

4. True or False? When you hide a layer containing components in an assembly, only the non-solid component parts are hidden.
   A - True
   B - False

5. If you associate an extrude feature to a layer and then Hide the layer, the children of the extrude feature will fail.
   A - True
   B - False
Module 23

Investigating Parent/Child Relationships

Module Overview

In a model, the order in which features are created and the references that they are provided creates hierarchical relationships. These are called parent/child relationships and they determine feature interaction.

In this module, you learn about parent/child relationships and how to view information about your models.
23.1 Understanding Parent/Child Relationships

Defining Parent/Child Relationships

You can use various types of Pro/ENGINEER features as building blocks in the progressive creation of solid parts. Certain features, by necessity, precede other more dependent features in the design process. Those dependent features rely on the previously defined features for dimensional and geometric references. This is known as a parent/child relationship.

The parent/child relationship is one of the most powerful aspects of Pro/ENGINEER and parametric modeling in general. This relationship plays an important role in propagating changes across the model to maintain the design intent. After a parent feature in a part is changed, all children are dynamically altered to reflect the changes in the parent feature. If you suppress or delete a parent feature, Pro/ENGINEER prompts you for an action pertaining to the related children. You can also minimize the cases of unnecessary or unintended parent/child relationships.

It is therefore essential to reference the desired geometry when creating feature dimensions so Pro/ENGINEER can correctly propagate design changes throughout the model. When working with parent/child relationships, it can be helpful to remember that parent features can exist without child features. However, child features cannot exist without their parents.

Effects of Parent/Child Relationships When Editing

Consider how the following editing functionality is affected by parent/child relationships:
Edit — Children of the feature or component update as edits are regenerated.
Dynamic Edit — Children of the dynamically edited feature automatically update as edits are made.
Edit Definition — Enables you to change the parent of the feature or component.
Suppress/Resume — Enables you to remove a feature or component and its children from the graphics window and the regeneration cycle.
Delete — Deletes all children of the selected feature or component by default. You can also choose to suspend the children, and then redefine each in turn.
Hide/Unhide — Does not affect parent/child relationships.

How Parent/Child Relationships are Created

Consider how the following sketching functionality is affected by parent/child relationships:

- Sketch Plane and Orientation Reference Plane — Are parents to the sketch feature.
- Sketcher References — Additional sketcher references, including selected references, dimension references, and constraint references, are parents to the sketch feature. Constraints and dimensions can create relationships between the constrained entity and its reference. Hence, the constrained entity becomes a child of the referenced feature.

Consider how the following feature and tools functionality is affected by parent/child relationships:

- Selected References — The edges or surfaces selected for rounds and chamfers become parents to the rounds and chamfers. A depth reference selected for a sketch-based feature becomes a parent to the sketch-based feature. Similarly, an axis of revolution specified for a Revolve feature becomes a parent to the revolve feature.
- Selected Sketch — An external sketch selected for a sketch-based feature such as an Extrude feature becomes a parent to the Extrude feature. A sketch-based feature that has an internal sketch inherits all sketch references as its own, including sketch plane, reference plane, references, constraints, and dimensions. A sketch-based feature that contains embedded datum features inherits all datum references as its own.

Consider how the following assembly functionality is affected by parent/child relationships:
- **Templates** — Like part templates, assembly templates do not create parent/child relationships between the template and the assembly file.
- **Constraint References** — Existing models that are referenced when assembling components with constraints or connections become parents to the components being assembled. Assembly models can also be children if they are assembled to other assembly models.

Consider how the following drawings functionality is affected by parent/child relationships:

- **Templates** — Are similar to part and assembly templates because they do not create a parent/child relationship between the template and the drawing file.
- **Views** — Are children to either the saved views in the part or to the reference orientations selected. Also, drawing views are children to other views. For example, a projection view is a child to the general view from which it was projected. Finally, a drawing view is a child to the source model.
- **Details** — Are generally children to their respective models. Examples of drawing details include dimensions, parametric notes, and BOM tables.

### 23.2 Viewing Part Parent/Child Information

You can view parent/child relationships of features in a part model by using the Reference viewer. You can launch the Reference Viewer by selecting the desired feature and then either clicking **Info > Reference Viewer** from the main menu or right-clicking and selecting **Info > Reference Viewer**.

The Reference Viewer displays a graph of parent/child relationships for a given feature. This graph is broken down into three columns from left to right:

- **Parents** — Displays the Parents for the currently selected feature.
- **Current Object** — Displays the currently selected feature for which you wish to view parent/child relationships.
- **Children** — Displays the Children of the currently selected feature.

The graph of parent/child relationships in the Reference Viewer is interactive with the model in the graphics window:

- You can cursor over the feature node to highlight it on the model.
- You can expand the feature nodes to see the list of references that creates the parent/child relationships. You can also select the reference to see it highlight in the model. You can also see which feature the reference is a parent to, as it highlights the Reference Type arrow to the proper child feature node in the graph. In the right figure, datum axis A_7
creates a parent/child relationship between the Hole_2 feature and the Hole_3 feature.

Obtaining Full Path Information Between Features

You can display the full parent/child relationship path between two features in tree representation by selecting the Reference Type arrow, then right-clicking and selecting Display Full Path. For example, the graph in the left figure displays the full chain of parent/child relationships between the Hole 2 and Hole 3 features. It shows that datum axis A_7 is a child to Hole 2, which is a child back to the part. It also shows that datum axis A_7 is a parent to Hole 3.

Switching the Current Object

You can switch which feature is the current object either by double-clicking the desired feature node in the graph, right-clicking it and selecting Set as current, or by clicking Actions > Set as current from the Reference Viewer dialog box menu. You can also revert back to the previously selected Current Object by clicking Use Previous at the top of the graph or clicking the down arrow next to it to view the history of Current Objects and selecting an earlier one.

Procedure: Viewing Part Parent/Child Information

Scenario
View Parent and Child information for features in a part using the Reference Viewer.

part_pc.prt

1. Select **Hole 2** from the model.

2. Click **Info > Reference Viewer** from the main menu.

3. Notice that the reference graph displays the current object, Hole 2, in the middle, that object’s Parents on the left, and that object’s Children on the right.

4. Cursor over each node in the Reference Viewer to highlight the respective feature on the model.

5. Click the down arrows on each Parent node to view its entities.

6. Select each of these entities to highlight them on the model.
7. Click the down arrows on the Current Object to see its entities.

8. In the Reference Viewer, select the arrow leading to the Hole 3 node, right-click, and select Display Full Path.

9. Notice that Hole 3 refers to datum axis A_7 in Hole 2.

10. Click Close from the Full Path Display dialog box.

11. In the Reference Viewer, right-click on the Hole 3 node and select Set as current.
Notice that the graph has now updated.
Notice the Parents specified for the Hole 3 feature.
Notice the Children specified for the Hole 3 feature.

12. Click Close from the Reference Viewer dialog box.

13. Edit the definition of Hole 3.

14. Notice the 14 dimension going to datum axis A_7 in Hole 2. This dimension established the parent/child relationship.

15. Click Complete Feature.

This completes the procedure.
**Procedure: Viewing Assembly Parent/Child Information**

**Scenario**
View Parent and Child information for components in an assembly using the Reference Viewer.

| Assy_PC | assy_pc.asm |

**Task 1. View Parent and Child information for components using the Reference Viewer.**

1. Select PLATE.PRT from the assembly.

2. Click **Info > Reference Viewer** from the main menu.

3. Select the **Components in path** check box as an additional Reference Type.

4. If necessary, widen both the Reference Viewer dialog box and the Parents column.

5. Click **Model As Current Object** from the Reference Viewer dialog box.

6. Click the down arrows on the Children assembly node to view the components.

7. Notice the two BOLT.PRT components.

8. Cursor over each of the BOLT.PRT models to highlight them in the model.
9. Click **Component Placement Current** from the Reference Viewer dialog box.

10. Notice that the graph updates to now show PLATE.PRT as a component in the assembly, as well as its Parents and Children.

11. Cursor over each node to highlight the respective features and components on the model.

12. Click the down arrows on each Parent node to expand it and view its referenced entities.

13. Select each of these entities to highlight them on the model.
14. In the Reference Viewer, select the arrow leading to the **Comp id 47 (BOLT.PRT)** node, right-click, and select **Display Full Path**.
   - If necessary, edit the Displayed Full Path to **Surface id 55**.
   - Notice that BOLT.PRT is assembled to a surface in **Extrude 1**.
   - Click **Close**.

15. In the Reference Viewer, right-click on the **Comp id 47 (BOLT.PRT)** node and select **Set as Current**.
   - Notice that the graph has now updated.
   - Notice the Parents specified for the **Comp id 47 (BOLT.PRT)** component.
   - Cursor over **Hole 2 in PLATE.PRT** to highlight it.
   - The BOLT.PRT is assembled into this hole. Hence, the component is a child to the hole.

This completes the procedure.
23.3 Viewing Model, Feature, and Component Information

Viewing Model, Feature, and Component Information Theory

You can access the menu selections to view model, feature, and component information either through the **Info** menu on the main menu or by right-clicking on the appropriate item in the model tree or graphics window.

When information is displayed about the item you have selected, the system helps you identify that item by displaying the following:

- **Name** — Either the model, component, or feature name of the item you have selected.
- **Feature Number/Component Number** — Displays the feature number or component number in the model tree as it is found in the model tree.
- **ID** — The internal identification number that the system has assigned to the item you select.

Understanding the Browser Information Window’s Contents

The information for the item you have selected is displayed in the Browser window. The information is categorized, depending upon its type, for example, Parents, Children, Feature List, and Dimensions.

Because information is displayed in the Browser window, there are many clickable items that can be selected to yield even more information. The following items can be clicked on in the Browser information window:

- **Blue Links** — Call out the name of something, such as a Feature Name or Model name. Clicking these blue links highlights the item in the model. An item that's name is a series of three dashes simply means that no name is given for that particular item.
- **Dimensions** — Dimensions are listed by their internal identification number. Clicking the dimension link highlights the dimension in the model.
- **Highlight Feature** — Highlights the feature in the model.
- **Feature Info** — Enables you to jump to information for that feature or component.

Viewing Model and Feature Information in Parts

When you view the model information for a part, the Browser window displays the following information:

- **Part Name** — Displays the name of the model.
- Unit Information — Displays the units that the model was created in, including Length, Mass, Force, Time, and Temperature.
- Feature List — Provides a list of features, similar to the model tree.

When you view the feature information for a given feature in a model, the Browser window displays the following information:

- Part Name, Feature Number, and Feature ID.
- Parents, if any.
- Children, if any.
- Feature Elements — Displays the elements that comprise the feature.
- Layers — Displays any layers that the feature is on, and the layer status.
- Feature Dimensions — Displays all dimensions found in the feature.

Viewing Model, Component, and BOM Information in Assemblies

When you view the model information for a component in an assembly, you must select whether you want the information for the top level assembly or a component in the assembly. The Browser window displays the following information:

- Part Name — Displays the name of the model.
- Component Information — Displays a list of the assembled components, only displays when model information is displayed for the top level assembly.
- Feature List — Provides a list of feature, similar to the model tree.

When you view the component information for a component in an assembly, the Component Constraints dialog box displays the assembly constraints used to assemble the component. You can highlight each constraint pair on the model by selecting it from the dialog box. The Browser window then displays the following:

- Component Name, Parent Assembly, Component Number in Parent assembly, Feature Number, and Feature ID.
- Parents List — Any components in the assembly which are parents.
- Children List — Any components in the assembly which are children.

When you view the Bill of Materials information for an assembly, the Browser window displays the components found in the assembly, and their quantities. You must specify whether the BOM is to be created for the Top Level assembly or a Sub-assembly.

**Procedure: Viewing Model, Feature, and Component Information**
Scenario
View information about assemblies and parts.

Task 1. View assembly information using Pro/ENGINEER’s tools.

1. Click **Info > Model** from the main menu.

2. Click **Apply > Close** from the Model Info dialog box.

3. View the information that displays in the Browser.

4. Close the Browser.

5. Click **Info > Component** from the main menu.

6. Select PLATE.PRT from the model tree.

7. Notice the component constraints used to assemble this component. Select the constraints in the dialog box and notice that the pair highlights in the model.
8. Click **Apply > Close** from the Component Constraints dialog box to display the component info for PLATE.PRT.

9. Click **Info > Bill of Materials** from the main menu.
10. Verify that **Top Level** is selected in the BOM dialog box and click **OK**.

11. Notice that there are two BOLT.PRT components in the assembly.

### Bom Report : ASSY_INFO

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Type</th>
<th>Name</th>
<th>Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Part</td>
<td>PART_INFO</td>
<td><img src="image" alt="action" /></td>
</tr>
<tr>
<td>1</td>
<td>Part</td>
<td>PLATE</td>
<td><img src="image" alt="action" /></td>
</tr>
<tr>
<td>2</td>
<td>Part</td>
<td>BOLT</td>
<td><img src="image" alt="action" /></td>
</tr>
</tbody>
</table>

### Summary of parts for assembly ASSY_INFO:

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Type</th>
<th>Name</th>
<th>Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Part</td>
<td>PART_INFO</td>
<td><img src="image" alt="action" /></td>
</tr>
<tr>
<td>1</td>
<td>Part</td>
<td>PLATE</td>
<td><img src="image" alt="action" /></td>
</tr>
<tr>
<td>2</td>
<td>Part</td>
<td>BOLT</td>
<td><img src="image" alt="action" /></td>
</tr>
</tbody>
</table>

**Task 2. View part information using Pro/ENGINEER’s tools.**

1. In the model tree, right-click PART_INFO.PRT and select **Open**.

2. Click **Info > Model** from the main menu.

3. Notice the model information for the model.
4. Click **Info > Feature** from the main menu.

5. Select **Hole 2** from the model tree.

6. Collapse the model tree and leave the Feature info window open.

7. Arrange the model and Browser window so both can be seen.

8. Scroll the Feature info window up to the **Parents** section.

9. Click the link for **Extrude 3**.

10. Click **Repaint**.
11. In the **Children** section of the Feature info, click the **Hole 3** link.

12. Click **Repaint**.

13. Click **Feature Info** next to **Chamfer 1**.

14. Notice that the Feature info for the chamfer now displays. Also notice that **Hole 3** is a parent to the chamfer.

15. Click **Hole 3** to highlight it.

16. Expand the model tree window.

This completes the procedure.
Check your Knowledge

1. Which statement regarding parent/child relationships is incorrect?

   A - The parent/child relationship is one of the most powerful aspects of Pro/ENGINEER.

   B - After a parent feature in a part is changed, all children are dynamically altered to reflect those changes.

   C - Parent features can exist without their children.

   D - Child features can exist without their parents.

2. What information is not displayed in the Reference Viewer?

   A - Layers of the currently selected object

   B - Parents of the currently selected object

   C - Currently selected object

   D - Children of the currently selected object

3. True or False? In the Reference Viewer you can see the specific surface references that were specified for a component's assembly.

   A - True

   B - False

4. What part and assembly information cannot be viewed within the Browser?

   A - Feature information

   B - Model information

   C - Component information

   D - Bill of materials information

   E - Start model template information
5. A parent/child relationship refers to the relationship between ...

A - a part and the relations it contains.
B - a layer and the items associated to it.
C - a feature and its references.
D - a drawing and its associated model.
Module 24

Capturing and Managing Design Intent

Module Overview

Now that you understand parent/child relationships, you can learn how to properly capture and manage design intent in models. In this module, you learn the tools available for modifying and capturing your design intent within all aspects of the modeling process. You also become more knowledgeable about selecting references that capture your design intent.
24.1 Handling Children of Deleted and Suppressed Items

If you try to suppress or delete an item that has children, the system highlights these child items in magenta. In the upper-left figure, the piston component is being suppressed, and the system highlights the piston pin and piston ring in magenta because they are children of the piston. In the upper-right figure, the two rounds highlighted in magenta are children of the round that is being suppressed.

The system also displays a Delete or Suppress dialog box. When you click Options within this dialog box, the system displays the Children Handling dialog box, as shown in the upper-left figure. The Children Handling dialog box displays each of the child items highlighted in magenta. You have three different options available for how to handle these children, and each child can be handled independently:

- **Suppress/Delete** — When suppressing a parent you can choose to also suppress a child item, and when deleting a parent you can choose to also delete a child item. If this is the desired option for all child items, you can click OK from the original Suppress or Delete dialog box without having to consider the options available in the Children Handling dialog box.

- **Suspend** — Suppresses or deletes the parent anyway, thus suspending the child item's regeneration temporarily. Once the parent is suppressed or deleted, the suspended child item regenerates. At this point, one of two things will happen to the child item:
  - The child item may regenerate successfully. However, if the child item is a feature, it may have different geometry; if the child item is a component, it may be in a different position. In the upper-right figure, the two round children were suspended. After the parent round was suppressed, these two child rounds successfully regenerated, although their geometry is different.
  - The child item may not regenerate successfully. If this occurs Pro/ENGINEER indicates the failure. You can then acknowledge and accept the failure or undo the changes. If you acknowledge the failure you can continue to work normally, but you should ultimately fix the failure. You can fix the failure by modifying the
child item, suppressing the child item, deleting the child item, or modifying another feature or part.

- **Freeze** — The Freeze option is available only for assembly components. Once the parent component is suppressed or deleted, the child component is “frozen,” or locked in 3-D space. Frozen components display in the model tree with a special icon preceding their name. In the left image of the lower figure, the PISTON_PIN.PRT component is frozen. In addition, any child components of the frozen component display in the model tree with a slightly different icon that includes a small square. Frozen components must be redefined and the missing assembly placement references must be replaced with valid references from components that still remain in the assembly. Once this is done, the component will “thaw,” meaning that it will no longer be frozen in the assembly, as shown in the lower figure.

Another method to “unthaw” frozen components temporarily is to delete the placement constraint that is missing references and add a Fix constraint, which “fixes” the component in its current orientation but keeps it fully constrained.

---

**Procedure: Handling Children of Deleted and Suppressed Items**

**Scenario**
Handle the children of deleted and suppressed items.

1. Select PISTON.PRT, right-click, and select **Delete**.
2. Notice that PISTON_PIN.PRT and PISTON_RING.PRT will also be deleted because they are children.
3. Click **OK** from the Delete dialog box.
4. Click **Undo**.
5. Select the PISTON.PRT, right-click, and select **Suppress**.

6. Again, notice that the PISTON_PIN.PRT and PISTON_RING.PRT are children and will therefore also be suppressed.

7. In the Suppress dialog box, click **Options**.
   - Edit the Status of PISTON_PIN.PRT to **Freeze**, leaving PISTON_RING.PRT to be suppressed.
   - Click **OK**.

8. Notice the suppressed components and the freeze symbol on PISTON_PIN.PRT.

9. Edit the definition of PISTON_PIN.PRT.

10. If necessary, select the **Insert** constraint to activate it.
11. Click **Complete Component ✓**.

12. Notice that PISTON_PIN.PRT has “thawed.” That is, the component is no longer frozen in the assembly.

**Task 2. Suppress SIDE_ROUND and suspend the resulting child rounds.**

1. Select CONNECTING_ROD.PRT, right-click, and select **Open**.

2. Right-click on SIDE_ROUND and select **Delete**.

3. Notice the two child round features.

4. Click **OK** from the Delete dialog box.

5. Click **Undo ↩️**.
6. Select SIDE_ROUND, right-click, and select Suppress.

7. Again, notice that the child rounds will also be suppressed.

8. In the Suppress dialog box, click Options.
   
   - Edit the Status of both Round ids to Suspend.
   - Click OK.

9. Notice the geometry changes to the model because SIDE_ROUND is no longer present.

This completes the procedure.
24.2 Reordering Features

When regenerating a model, Pro/ENGINEER regenerates features one at a time, following the order in which they are displayed in the model tree. As you create new features, they are added to the bottom of the list in the model tree.

The order of features is the sequence in which features are displayed in the model tree. You can drag a feature within the model tree to place it just after its parent, even though you may have added several features to it after the parent was created. Since you must regenerate a parent before you regenerate its children, you cannot reorder a parent to be after its children; nor can you reorder a child to be before its parents.

Feature order can affect the geometry of a model. When a feature is created it can only add or remove material from the model as the model exists at that point in time. For example, in the lower-left figure the hole feature’s depth is Through All, which drills the hole through the unseen side of the block. If you add an additional protrusion to the block, you would need to reorder the hole after this new protrusion if you want to retain its Through All design intent. Then the Through All depth would include the new protrusion and drill the hole through the entire block.

Procedure: Reordering Features

Scenario
Reorder features in a part model.

Task 1. Reorder features in a part model.

1. Locate Hole 1 in the model tree.

2. Notice its position in the feature order.
3. Edit the definition of **Hole 1**.
   - Select the **Shape** tab.
   - Notice the hole depth is **Through All**.
   - Click **Complete Feature**.

4. Start the **Extrude Tool** and select **Sketch 2**.
   - Edit the depth to **6**.
   - Click **Complete Feature**.

5. Select **Hole 1**.

6. Notice that the hole does not appear to have a depth of **Through All**, but recall that it does have a depth of Through All at the time of creation.

---

A feature can only add/remove material from the model as the model exists at the point in time in which the feature is created.
7. In the model tree, click and drag **Hole 1** to reorder it after **Extrude 2**.

8. Select **Hole 1**.

9. Just as before, the hole still removes material Through All from the model, but because the extrude feature now occurs before the hole feature, the Through All depth has the desired effect.

10. Start the **Shell Tool**.

11. Select the front face to remove it.

12. Edit the thickness to **0.50**.

13. Click **Complete Feature**.
14. Notice the “boss” around the hole feature.

15. In the model tree, click and drag Shell 1 to reorder it before Hole 1.

16. Reorient the model and notice that the shell feature now hollows out the entire model.

This completes the procedure.
24.3 Inserting Features

The model tree insertion indicator, shown in the model tree as **Insert Indicator** ➔, indicates where features are inserted upon creation. By default, its position is always after all items listed in the model tree. You may drag it higher or lower in the model tree to insert features between other features in the tree. When you move the insert indicator, you enter Insert Mode and the model is rolled backward or forward in its regeneration in response to its new position, and all features update in the graphics window. If a feature is located before the indicator, then it is displayed in the graphics window and processed during regeneration. If a feature lies after the indicator, then it is temporarily suppressed. Thus, it is not regenerated or shown in the graphics window.

In addition to dragging the Insert Indicator up into the model tree, you can specify an insert location in the tree. To do this you select a feature, then right-click and select **Insert Here**. The insert indicator is then placed directly below the selected item.

You can exit Insert Mode and return the insert indicator to its default location at the bottom of the model tree by cursing over it, right-clicking, and selecting **Cancel**. You are then prompted to resume the features you suppressed when you activated Insert mode. When you choose to resume them, Pro/ENGINEER places them after the inserted features.

For example, the model in the figures is a cast metal cover. However, a design change is needed to make another protrusion with a rounded notch in the middle. Hence, we need to mirror the existing protrusion and round the edges of the resulting notch. Additionally, these rounded edges should also be on the inside of the part to enable easier extraction from the cast.

As shown in the part’s model tree, you can delete and recreate the shell and hole features after creating the necessary protrusion and rounds. Alternatively, you can use Insert mode to add the protrusion and round features before the Shell feature. Notice that this includes the round feature in the shell, which accomplishes the task of having round edges on the inside of the part.

Insert Mode works the same way when you are in an assembly. You may drag the Insert Indicator higher or lower in the model tree to insert components between other components in the tree, or you may select a component, right-click, and select **Insert Here**. Again, when you move the insert indicator, you enter Insert Mode and the assembly is rolled backward or forward in its regeneration in response to its new position, and all components update in the graphics window.
**Procedure: Inserting Features**

**Scenario**
Insert new features in a part model.

1. Select each of the five solid features in the model tree to highlight them in the graphics window.

2. In the model tree, click and drag the Insert Indicator to before Shell 1.

3. Notice the features that are suppressed and therefore not currently regenerated.

4. Select **Extrude 2** and start the **Mirror Tool**.
   - Select datum plane RIGHT.
   - Click **Complete Feature**.

5. Click **Named View List** and select 3D-2.
6. Start the **Round Tool** 🔄, press CTRL, and select both edges of the notch bottom.
   - Right-click and select **Full round**.
   - Click **Complete Feature ✔️**.

7. Start the **Round Tool** 🔄, press CTRL, and select a vertical edge on the front and back of the notch.
   - Edit the radius to **1**.
   - Click **Complete Feature ✔️**.
8. In the model tree, select the **Insert Indicator ➤**, right-click, and select **Cancel**.

9. Click **Yes** from the Confirmation dialog box.

10. Click **Named View List** and select 3D-1.

11. Notice the hole on the left that goes through the mirrored protrusion.

12. Also notice that the shell now hollows out both the mirrored protrusion and the newly inserted rounds.
This completes the procedure.

24.4 Redefining Features and Sketches

In Pro/ENGINEER, altering the parents of a feature or sketch can drastically affect the outcome of the resulting geometry. To change a parent/child relationship, the easiest method is to use the Edit Definition option. This option enables you to reselect your references using dialog boxes, the dashboard, or menu options depending on the feature you are redefining. You can redefine a feature or sketch by selecting it, and then either right-clicking and selecting Edit Definition, or clicking Edit > Definition from the main menu.

For example, if you redefine a datum feature, you can select new references using a dialog box. If you redefine a Sketch feature, you can use the Sketch dialog box to change its placement. You can also use the References dialog box to change references internal to the sketch. For most solid features, you can use the dashboard to edit references; for example, selecting a different sketch for an extrude, or selecting different edges for a round.
Controlling Features By Using Edit Definition

The Edit Definition functionality provides you with complete control over a feature within its tool. Consider the control that Edit Definition provides in the following areas:

- **Feature Type** — You can switch the feature type for many features. For example, you can edit a feature to change it from a solid feature to a surface feature.
- **Size** — You can increase or decrease the size of many features. For example, you can edit the radius value of a round feature.
- **Shape** — You can edit the resulting geometry shape of a model. For example, you can edit a feature’s Sketch, depth or angle value, or switch the external sketch used.
- **Location** — You can edit the location of a feature. For example, you can edit the sketching plane specified for a Sketch feature which changes the location of the resulting sketch feature and therefore any features using that Sketch.
- **Options** — You can edit numerous options of a feature. For example, you can edit the depth of a hole from Blind to Through All, or you can add an additional side for material to be removed.
- **References (Parents)** — You can edit the parent references to a feature. For example, you can switch which external sketch is used in the creation of a feature, or you can specify different references to different features within the Sketch References dialog box.

Following the Edit Definition Workflow

When you redefine, or edit the definition of, a feature or sketch, the following occurs:

- The model regenerates back to the feature being redefined. The model tree reflects that this has happened by removing all features that occur after the feature being redefined. In addition, the feature being redefined displays a yellow icon preceding its name in the model tree, as shown here: ![Round id 858](#)
- Most features being redefined display in their yellow dynamic preview color. In this state, the feature’s drag handles are displayed, enabling you to edit their respective values. Plus the on-screen flip arrows are displayed.
- The feature’s GUI is presented. Depending upon the feature being redefined, this could be either a dialog box or the dashboard. The GUI or dialog boxes enable you to make changes to the feature.
- Most features, once changes have been made, can be previewed solid if desired. This option regenerates the feature to determine whether the changes you have made are valid.
Once you have completed the feature, it regenerates. After this occurs, the child features also regenerate to reflect the changes made to their parent.

**Procedure: Redefining Features and Sketches**

**Scenario**
Redefine features and sketches in a part model.

![Redefine](redefine.prt)

**Task 1. Redefine features and sketches in a part model.**

1. Edit the definition of RING_CUT.
2. Select the **Placement** tab, and notice that the Sketch is Internal.
   - Click **Edit**.
3. Edit the **1.5** dimension to **-1.5**.
4. Click **Done Section ✓**.
5. Orient to the **Standard Orientation**.
6. Click **Remove Material** to toggle it off.
7. Drag the handle from **360** to **75**.
8. Click **Complete Feature ✓**.
9. Click **Undo**.

10. Click **Named View List** and select FRONT.

11. Edit the definition of SKIRT_CUT.

12. Select the **Placement** tab, and notice that the Sketch is external to the extrude feature.
   
   - Select an alternate external sketch **Sketch 2**, from the model tree.

13. Click **Complete Feature**.

14. Notice the new skirt shape.

15. Click **Undo**.
16. Edit the definition of Sketch 1.

17. Click Sketch Setup.

18. In the graphics window, right-click and select Placement.

19. Orient to the Standard Orientation and notice the sketch in the model.

20. Select datum plane RIGHT from the model tree as the new sketching plane.

21. Orient to the Standard Orientation and again notice the sketch in the model.
22. Click **Sketch** from the Sketch dialog box.

23. Click **Done Section ✓**.

24. Orient to the **Standard Orientation**.

25. The **SKIRT_CUT** has been rotated 90 degrees.

This completes the procedure.
24.5 Capturing Design Intent in Sketches

Design intent is captured in Sketcher by selecting references and by sketching, constraining, and dimensioning entities. It is important to capture design intent in sketches because so many other features build up from sketches. Consequently, you must carefully consider how to define a sketch and then capture it. You can always modify the sketch’s design intent, but it is much easier to do so when you have planned for what changes may occur later on.

Considerations When Capturing Design Intent in Sketches

When you create a new sketch in Pro/ENGINEER consider the options available for capturing design intent in each of the following areas, and some of the examples listed. The decisions you make in these areas at the time of sketch creation can affect the overall model downstream when you want to make a change to it.

- Sketch/Reference Plane — Should these selected references be default datum planes or a construction plane created with an adjustable offset or angle? Perhaps the sketch plane should be on a surface created from another feature.
- References — Remember that when you select additional sketching references or dimension to existing geometry you are selecting the parents for your sketch. If the references you select update, so does the sketch. Consider whether you want your sketcher references to be default datums or another feature. In the lower-left figure, the sketch feature references the angled surface of existing geometry, so if that angled surface updates, so will the sketch. Additionally, the sketch references the existing hole. Therefore, if the hole location updates, the sketch’s location must update.
- Dimensioning scheme — When dimensioning circles and arcs, should the dimension be a radius or diameter? Should the sketch be dimensioned with an X-Y scheme or a radius-angle scheme? Deciding whether the sketch must pivot can help you determine which scheme to use. Consider which dimensions you might want to modify at a later time if the design changes.
- Constraints — You must decide which constraints to use, and which reference to constrain to because you are again creating parents when selecting constraint references. How should the sketch entities react to each other? Should they be parallel, perpendicular, or tangent? Should the sketch be symmetrical? If so, you will need a centerline. Do you want arc and circle centers to remain lined up? In the lower-left figure, the sketch’s construction line between each arc center is constrained to be parallel to the angled surface. Therefore, if the angle of the existing surface changes, so too must the angle of the sketch. Similarly, if the
existing hole diameter is changed, this sketch's upper arc diameter will also change because it is constrained to be of equal radius.

- Sketched geometry type — When sketching arcs, for example, you should use the arc type that gets you your desired design intent. Remember to use construction geometry or sketched datum points to your advantage.

**Open Sketches Versus Closed Sketches**

There are two different techniques of creating sketch features:

- Closed-section sketch — The sketched geometry forms a closed loop.
- Open-section sketch — The sketch geometry does not form a closed loop.

Closed-section sketches are the more robust of the two options and should therefore be used whenever possible. However, your desired design intent should ultimately dictate which type of sketch section is created. The yellow extrude features shown in the upper-right figure are created from closed-section sketches, whereas the yellow extrude features created in the lower-right figure are created from open-section sketches. The geometry created by using an open-section sketch causes the resulting geometry to follow the 3-D contour of a surface. The endpoints of the open-section sketch must be constrained to the surface edge. The geometry created by using the closed-section sketches ignores the 3-D contour of the surface and simply extends the geometry upward.

There are two specific rules regarding open-section versus closed-section sketches when it comes to feature requirements:

- Rib features require an open-section sketch.
- You must create the first extrude or revolve feature by using a closed-section sketch.

### 24.6 Capturing Design Intent in Features

Design intent is captured in Features by specifying the correct feature and its options. As a result, you must carefully consider which feature options to specify to properly capture your design intent. You can always modify the feature's design intent, but it is much easier to do so when you have planned for what changes may occur later on.

Considerations When Capturing Design Intent in Features

When you create a new feature in Pro/ENGINEER, consider the options available for capturing design intent in each of the following areas. The decisions you make in these areas at the time of feature creation can affect the overall model downstream when you want to make a change to it.
• Depth — When creating an extrude feature, determine whether the depth should be symmetric or defined with 2-side blind depth values. Determine whether the depth be defined to a reference. If so, remember that the reference you select becomes a parent to the feature. Or should the depth be Through All?

• Solid or Thicken — Determine whether the feature you create should be a solid feature in which you create a cut through, or should it be a thickened feature with a defined thickness? If so, which side?

• Round/Chamfer type — Determine which type of chamfer best captures your design intent. Is it better to use a 45 x D or a D x D? Again, considering how the design may change in the future helps you decide. Should the round be created by selecting the edge or by selecting the two surfaces in your model? If you think the design may change so the edge disappears, then use the two surfaces.

• Hole type — Determine which dimensioning scheme works better in your design. To the tip or to the shoulder of the hole?

• Sketch trajectory or select trajectory — When creating a sweep feature, you must decide whether to select the sweep trajectory from existing geometry or to sketch it. Deciding whether you want the trajectory to be independent from the feature or built-in can help you decide.

• Internal versus external sketches — In the upper figure, notice that feature Extrude 2 was created using an external sketch, but feature Extrude 3 was created using an internal sketch. Which sketch you ultimately use for feature creation depends upon these factors:
  o You must use an internal sketch to create Geometry Points in the sketch.
  o Internal sketches reduce the clutter in the model tree. As you can see in the upper figure, there are two additional model tree entries for Sketches 1 and 2 due to the fact that these were external sketches. Had Extrude 1 and Extrude 2 been created with internal sketches, neither of these entities would reside in the model tree.
  o External sketches come in handy if you want to try multiple design alternatives for a feature. You can select alternate external sketches to try these design alternatives.

• Embedded datum features — Embedded datum features work well if you want to edit the feature as all one feature. This also simplifies the tree and reduces the display clutter. In the lower figure Extrude 4 was created using five embedded datum features. However, embedded datum features do not work so well if you want to reuse those datums for other features.

24.7 Capturing Design Intent in Parts

Design intent is captured in Parts by properly planning your model design and specifying which features to use, as well as their order. Often the same geometry result can be achieved by creating many different types or combinations of features. As a result, you must carefully consider which features to use to properly
capture your design intent. You can always modify the part’s design intent, but it is much easier to do so when you have planned for what changes may occur later on.

Planning Your Model Design

Before you begin your new part model you should plan its design. As a general guideline, you should follow the 80/20 rule, which states that 80 percent of the overall shape of the model should typically be created in the initial 20 percent of the model’s features. The upper-right figure is an illustration of the 80/20 rule. The left image shows only the first four extrude features of the muffler, while the right image displays the completed model. Even though only the first four features are displayed, roughly 80 percent of the overall model shape is there.

Here are some guidelines that you can follow when planning your part model design.

- Start with the feature that determines the overall size and shape of the model. This is your base feature. The left image of the upper-right figure shows the first four extrude features of a muffler model. The first feature is an extruded rectangle, which is the base feature of this model.
- Create major geometry features that add or remove material from your model. In the left image of the upper-right figure, the extruded cut along the front face of the muffler is an example of this type of major geometry feature.
- Create minor geometry features that add or remove material. These include smaller features such as protrusions, cuts, bosses, ribs, or holes. In the upper-right figure, the smaller extruded cuts are an example of this type of feature in the left image, and the holes in the right image are another example.
- Finally, add finishing features such as rounds and chamfers. In the right image of the upper-right figure, the rounds and shell are both finishing features.

Deciding Upon Feature Type and Order

Often the same geometry result can be achieved by creating many different types or combinations of features. It is up to you to decide how best to create the geometry so when the design is modified later on it updates in a predictable manner. For example, an extrude is common, but what if any of the following situations arise:

- You need the profile to change along the extrude length later in the design — In this case, a blend feature may be the better option. You could initially create the blend straight back, and edit the individual blend sections at a later time.
• The path of extrusion may change — In this case, a sweep may be the better option. You could initially create a straight sweep trajectory, and modify it at a later time.
• You need the feature to rotate — In this case, a revolve may be the better option.

The feature order also has an impact later on if the design is modified. In the bottom figures, the resulting geometry is identical, but was created differently. In the left figure, the first feature extrudes the entire length, with subsequent features adding or removing material. In the right figure, three extrudes were stacked up in series, with the overall length being created as the sum of the three features. If the length must be modified later, it is easier to modify the length of the design in the left figure.

Thinking About Parent/Child Effects

It is important that you do not tie too many features together with parent/child relationships if not necessary. Rather, use default datum planes. These are common references and you don’t have to worry about them being deleted. Using default datums also minimizes unwanted parent/child relationships.

24.8 Capturing Design Intent in Assemblies

Design intent is captured in assemblies by specifying which assembly type to use, the assembly/sub-assembly structure, choice of base model, assembly references used, and any fit or interference issues. As a result, you must carefully consider how to create your assembly to properly capture your design intent. You can always modify the assembly’s design intent, but it is much easier to do so when you have planned for what changes may occur later on.

Considerations When Capturing Design Intent in Assemblies

When you create a new assembly in Pro/ENGINEER, consider the options available for capturing design intent in each of the following areas. The decisions you make in these areas at the time of feature creation can affect the overall assembly model later on when you want to make a change.

• Assembly type — There are three different types of assemblies that you can create in Pro/ENGINEER. Create the assembly type that will best fit your needs:
  o Static — Assemblies are created using constraints. If you choose to create this type of assembly, determine whether some components need angular or linear offsets. If so, remember to create the proper constraint types.
Dynamic — Assemblies are created using connections. Determine whether your assembly needs to contain components that can be dynamically moved. If so, a dynamic assembly with pin, slider, and cylinder connections may be your best option.

Mixture — Assemblies are created with both static and dynamic components.

- Assembly/Sub-assembly Structure — There are usually multiple ways to assemble components and still achieve the same assembly result. In the upper figure, notice that in one assembly example component D is assembled into the sub-assembly SUB, while in the other example it is assembled directly to the top level. The end result may appear the same, but may cause the assemblies to behave differently should another component's placement be modified.

- Choice of base model — The base model is the first component assembled into the assembly. It is important to consider which component you choose as the base model because if all other models reference this component it becomes difficult to remove the base model.

- Assembly references used — Remember that the assembly references you select for placing components creates parent/child relationships between these components. Make sure to select references that are more robust if possible, such as selecting surfaces over edges.

- Fit or interference issues — Determine what happens when you assemble all your components into the assembly and you find you have interference or fit issues. Remember that you can always activate components to edit them within the context of the assembly. Once the top level assembly is activated and regenerated, the other components update. Be careful when creating features in components in an assembly because you may inadvertently select a reference from a different component, and this creates a parent/child relationship both between the two components and between the component and the assembly.
Check your Knowledge

1. When suppressing an assembly component that has children, what option is not available for handling the child components?
   
   A - Suppress them
   B - Suspend them
   C - Freeze them
   D - Delete them

2. After you move the insert indicator to a location other than after all items listed in the model tree, which of the following does not happen?
   
   A - You enter Insert mode.
   B - The model is rolled backward or forward in its regeneration.
   C - All features after the insert indicator are temporarily deleted.
   D - All features update in the graphics window based on the insert indicator's location.

3. Which of the following does not occur when you edit the definition of a feature?
   
   A - The model is saved as a precautionary measure.
   B - The mode regenerates back to the feature being redefined.
   C - The feature displays in its dynamic yellow preview color.
   D - The feature's GUI is presented, enabling you to make changes.

4. What captures design intent in Sketcher?
   
   A - Selecting references
   B - Sketching entities
   C - Constraining entities
   D - Dimensioning entities
5. You can capture design intent in an assembly in which way?

A - Determining whether to use a static versus dynamic assembly
B - Determining which base model to use
C - Which references to select when assembling components
D - Determining fit or interference issues
E - All of the above
Module 25

Resolving Failures and Seeking Help

Module Overview

When using features as the "building blocks" of design models, you create several references and parent/child relationships between them. Regeneration failures occur when Pro/ENGINEER cannot successfully resolve a parent/child relationship, geometric situation, or a missing reference in a part or assembly model. Because the failure can occur for different reasons, you need to be able to diagnose the problem in order to correct it.

In this module, you learn the different reasons why models fail and the tools and diagnostics available in order to fix those failing models.
25.1 Understanding and Identifying Failures

Understanding and Identifying Failures Theory

When Pro/ENGINEER regenerates a model, it recreates the model feature by feature, in the order in which each feature was created, and according to the hierarchy of the parent/child relationship between features. Occasionally during the model regeneration a problem occurs that causes the model to fail regeneration. Regeneration can fail for any of the following reasons:

- Invalid or impossible geometry.
- Missing or broken references between parent/child relationships.
- Missing models for an assembly.

The fact that a model fails regeneration is beneficial, as you would not want to hand off or continue working with a problematic model.

Failure Indications

When a failure occurs, the system alerts you using several methods.

- The Regeneration Manager icon in the status bar appears red:
- The Regeneration 'Caption' appears. Before you can continue working, you must acknowledge the failure by clicking OK to accept the failure or Cancel to undo the changes. Note that there are situations in both part and assembly modes where the Cancel option is not available.
- The system will highlight the failed features or components in the model tree. The failed items are shown in bold red text and any children of the failed item are shown in standard red text. In the lower-left figure, the Chamfer feature is the failing item, and the Round is a child of the failed Chamfer.
  - If possible, the system will also highlight failed geometry on the model in red, with child geometry highlighted in blue.

Using the Regeneration Manager
The Regeneration Manager can be used any time changes are made to a model to selectively regenerate certain features or components.

However, the Regeneration Manager is particularly useful during a failure to identify failed features/components. Once activated in a failure situation, the Regeneration Manager lists the failed items and any children of the failed items.

You can then select any of the listed items and right-click to obtain feature information or reference information for that item. This information can be useful in determining the cause of the failure, so you can intelligently resolve the failure.

You can activate the Regeneration Manager in several ways:

- By clicking Edit > Regeneration Manager from the main menu.
- By clicking Regeneration Manager from main toolbar.
- By clicking the icon from the status bar:
  - You can click Regeneration Manager when it appears 'green', indicating a model is successfully regenerated. When the status bar icon is green, the Regeneration Manager dialog box does not launch.
  - You can click Regeneration Manager when it appears 'yellow', indicating a model is modified and some features or components need to be regenerated.
  - You can click Regeneration Manager when it appears 'red', indicating the model has failed regeneration.

Locating Failed Features / Components

Failed features or components are not always immediately identifiable. You can use these additional methods to locate failed features / components:

- Adding a status column in the model tree for Failed or Child of Failed.
- Search in the model by clicking Find.
  - You can look for features or components that have the status of Failed or Child of Failed.
  - Once the failed items are found and selected, you can click Filter Tree to display only the failed items in the model tree.

Working on Failed Models

Once the failure is acknowledged by clicking OK from the Regeneration Caption, you can continue working normally, or Save / Erase the model to resolve at a later time. However, it is recommended that you resolve the failure as soon as possible by following these three basic steps:
• Investigate the failure by obtaining feature information or reference information.
• Resolve the failure by using tools such as Edit or Edit Definition on the failed feature(s), parent features, or any feature in the model.
  o You can also use Suppress to remove failing feature(s) from the current regeneration, or Delete to remove them from the model.
• Regenerate the model to obtain a successful regeneration.

25.2 Analyzing Geometry Failures

When a feature fails due to invalid or impossible geometry, the system highlights the failing feature and its children in the model tree. A message such as “could not construct feature geometry” can then be found in the feature information. Some examples of invalid or impossible geometry include:

• Round radii too small or too large — If a round radius becomes too big for the geometry that is being rounded then it will fail. In the upper-right figure, the round in the left image previews properly because it is small enough to fit on the geometry. In the right image, the round becomes too large for the size of the geometry and cannot be created. Hence, the yellow round preview is no longer available.
• Blend start points mismatch — If the start points between blend sections become mismatched by too high an angle, the resulting geometry twists upon itself, which cannot occur. In the lower-right figure, the blend section start points are mismatched by 90 degrees and the resulting geometry twists. If the start points are mismatched by 180 degrees, the feature fails.
• Sweep radii — If a circular section of radius T is swept along a curved trajectory of radius R, the radius R must be greater than or equal to radius T or else the resulting geometry will overlap, resulting in invalid geometry. In the lower-left figure, the circular section is swept along the curved trajectory, resulting in the cane-shaped geometry. In the middle image, the red cross-section lines in the FRONT view show that the geometry does not overlap. Hence, it is valid and R≥T. In the right image, however, the cross-section radius T has grown, as shown by the red cross-section lines. As a result, the cross-section lines overlap, and thus the geometry overlaps. So the rule of R≥T is not valid, and the geometry cannot be created.
• Extrude Through Until — If a feature is extruded to a depth of Through Until, the feature must actually pass through the selected reference. If it does not, the feature fails because the geometry cannot be created.
Procedure: Analyzing Geometry Failures

Scenario
Resolve geometry failures in a part model.

Task 1. Resolve geometry failures using Undo.

1. Orient to the named view 3D.

2. In the model tree, right-click Chamfer 1 and select Edit.

3. Edit the chamfer D value to 2.

4. Click Regenerate.

5. Notice the failed chamfer and its children are indicated on the model and in the model tree.

6. Click Cancel to undo the changes.
Task 2. Resolve geometry failures by fixing the failing feature.

1. Orient to the named view FRONT.

2. In the model tree, right-click TRAJ_2 and select Edit.

3. Edit the $R^2$ dimension to 1, and click Regenerate.

The smallest trajectory radius ($R$) is 2. The sweep diameter is currently 3, therefore $T=1.5$, and $R \geq T$.

Editing the trajectory radius to 1 violates the $R \geq T$ rule.
4. Click **OK** to accept the changes.

5. Click **Regeneration Manager** 🔄 from the status bar.

6. Notice the failed sweep feature and its children, then click **Cancel**.

![Regeneration Manager](image)

7. Select **SWEEP_1** from the model tree, then right-click and select **Edit Definition**.

8. Click **Section > Define** from the Protrusion dialog box.

9. Edit the diameter from **3** to **2**.

10. Click **Done Section ✔**.

![Diagram with diameter 2.00](image)

11. Click **OK** from the dialog box.

12. Orient to the named view **FRONT**.

13. Notice the model has regenerated successfully.
Task 3. Resolve geometry failures by fixing a non-failing feature.

1. Press CTRL + D.

2. In the model tree, right-click SWEEP_1 and select **Edit**.

3. Edit the diameter from 2 to 3 and press CTRL + G.

4. Click **OK** to accept the result.

5. Select TRAJ_2 from the model tree. Right-click and select **Edit**.

6. Edit the radius to 2 and press CTRL + G.

7. Notice the model has regenerated successfully.
This completes the procedure.

25.3 Analyzing Open Section Failures

Most sketches for solid features should be closed sketches. However, when the design intent dictates that the sketch be an open section, the resulting feature must be bounded by other solid geometry. In the lower-right figure, the highlighted feature was extruded from an open-section sketch.

![Open Section Sketch Failure](image)

However, if the depth is extended further than the bounding solid geometry, the feature fails because it is no longer bounded entirely by solid geometry, as shown in the upper figure.

When a feature fails due to an open section, the system highlights the failing feature and its children in the model tree. A message such as “could not intersect part with feature” can then be found in the feature information.

Procedure: Analyzing Open Section Failures

Scenario
Resolve an open-section failure in a part model.

Task 1. Resolve an open-section failure in a part model.

1. In the model tree, right-click LEFT_TOOTH and select Edit.

2. Edit the height from 9 to 11.
3. Click **Regenerate**.

4. Notice the failed feature and its children are highlighted.

5. Click **OK** to accept the result.

6. From the status bar, click **Regeneration Manager**.

7. Select the failing LEFT_TOOTH feature, right-click and select **Feature Info**.

8. Notice the system could not intersect the part with the feature, and the feature is unattached.
9. In the Browser, scroll down to **Section Data** and notice that the feature was created with an open section.

10. Scroll back up to the Children section for RIGHT_TOOTH and click **Feature Info**.

11. Scroll down to **Section Data** and notice that this feature does not indicate an open section.

12. Minimize the Browser.

13. Click **Cancel** from the Regeneration Manager.

14. Right-click LEFT_TOOTH from the model tree and select **Edit Definition**.

15. Notice that the open section is visible in the feature preview. The system cannot create the open section protrusion past the existing solid material.
16. Right-click in the graphics window and select **Edit Internal Sketch**.

17. Sketcher display: ![Sketcher Display](image)

18. Click **Concentric Arc** select the existing arc, and sketch an arc to close the section.

19. Click **Done Section** ✓.

20. Orient to the **Standard Orientation**.

21. Click **Complete Feature** ✓.

22. Notice the model regenerates successfully.

---

Alternatively, this failure could have been resolved by increasing the height of the main cylinder, so the open section would not fall off the edge of the cylinder.
This completes the procedure.

25.4 Analyzing Missing Part References Failures

When a change is made to a parent feature it automatically updates any children. This is beneficial functionality and shows the power of Pro/ENGINEER. However, if a change to a parent feature results in a child not being able to find a particular parent’s reference, a failure occurs.

When a feature fails due to a missing reference, the system highlights the failing feature and its children in the model tree. A message such as “feature references are missing” can then be found in the feature information.

The following are common examples of why missing part reference failures occur:

- **Missing axes** — In the upper-right figure, the slot sketch is dimensioned off of the hole axis. If the hole is deleted, its axis is deleted, and therefore the dimensioning reference for the slot is deleted. Thus, the slot feature will now fail due to missing part references.
- **Missing references for rounds or chamfers** — Occurs if you delete or redefine a feature and remove the edge that a round or chamfer uses. In the lower-left figure, the edges where the boss intersects the remainder of the part are rounded. If the boss is deleted, the edges are therefore deleted, and the rounds will fail. Missing references can also occur if you insert a feature before the round or chamfer that causes the edge to be removed. For example, if you cut material off of an extrude feature,
consequently cutting the edge off that a round references, the round will fail.

- Editing a sketch — Can result in changed or removed edges and surfaces in a model. If those changed or removed edges and surfaces are parents to other features, failures can occur. In the lower-right figure, the sketched entity is being deleted because you want to modify the sketch. However, Pro/ENGINEER informs you that this entity is referenced by other entities. If you choose to continue and delete this entity, the child features will fail due to this reference being removed.

**Using the Replace Function**

One way to help mitigate missing reference failures when editing sketches is to use the Replace function. The Replace function transfers references from an old entity to the new entity you have created. You can click *Edit > Replace* from the main menu while in Sketcher to access Replace. You then select the original entity that contains the references, then select the new entity you want references transferred to.

You can also replace dimensions within Sketcher. When you select a dimension to replace you must create the new dimension. The new dimension will maintain the original dimension’s sd#, enabling any relations using the sketcher dimension to remain valid.

---

**Procedure: Analyzing Missing Part References Failures**

**Scenario**
Resolve missing references part failures.

![Part_Missing-Ref](missing-ref_fail.prt)

**Task 1. Resolve a failure caused by missing part references.**

1. Edit the definition of BASE_PROTRUSION.
2. In the graphics window, right-click and select *Edit Internal Sketch*.
3. Sketcher display:
4. Select the right side angled line, right-click, and select *Delete*.
5. Read the warning message and click *Yes*. 
6. Click **3-Point / Tangent End Arc** and sketch an arc in its place.

7. Click **Done Section**.

8. Click **Complete Feature**.


10. Click **OK** to accept the result.

11. In the model tree, right-click SIDE_ROUND and select **Info > Feature**.

12. Notice that SIDE_ROUND is failing because feature references are missing.
13. Close the Browser.

![Failure Info]

**Failure Info**

FEATURE #10 (ROUND) failed regeneration.

Feature geometry can not be restored.

Reasons for failure:

Feature references are missing.

14. Edit the definition of SIDE_ROUND.

15. In the dashboard, select the **Sets** tab, select **Set 2**, and click in the **Driving surface** collector.

16. Spin the model and select the surface shown to satisfy the missing reference.

17. Click **Complete Feature ✔**.

18. Notice the model regenerates successfully.

---

**Task 2. Transfer references using Replace to avoid a missing references failure.**

1. Edit the definition of BASE_PROTRUSION.
2. In the graphics window, right-click and select **Edit Internal Sketch**.

3. Select the right arc and click **Mirror**.
   - Select the vertical centerline.

4. Select the left angled line.
   - Click **Edit > Replace**.
   - Select the newly mirrored arc.
   - Click **Yes** from the Replace Entity dialog box.

5. Click **Done Section ✔**.

6. Click **Complete Feature ✔**.

---

By using the Replace functionality, you have transferred references to the arc entity, thus avoiding a failure.
This completes the procedure.

25.5 Analyzing Missing Component Failures

If an assembly fails regeneration due to a missing component, the system highlights the failing component and its children in the model tree. A message such as “Component model missing” can then be found in the feature information for that component. Reasons for missing components in assemblies include:
• The component was renamed in the operating system — Pro/ENGINEER does not know that the component was renamed if it was done on the operating system. Consequently, the assembly containing this renamed component fails because it is looking for the component with the old name.

• The component was renamed in Pro/ENGINEER without the assembly in session — Again, if the assembly containing the component is not in session at the time one of its components is renamed, the assembly continues to look for the original name, and thus the assembly fails.

• The component was moved to a different folder. If a component is moved from its original location, Pro/ENGINEER continues to look for the component in its old location. Because the component has been moved, the assembly fails. In the upper figure, component HANDLE.PRT has been moved out of the Assy_Missing-Comp folder and placed in the Handle_Folder. Because the assembly requires this component (it can be seen in the model tree in the lower figure), it fails when opened.

Procedure: Analyzing Missing Component Failures

Scenario
Resolve a missing component failure in an assembly.

Task 1. Resolve a missing component failure in an assembly.

1. Notice a failure occurs when opening the assembly.

2. Also notice the message window states that the system “Can not retrieve model HANDLE.”

3. Click Close Window, Erase Not Displayed, and click OK.

4. Click Working Directory from the Navigator.
Double-click **Handle_Folder**. Notice that this sub-folder contains HANDLE.PRT, which is the cause of the failure.

5. Click **Working Directory** again.

6. Double-click **MISSING-COMP_FAIL.ASM** to open it.

7. The assembly fails for the same reason.

8. From the status bar, click **Regeneration Manager**.

   - Notice the **HANDLE component** within the **JAW_SUB** assembly has failed.

9. In the Regeneration Manager, right-click the HANDLE.PRT and select **Feature Info**.

   - Notice the handle is failing because the model is missing.
   - Close the browser.

10. Click **Cancel** from the Regeneration Manager.
11. Click **Find**.
   - Select **Component** as the Look For option.
   - Select the **Status** tab, and select **Failed** as the Value.
   - Click **Find Now** and then click **Close**.

12. Notice the HANDLE.PRT is located in the model tree, and then select the JAW_SUB.ASM to highlight it.

13. Right-click HANDLE.PRT and select **Retrieve Missing Component**.
   - Double-click **Handle_Folder** if necessary.
   - Select HANDLE.PRT, and click **Open**.

14. Press CTRL+ G to regenerate the model. Notice it regenerates successfully.
15. Click **Save** and click **OK**.

16. Click **Close Window**, **Erase Not Displayed**, and click **OK**.

17. Click **Working Directory**.

18. Double-click **Handle_Folder**.

19. Right-click **HANDLE.PRT** and select **Cut**.

20. Click **Working Directory** from the Navigator, and click in the Browser to de-select any files.

21. Right-click in the Browser and select **Paste**.
22. Double-click MISSING-COMP_FAIL.ASM to verify the failure has been fixed.

This completes the procedure.

25.6 Analyzing Missing Component Reference Failures

If a component's placement cannot be resolved in an assembly, Pro/ENGINEER reports the failure in the message window as "Some features failed to regenerate." Remember, this message is within assembly mode, so the "feature" is actually a failing component in this context. Feature information on the failing component will reveal messages such as "Failed to regenerate component placement" or "Feature references are missing." This type of failure occurs when features in a component are modified that have parents or children in an assembly. If the feature modification removes the reference used in the assembly, this causes either the component or the component's children to fail placement.

In the upper figure, the Reference Viewer displays the parent/child relationships for the JAW_SLIDE.PRT component in the assembly. Component LEADSCREW.PRT is a child to the jaw slide component. In looking at the Reference Graph, LEADSCREW.PRT is assembled to surface id 238 of JAW_SLIDE.PRT. As such, if the feature containing surface id 238 in JAW_SLIDE.PRT were modified, it could cause the leadscrew to fail.

Procedure: Analyzing Missing Component Reference Failures

Scenario
Resolve a missing component reference failure.

Task 1. Resolve a missing component reference failure.

1. Select Hole 2.

2. A leadscrew in the assembly mates to the flat base surface of this hole.
3. Edit the definition of Hole 2.
   - Click **Drill Hole Profile**.

4. In the dashboard, select the **Shape** tab.
   - Notice that the flat base surface of the hole has been replaced by a drill point.

5. Click **Complete Feature**.

6. Click **Close Window**.
7. Click **Working Directory** from the Navigator.
   - Double-click **MISSING-REFS.ASM** to open it.

8. Notice that the assembly fails to regenerate, but still displays all components.

9. From the status bar, click **Regeneration Manager**.

10. Notice that **LEADCROWE.PRT** within **JAW_SUB.ASM** is failing.
11. Right-click LEADSCREW.PRT and select **Feature Info**.

12. Notice that LEADSCREW.PRT is failing due to missing placement references.

13. Close the browser, and click **Cancel** from the Regeneration Manager.

   ![Failure Info]

   **Failure Info**

   COMPONENT #6 (LEADSCREW) failed regeneration.

   Feature geometry can not be restored.

   Reasons for failure:

   - Failed to regenerate component placement.
   - Feature references are missing.


15. Notice the failed LEADSCREW.PRT and its failing child component are highlighted.

   ![Model Tree]

   - **JAW_SUB.ASM**
     - **Placement**
       - **ASM_RIGHT**
       - **ASM_TOP**
       - **ASM_FRONT**
       - **ASM_DEF_CSYS**
     - **JAW_SLIDE.PRT**
     - **LEADSCREW.PRT**
     - **HANDLE.FRT**
     - **Insert Here**
   - **Insert Here**

16. Right-click JAW_SLIDE.PRT and select **Activate**.

17. Select **Hole 2**.
18. Click **Edit > Definition** from the main menu.

19. In the dashboard, click **Rectangle Hole Profile** to remove the drill point.

![Image](image1.jpg)

20. Click **Complete Feature**.

21. Click **Window > Activate**.

22. Click **Regenerate**.

23. Notice the model regenerates successfully.

![Image](image2.jpg)

This completes the procedure.

### 25.7 Analyzing Invalid Assembly Constraint Failures

Assembly constraints are based on component references. A component's references can change, and therefore become invalid. This can occur if parent assembly components are modified or deleted, or if the features in parent components are modified or deleted. In the upper figure, the ends of a rod are inserted into holes on each block using Insert constraints. The holes in the transparent block were then moved outward, without modifying the holes on the
other block. Consequently the holes do not line up, and it becomes impossible for the rod ends to be inserted into both holes given the misalignment. The result is that the rod constraints become invalid. Pro/ENGINEER then issues a failure and reports it as “Failed to regenerate component placement” in the feature information for the failed component.

Fixing Invalid Assembly Constraint Failures

When assembly constraints become invalid, you can do one of three things:

- **Modify features to satisfy constraints** — You can modify either the features in the failing component or in the other components. In the lower-left figure, the holes in the other two components were moved outward so all constraints are again satisfied.
- **Change constraints** — You can constrain the component differently so all constraints are satisfied, or you can disable constraints. Disabling constraints maintains the original references, but makes the constraint inactive for regeneration purposes. In the lower-right figure, the Insert constraints for the rods were disabled. Notice that the components are still misaligned with respect to the holes. The disabled constraints can always be re-enabled at a later time. You can also disable constraints to test out different assembly scenarios.
- **Suppress or freeze the failing component** — You can then either modify the part or delete it from the assembly at a later time.

**Procedure: Analyzing Invalid Assembly Constraint Failures**

**Scenario**
Resolve invalid assembly constraint failures.

**Task 1. Resolve invalid assembly constraint failures.**

Our goal is to modify the rod spacing by modifying the hole spacing from 10 to 8 for the three block-shaped components.

1. In the model tree, right-click JAW_FIXED.PRT and select **Activate**.
   - Select the hole on the right.
   - Right-click and select **Edit**.
2. Edit the offset value from 10 to 8.

3. Click Window > Activate.

4. Click Regenerate.

5. Failures occur. Click OK.

6. Notice that the two ROD.PRT components and their child assembly fails.

7. Right-click the first ROD.PRT in the model tree and select Info > Feature.

8. Notice that ROD.PRT failed to regenerate due to component placement.

9. Close the browser.
10. Right-click the first ROD.PRT and select **Edit Definition**.

11. In the dashboard, notice that the constraint STATUS is “Constraints Invalid.”
   - Select the **Placement** tab.
   - Placement has failed due to conflicting Insert constraints.
   - Select the second Insert constraint and clear the **Constraint Enabled** check box for testing purposes.

12. Click **Complete Component ✔**.

13. The first ROD.PRT now regenerates successfully.

14. Right-click the second ROD.PRT and select **Edit Definition**.
15. Notice the dashboard constraint status.
   - Select the **Placement** tab.
   - Select the second Insert constraint and clear the **Constraint Enabled** check box.

16. Click **Complete Component**.

17. The second ROD.PRT now regenerates successfully.

18. The JAW_SUB.ASM fails because its hole spacing still needs to be modified.

19. Expand JAW_SUB.ASM.

20. Right-click JAW_SLIDE.PRT and select **Activate**.

21. Select the lower right hole, right-click, and select **Edit**.

22. Edit the offset value from **10** to **8**.
23. Click **Window > Activate**.

24. Click **Regenerate**.

25. Collapse JAW_SUB.ASM.

26. Notice the model now regenerates successfully.

27. Zoom in and notice the rod misalignment. Recall that the Insert constraints were disabled at this end.

28. In the model tree, right-click HEAD_BLOCK.PRT and select **Activate**.

29. Double-click the bottom right hole and edit its offset from 10 to 8.
30. Click **Window > Activate**.

31. Click **Regenerate**.

32. The hole spacing has been resolved for all three block components.

⚠️ The Insert constraints for this end could now be re-enabled to “detect” misalignment in the future.
This completes the procedure.

25.8 Understanding Resolve Mode Tools

If desired, you can activate Pro/ENGINEER's traditional Resolve Mode upon a regeneration failure. Resolve mode is a menu-manager driven system that provides tools and diagnostics to resolve the current failure. You can activate Resolve Mode by changing preferences in the Regeneration Manager, or by using the `regen_failure_handling` config.pro option.

The Resolve Mode Environment

When you activate Resolve Mode, the following occurs:

- The message window displays a message about the failure.
- The failing feature and all subsequent features remain unregenerated and therefore are not displayed.
- The Failure Diagnostics window
appears, providing you with information about the failing feature. The Failure Diagnostics window is shown in the lower figure.

- **The Resolve menu appears** which uses the traditional menu manager interface. The Resolve menu is shown in the upper figure. When using Resolve Mode, you must specify your intended action first such as **Modify** (Edit) or **Redefine** (Edit Definition), and then select an object such as a feature or component.
- **The option to Save** is disabled until the failure is resolved.

Failure Diagnostics Window

The Failure Diagnostics window prominently displays above the graphics window upon entering Resolve Mode, and is one of the tools available for resolving or preventing the regeneration problem that has occurred. It displays the following options:

- **Overview** — Displays help information on the various Resolve mode tools.
- **Feature Info** — Displays the Feature Information for the failing feature in the Browser.
- **Resolve Hints** — If a resolve hint exists, the system displays this link. Click the link for a suggestion on how to fix the problem.

Resolve Menu

The Resolve menu is the other tool available for resolving or preventing the regeneration problem that has occurred, and contains these main options:

- **Undo Changes** — Undo all the changes that caused the failure.
- **Current Model/Backup Model** — For both Investigating and fixing the problem, you can choose to work on the current (failed) model or the backup model. The backup model shows all features in their pre-regenerated state, and can be used to modify or restore dimensions of the features that are not displayed in the current (failed) model. You can toggle back and forth between the current and backup model.
- **Investigate** — Enables you to investigate the cause of the model failure. You can list the changes made to items, show every object referenced by the failed feature, report geometrical misalignments found during the last regeneration, and roll the model back to a specified feature.
- **Quick Fix** — Enables you to fix the failing feature by performing standard operations including Redefine, Reroute, Suppress, Clip Suppress, and Delete. Reroute enables you to reroute the failing feature's references to prevent failures in subsequent features. Clip Suppress suppresses not only the failing feature, but all subsequent features, too. Depending upon the operation selected, the Undo Changes option may become unavailable.
- **Fix Model** — Enables you to fix other features in the model to fix the failing feature. Using fix model enables you to create, delete, suppress, or
redefine other features. It also enables you to modify the dimensions of the other non-failing features in the model, as well as restore all modified dimensions to their previous values. Again, depending upon the operation selected the Undo Changes option becomes unavailable.

You must click Regenerate in the menu manager after a change is made to the model. While in Resolve Mode, the regenerate icon is disabled since the resolve menu contains Regenerate in the menu manager.

- Yes / No— When you have fixed the regeneration failure using Resolve Mode, you can click Yes to exit Resolve Mode and return to normal operation. You can also click No to remain in Resolve Mode if desired.

25.9 Recovering Models

In the event of a system crash, Pro/ENGINEER captures a snapshot of the models in session, as well as any applied configuration settings.

Upon restarting Pro/ENGINEER, you are prompted to either Retrieve the previous model or Continue onto a fresh Pro/ENGINEER session.

Using the Retrieve option is very useful to avoid lost work on your models.

Retrieval Dialog Box
Check your Knowledge

1. Which of the following is not a reason for the system to enter Resolve mode?
   
   A - Invalid or impossible geometry
   B - Missing or broken references
   C - Wrong feature created
   D - Missing models
   E - Both A and B

2. Which of the following is not a reason for a geometry failure?
   
   A - One feature extrudes into another feature
   B - Round radii too small or too large
   C - Blend start points mismatch
   D - A circular sweep section radius is larger than the sweep trajectory radius

3. True or False? An open section sketch extending further than the bounding solid geometry can cause an open section failure.
   
   A - True
   B - False

4. True or False? Pro/ENGINEER is smart enough to automatically find a component that was renamed in the operating system.
   
   A - True
   B - False
5. Which of the following is not a method you can use to get help from Pro/ENGINEER?

A - Use Pro/Engineer's Help Center.
B - Click Help > Online Resources from the main menu.
C - Use the What’s This? Icon.
D - Right-click on an icon and select, Help.